[PATCH] gnu: Add some gnome extensions

  • Done
  • quality assurance status badge
Details
3 participants
  • Sughosha
  • Liliana Marie Prikler
  • Maxime Devos
Owner
unassigned
Submitted by
Sughosha
Severity
normal
S
S
Sughosha wrote on 21 Jun 2022 20:59
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
bl-ku5-zCxO6HF-iRmLKeLlE7JVAJGlmWmHN1F2By-UUlH4frqjdos3AeK6p7AGykzxnt5glNbLZ3FBCk50p7c4ULNYpne7H8cK9N2DBZ2g=@proton.me
From aa21788fe28ff0b271ccab8b49e3602c783604fc Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Tue, 21 Jun 2022 20:41:12 +0200
Subject: [PATCH] gnu: Add some gnome extensions

---
gnu/packages/gnome-xyz.scm | 113 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 113 insertions(+)

Toggle diff (124 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 465f81b..a96fe8b 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -985,6 +985,119 @@ animation of closing windowed applications.")
GNOME Shell, including the top panel, dash and overview.")
(license license:gpl3)))

+(define-public gnome-shell-extension-activities-icons
+ (let ((revision "12")
+ (commit "651179d1727d5ed80866f2319d5e4793b28631ae"))
+ (package
+ (name "gnome-shell-extension-activities-icons")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/fawtytoo/activities-icons")
+ (commit commit)))
+ (sha256
+ (base32 "0c77f77knchzdg1mmyn6ahb3lgfd54ym30wnyrh20y4zbwn8ri2w"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ `(("." "/share/gnome-shell/extensions/activities_icons@fawtytoo"))))
+ (home-page "https://github.com/fawtytoo/activities-icons")
+ (synopsis "Gnome Shell extension that replaces the Activities button with 2 icons for selecting between Applications and Workspaces")
+ (description "The Activities button becomes 2 icons for selecting either Applications or Workspaces in the overview. Selecting the same view again will hide the overview.
+
+Scrolling on the icons allows switching windows on a workspace or cycling through the Workspaces.")
+ (license license:gpl3))))
+
+(define-public gnome-shell-extension-radio
+ (package
+ (name "gnome-shell-extension-radio")
+ (version "19")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/hslbck/gnome-shell-extension-radio")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qsi6c57hxh4jqdw18knm06601lhag6jdbvzg0r79aa9572zy8a0"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ `(("radio@hslbck.gmail.com" "/share/gnome-shell/extensions/"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'glib-compile-schemas
+ (lambda _
+ (invoke "glib-compile-schemas" "radio@hslbck.gmail.com/schemas"))))))
+ (native-inputs
+ `(("glib:bin" ,glib "bin")))
+ (home-page "https://github.com/hslbck/gnome-shell-extension-radio")
+ (synopsis "Gnome shell extension for listening to internet radio streams")
+ (description "This extension is for listening to internet radio streams.")
+ (license license:gpl3+)))
+
+(define-public gnome-shell-extension-sound-output-device-chooser
+ (package
+ (name "gnome-shell-extension-sound-output-device-chooser")
+ (version "43")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/kgshank/gse-sound-output-device-chooser")
+ (commit version)))
+ (sha256
+ (base32 "1qk6ypyqbv8zwwlky6cgk9hgp1zh32jmzw4wza200g4v94ifkwm9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-hardcoded-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("INSTALL_DIR=~/.local/share/gnome-shell/extensions") (string-append "INSTALL_DIR=" (assoc-ref outputs "out") "/share/gnome-shell/extensions")))))
+ (delete 'configure))))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")))
+ (inputs
+ (list python))
+ (home-page "https://extensions.gnome.org/extension/906/sound-output-device-chooser")
+ (synopsis "simple selector to enabled selection of sound source and sink based on Gnome Control Center")
+ (description "This extension shows a list of sound output and input devices (similar to gnome sound settings) in the status menu below the volume slider. Various active ports like HDMI , Speakers etc. of the same device are also displayed for selection.")
+ (license license:gpl3)))
+
+(define-public gnome-shell-extension-transparent-window
+ (let ((revision "45")
+ (commit "cc9bc70c192dd565fa6f1d1b28d9a20f99684f2a"))
+ (package
+ (name "gnome-shell-extension-transparent-window")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/pbxqdown/gnome-shell-extension-transparent-window")
+ (commit commit)))
+ (sha256
+ (base32 "1f9iqqjpmmylqz0ws8cy5rs475bwzi7jy44q9ip44ig2acz2wxzp"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ `(("." "/share/gnome-shell/extensions/transparent-window@pbxqdown.github.com"))))
+ (home-page "https://github.com/pbxqdown/gnome-shell-extension-transparent-window")
+ (synopsis "Gnome shell extension which changes the opacity of window through mouse operation")
+ (description "The extension will change the opacity of window through simple mouse/keyboard operation.")
+ (license license:expat))))
+
(define-public arc-theme
(package
(name "arc-theme")
--
libgit2 1.4.3
Attachment: file
L
L
Liliana Marie Prikler wrote on 21 Jun 2022 21:52
c099ca3ff6733a8084d37d50d8d50bf156c0096d.camel@gmail.com
Am Dienstag, dem 21.06.2022 um 18:59 +0000 schrieb Sughosha:
Toggle quote (6 lines)
> From aa21788fe28ff0b271ccab8b49e3602c783604fc Mon Sep 17 00:00:00
> 2001
> From: Sughosha <sughosha@proton.me>
> Date: Tue, 21 Jun 2022 20:41:12 +0200
> Subject: [PATCH] gnu: Add some gnome extensions
>
Missing ChangeLog.
Toggle quote (20 lines)
> ---
>  gnu/packages/gnome-xyz.scm | 113
> +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> ++++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 113 insertions(+)
>
> diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
> index 465f81b..a96fe8b 100644
> --- a/gnu/packages/gnome-xyz.scm
> +++ b/gnu/packages/gnome-xyz.scm
> @@ -985,6 +985,119 @@ animation of closing windowed applications.")
>  GNOME Shell, including the top panel, dash and overview.")
>      (license license:gpl3)))
>  
> +(define-public gnome-shell-extension-activities-icons
> +  (let ((revision "12")
> +        (commit "651179d1727d5ed80866f2319d5e4793b28631ae"))
> +    (package
> +      (name "gnome-shell-extension-activities-icons")
> +      (version (git-version "0" revision commit))
If possible, use an actual version, e.g. one advertised at
extensions.gnome.org
Toggle quote (19 lines)
> +      (source
> +        (origin
> +          (method git-fetch)
> +          (uri
> +            (git-reference
> +              (url "https://github.com/fawtytoo/activities-icons")
> +              (commit commit)))
> +          (sha256
> +            (base32
> "0c77f77knchzdg1mmyn6ahb3lgfd54ym30wnyrh20y4zbwn8ri2w"))))
> +      (build-system copy-build-system)
> +      (arguments
> +       `(#:install-plan
> +         `(("."
> "/share/gnome-shell/extensions/activities_icons@fawtytoo"))))
> +     (home-page "https://github.com/fawtytoo/activities-icons")
> +     (synopsis "Gnome Shell extension that replaces the Activities
> button with 2 icons for selecting between Applications and
> Workspaces")
Synopses should be short.
Toggle quote (6 lines)
> +     (description "The Activities button becomes 2 icons for
> selecting either Applications or Workspaces in the overview.
> Selecting the same view again will hide the overview.
> +
> +Scrolling on the icons allows switching windows on a workspace or
> cycling through the Workspaces.")
No need to break this into multiple lines.
Toggle quote (2 lines)
> +     (license license:gpl3))))
> +
Split into a separate commit here.

Toggle quote (36 lines)
> +(define-public gnome-shell-extension-radio
> +  (package
> +    (name "gnome-shell-extension-radio")
> +    (version "19")
> +    (source
> +      (origin
> +        (method git-fetch)
> +        (uri
> +          (git-reference
> +            (url
> "https://github.com/hslbck/gnome-shell-extension-radio")
> +            (commit (string-append "v" version))))
> +        (file-name (git-file-name name version))
> +        (sha256
> +          (base32
> "1qsi6c57hxh4jqdw18knm06601lhag6jdbvzg0r79aa9572zy8a0"))))
> +    (build-system copy-build-system)
> +    (arguments
> +     `(#:install-plan
> +        `(("radio@hslbck.gmail.com" "/share/gnome-
> shell/extensions/"))
> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-before 'install 'glib-compile-schemas
> +           (lambda _
> +             (invoke "glib-compile-schemas"
> "radio@hslbck.gmail.com/schemas"))))))
> +    (native-inputs
> +     `(("glib:bin" ,glib "bin")))
> +    (home-page
> "https://github.com/hslbck/gnome-shell-extension-radio")
> +    (synopsis "Gnome shell extension for listening to internet radio
> streams")
> +    (description "This extension is for listening to internet radio
> streams.")
> +    (license license:gpl3+)))
Synopsis and description could possibly use some work. Split into
another commit here.

Toggle quote (25 lines)
> +(define-public gnome-shell-extension-sound-output-device-chooser
> +  (package
> +    (name "gnome-shell-extension-sound-output-device-chooser")
> +    (version "43")
> +    (source
> +      (origin
> +        (method git-fetch)
> +        (uri
> +          (git-reference
> +            (url
> "https://github.com/kgshank/gse-sound-output-device-chooser")
> +            (commit version)))
> +        (sha256
> +          (base32
> "1qk6ypyqbv8zwwlky6cgk9hgp1zh32jmzw4wza200g4v94ifkwm9"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:tests? #f
> +       #:phases
> +        (modify-phases %standard-phases
> +          (add-after 'unpack 'fix-hardcoded-path
> +            (lambda* (#:key outputs #:allow-other-keys)
> +              (substitute* "Makefile"
> +                (("INSTALL_DIR=~/.local/share/gnome-
> shell/extensions")
You can match this as INSTALL_DIR=.*
Toggle quote (13 lines)
> (string-append "INSTALL_DIR=" (assoc-ref outputs "out")
> "/share/gnome-shell/extensions")))))
> +          (delete 'configure))))
> +    (native-inputs
> +     `(("gettext" ,gettext-minimal)
> +       ("glib:bin" ,glib "bin")))
> +    (inputs
> +      (list python))
> +    (home-page
> "https://extensions.gnome.org/extension/906/sound-output-device-chooser
> ")
> +    (synopsis "simple selector to enabled selection of sound source
> and sink based on Gnome Control Center")
Avoid marketing words like "simple", also synopses ought to be short.
Toggle quote (5 lines)
> +    (description "This extension shows a list of sound output and
> input devices (similar to gnome sound settings) in the status menu
> below the volume slider. Various active ports like HDMI , Speakers
> etc. of the same device are also displayed for selection.")
> +    (license license:gpl3)))
Split.

Toggle quote (6 lines)
> +(define-public gnome-shell-extension-transparent-window
> +  (let ((revision "45")
> +        (commit "cc9bc70c192dd565fa6f1d1b28d9a20f99684f2a"))
> +    (package
> +      (name "gnome-shell-extension-transparent-window")
> +      (version (git-version "0" revision commit))
Same version problem as for the first package.
Toggle quote (23 lines)
> +      (source
> +        (origin
> +          (method git-fetch)
> +          (uri
> +            (git-reference
> +              (url
> "https://github.com/pbxqdown/gnome-shell-extension-transparent-window
> ")
> +              (commit commit)))
> +          (sha256
> +            (base32
> "1f9iqqjpmmylqz0ws8cy5rs475bwzi7jy44q9ip44ig2acz2wxzp"))))
> +      (build-system copy-build-system)
> +      (arguments
> +       `(#:install-plan
> +         `(("."
> "/share/gnome-shell/extensions/transparent-window@pbxqdown.github.com
> "))))
> +      (home-page
> "https://github.com/pbxqdown/gnome-shell-extension-transparent-window
> ")
> +      (synopsis "Gnome shell extension which changes the opacity of
> window through mouse operation")
Synopses should be short.
Toggle quote (5 lines)
> +      (description "The extension will change the opacity of window
> through simple mouse/keyboard operation.")
> +      (license license:expat))))
> +

Cheers
M
M
Maxime Devos wrote on 21 Jun 2022 22:09
Re: [bug#56128] [PATCH] gnu: Add some gnome extensions
aa3a104ac446a7d0532cb4da453bcb58c8c839ac.camel@telenet.be
Sughosha via Guix-patches via schreef op di 21-06-2022 om 18:59
[+0000]:
Toggle quote (4 lines)
> +    (native-inputs
> +     `(("gettext" ,gettext-minimal)
> +       ("glib:bin" ,glib "bin")))

IIUC, you can delabelify that with:

./pre-inst-env guix style --input-simplification=always gnome-shell-extension-sound-output-device-chooser

Likewise for other packages.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYrIlfBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7nztAQCOBIeJPoV8OM8iFDX0ZmPu1GjN
Gq5d6KZ+nsKLTLxVVgD9HVx3tQyMB7rYR1nSrrfKzB0fFQSYqSsGKL+8c8/C4go=
=JUQX
-----END PGP SIGNATURE-----


S
S
Sughosha wrote on 22 Jun 2022 08:19
[PATCH 2/4] gnu: Add gnome-shell-extension-radio
(address . 56128@debbugs.gnu.org)
DAUNLmxNSbAbeIWv1hdm8itnvlWEsHFkTdjYoxXUWeOKoM9hIDM6zB-dPGGiNw8frhw01IiYHP43__a5J64vDV5Kw_NJpNSf2A43S80ItdA=@proton.me
From f832d7a58538dec2216345c31eb22aa257f88594 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 08:07:21 +0200
Subject: [PATCH 2/4] gnu: Add gnome-shell-extension-radio

* gnu/packages/gnome-xyz.scm: Add gnome-shell-extension-radio
---
gnu/packages/gnome-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 4f4ac11f41..f91d59dd62 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1008,6 +1008,36 @@ (define-public gnome-shell-extension-activities-icons
"The Activities button becomes 2 icons for selecting either Applications or Workspaces in the overview. Selecting the same view again will hide the overview. Scrolling on the icons allows switching windows on a workspace or cycling through the Workspaces.")
(license license:gpl3))))

+(define-public gnome-shell-extension-radio
+ (package
+ (name "gnome-shell-extension-radio")
+ (version "19")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/hslbck/gnome-shell-extension-radio")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qsi6c57hxh4jqdw18knm06601lhag6jdbvzg0r79aa9572zy8a0"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan `(("radio@hslbck.gmail.com"
+ "/share/gnome-shell/extensions/"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'glib-compile-schemas
+ (lambda _
+ (invoke "glib-compile-schemas" "radio@hslbck.gmail.com/schemas"))))))
+ (native-inputs `(("glib:bin" ,glib "bin")))
+ (home-page "https://github.com/hslbck/gnome-shell-extension-radio")
+ (synopsis "Internet radio for GNOME Shell")
+ (description
+ "This extension allows to browse, add and play internet radio streams.")
+ (license license:gpl3+)))
+
(define-public arc-theme
(package
(name "arc-theme")
--
2.36.1
Attachment: file
S
S
Sughosha wrote on 22 Jun 2022 08:19
[PATCH 1/4] gnu: Add gnome-shell-extension-activities-icons
(address . 56128@debbugs.gnu.org)
HhYpxeYKHi1ryauYJ2F-8Tw9O9e-3NtQPPIuQOOQ04EvQo_0BTjfiV-osJVIShk0NObN-8UdIlN1GT582z8rjZBj8GkBi19SiknPh-b8V3k=@proton.me
From 2af37e0bd6803f8be86106d4d795dce92d790e4a Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 08:05:51 +0200
Subject: [PATCH 1/4] gnu: Add gnome-shell-extension-activities-icons

* gnu/packages/gnome-xyz.scm: Add gnome-shell-extension-activities-icons
---
gnu/packages/gnome-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 9e5d319291..4f4ac11f41 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -985,6 +985,29 @@ (define-public gnome-shell-extension-blur-my-shell
GNOME Shell, including the top panel, dash and overview.")
(license license:gpl3)))

+(define-public gnome-shell-extension-activities-icons
+ (let ((revision "12") (commit "651179d1727d5ed80866f2319d5e4793b28631ae"))
+ (package
+ (name "gnome-shell-extension-activities-icons")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fawtytoo/activities-icons")
+ (commit commit)))
+ (sha256
+ (base32
+ "0c77f77knchzdg1mmyn6ahb3lgfd54ym30wnyrh20y4zbwn8ri2w"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan `(("."
+ "/share/gnome-shell/extensions/activities_icons@fawtytoo"))))
+ (home-page "https://github.com/fawtytoo/activities-icons")
+ (synopsis "Activities Icons for GNOME Shell")
+ (description
+ "The Activities button becomes 2 icons for selecting either Applications or Workspaces in the overview. Selecting the same view again will hide the overview. Scrolling on the icons allows switching windows on a workspace or cycling through the Workspaces.")
+ (license license:gpl3))))
+
(define-public arc-theme
(package
(name "arc-theme")
--
2.36.1
Attachment: file
S
S
Sughosha wrote on 22 Jun 2022 08:20
[PATCH 3/4] gnu: Add gnome-shell-extension-sound-output-device-chooser
(address . 56128@debbugs.gnu.org)
AqzzvTz8FqF_ZjPIuXsryf0YeeaFePvL9eRhF2gxSC7Vzl5oPDj0-tgdfhUUd9iCqa_7Vv7KXT5DcFwPNXqGs-FUt4tKnqQp9M5ClMhkpws=@proton.me
From f6090daf39b938440bc5381bfd53ffc69083f25f Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 08:08:04 +0200
Subject: [PATCH 3/4] gnu: Add gnome-shell-extension-sound-output-device-chooser

* gnu/packages/gnome-xyz.scm: Add gnome-shell-extension-sound-output-device-chooser
---
gnu/packages/gnome-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index f91d59dd62..0c256c3187 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1038,6 +1038,40 @@ (define-public gnome-shell-extension-radio
"This extension allows to browse, add and play internet radio streams.")
(license license:gpl3+)))

+(define-public gnome-shell-extension-sound-output-device-chooser
+ (package
+ (name "gnome-shell-extension-sound-output-device-chooser")
+ (version "43")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/kgshank/gse-sound-output-device-chooser")
+ (commit version)))
+ (sha256
+ (base32
+ "1qk6ypyqbv8zwwlky6cgk9hgp1zh32jmzw4wza200g4v94ifkwm9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-hardcoded-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("INSTALL_DIR=~/.*") (string-append "INSTALL_DIR="
+ (assoc-ref outputs "out")
+ "/share/gnome-shell/extensions")))))
+ (delete 'configure))))
+ (native-inputs `(("gettext" ,gettext-minimal) ("glib:bin" ,glib "bin")))
+ (inputs (list python))
+ (home-page
+ "https://extensions.gnome.org/extension/906/sound-output-device-chooser")
+ (synopsis "Sound output chooser for GNOME Shell")
+ (description
+ "This extension shows a list of sound output and input devices (similar to gnome sound settings) in the status menu below the volume slider. Various active ports like HDMI , Speakers etc. of the same device are also displayed for selection.")
+ (license license:gpl3)))
+
(define-public arc-theme
(package
(name "arc-theme")
--
2.36.1
Attachment: file
S
S
Sughosha wrote on 22 Jun 2022 08:21
[PATCH 4/4] gnu: Add gnome-shell-extension-transparent-window
(address . 56128@debbugs.gnu.org)
riL5rUH-N7ksGRJA-coWO6bcYupToYBiCOCX68eJO8RMV-ETxC2BCuVFx4P43QqMooTpBsXs8ohYMKNMJaOMdA7t5cdNlaCYloqgAchFsIM=@proton.me
From 71a7b816831d2491297a5784612767d557fbd114 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 08:09:28 +0200
Subject: [PATCH 4/4] gnu: Add gnome-shell-extension-transparent-window

* gnu/packages/gnome-xyz.scm: Add gnome-shell-extension-transparent-window
---
gnu/packages/gnome-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 0c256c3187..7bf9d433e9 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1072,6 +1072,31 @@ (define-public gnome-shell-extension-sound-output-device-chooser
"This extension shows a list of sound output and input devices (similar to gnome sound settings) in the status menu below the volume slider. Various active ports like HDMI , Speakers etc. of the same device are also displayed for selection.")
(license license:gpl3)))

+(define-public gnome-shell-extension-transparent-window
+ (let ((revision "45") (commit "cc9bc70c192dd565fa6f1d1b28d9a20f99684f2a"))
+ (package
+ (name "gnome-shell-extension-transparent-window")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/pbxqdown/gnome-shell-extension-transparent-window")
+ (commit commit)))
+ (sha256
+ (base32
+ "1f9iqqjpmmylqz0ws8cy5rs475bwzi7jy44q9ip44ig2acz2wxzp"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan `(("."
+ "/share/gnome-shell/extensions/transparent-window@pbxqdown.github.com"))))
+ (home-page
+ "https://github.com/pbxqdown/gnome-shell-extension-transparent-window")
+ (synopsis "Change the opacity of windows in GNOME Shell")
+ (description
+ "The extension will change the opacity of window through simple mouse/keyboard operation.")
+ (license license:expat))))
+
(define-public arc-theme
(package
(name "arc-theme")
--
2.36.1
Attachment: file
L
L
Liliana Marie Prikler wrote on 22 Jun 2022 21:17
Re: [PATCH 1/4] gnu: Add gnome-shell-extension-activities-icons
8206cd6ee9b085bfda5983f0f4329e5f1cc2a8b6.camel@gmail.com
Am Mittwoch, dem 22.06.2022 um 06:19 +0000 schrieb Sughosha:
Toggle quote (9 lines)
> From 2af37e0bd6803f8be86106d4d795dce92d790e4a Mon Sep 17 00:00:00
> 2001
> From: Sughosha <sughosha@proton.me>
> Date: Wed, 22 Jun 2022 08:05:51 +0200
> Subject: [PATCH 1/4] gnu: Add gnome-shell-extension-activities-icons
>
> * gnu/packages/gnome-xyz.scm: Add gnome-shell-extension-activities-
> icons
> ---
Use full sentences in the ChangeLog.

Note that your mail client messes up the messages, breaking the patches
so that git can't apply them.

Cheers
S
S
Sughosha wrote on 24 Jun 2022 10:39
[PATCH] gnu: Add some gnome extensions
(address . 56128@debbugs.gnu.org)
rupH90q5mdy6Qyq3U-REHIBooaNvSXwkqOGAJD7dNLjQcJxAlOqT-UUKPTGKzZqznwXEWtc38Bpz6hGa1XO1Y9hW7b_Bx0o-v-J6ruFaG2Q=@proton.me
Empty Message
Attachment: file
From 2af37e0bd6803f8be86106d4d795dce92d790e4a Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 08:05:51 +0200
Subject: [PATCH 1/4] gnu: Add gnome-shell-extension-activities-icons

* gnu/packages/gnome-xyz.scm: Add gnome-shell-extension-activities-icons.
---
gnu/packages/gnome-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 9e5d319291..4f4ac11f41 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -985,6 +985,29 @@ (define-public gnome-shell-extension-blur-my-shell
GNOME Shell, including the top panel, dash and overview.")
(license license:gpl3)))
+(define-public gnome-shell-extension-activities-icons
+ (let ((revision "12") (commit "651179d1727d5ed80866f2319d5e4793b28631ae"))
+ (package
+ (name "gnome-shell-extension-activities-icons")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fawtytoo/activities-icons")
+ (commit commit)))
+ (sha256
+ (base32
+ "0c77f77knchzdg1mmyn6ahb3lgfd54ym30wnyrh20y4zbwn8ri2w"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan `(("."
+ "/share/gnome-shell/extensions/activities_icons@fawtytoo"))))
+ (home-page "https://github.com/fawtytoo/activities-icons")
+ (synopsis "Activities Icons for GNOME Shell")
+ (description
+ "The Activities button becomes 2 icons for selecting either Applications or Workspaces in the overview. Selecting the same view again will hide the overview. Scrolling on the icons allows switching windows on a workspace or cycling through the Workspaces.")
+ (license license:gpl3))))
+
(define-public arc-theme
(package
(name "arc-theme")
--
2.36.1
From f832d7a58538dec2216345c31eb22aa257f88594 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 08:07:21 +0200
Subject: [PATCH 2/4] gnu: Add gnome-shell-extension-radio

* gnu/packages/gnome-xyz.scm: Add gnome-shell-extension-radio.
---
gnu/packages/gnome-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 4f4ac11f41..f91d59dd62 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1008,6 +1008,36 @@ (define-public gnome-shell-extension-activities-icons
"The Activities button becomes 2 icons for selecting either Applications or Workspaces in the overview. Selecting the same view again will hide the overview. Scrolling on the icons allows switching windows on a workspace or cycling through the Workspaces.")
(license license:gpl3))))
+(define-public gnome-shell-extension-radio
+ (package
+ (name "gnome-shell-extension-radio")
+ (version "19")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/hslbck/gnome-shell-extension-radio")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qsi6c57hxh4jqdw18knm06601lhag6jdbvzg0r79aa9572zy8a0"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan `(("radio@hslbck.gmail.com"
+ "/share/gnome-shell/extensions/"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'glib-compile-schemas
+ (lambda _
+ (invoke "glib-compile-schemas" "radio@hslbck.gmail.com/schemas"))))))
+ (native-inputs `(("glib:bin" ,glib "bin")))
+ (home-page "https://github.com/hslbck/gnome-shell-extension-radio")
+ (synopsis "Internet radio for GNOME Shell")
+ (description
+ "This extension allows to browse, add and play internet radio streams.")
+ (license license:gpl3+)))
+
(define-public arc-theme
(package
(name "arc-theme")
--
2.36.1
From f6090daf39b938440bc5381bfd53ffc69083f25f Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 08:08:04 +0200
Subject: [PATCH 3/4] gnu: Add gnome-shell-extension-sound-output-device-chooser

* gnu/packages/gnome-xyz.scm: Add gnome-shell-extension-sound-output-device-chooser.
---
gnu/packages/gnome-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index f91d59dd62..0c256c3187 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1038,6 +1038,40 @@ (define-public gnome-shell-extension-radio
"This extension allows to browse, add and play internet radio streams.")
(license license:gpl3+)))
+(define-public gnome-shell-extension-sound-output-device-chooser
+ (package
+ (name "gnome-shell-extension-sound-output-device-chooser")
+ (version "43")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/kgshank/gse-sound-output-device-chooser")
+ (commit version)))
+ (sha256
+ (base32
+ "1qk6ypyqbv8zwwlky6cgk9hgp1zh32jmzw4wza200g4v94ifkwm9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-hardcoded-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("INSTALL_DIR=~/.*") (string-append "INSTALL_DIR="
+ (assoc-ref outputs "out")
+ "/share/gnome-shell/extensions")))))
+ (delete 'configure))))
+ (native-inputs `(("gettext" ,gettext-minimal) ("glib:bin" ,glib "bin")))
+ (inputs (list python))
+ (home-page
+ "https://extensions.gnome.org/extension/906/sound-output-device-chooser")
+ (synopsis "Sound output chooser for GNOME Shell")
+ (description
+ "This extension shows a list of sound output and input devices (similar to gnome sound settings) in the status menu below the volume slider. Various active ports like HDMI , Speakers etc. of the same device are also displayed for selection.")
+ (license license:gpl3)))
+
(define-public arc-theme
(package
(name "arc-theme")
--
2.36.1
From 71a7b816831d2491297a5784612767d557fbd114 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 08:09:28 +0200
Subject: [PATCH 4/4] gnu: Add gnome-shell-extension-transparent-window

* gnu/packages/gnome-xyz.scm: Add gnome-shell-extension-transparent-window.
---
gnu/packages/gnome-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 0c256c3187..7bf9d433e9 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1072,6 +1072,31 @@ (define-public gnome-shell-extension-sound-output-device-chooser
"This extension shows a list of sound output and input devices (similar to gnome sound settings) in the status menu below the volume slider. Various active ports like HDMI , Speakers etc. of the same device are also displayed for selection.")
(license license:gpl3)))
+(define-public gnome-shell-extension-transparent-window
+ (let ((revision "45") (commit "cc9bc70c192dd565fa6f1d1b28d9a20f99684f2a"))
+ (package
+ (name "gnome-shell-extension-transparent-window")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/pbxqdown/gnome-shell-extension-transparent-window")
+ (commit commit)))
+ (sha256
+ (base32
+ "1f9iqqjpmmylqz0ws8cy5rs475bwzi7jy44q9ip44ig2acz2wxzp"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan `(("."
+ "/share/gnome-shell/extensions/transparent-window@pbxqdown.github.com"))))
+ (home-page
+ "https://github.com/pbxqdown/gnome-shell-extension-transparent-window")
+ (synopsis "Change the opacity of windows in GNOME Shell")
+ (description
+ "The extension will change the opacity of window through simple mouse/keyboard operation.")
+ (license license:expat))))
+
(define-public arc-theme
(package
(name "arc-theme")
--
2.36.1
L
L
Liliana Marie Prikler wrote on 26 Jun 2022 17:13
2773a9193b3a7fd8a35a151ef299c031b87f6ae4.camel@gmail.com
Am Freitag, dem 24.06.2022 um 08:39 +0000 schrieb Sughosha:
Toggle quote (1 lines)
> Empty Message
Pushed 2-4 with some adjustments. I didn't push the first one, because
I couldn't find a free license in it.

Cheers
Closed
?