I want to add a Haskell development package
(define-module (n0lim ghc-cryptohash-sha512) 
	       #:use-module (guix packages)
	       #:use-module (guix download)
	       #:use-module (gnu packages haskell-xyz)
	       #:use-module (gnu packages haskell-crypto)
	       #:use-module (gnu packages haskell-check)
	       #:use-module (guix build-system haskell)
	       #:use-module ((guix licenses) #:prefix license:))
(define-public ghc-cryptohash-sha512
  (package
    (name "ghc-cryptohash-sha512")
    (version "0.11.101.0")
    (source
      (origin
        (method url-fetch)
        (uri (hackage-uri "cryptohash-sha512" version))
        (sha256
          (base32 "0a6sc5b6w0k47fyjhyrfm3p25jsbsqjknfq5mbj53p2p1qsfykc1"))))
    (build-system haskell-build-system)
    (native-inputs
      (list ghc-base16-bytestring
            ghc-sha
            ghc-tasty
            ghc-tasty-quickcheck
            ghc-tasty-hunit))
    (home-page "https://github.com/haskell-hvr/cryptohash-sha512")
    (synopsis "Fast, pure and practical SHA-512 implementation")
    (description
      "This package provides a practical incremental and one-pass,
pure API to the SHA-512 hash algorithm (including HMAC support) with
performance close to the fastest implementations available in other
languages.  The implementation is made in C with a haskell FFI wrapper
that hides the C implementation.  NOTE: This package has been forked
off cryptohash-0.11.7 because the cryptohash package has been
deprecated and so this package continues to satisfy the need for a
lightweight package providing the SHA512 hash algorithm without any
dependencies on packages other than base and bytestring.  Consequently,
this package can be used as a drop-in replacement for cryptohash's
\"Crypto.Hash.SHA512\" module, though with a clearly smaller
footprint.")
    (license license:bsd-3)))