[PATCH core-updates-frozen 0/2] gnu: ocl-icd: Fix build.

  • Done
  • quality assurance status badge
Details
3 participants
  • Sarah Morgensen
  • Lars-Dominik Braun
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Sarah Morgensen
Severity
normal
S
S
Sarah Morgensen wrote on 6 Sep 2021 04:46
(address . guix-patches@gnu.org)
cover.1630896250.git.iskarian@mgsn.dev
This fixes the build by updating one minor patch version to 2.2.13. (There
is a 2.3.1 available if that's preferable.) The package seems to have
permanently moved to Github, so this updates the location as well.

I was able to build this and its dependent darktable on x86_64.

Sarah Morgensen (2):
gnu: ocl-icd: Update project location.
gnu: ocl-icd: Update to 2.2.13.

gnu/packages/opencl.scm | 22 +++++++++++++---------
1 file changed, 13 insertions(+), 9 deletions(-)


base-commit: c5bb7b5d97b341c625c269b21e4958d61e7f40c9
--
2.32.0
S
S
Sarah Morgensen wrote on 6 Sep 2021 04:49
[PATCH core-updates-frozen 1/2] gnu: ocl-icd: Update project location.
(address . 50418@debbugs.gnu.org)
5a9e260b1b55e98ea95b75ce6def549d73196452.1630896250.git.iskarian@mgsn.dev
The project seems to have permanently moved to Github, with no
distribution tarballs available, so update it.

* gnu/packages/opencl.scm (ocl-icd)[origin]: Retrieve source from Github
checkout instead of distribution tarballs.
[native-inputs]: Add 'autoconf', 'automake', and 'libtool'.
---
gnu/packages/opencl.scm | 20 ++++++++++++--------
1 file changed, 12 insertions(+), 8 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index e95d19db47..4c9c440b3d 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -131,19 +132,22 @@
(name "ocl-icd")
(version "2.2.12")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://forge.imag.fr/frs/download.php/836/ocl-icd-"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OCL-dev/ocl-icd")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1x2dr8p4dkfds56r38av360i3nv1y3326jmshxvjngaf6mlg6rbn"))
+ "075pj99nanl75hyv93wys9ba3x7lhcdj0awdcd8bss6mdxqxj5mc"))
(modules '((guix build utils)))
(snippet
'(delete-file-recursively "khronos-headers"))))
(native-inputs
- `(("opencl-headers" ,opencl-headers)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("opencl-headers" ,opencl-headers)
("ruby" ,ruby)))
(inputs
`(("libgcrypt" ,libgcrypt)))
@@ -155,7 +159,7 @@
(variable "OPENCL_VENDOR_PATH")
(files '("etc/OpenCL/vendors")))))
(search-paths native-search-paths)
- (home-page "https://forge.imag.fr/projects/ocl-icd/")
+ (home-page "https://github.com/OCL-dev/ocl-icd/")
(synopsis "OpenCL loader for Installable Client Drivers (ICDs)")
(description
"OpenCL implementations are provided as ICDs (Installable Client
--
2.32.0
S
S
Sarah Morgensen wrote on 6 Sep 2021 04:49
[PATCH core-updates-frozen 2/2] gnu: ocl-icd: Update to 2.2.13.
(address . 50418@debbugs.gnu.org)
965cca9da43691a9e1329134bee66511aa00e404.1630896250.git.iskarian@mgsn.dev
Fix building with GCC 10 by updating to 2.2.13.

* gnu/packages/opencl.scm (ocl-icd): Update to 2.2.13.
---
gnu/packages/opencl.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index 4c9c440b3d..9b64780941 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -130,7 +130,7 @@
(define-public ocl-icd
(package
(name "ocl-icd")
- (version "2.2.12")
+ (version "2.2.13")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -139,7 +139,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "075pj99nanl75hyv93wys9ba3x7lhcdj0awdcd8bss6mdxqxj5mc"))
+ "1cpys998467fdi0khdr1cj8qaawhrw0xn6z48b1jsq52c7hgd682"))
(modules '((guix build utils)))
(snippet
'(delete-file-recursively "khronos-headers"))))
--
2.32.0
L
L
Lars-Dominik Braun wrote on 6 Sep 2021 07:57
Re: [bug#50418] [PATCH core-updates-frozen 0/2] gnu: ocl-icd: Fix build.
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)(address . 50418@debbugs.gnu.org)
YTWtxKMfvecmUPRM@noor.fritz.box
Hi Sarah,

Toggle quote (3 lines)
> This fixes the build by updating one minor patch version to 2.2.13. (There
> is a 2.3.1 available if that's preferable.) The package seems to have
> permanently moved to Github, so this updates the location as well.
note that I replaced this package on master with commit
4d1157fca7627c11672df0cd80fae4f4d27e2185 by the Khronos Group’s loader,
which seemed the only maintained one. I didn’t know the project had
moved to GitHub.

Cheers,
Lars
S
S
Sarah Morgensen wrote on 6 Sep 2021 19:20
(name . Lars-Dominik Braun)(address . lars@6xq.net)(address . 50418@debbugs.gnu.org)
86v93dipst.fsf@mgsn.dev
Hello,

Lars-Dominik Braun <lars@6xq.net> writes:

Toggle quote (10 lines)
> Hi Sarah,
>
>> This fixes the build by updating one minor patch version to 2.2.13. (There
>> is a 2.3.1 available if that's preferable.) The package seems to have
>> permanently moved to Github, so this updates the location as well.
> note that I replaced this package on master with commit
> 4d1157fca7627c11672df0cd80fae4f4d27e2185 by the Khronos Group’s loader,
> which seemed the only maintained one. I didn’t know the project had
> moved to GitHub.

Thanks for letting me know.

Is the Khronos Group one better, such that there's no reason to keeping
ocl-icd? (The README for ocl-icd states "[t]his package aims at
creating an Open Source alternative to vendor specific OpenCL ICD
loaders." Is the Khronos Group one similarly not vendor-specific?)

If so, would you consider replacing ocl-icd with it in
core-updates-frozen, since it and its dependents are currently broken?

--
Sarah
L
L
Lars-Dominik Braun wrote on 8 Sep 2021 17:01
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)(address . 50418@debbugs.gnu.org)
YTjQRS3/rPdeYrj4@noor.fritz.box
Hi Sarah,

Toggle quote (4 lines)
> Is the Khronos Group one better, such that there's no reason to keeping
> ocl-icd? (The README for ocl-icd states "[t]his package aims at
> creating an Open Source alternative to vendor specific OpenCL ICD
> loaders." Is the Khronos Group one similarly not vendor-specific?)
I’m not really sure which one is “better”, but the Khronos-loader
is vendor-independent like ocl-icd, so there’s no real reason to
keep two imho.

Toggle quote (2 lines)
> If so, would you consider replacing ocl-icd with it in
> core-updates-frozen, since it and its dependents are currently broken?
Ludovic actually merged master into core-updates-frozen yesterday, so
this issue should be resolved. Unfortunately the CI is going to take
some time to catch up, so we don’t know yet whether that was successful.

Cheers,
Lars
M
M
Maxim Cournoyer wrote on 12 Oct 2021 20:37
Re: bug#50418: [PATCH core-updates-frozen 0/2] gnu: ocl-icd: Fix build.
(name . Lars-Dominik Braun)(address . lars@6xq.net)
878ryyytqf.fsf_-_@gmail.com
Hi,

Lars-Dominik Braun <lars@6xq.net> writes:

Toggle quote (19 lines)
> Hi Sarah,
>
>> Is the Khronos Group one better, such that there's no reason to keeping
>> ocl-icd? (The README for ocl-icd states "[t]his package aims at
>> creating an Open Source alternative to vendor specific OpenCL ICD
>> loaders." Is the Khronos Group one similarly not vendor-specific?)
> I’m not really sure which one is “better”, but the Khronos-loader
> is vendor-independent like ocl-icd, so there’s no real reason to
> keep two imho.
>
>> If so, would you consider replacing ocl-icd with it in
>> core-updates-frozen, since it and its dependents are currently broken?
> Ludovic actually merged master into core-updates-frozen yesterday, so
> this issue should be resolved. Unfortunately the CI is going to take
> some time to catch up, so we don’t know yet whether that was successful.
>
> Cheers,
> Lars

Since we already have opencl-icd-loader deprecating ocl-icd in the
frozen branch (see commit 4d1157fca7), let's drop this change for now.

Thank you,

Closing.

Maxim
Closed
?