[PATCH] gnu: bc: Fix readline support.

  • Done
  • quality assurance status badge
Details
2 participants
  • dftxbs3e
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
dftxbs3e
Severity
normal
D
D
dftxbs3e wrote on 1 Dec 2020 02:21
(address . guix-patches@gnu.org)
60731725a08a956c8f8128eb1c26baa526ff4671.camel@free.fr
Hello!

Someone on IRC complained they could not use arrow keys in GNU Guix's
bc, turns out there was a bug.

Thank you!
From 85566761f612330be749e05f15eda6e62b8891c8 Mon Sep 17 00:00:00 2001
From: John Doe <dftxbs3e@free.fr>
Date: Tue, 1 Dec 2020 02:15:20 +0100
Subject: [PATCH] gnu: bc: Fix readline support.

--with-readline is given to configure but there's no readline input
present so it is not effective. Probably bc's configure should fail when
that is the case but that's another story.

* gnu/packages/albegra.scm (bc)[inputs]: Add readline.
---
gnu/packages/algebra.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 5b391449a0..ea2ec6f1ef 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -710,6 +710,8 @@ binary.")
"0amh9ik44jfg66csyvf4zz1l878c4755kjndq9j0270akflgrbb2"))
(patches (search-patches "bc-fix-cross-compilation.patch"))))
(build-system gnu-build-system)
+ (inputs
+ `(("readline" ,readline)))
(native-inputs
`(("automake" ,automake)
("autoconf" ,autoconf)
--
2.28.0
D
D
dftxbs3e wrote on 1 Dec 2020 02:31
(address . 44977@debbugs.gnu.org)
4fddf8d02cdc75a6e1ada39385702f68f80f189f.camel@free.fr
Fix typo in path.
From ba427730bb61e7d8270a3c71ce36f631d8227bbd Mon Sep 17 00:00:00 2001
From: John Doe <dftxbs3e@free.fr>
Date: Tue, 1 Dec 2020 02:15:20 +0100
Subject: [PATCH] gnu: bc: Fix readline support.

--with-readline is given to configure but there's no readline input
present so it is not effective. Probably bc's configure should fail when
that is the case but that's another story.

* gnu/packages/algebra.scm (bc)[inputs]: Add readline.
---
gnu/packages/algebra.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 5b391449a0..ea2ec6f1ef 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -710,6 +710,8 @@ binary.")
"0amh9ik44jfg66csyvf4zz1l878c4755kjndq9j0270akflgrbb2"))
(patches (search-patches "bc-fix-cross-compilation.patch"))))
(build-system gnu-build-system)
+ (inputs
+ `(("readline" ,readline)))
(native-inputs
`(("automake" ,automake)
("autoconf" ,autoconf)
--
2.28.0
T
T
Tobias Geerinckx-Rice wrote on 1 Dec 2020 02:39
gnu: bc: Fix readline support.
(address . 44977-done@debbugs.gnu.org)
877dq2wbho.fsf@nckx
Pushed as e76867e285710d06b319145e0acdb6208e1af811.

Thanks!

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCX8We0w0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15BXgA/A7HRmR8rJaQJAsbiv++GVCkslrdjqgVl/POj/vC
B2pwAP0W0K985nWDpnNw0OsqRiiUKcu8dtFmZm/xr9lRD0ovAQ==
=RAGj
-----END PGP SIGNATURE-----

Closed
?