Poezio

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Raghav Gururajan
Owner
unassigned
Submitted by
Raghav Gururajan
Severity
normal
R
R
Raghav Gururajan wrote on 11 Sep 2020 20:26
(address . guix-patches@gnu.org)(address . dannym@scratchpost.org)
4545758a-5330-7b09-39e3-6145c3723d6b@disroot.org
Hello Guix!

Please find the attached patches to add Poezio into Guix.

Regards,
RG.
From 460621aba2789d2986649d9a5dcc159aa48d4b6e Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 11 Sep 2020 11:23:35 -0400
Subject: [PATCH 1/3] gnu: Add python-slixmpp.

* gnu/packages/python-xyz.scm (python-slixmpp): New variable.
---
gnu/packages/python-xyz.scm | 69 +++++++++++++++++++++++--------------
1 file changed, 43 insertions(+), 26 deletions(-)

Toggle diff (99 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ff8fc55aed..305f16993a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -123,6 +123,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gnupg)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages graphics)
#:use-module (gnu packages gsasl)
@@ -134,6 +135,7 @@
#:use-module (gnu packages kerberos)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libffi)
+ #:use-module (gnu packages libidn)
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
#:use-module (gnu packages man)
@@ -188,35 +190,50 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
-(define-public python-tenacity
+(define-public python-slixmpp
(package
- (name "python-tenacity")
- (version "6.1.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "tenacity" version))
- (sha256
- (base32
- "1j36v9fcpmmd4985ix0cwnvcq71rkrn5cjiiv0id9vkl4kpxh0gv"))))
+ (name "python-slixmpp")
+ (version "1.5.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://lab.louiz.org/poezio/slixmpp.git")
+ (commit
+ (string-append "slix-" version))))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32 "15mqxcws14bjvh5jcfwl86zsvrymkdw3ya07vb44md7vfnsnclwx"))))
(build-system python-build-system)
- (native-inputs
- `(("python-setuptools-scm" ,python-setuptools-scm)
- ("python-sphinx" ,python-sphinx)
- ("python-tornado" ,python-tornado)
- ("python-pytest" ,python-pytest)))
- (propagated-inputs
- `(("python-six" ,python-six)))
(arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "pytest")
- #t)))))
- (home-page "https://github.com/jd/tenacity")
- (synopsis "Retrying library for python")
- (description "Tenacity is a general-purpose python library to simplify the
-task of adding retry behavior to just about anything.")
- (license license:asl2.0)))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* "setup.py"
+ (("'CC', 'cc'")
+ "'CC', 'gcc'"))
+ #t)))))
+ (native-inputs
+ `(("gnupg" ,gnupg)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("aiodns" ,python-aiodns)
+ ("aiohttp" ,python-aiohttp)
+ ("cython" ,python-cython)
+ ("libidn" ,libidn)
+ ("pyasn1" ,python-pyasn1)
+ ("pyasn1-modules" ,python-pyasn1-modules)
+ ("python" ,python)))
+ (synopsis "XMPP Library")
+ (description "Slixmpp is a XMPP library for Python 3.7+. It is a fork of
+SleekXMPP. Its goal is to only rewrite the core of the library (the low level
+socket handling, the timers, the events dispatching) in order to remove all
+threads.")
+ (home-page "https://lab.louiz.org/poezio/slixmpp")
+ (license license:expat)))
(define-public python-colorlog
(package
--
2.28.0
From ae59dca506da9faa5be69ba65bc3a70c14f64267 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 11 Sep 2020 12:45:24 -0400
Subject: [PATCH 2/3] gnu: Add python-potr.

* gnu/packages/python-crypto.scm (python-potr): New variable.
---
gnu/packages/python-crypto.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 76f2ba18e1..cfc64e4b45 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -64,6 +64,30 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (srfi srfi-1))
+(define-public python-potr
+ (package
+ (name "python-potr")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/python-otr/pure-python-otr.git")
+ (commit version)))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32 "1hzw6h01fm216nmipyylgz0zybd80w1xsk12m7djycnhqrnrvvv1"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("pycrypto" ,python-pycrypto)))
+ (synopsis "Python OTR Implementation")
+ (description "Python OTR is an Off-The-Record Protocol Implementation in
+Python. It does not bind to libotr.")
+ (home-page "https://github.com/python-otr/pure-python-otr")
+ (license license:lgpl3)))
+
(define-public python-base58
(package
(name "python-base58")
--
2.28.0
From 0945fb6c1e784dbdf8e62f5034316594bf7564b6 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 11 Sep 2020 14:04:08 -0400
Subject: [PATCH 3/3] gnu: Add poezio.

* gnu/packages/messaging.scm (poezio): New variable.
---
gnu/packages/messaging.scm | 59 ++++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)

Toggle diff (86 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 1cb9c01942..ae9f73dcb7 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -80,6 +80,7 @@
#:use-module (gnu packages lua)
#:use-module (gnu packages man)
#:use-module (gnu packages markup)
+ #:use-module (gnu packages mpd)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages networking)
#:use-module (gnu packages pcre)
@@ -94,6 +95,7 @@
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tcl)
#:use-module (gnu packages texinfo)
@@ -120,6 +122,63 @@
#:use-module (guix packages)
#:use-module (guix utils))
+(define-public poezio
+ (package
+ (name "poezio")
+ (version "0.13.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://lab.louiz.org/poezio/poezio.git")
+ (commit
+ (string-append "v" version))))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32 "041y61pcbdb86s04qwp8s1g6bp84yskc7vdizwpi2hz18y01x5fy"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* "setup.py"
+ (("'CC', 'cc'")
+ "'CC', 'gcc'"))
+ #t)))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("setuptools" ,python-setuptools)
+ ("sphinx" ,python-sphinx)))
+ (inputs
+ `(("aiodns" ,python-aiodns)
+ ("aiohttp" ,python-aiohttp)
+ ("cython" ,python-cython)
+ ("mpd2" ,python-mpd2)
+ ("potr" ,python-potr)
+ ("pyasn1" ,python-pyasn1)
+ ("pyasn1-modules" ,python-pyasn1-modules)
+ ("pycares" ,python-pycares)
+ ("pygments" ,python-pygments)
+ ("pyinotify" ,python-pyinotify)
+ ("python" ,python)
+ ("qrcode" ,python-qrcode)
+ ("slixmpp" ,python-slixmpp)))
+ (synopsis "Console Jabber/XMPP Client")
+ (description "Poezio is a free console XMPP client (the protocol on which
+the Jabber IM network is built).
+Its goal is to let you connect very easily (no account creation needed) to the
+network and join various chatrooms, immediately. It tries to look like the
+most famous IRC clients (weechat, irssi, etc). Many commands are identical and
+you won't be lost if you already know these clients. Configuration can be
+made in a configuration file or directly from the client.
+You'll find the light, fast, geeky and anonymous spirit of IRC while using a
+powerful, standard and open protocol.")
+ (home-page "https://poez.io/en/")
+ (license license:zlib)))
+
(define-public libotr
(package
(name "libotr")
--
2.28.0
Attachment: signature.asc
R
R
Raghav Gururajan wrote on 11 Sep 2020 20:36
Poezio (Revised Patches)
(address . 43346@debbugs.gnu.org)
07633e0e-9f1d-1cef-045b-64ee12aa52ec@disroot.org

From 9100b40377fff4b6611951164d1c2f06f0d8368a Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 11 Sep 2020 14:34:02 -0400
Subject: [PATCH 1/3] gnu: Add python-slixmpp.

* gnu/packages/python-xyz.scm (python-slixmpp): New variable.
---
gnu/packages/python-xyz.scm | 47 +++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (74 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ff8fc55aed..029b0fa2e7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -123,6 +123,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gnupg)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages graphics)
#:use-module (gnu packages gsasl)
@@ -134,6 +135,7 @@
#:use-module (gnu packages kerberos)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libffi)
+ #:use-module (gnu packages libidn)
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
#:use-module (gnu packages man)
@@ -188,6 +190,51 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public python-slixmpp
+ (package
+ (name "python-slixmpp")
+ (version "1.5.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://lab.louiz.org/poezio/slixmpp.git")
+ (commit
+ (string-append "slix-" version))))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32 "15mqxcws14bjvh5jcfwl86zsvrymkdw3ya07vb44md7vfnsnclwx"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* "setup.py"
+ (("'CC', 'cc'")
+ "'CC', 'gcc'"))
+ #t)))))
+ (native-inputs
+ `(("gnupg" ,gnupg)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("aiodns" ,python-aiodns)
+ ("aiohttp" ,python-aiohttp)
+ ("cython" ,python-cython)
+ ("libidn" ,libidn)
+ ("pyasn1" ,python-pyasn1)
+ ("pyasn1-modules" ,python-pyasn1-modules)
+ ("python" ,python)))
+ (synopsis "XMPP Library")
+ (description "Slixmpp is a XMPP library for Python 3.7+. It is a fork of
+SleekXMPP. Its goal is to only rewrite the core of the library (the low level
+socket handling, the timers, the events dispatching) in order to remove all
+threads.")
+ (home-page "https://lab.louiz.org/poezio/slixmpp")
+ (license license:expat)))
+
(define-public python-tenacity
(package
(name "python-tenacity")
--
2.28.0
From 6f853b884744cf21ac3c2ae6f19199d8511b1573 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 11 Sep 2020 12:45:24 -0400
Subject: [PATCH 2/3] gnu: Add python-potr.

* gnu/packages/python-crypto.scm (python-potr): New variable.
---
gnu/packages/python-crypto.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 76f2ba18e1..cfc64e4b45 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -64,6 +64,30 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (srfi srfi-1))
+(define-public python-potr
+ (package
+ (name "python-potr")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/python-otr/pure-python-otr.git")
+ (commit version)))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32 "1hzw6h01fm216nmipyylgz0zybd80w1xsk12m7djycnhqrnrvvv1"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("pycrypto" ,python-pycrypto)))
+ (synopsis "Python OTR Implementation")
+ (description "Python OTR is an Off-The-Record Protocol Implementation in
+Python. It does not bind to libotr.")
+ (home-page "https://github.com/python-otr/pure-python-otr")
+ (license license:lgpl3)))
+
(define-public python-base58
(package
(name "python-base58")
--
2.28.0
From e4350beb99ebf4e91091507a12fbb40c01c7c430 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 11 Sep 2020 14:04:08 -0400
Subject: [PATCH 3/3] gnu: Add poezio.

* gnu/packages/messaging.scm (poezio): New variable.
---
gnu/packages/messaging.scm | 59 ++++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)

Toggle diff (86 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 1cb9c01942..ae9f73dcb7 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -80,6 +80,7 @@
#:use-module (gnu packages lua)
#:use-module (gnu packages man)
#:use-module (gnu packages markup)
+ #:use-module (gnu packages mpd)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages networking)
#:use-module (gnu packages pcre)
@@ -94,6 +95,7 @@
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tcl)
#:use-module (gnu packages texinfo)
@@ -120,6 +122,63 @@
#:use-module (guix packages)
#:use-module (guix utils))
+(define-public poezio
+ (package
+ (name "poezio")
+ (version "0.13.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://lab.louiz.org/poezio/poezio.git")
+ (commit
+ (string-append "v" version))))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32 "041y61pcbdb86s04qwp8s1g6bp84yskc7vdizwpi2hz18y01x5fy"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* "setup.py"
+ (("'CC', 'cc'")
+ "'CC', 'gcc'"))
+ #t)))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("setuptools" ,python-setuptools)
+ ("sphinx" ,python-sphinx)))
+ (inputs
+ `(("aiodns" ,python-aiodns)
+ ("aiohttp" ,python-aiohttp)
+ ("cython" ,python-cython)
+ ("mpd2" ,python-mpd2)
+ ("potr" ,python-potr)
+ ("pyasn1" ,python-pyasn1)
+ ("pyasn1-modules" ,python-pyasn1-modules)
+ ("pycares" ,python-pycares)
+ ("pygments" ,python-pygments)
+ ("pyinotify" ,python-pyinotify)
+ ("python" ,python)
+ ("qrcode" ,python-qrcode)
+ ("slixmpp" ,python-slixmpp)))
+ (synopsis "Console Jabber/XMPP Client")
+ (description "Poezio is a free console XMPP client (the protocol on which
+the Jabber IM network is built).
+Its goal is to let you connect very easily (no account creation needed) to the
+network and join various chatrooms, immediately. It tries to look like the
+most famous IRC clients (weechat, irssi, etc). Many commands are identical and
+you won't be lost if you already know these clients. Configuration can be
+made in a configuration file or directly from the client.
+You'll find the light, fast, geeky and anonymous spirit of IRC while using a
+powerful, standard and open protocol.")
+ (home-page "https://poez.io/en/")
+ (license license:zlib)))
+
(define-public libotr
(package
(name "libotr")
--
2.28.0
Attachment: signature.asc
D
D
Danny Milosavljevic wrote on 12 Sep 2020 02:41
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)(address . 43346-done@debbugs.gnu.org)
20200912024131.373f68a4@scratchpost.org
Pushed to guix master with lots of changes to what are inputs, propagated-inputs
and native-inputs.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl9cGTsACgkQ5xo1VCww
uqXnpwgAotwl0AH/dO9ftyMLbwkLlM1tZ6PIvfOajw+aEA+gRQ9Y1b2qmorlKwch
KtRcNL9SGQGBJQzmlMlp1UDlhcJh0VoD1/PMxSLRajkC1FJR7cR9AF0+p3bV7ees
tAwaF5CdzR8T5Q3DUvCf380V5i+hW889ePiUBy0Nfd9AxU8wtRJVIcLR4A+YlBoq
a+nHmcQUNpEaGM/PgJ5CvtBKD93hTyV+9v68ca1XmYLDj9vCpXzE+jb8Mw13bYz3
cizEhGCmB36P5Re9Bn6TvMfgoj3nmg8aeaBYSARiN9COsRuy/YsFII1jCbPBozGW
62IsI70CRFlhMP1PoGLILXR7sQDKeA==
=faHN
-----END PGP SIGNATURE-----


Closed
R
R
Raghav Gururajan wrote on 12 Sep 2020 14:06
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 43346-done@debbugs.gnu.org)
3bbb8349-fd68-3c2b-53b4-8b258d54ad87@disroot.org
Hi Danny!

Toggle quote (3 lines)
> Pushed to guix master with lots of changes to what are inputs, propagated-inputs
> and native-inputs.

Thanks so much.

I had to make some changes to poezio, based on your changes. Could you
push the attached patches please?

Regards,
RG.
From 1a44fd4f34b0e07e81459ad63651428a74c1ecc3 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sat, 12 Sep 2020 07:36:24 -0400
Subject: [PATCH 85/86] gnu: poezio: Add missing dependencies.

* gnu/packages/messaging.scm (poezio): Add missing dependencies.
[native-inputs]: Add python-cython.
[inputs]: Add python-aiodns, python-aiohttp, python-cffi and python-pycares.

The above changes satisfy dependencies mentioned in setup.py, requirements.txt
and requirements-plugins.txt.
---
gnu/packages/messaging.scm | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 1f41f0cb8b..8f1c71563c 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -150,16 +150,20 @@
#t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("python-cython" ,python-cython)
("python-setuptools" ,python-setuptools)
("python-sphinx" ,python-sphinx)))
(inputs
- `(("python-mpd2" ,python-mpd2)
+ `(("python-aiodns" ,python-aiodns)
+ ("python-aiohttp" ,python-aiohttp)
+ ("python-cffi" ,python-cffi)
+ ("python-mpd2" ,python-mpd2)
("python-potr" ,python-potr)
("python-pyasn1" ,python-pyasn1)
("python-pyasn1-modules" ,python-pyasn1-modules)
+ ("python-pycares" ,python-pycares)
("python-pygments" ,python-pygments)
("python-pyinotify" ,python-pyinotify)
- ;("python" ,python)
("python-qrcode" ,python-qrcode)
("python-slixmpp" ,python-slixmpp)))
(synopsis "Console Jabber/XMPP Client")
--
2.28.0
From 5a6ae94b2fafad1148f21a617295b941bc206851 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sat, 12 Sep 2020 07:57:17 -0400
Subject: [PATCH 86/86] gnu: poezio: Propagated certain dependencies.

* gnu/packages/messaging.scm (poezio): Propagated certain dependencies.
[inputs]: Move python-aiodns, python-cffi, python-potr, python-pyasn1,
python-pyasn1-modules, python-pyinotify and python-slixmpp to ...
[propagated-inputs]: ... here.

The above changes satisfy install.requires and extras.require sections
of setup.py.
---
gnu/packages/messaging.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 8f1c71563c..5f4e13365f 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -154,17 +154,18 @@
("python-setuptools" ,python-setuptools)
("python-sphinx" ,python-sphinx)))
(inputs
+ `(("python-aiohttp" ,python-aiohttp)
+ ("python-mpd2" ,python-mpd2)
+ ("python-pycares" ,python-pycares)
+ ("python-pygments" ,python-pygments)
+ ("python-qrcode" ,python-qrcode)))
+ (propagated-inputs
`(("python-aiodns" ,python-aiodns)
- ("python-aiohttp" ,python-aiohttp)
("python-cffi" ,python-cffi)
- ("python-mpd2" ,python-mpd2)
("python-potr" ,python-potr)
("python-pyasn1" ,python-pyasn1)
("python-pyasn1-modules" ,python-pyasn1-modules)
- ("python-pycares" ,python-pycares)
- ("python-pygments" ,python-pygments)
("python-pyinotify" ,python-pyinotify)
- ("python-qrcode" ,python-qrcode)
("python-slixmpp" ,python-slixmpp)))
(synopsis "Console Jabber/XMPP Client")
(description "Poezio is a free console XMPP client (the protocol on which
--
2.28.0
Attachment: signature.asc
Closed
D
D
Danny Milosavljevic wrote on 12 Sep 2020 16:19
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)(address . 43346@debbugs.gnu.org)
20200912161915.43ea7f24@scratchpost.org
Hi RG,

On Sat, 12 Sep 2020 08:06:05 -0400
Raghav Gururajan <raghavgururajan@disroot.org> wrote:

Toggle quote (3 lines)
> I had to make some changes to poezio, based on your changes. Could you
> push the attached patches please?

... why?

I've checked the source code of poezio and it does not use aiodns, aiohttp.

In order to find that out:

$ guix build python-aiodns

Check resulting directory to find
/gnu/store/8bzk4dwhhbblz8gky9hzdnzjlsi1nk7v-python-aiodns-1.1.1/lib/python3.8/site-packages/aiodns/__init__.py

That means a user of the library would have to do

from aiodns import *

or

import aiodns
.

So I grepped the whole source code of poezio, and it doesn't do that. Hence
it is not a direct input.

It is a propagated-input in a dependency, which indeed does do the import.

You can't really trust what upstream says here. Almost no package manager
has non-propagated inputs, so of course they wouldn't be saying "the input
such and such is propagated, and the input such and such is not propagated".

Thus you have to check it yourself.

Could you do so with the other dependencies before adding them?

Thanks.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl9c2OMACgkQ5xo1VCww
uqVw6Af9EMZKnsl66FohjRL7mXVGIYKvJ1D6DZYnoi/CjjCMXotBZp3v/+H5tASR
ikGRM6yd850Y6rIA0lcEr96Wezjhj94kdliVquZ9UgxL4syHgyUgymELHJIEgaRe
Kz4L74Fiecl6ctvRfBiBJqQlixlXWI0YTqRC+dzjxwwsvqj27wJBMjMTQDB+Junb
tlQrSp0R+FkbSJYtQPrPLL/BF4tPhZJgrfn+KdOvHHysu9apYSSVUBNq+yVn8G7B
KZw6jdBkqwYZw5uol8XkSITr2v3QpxnfubzLDjNxeiaZMq1i20fWerwO6zg8OnTI
jiGxrdJfiF/MyMPwaMufSAHUiF+ZRA==
=svtL
-----END PGP SIGNATURE-----


R
R
Raghav Gururajan wrote on 12 Sep 2020 16:22
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 43346@debbugs.gnu.org)
29e9ca7b-a60f-2432-f26a-4832a1d17047@disroot.org
Hi Danny!

Toggle quote (34 lines)
>
> ... why?
>
> I've checked the source code of poezio and it does not use aiodns, aiohttp.
>
> In order to find that out:
>
> $ guix build python-aiodns
>
> Check resulting directory to find
> /gnu/store/8bzk4dwhhbblz8gky9hzdnzjlsi1nk7v-python-aiodns-1.1.1/lib/python3.8/site-packages/aiodns/__init__.py
>
> That means a user of the library would have to do
>
> from aiodns import *
>
> or
>
> import aiodns
> .
>
> So I grepped the whole source code of poezio, and it doesn't do that. Hence
> it is not a direct input.
>
> It is a propagated-input in a dependency, which indeed does do the import.
>
> You can't really trust what upstream says here. Almost no package manager
> has non-propagated inputs, so of course they wouldn't be saying "the input
> such and such is propagated, and the input such and such is not propagated".
>
> Thus you have to check it yourself.
>
> Could you do so with the other dependencies before adding them?

Hmm. When I grep the source, they were mentioned in requirements.txt and
requirements-plugins.txt. Also, the setup.py has install_requires and
plugins_require sections, which are similar to required section in .pc
files right?

Regards,
RG.
Attachment: signature.asc
?