Thanks for the report.

tsmish <tsymsh@gmail.com> ezt írta (időpont: 2020. febr. 2., Vas 18:57):
Steps to reproduce:
1. Make file ~/.config/vis/visrc.lua with following text:
```
require('vis')

vis.events.subscribe(vis.events.INIT, function()
    vis:command('qall')
end)
```
2. Open vis

vis should immediately close on startup, but it doesn't.

It happens because package defines $VIS_PATH search path to directory
which contains example visrc.lua file and $VIS_PATH is highest
priority directory according to man page.

Suggestions:
1. Remove or rename example visrc.lua in share/vis
I would go for renaming it like visrc.lua.example, or similar.

Would you like to propose a patch?

2. Remove $VIS_PATH search path from package. This shouldn't break
anything, as it seems share/vis is in later resolution path.