Add a guide to the guix cookbook about setting up sway.

  • Done
  • quality assurance status badge
Details
2 participants
  • jbranso
  • Leo Famulari
Owner
unassigned
Submitted by
jbranso
Severity
normal
J
J
jbranso wrote on 24 Jan 2020 18:03
(address . guix-patches@gnu.org)
7a8627b16fee4c4609d38e87f260d15f@dismail.de
Hello,

I've created a brief and simple guide for users to set up sway. It
would probably be better for someone to create a sway-service-type
instead, but until that happens users need to configure sway manually.

In the guide, I include a code snippet of a minimal operating
configuration for sway. I tested the code last night with guix system
vm, and it did produce a run-able vm.

I hope this helps someone!

Thanks,

Joshua
Attachment: file
L
L
Leo Famulari wrote on 15 Mar 2020 20:54
(name . jbranso--- via Guix-patches via)(address . guix-patches@gnu.org)(address . 39271@debbugs.gnu.org)
20200315195404.GA27602@jasmine.lan
On Fri, Jan 24, 2020 at 05:03:27PM +0000, jbranso--- via Guix-patches via wrote:
Toggle quote (10 lines)
> Hello,
>
> I've created a brief and simple guide for users to set up sway. It
> would probably be better for someone to create a sway-service-type
> instead, but until that happens users need to configure sway manually.
>
> In the guide, I include a code snippet of a minimal operating
> configuration for sway. I tested the code last night with guix system
> vm, and it did produce a run-able vm.

Thanks for this!

I wonder, are you using sway on Guix with GDM? I think we should
establish whether or not GDM works with sway in Guix, and then base the
recipe on that.
J
J
Joshua Branson wrote on 2 Jun 2020 02:38
Re: Status: Add a guide to the guix cookbook about setting up sway.
(name . bug#39271)(address . 39271@debbugs.gnu.org)
87v9kaz4h5.fsf@dismail.de
I created an updated patch.

According to this email thread, GDM does not work with sway.


Most users use SSDM. I do not know how to get SSDM to work with sway.
Essentially I use the dvorak keyboard layout, and I do not know how to
get SSDM to use the dvorak layout to login. BUT I should probably send
an updated patch to show one how to use sway with SSDM, because most
users use qwerty anyway...until then...

For now, here is just an updated patch that moves the guix cookbook bit
to the proper spot: "Customizing a Window Manager".

Thanks,



--
Joshua Branson
Sent from Emacs and Gnus
J
J
Joshua Branson wrote on 2 Jun 2020 06:54
Re: [bug#39271] Status: Add a guide to the guix cookbook about setting up sway.
(name . bug#39271)(address . 39271@debbugs.gnu.org)
87o8q2ysmw.fsf@dismail.de
From 81cf42cebd6697f16a6b760618bd1a2265c8844e Mon Sep 17 00:00:00 2001
From: Joshua Branson <jbranso@dismail.de>
Date: Mon, 1 Jun 2020 20:12:15 -0400
Subject: [PATCH] doc: Add a sway configuration example.

* doc/guix-cookbook.texi (Sway): Add a sway configuration example.
---
doc/guix-cookbook.texi | 94 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 94 insertions(+)

Toggle diff (107 lines)
diff --git a/doc/guix-cookbook.texi b/doc/guix-cookbook.texi
index 8651bc4429..a2ed25fdfc 100644
--- a/doc/guix-cookbook.texi
+++ b/doc/guix-cookbook.texi
@@ -1617,6 +1617,100 @@ Then you need to add the following code to a StumpWM configuration file
(set-font (make-instance 'xft:font :family "DejaVu Sans Mono" :subfamily "Book" :size 11))
@end lisp
+@node Sway
+@subsection Sway
+@cindex Sway
+
+Sway is a tiling window manager written for wayland. Since sway does not
+officially support login managers, some users may need to execute
+"sway" at the virtual console after login. However, according to Sway's
+developers, the GNOME display manager, usually works to start sway.
+
+To get started using sway, install sway, and the configuration
+file.
+
+@example
+$ guix package -i sway wget
+$ wget https://raw.githubusercontent.com/swaywm/sway/master/config.in
+$ mkdir -p ~/.config/sway/
+$ mv config.in ~/.config/sway/config
+# optionally remove wget
+$ guix package -r wget
+@end example
+
+Sway supports several configuration options including your default
+terminal and keyboard layout. Read @code{man sway} for details.
+
+You will need to use @code{%desktop-services} to run sway. Try to login
+into sway with gdm. If gdm does not work then try to remove
+@code{gdm-service-type} like so.
+
+@lisp
+ (use-modules (gnu) (guix)
+ (srfi srfi-1))
+
+ (use-service-modules desktop xorg)
+
+ (operating-system
+ (host-name "dobby")
+ (timezone "America/Indiana/Indianapolis")
+ (locale "en_US.utf8")
+ ;; Boot in "legacy" BIOS mode, assuming /dev/sdX is the
+ ;; target hard disk, and "my-root" is the label of the target
+ ;; root file system.
+ (bootloader (bootloader-configuration
+ (bootloader grub-bootloader)
+ (target "/dev/sda")))
+
+ (file-systems
+ (cons* (file-system
+ (mount-point "/")
+ (device "/dev/sda1")
+ (type "btrfs"))
+ %base-file-systems))
+ (users (cons*
+ (user-account
+ (name "username")
+ (comment "user name")
+ (group "users")
+ (home-directory "/home/user")
+ (supplementary-groups
+ '("wheel" "netdev" "audio" "video")))
+ %base-user-accounts))
+
+ ;; Globally-installed packages.
+ (packages (append (map specification->package
+ '("nss-certs"))
+ %base-packages))
+
+ (services
+ (cons*
+ (modify-services
+ (remove (lambda (service)
+ (member (service-kind service)
+ (list
+ gdm-service-type
+ )))
+ %desktop-services) ;;end of remove services
+ ))))
+
+@end lisp
+
+You can now login to sway after login to the virtual console by typing
+
+@example
+$ sway
+@end example
+
+You can also set up sway to autostart after you login. Add this to your
+~/.bash_profile
+
+@example
+if [[ -z $DISPLAY ]] && [[ $(tty) = /dev/tty1 ]]; then
+ XKB_DEFAULT_LAYOUT=us exec sway
+fi
+@end example
+
@node Session lock
@subsection Session lock
@cindex sessionlock
--
2.26.0
J
J
Joshua Branson wrote on 8 Jul 2022 05:19
control message for bug #39271
(address . control@debbugs.gnu.org)
6ad6a47073ebaf99@smtp1.dismail.de
close 39271
quit
?