* gnu/packages/finance.scm (electron-cash): Update to 4.0.10.
[inputs]: Add python-dateutil.
[documentation]: Keep line width below 80.
---
gnu/packages/finance.scm | 17 +++++++++++------
1 file changed, 11 insertions(+), 6 deletions(-)
Toggle diff (53 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 960e3adeb3..1f2d9ada04 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -76,6 +76,7 @@
#:use-module (gnu packages sphinx)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages textutils)
+ #:use-module (gnu packages time)
#:use-module (gnu packages tls)
#:use-module (gnu packages upnp)
#:use-module (gnu packages version-control)
@@ -413,7 +414,7 @@ other machines/servers. Electrum does not download the Bitcoin blockchain.")
(package
(inherit electrum)
(name "electron-cash")
- (version "4.0.7")
+ (version "4.0.10")
(source
(origin
(method url-fetch)
@@ -424,20 +425,24 @@ other machines/servers. Electrum does not download the Bitcoin blockchain.")
".tar.gz"))
(sha256
(base32
- "0xswmr68cm1c77lzisi3z812jzqczm9dfrshfhdq42zz5kaz4gnn"))
+ "1rcywlma6hk52ymisx536jvkdwa73rhn1jxhsbs4wbvajl90w9s8"))
(modules '((guix build utils)))
(snippet
'(begin
;; Delete the bundled dependencies.
(delete-file-recursively "packages")
#t))))
+ (inputs
+ `(("python-dateutil" ,python-dateutil)
+ ,@(package-inputs electrum)))
(home-page "https://electroncash.org/")
(synopsis "Bitcoin Cash wallet")
(description
- "Electroncash is a lightweight Bitcoin Cash client, based on a client-server
-protocol. It supports Simple Payment Verification (SPV) and deterministic key
-generation from a seed. Your secret keys are encrypted and are never sent to
-other machines/servers. Electroncash does not download the Bitcoin Cash blockchain.")
+ "Electroncash is a lightweight Bitcoin Cash client, based on
+a client-server protocol. It supports Simple Payment Verification (SPV) and
+deterministic key generation from a seed. Your secret keys are encrypted and
+are never sent to other machines/servers. Electroncash does not download the
+Bitcoin Cash blockchain.")
(license license:expat)))
(define-public monero
--
2.23.0