[PATCH] gnu: electron-cash: Update to 4.0.10.

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Guillaume Le Vaillant
  • Ludovic Courtès
Owner
unassigned
Submitted by
Guillaume Le Vaillant
Severity
normal
G
G
Guillaume Le Vaillant wrote on 25 Oct 2019 11:35
(address . guix-patches@gnu.org)
20191025093555.27128-1-glv@posteo.net
Some icons are not showing properly in the application because it wants
PyQt 5.12.* and Guix only has PyQt 5.11.3 so far. The current packaged version
of electron-cash (4.0.7) also has this problem, but it doesn't tell the user
why. Anyway, it doesn't prevent the application from working (sending and
receiving transactions, etc).
G
G
Guillaume Le Vaillant wrote on 25 Oct 2019 11:35
(address . guix-patches@gnu.org)(name . Guillaume Le Vaillant)(address . glv@posteo.net)
20191025093555.27128-2-glv@posteo.net
* gnu/packages/finance.scm (electron-cash): Update to 4.0.10.
[inputs]: Add python-dateutil.
[documentation]: Keep line width below 80.
---
gnu/packages/finance.scm | 17 +++++++++++------
1 file changed, 11 insertions(+), 6 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 960e3adeb3..1f2d9ada04 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -76,6 +76,7 @@
#:use-module (gnu packages sphinx)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages textutils)
+ #:use-module (gnu packages time)
#:use-module (gnu packages tls)
#:use-module (gnu packages upnp)
#:use-module (gnu packages version-control)
@@ -413,7 +414,7 @@ other machines/servers. Electrum does not download the Bitcoin blockchain.")
(package
(inherit electrum)
(name "electron-cash")
- (version "4.0.7")
+ (version "4.0.10")
(source
(origin
(method url-fetch)
@@ -424,20 +425,24 @@ other machines/servers. Electrum does not download the Bitcoin blockchain.")
".tar.gz"))
(sha256
(base32
- "0xswmr68cm1c77lzisi3z812jzqczm9dfrshfhdq42zz5kaz4gnn"))
+ "1rcywlma6hk52ymisx536jvkdwa73rhn1jxhsbs4wbvajl90w9s8"))
(modules '((guix build utils)))
(snippet
'(begin
;; Delete the bundled dependencies.
(delete-file-recursively "packages")
#t))))
+ (inputs
+ `(("python-dateutil" ,python-dateutil)
+ ,@(package-inputs electrum)))
(home-page "https://electroncash.org/")
(synopsis "Bitcoin Cash wallet")
(description
- "Electroncash is a lightweight Bitcoin Cash client, based on a client-server
-protocol. It supports Simple Payment Verification (SPV) and deterministic key
-generation from a seed. Your secret keys are encrypted and are never sent to
-other machines/servers. Electroncash does not download the Bitcoin Cash blockchain.")
+ "Electroncash is a lightweight Bitcoin Cash client, based on
+a client-server protocol. It supports Simple Payment Verification (SPV) and
+deterministic key generation from a seed. Your secret keys are encrypted and
+are never sent to other machines/servers. Electroncash does not download the
+Bitcoin Cash blockchain.")
(license license:expat)))
(define-public monero
--
2.23.0
E
E
Efraim Flashner wrote on 25 Oct 2019 12:41
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 37919@debbugs.gnu.org)
20191025104130.GJ15460@E5400
On Fri, Oct 25, 2019 at 11:35:55AM +0200, Guillaume Le Vaillant wrote:
Toggle quote (3 lines)
> Some icons are not showing properly in the application because it wants
> PyQt 5.12.* and Guix only has PyQt 5.11.3 so far.

qt-5.12 and pyqt-5.12 are coming soon™ with the staging branch.

Toggle quote (6 lines)
> The current packaged version
> of electron-cash (4.0.7) also has this problem, but it doesn't tell the user
> why. Anyway, it doesn't prevent the application from working (sending and
> receiving transactions, etc).
>

If it already has the problem then I don't see it being a blocker. Are
you sure the new version doesn't want qt-5.13+? We haven't started with
that yet.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl2y0VoACgkQQarn3Mo9
g1EEfRAApVGcBqv4oQT2XaoAlPys+Fotqi/agzHr3gwa6sd9JkmAE0TavRM5fezb
9eI077/rgXBz3PAEHEfY9dndAsdJLxWmAVGZzeysfM6xWdktLYBBHVdp8TxDuqNK
FahHtLcgE14ektYtRhsIv+btIB1BAbvPi/xHYNDKH3+6Jtd2ObzfZTFRzv1bNF4X
D7T4+tthiQZ9ntvVMkxUnIXpeLB5i6W3AVga2Sw+iMjaHIAQRrlAVWSlfIedCzuT
Dn99jVVMvBM4agJmfOMrjUC1+vNIpRTWYGi3ABSzy1AZSOhS0tDlSESFu6FajugN
WaBPyYP3VEPeA0tyPiO5dkFzxCIiEIFMcbyAn3LmwUr3e5t+CG0MWMnfCwrK0SSe
pbbBEXlEv1Hv1M3WysNYkZxbCItAIV2GYjD3oFTxq1azZwFT4rGNI2lD7dcFDmfN
Cd1H+T3ofFST+iZd3PhkdxBWRFby/gmeATD0wz5J+x+88PTjT5VRhCg8+8STw9Rq
IdGry00RIGpXncvt0DP/DCFevO1uAElgFS+pV9qWhiX7WCi6/ggutfn8t2fnkT3Z
orqXsnN/ZYe+V3CKcgfxS0/CNQiHXdCv2VQ2jQ7Dk2jC6nqY+PUhNAbjjhLdps5M
uC8FENofDX5KmaaQ8C1KDmvaPnW1ai7WyXvIdU0VChDrLYs6fXk=
=+ajD
-----END PGP SIGNATURE-----


G
G
Guillaume Le Vaillant wrote on 25 Oct 2019 13:40
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 37919@debbugs.gnu.org)
871rv1dpdw.fsf@yamatai
Efraim Flashner skribis:

Toggle quote (4 lines)
> If it already has the problem then I don't see it being a blocker. Are
> you sure the new version doesn't want qt-5.13+? We haven't started with
> that yet.

Yes, when the program starts it shows the following warning:

Toggle snippet (7 lines)
Electron Cash on Linux requires PyQt5 5.12+.

You have version 5.11.3 installed.

Please upgrade otherwise you may experience font rendering issues
with emojis and other unicode characters used by Electron Cash.
L
G
G
Guillaume Le Vaillant wrote on 27 Nov 2019 11:20
(name . Ludovic Courtès)(address . ludo@gnu.org)
87y2w1k4c8.fsf@yamatai
Ludovic Courtès skribis:

Toggle quote (10 lines)
> Hello!
>
> What’s the conclusion regarding this upgrade? Should we apply it or
> not? :-)
>
> https://issues.guix.gnu.org/issue/37919
>
> TIA,
> Ludo’.

As there's been another release of electron-cash since, I think we could
close this issue, wait for the staging branch which has Qt 5.12 to be
merged, and make a new upgrade patch for electron-cash then.
L
L
Ludovic Courtès wrote on 28 Nov 2019 09:30
(name . Guillaume Le Vaillant)(address . glv@posteo.net)
87h82oz9m9.fsf@gnu.org
Hi Guillaume,

Guillaume Le Vaillant <glv@posteo.net> skribis:

Toggle quote (16 lines)
> Ludovic Courtès skribis:
>
>> Hello!
>>
>> What’s the conclusion regarding this upgrade? Should we apply it or
>> not? :-)
>>
>> https://issues.guix.gnu.org/issue/37919
>>
>> TIA,
>> Ludo’.
>
> As there's been another release of electron-cash since, I think we could
> close this issue, wait for the staging branch which has Qt 5.12 to be
> merged, and make a new upgrade patch for electron-cash then.

Sounds good, closing it!

I think we’ll all have to take care of ‘staging’, it needs more
attention. :-)

Thanks,
Ludo’.
Closed
?