[core-updates] Error building module-import-compiled

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Marius Bakke
  • Timothy Sample
Owner
unassigned
Submitted by
Timothy Sample
Severity
normal
T
T
Timothy Sample wrote on 18 Jul 2019 19:59
(address . bug-guix@gnu.org)
87k1cf5ilr.fsf@ngyro.com
Hi,

Whenever I try to build the following (i.e., using “guix build -f”)

(use-modules (guix gexp)
(guix modules))

(scheme-file
"test.scm"
(with-imported-modules (source-module-closure
'((gnu build file-systems)))
#~(values #t)))

it says:

-----
building /gnu/store/2gmxyxpfs0a2j6pcn9xagam6hczlvihb-module-import-compiled.drv...
[ 1/14] Loading './gnu/build/file-systems.scm'...
[ 2/14] Loading './gnu/system/file-systems.scm'...
[ 3/14] Loading './gnu/system/uuid.scm'...
[ 4/14] Loading './guix/build/bournish.scm'...
[ 5/14] Loading './guix/build/syscalls.scm'...
Backtrace:
11 (primitive-load "/gnu/store/qz6d59zqvdd5pj9hprk7sfjkpy3?")
In ice-9/eval.scm:
619:8 10 (_ #f)
In srfi/srfi-1.scm:
466:18 9 (fold #<procedure 7ffff5d2d520 at ice-9/eval.scm:336:1?> ?)
466:18 8 (fold #<procedure 7ffff54bc2c0 at ice-9/eval.scm:336:1?> ?)
466:18 7 (fold #<procedure 7ffff54c3dc0 at ice-9/eval.scm:336:1?> ?)
In ice-9/eval.scm:
619:8 6 (_ #(#(#<directory (guix build utils) 7ffff6f53500>) # ?))
In ice-9/boot-9.scm:
2312:4 5 (save-module-excursion _)
In unknown file:
4 (primitive-load "./guix/build/syscalls.scm")
In ice-9/eval.scm:
619:8 3 (_ #f)
In ice-9/boot-9.scm:
2071:24 2 (call-with-deferred-observers #<procedure 7ffff50e4700 ?>)
260:13 1 (for-each #<procedure 7ffff50e4480 at ice-9/boot-9.scm?> ?)
In unknown file:
0 (scm-error misc-error #f "~A ~S" ("re-exporting loc?" ?) ?)

ERROR: In procedure scm-error:
re-exporting local variable: AT_SYMLINK_NOFOLLOW
builder for `/gnu/store/2gmxyxpfs0a2j6pcn9xagam6hczlvihb-module-import-compiled.drv' failed with exit code 1
-----

Importing “(guix build syscalls)” by itself using
“with-imported-modules” works fine.

This is needed when building the Shepherd service for mounting file
systems, so it prevents me from building any systems on core-updates
(for example, building a VM or reconfiguring). I did try (just to be
sure) running “make clean-go” and then recompiling, but it didn’t help.


-- Tim
M
M
Marius Bakke wrote on 18 Jul 2019 21:38
877e8f5e16.fsf@devup.no
Timothy Sample <samplet@ngyro.com> writes:

Toggle quote (57 lines)
> Hi,
>
> Whenever I try to build the following (i.e., using “guix build -f”)
>
> (use-modules (guix gexp)
> (guix modules))
>
> (scheme-file
> "test.scm"
> (with-imported-modules (source-module-closure
> '((gnu build file-systems)))
> #~(values #t)))
>
> it says:
>
> -----
> building /gnu/store/2gmxyxpfs0a2j6pcn9xagam6hczlvihb-module-import-compiled.drv...
> [ 1/14] Loading './gnu/build/file-systems.scm'...
> [ 2/14] Loading './gnu/system/file-systems.scm'...
> [ 3/14] Loading './gnu/system/uuid.scm'...
> [ 4/14] Loading './guix/build/bournish.scm'...
> [ 5/14] Loading './guix/build/syscalls.scm'...
> Backtrace:
> 11 (primitive-load "/gnu/store/qz6d59zqvdd5pj9hprk7sfjkpy3?")
> In ice-9/eval.scm:
> 619:8 10 (_ #f)
> In srfi/srfi-1.scm:
> 466:18 9 (fold #<procedure 7ffff5d2d520 at ice-9/eval.scm:336:1?> ?)
> 466:18 8 (fold #<procedure 7ffff54bc2c0 at ice-9/eval.scm:336:1?> ?)
> 466:18 7 (fold #<procedure 7ffff54c3dc0 at ice-9/eval.scm:336:1?> ?)
> In ice-9/eval.scm:
> 619:8 6 (_ #(#(#<directory (guix build utils) 7ffff6f53500>) # ?))
> In ice-9/boot-9.scm:
> 2312:4 5 (save-module-excursion _)
> In unknown file:
> 4 (primitive-load "./guix/build/syscalls.scm")
> In ice-9/eval.scm:
> 619:8 3 (_ #f)
> In ice-9/boot-9.scm:
> 2071:24 2 (call-with-deferred-observers #<procedure 7ffff50e4700 ?>)
> 260:13 1 (for-each #<procedure 7ffff50e4480 at ice-9/boot-9.scm?> ?)
> In unknown file:
> 0 (scm-error misc-error #f "~A ~S" ("re-exporting loc?" ?) ?)
>
> ERROR: In procedure scm-error:
> re-exporting local variable: AT_SYMLINK_NOFOLLOW
> builder for `/gnu/store/2gmxyxpfs0a2j6pcn9xagam6hczlvihb-module-import-compiled.drv' failed with exit code 1
> -----
>
> Importing “(guix build syscalls)” by itself using
> “with-imported-modules” works fine.
>
> This is needed when building the Shepherd service for mounting file
> systems, so it prevents me from building any systems on core-updates
> (for example, building a VM or reconfiguring). I did try (just to be
> sure) running “make clean-go” and then recompiling, but it didn’t help.

Reverting 456c7ade095cce96f47389c37a4fe3b0390047fd makes the problem
disappear.

I don't really understand why, though.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl0wyrUACgkQoqBt8qM6
VPoltgf/dVW6ansz7+gMkqUSm6Sb9idfJea3JovDbg7aMHVakae3ue4k78fxw5IA
LuKI0tvfyjaps3CAjRerHnJDjHe3p3MUouozEtyuI01u1GmHfpTkd+J6WK5P9WlA
7BiuCb0Kmj2Eu6bQiJWX18N19tGRprPMAIC7mosl/EAhCnmfao7QYxSGM878m5MR
Wt7fhsEBIgHzJpEz85rqboZEMpjufpC75h3hYp7//u60ETdMSKbArRiJpiHNi/jK
jTic+8uKDewI3QKDT/yXzq335krjU7CENI+G/IOUGcDnFsdvStY3SOcP3ocixsnL
D/cdmNUXDvptQc6G4AlX4OplCgjvOQ==
=afyD
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 19 Jul 2019 00:55
(name . Timothy Sample)(address . samplet@ngyro.com)(address . 36723-done@debbugs.gnu.org)
87r26nc5ri.fsf@gnu.org
Hello,

Timothy Sample <samplet@ngyro.com> skribis:

Toggle quote (31 lines)
> building /gnu/store/2gmxyxpfs0a2j6pcn9xagam6hczlvihb-module-import-compiled.drv...
> [ 1/14] Loading './gnu/build/file-systems.scm'...
> [ 2/14] Loading './gnu/system/file-systems.scm'...
> [ 3/14] Loading './gnu/system/uuid.scm'...
> [ 4/14] Loading './guix/build/bournish.scm'...
> [ 5/14] Loading './guix/build/syscalls.scm'...
> Backtrace:
> 11 (primitive-load "/gnu/store/qz6d59zqvdd5pj9hprk7sfjkpy3?")
> In ice-9/eval.scm:
> 619:8 10 (_ #f)
> In srfi/srfi-1.scm:
> 466:18 9 (fold #<procedure 7ffff5d2d520 at ice-9/eval.scm:336:1?> ?)
> 466:18 8 (fold #<procedure 7ffff54bc2c0 at ice-9/eval.scm:336:1?> ?)
> 466:18 7 (fold #<procedure 7ffff54c3dc0 at ice-9/eval.scm:336:1?> ?)
> In ice-9/eval.scm:
> 619:8 6 (_ #(#(#<directory (guix build utils) 7ffff6f53500>) # ?))
> In ice-9/boot-9.scm:
> 2312:4 5 (save-module-excursion _)
> In unknown file:
> 4 (primitive-load "./guix/build/syscalls.scm")
> In ice-9/eval.scm:
> 619:8 3 (_ #f)
> In ice-9/boot-9.scm:
> 2071:24 2 (call-with-deferred-observers #<procedure 7ffff50e4700 ?>)
> 260:13 1 (for-each #<procedure 7ffff50e4480 at ice-9/boot-9.scm?> ?)
> In unknown file:
> 0 (scm-error misc-error #f "~A ~S" ("re-exporting loc?" ?) ?)
>
> ERROR: In procedure scm-error:
> re-exporting local variable: AT_SYMLINK_NOFOLLOW

Fixed by 96783ed6275cd2818ff56916274e6e4582f1dc9b.

Thanks,
Ludo’.
Closed
?