[PATCH] gnu: Add libresprite.

  • Done
  • quality assurance status badge
Details
5 participants
  • Christopher Lemmer Webber
  • Julien Lepiller
  • Tobias Geerinckx-Rice
  • swedebugia
  • Jakob L. Kreuze
Owner
unassigned
Submitted by
Jakob L. Kreuze
Severity
normal
J
J
Jakob L. Kreuze wrote on 28 Jun 2019 02:43
(address . guix-patches@gnu.org)
87y31m7d62.fsf@sdf.lonestar.org
* gnu/packages/game-development.scm (libresprite): New variable.
---
gnu/packages/game-development.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 05a68b717a..0e9d5f0b96 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2017, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -799,6 +800,27 @@ the creation of animations, tiled graphics, texture atlases, and more.")
(home-page "https://www.aseprite.org/")
(license license:gpl2+)))
+(define-public libresprite
+ (let ((commit "f9002f282afd8a6a31bb4cd2dc6b665c24bd7779"))
+ (package
+ (inherit aseprite)
+ (name "libresprite")
+ (version (string-append "1.1.7" "-" (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/LibreSprite/LibreSprite.git")
+ (commit commit)
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1gjvlkpjyxkp5srqwa9g0a8x0kl1jm0xp6fs9a52nr1ynaaza1lx"))))
+ (description "LibreSprite is a tool for creating 2D pixel art for video
+games. In addition to basic pixel editing features, LibreSprite can assist in
+the creation of animations, tiled graphics, texture atlases, and more.")
+ (home-page "https://github.com/LibreSprite/LibreSprite/")
+ (license license:gpl2+))))
+
(define-public qqwing
(package
(name "qqwing")
--
2.22.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEa1VJLOiXAjQ2BGSm9Qb9Fp2P2VoFAl0VYpUACgkQ9Qb9Fp2P
2Vonxw//S/TolWwTgOfES5ZAoP5D6gZSBuu/An3OgpiU9+vrit3jS7BzT1mpaS97
i5jewVfgaDbLUhBCuqrdDFz5TPwHCVo50LQdpqVe3XKpp1N0OiZo/pcqBRjCQIwF
Q2nbNDRZSlbfIkUE7dhcC9wePXGuySq6w8kS5EQ+o9CqMmB7icn+qlkAo3H6fh4C
7Z98tlTkjpkaCj0KmZFu5zM2gh2Le0z7/lSMJFQTlDgoNWRZkTs2E+mMoqN7PtoU
Z68QAEXiTi7u8pFeJ35xK4SkB/i9X+8uH2AYyNagwI/oFZgjIQ878RfnqWQZW4qE
29EXqZjzkSAj/vAkGxHUp3pr38Tsd3ui5UOpeKzw1k+858x024eU8eP3QDuyxJWL
tcyg07YKhy08bra6nJCqQL72jM6/dNu6rkHz0f4yD+/gmuBOw6JXKrvH6JvEDgNE
L2Tj4qRy/aUSRtbjvwuITB0Yk9GwpqHxjwP+1KLgM72vsATn8go1PR8ZXXic6ug7
UaI67F2lM08jTMjTV2mH7bCyjO5TWpJkXGjji4HuAlas3eYI9LW6m/xvr2M45hEo
L2vVCTf0vkxWl19Vk9fX45I6kirNGuCX5N1+u6+TyHRnzyqjs7z7B7CNA0ij54/L
QQTc/nO5dYDWnLP1j1C78RTXjekQewIwjMec9B3dhd7LvrpUUGc=
=3Hu4
-----END PGP SIGNATURE-----

S
S
swedebugia wrote on 28 Jun 2019 07:28
(address . guix-patches@gnu.org)
30d2762e-8cea-fa2d-24df-68a019fcea90@riseup.net
On 2019-06-28 02:43, Jakob L. Kreuze wrote:
Toggle quote (24 lines)
> * gnu/packages/game-development.scm (libresprite): New variable.
> ---
> gnu/packages/game-development.scm | 22 ++++++++++++++++++++++
> 1 file changed, 22 insertions(+)
>
> diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
> index 05a68b717a..0e9d5f0b96 100644
> --- a/gnu/packages/game-development.scm
> +++ b/gnu/packages/game-development.scm
> @@ -15,6 +15,7 @@
> ;;; Copyright © 2017, 2019 Rutger Helling<rhelling@mykolab.com>
> ;;; Copyright © 2018 Marius Bakke<mbakke@fastmail.com>
> ;;; Copyright © 2019 Pierre Neidhardt<mail@ambrevar.xyz>
> +;;; Copyright © 2019 Jakob L. Kreuze<zerodaysfordays@sdf.lonestar.org>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -799,6 +800,27 @@ the creation of animations, tiled graphics, texture atlases, and more.")
> (home-page"https://www.aseprite.org/")
> (license license:gpl2+)))
>
> +(define-public libresprite
> + (let ((commit "f9002f282afd8a6a31bb4cd2dc6b665c24bd7779"))

Why not a release? Please ask upstream to release.

Toggle quote (11 lines)
> + (package
> + (inherit aseprite)
> + (name "libresprite")
> + (version (string-append "1.1.7" "-" (string-take commit 7)))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url"https://github.com/LibreSprite/LibreSprite.git")
> + (commit commit)
> + (recursive? #t)))

I see these:
Submodule 'third_party/duktape'
'third_party/duktape'
Submodule 'third_party/freetype2'
'third_party/freetype2'
Submodule 'third_party/gtest' (https://github.com/aseprite/gtest.git)
registered for path 'third_party/gtest'
Submodule 'third_party/libpng' (https://github.com/aseprite/libpng.git)
registered for path 'third_party/libpng'
Submodule 'third_party/libwebp'
'third_party/libwebp'
Submodule 'third_party/pixman' (https://github.com/aseprite/pixman.git)
registered for path 'third_party/pixman'
Submodule 'third_party/simpleini'
'third_party/simpleini'
Submodule 'third_party/zlib' (https://github.com/aseprite/zlib.git)
registered for path 'third_party/zlib'

Please unbundle as many as possible.

Toggle quote (4 lines)
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "1gjvlkpjyxkp5srqwa9g0a8x0kl1jm0xp6fs9a52nr1ynaaza1lx"))))

Synopsis?

Toggle quote (12 lines)
> + (description "LibreSprite is a tool for creating 2D pixel art for video
> +games. In addition to basic pixel editing features, LibreSprite can assist in
> +the creation of animations, tiled graphics, texture atlases, and more.")
> + (home-page"https://github.com/LibreSprite/LibreSprite/")
> + (license license:gpl2+))))
> +
> (define-public qqwing
> (package
> (name "qqwing")
> -- 2.22.0
>

I did not build it because of all the thirdparty bundles.

--
Cheers Swedebugia
J
J
Jakob L. Kreuze wrote on 28 Jun 2019 16:05
(name . swedebugia)(address . swedebugia@riseup.net)(address . 36411@debbugs.gnu.org)
8736jthkkd.fsf@sdf.lonestar.org
swedebugia <swedebugia@riseup.net> writes:

Toggle quote (2 lines)
> Why not a release? Please ask upstream to release.

Will do. I agree, looking at their roadmap, the current state of the
repository is ripe for a release.

Toggle quote (20 lines)
> I see these:
> Submodule 'third_party/duktape' (https://github.com/aseprite/duktape.git)
> registered for path 'third_party/duktape'
> Submodule 'third_party/freetype2' (https://github.com/aseprite/freetype2.git)
> registered for path 'third_party/freetype2'
> Submodule 'third_party/gtest' (https://github.com/aseprite/gtest.git) registered
> for path 'third_party/gtest'
> Submodule 'third_party/libpng' (https://github.com/aseprite/libpng.git)
> registered for path 'third_party/libpng'
> Submodule 'third_party/libwebp' (https://chromium.googlesource.com/webm/libwebp)
> registered for path 'third_party/libwebp'
> Submodule 'third_party/pixman' (https://github.com/aseprite/pixman.git)
> registered for path 'third_party/pixman'
> Submodule 'third_party/simpleini' (https://github.com/aseprite/simpleini.git)
> registered for path 'third_party/simpleini'
> Submodule 'third_party/zlib' (https://github.com/aseprite/zlib.git) registered
> for path 'third_party/zlib'
>
> Please unbundle as many as possible.

The bundled libraries is an issue with 'aseprite' as well. I'll see
about submitting a separate patch to resolve it there.

Toggle quote (2 lines)
> Synopsis?

Inherited from 'aseprite'. Should I alter it to mention that it's a fork
of Aseprite?

Regards,
Jakob
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEa1VJLOiXAjQ2BGSm9Qb9Fp2P2VoFAl0WHqIACgkQ9Qb9Fp2P
2VpA/Q/+NAPPWqcSbB/DEPzRPa0bQz+6RmB0NvIgX3xS868lqFdcZhagHfiKNOkZ
ub0JNodcQ2twH2o26gomq8+8xVbmZejsqmxDSOXfydGqy8mpQux/b0a6leWXwr/t
QpmBHNbR7O/kvtaZglNdARzt/SnDR9qCxgF7oSsKyh3Zy2hGTigw722gedGX8L/r
J8w/dvpn6hlvcbTf1/lhWSDC0vGR4wK3YwtSrGvfhrpe5C9Yb1nfyGKMAry1sSEd
oQSCgzd0wP7i2JPefAc40azdvbI9oUFZAjVDPsf6jkLBgDsTqFMH4JU3WlBQHZRn
uhRNqVS1i6DkjMEamVUZrWc4jGBUuCOtUnE4PGMiQDQ5zeJp1cbc1NUmLAj87Gkd
NszCWDbMEXrna6UmYc0RiGCBHSUxRpuke09ym0mqoKa90nGs8t5UKf2jYi48aJFi
DRdhqr1BgMaL0gXKOx6tt++fMBU2pYOHX6a1DNby7ZtUmPhnTwEqgpzMkhWGKM6o
JukqboY5kwL7KvBTgj5qIoKFuLO4yQz6i8ADvj/MmVimpMj3Jbsl7uqq+aIpFdQs
tlHTffuVXn9OQddbZzZczlAuLVOmXgYQx3hsKRWHk4xwaP46zn76gIuguroaDzpj
leLdjnGO76yj8QjevENgcPfQL4GiwtzgJ/MXRNvEzO3PIN3ax4c=
=cfHy
-----END PGP SIGNATURE-----

S
S
swedebugia wrote on 28 Jun 2019 17:51
(name . Jakob L. Kreuze)(address . zerodaysfordays@sdf.lonestar.org)(address . 36411@debbugs.gnu.org)
cd1bd239-0135-bcd1-c103-736e86f87504@riseup.net
On 2019-06-28 16:05, Jakob L. Kreuze wrote:
Toggle quote (30 lines)
> swedebugia <swedebugia@riseup.net> writes:
>
>> Why not a release? Please ask upstream to release.
>
> Will do. I agree, looking at their roadmap, the current state of the
> repository is ripe for a release.
>
>> I see these:
>> Submodule 'third_party/duktape' (https://github.com/aseprite/duktape.git)
>> registered for path 'third_party/duktape'
>> Submodule 'third_party/freetype2' (https://github.com/aseprite/freetype2.git)
>> registered for path 'third_party/freetype2'
>> Submodule 'third_party/gtest' (https://github.com/aseprite/gtest.git) registered
>> for path 'third_party/gtest'
>> Submodule 'third_party/libpng' (https://github.com/aseprite/libpng.git)
>> registered for path 'third_party/libpng'
>> Submodule 'third_party/libwebp' (https://chromium.googlesource.com/webm/libwebp)
>> registered for path 'third_party/libwebp'
>> Submodule 'third_party/pixman' (https://github.com/aseprite/pixman.git)
>> registered for path 'third_party/pixman'
>> Submodule 'third_party/simpleini' (https://github.com/aseprite/simpleini.git)
>> registered for path 'third_party/simpleini'
>> Submodule 'third_party/zlib' (https://github.com/aseprite/zlib.git) registered
>> for path 'third_party/zlib'
>>
>> Please unbundle as many as possible.
>
> The bundled libraries is an issue with 'aseprite' as well. I'll see
> about submitting a separate patch to resolve it there.

+1

Toggle quote (6 lines)
>
>> Synopsis?
>
> Inherited from 'aseprite'. Should I alter it to mention that it's a fork
> of Aseprite?

Yeah, I think that would be preferable. We/I normally ad that as an
aside in the end of the description "xx is a fork of yy". :)


--
Cheers Swedebugia
J
J
Jakob L. Kreuze wrote on 28 Jun 2019 23:23
(name . swedebugia)(address . swedebugia@riseup.net)(address . 36411@debbugs.gnu.org)
87mui1flpv.fsf@sdf.lonestar.org
swedebugia <swedebugia@riseup.net> writes:

Toggle quote (5 lines)
>> The bundled libraries is an issue with 'aseprite' as well. I'll see
>> about submitting a separate patch to resolve it there.
>
> +1

Though, after looking at it, I'm realizing that this involves about
three new packages, as well as some minor patches upstream. I think I'll
still work towards unbundling libraries, but it will take some time.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEa1VJLOiXAjQ2BGSm9Qb9Fp2P2VoFAl0WhUwACgkQ9Qb9Fp2P
2VqKzg//aghTF+7R8tsvqinusIbTAGxEJGJ51ENFRniSLRqrEosOFH0lj1mzZBV6
ra6mzgmSeA7w0334niaIKvz1oztqPEAlzx+aRtwYoTH3gJg5Yjilje6RQrrWcoXW
Djdxz/JyG5i2fpxomM1DUtf21VUVlF3W790L1b1JkuWIS2pWgHq5M2Qp9c5usqQ1
LEsLO/wQHCG07H0UkZ215i5Wcy/t2+lVAo9VXgriG8AJkWHQ459CaRmo4CKI5zVu
9fVFHJr7KHc4YKteQ4mewWmu9HMdawc9yMSuzme3RN5cPJsyo0uS3FrYa0RZAILt
8+/8h2sShnmwMUdD58LRkYYm5VCZK+o5Kb4pNDz3YV0MUkYgBUJDztYenBvTi6uP
fCk62HXDawnOGLACbTuSERKJXceKsTHSyBcxp8hYe8Q8w1O3FRwigo4fIKr0m5ql
TyfEZGQrhcAdzRWiwdPNEvaQSCKRJt7KhsYBvh6gKBYGYm6oaqIIZYTIoa6BIRI4
xjTi9TJ1kkOGXiD7h3ssqXxfXkr0Bwq07Os6+WcPWek22DGMswdQWJHCdGpVGo/g
wuE/OI8d/iV/hKKW+APSAtCFWMdeaCn8oaHKT4W8L5IMTxyaUYgUiuFBsGrK4Xfv
dmMAVR7+zusxTPQr5tPYQ/fq2bWLSkpVT6/hcIkk14VNgY/5jdc=
=6vwl
-----END PGP SIGNATURE-----

C
C
Christopher Lemmer Webber wrote on 29 Jun 2019 16:39
(address . guix-patches@gnu.org)
87mui0lal9.fsf@dustycloud.org
Jakob L. Kreuze writes:

Toggle quote (11 lines)
> swedebugia <swedebugia@riseup.net> writes:
>
>>> The bundled libraries is an issue with 'aseprite' as well. I'll see
>>> about submitting a separate patch to resolve it there.
>>
>> +1
>
> Though, after looking at it, I'm realizing that this involves about
> three new packages, as well as some minor patches upstream. I think I'll
> still work towards unbundling libraries, but it will take some time.

I don't think this needs to be a blocker on merging libresprite if it
wasn't a blocker on merging aesprite. How about filing a separate bug
for that so we don't forget, then we can just worry about getting this
one in?

I wonder also if there are any significant benefits to keeping aesprite
around if we have libresprite. What do you think? Maybe aesprite could
become an alias for the new libresprite. Thoughts?
T
T
Tobias Geerinckx-Rice wrote on 29 Jun 2019 17:27
(name . Jakob L. Kreuze)(address . zerodaysfordays@sdf.lonestar.org)(address . 36411@debbugs.gnu.org)
87woh4bee5.fsf@nckx
Jakob,

I didn't check all the bundled packages, but at least freetype2
and libpng are trivial to unbundle (not patched in any way) and
probably the most important to, security-wise, so things are
looking good even if upstream wouldn't cooperate.

Jakob L. Kreuze wrote:
Toggle quote (5 lines)
>> Synopsis?
>
> Inherited from 'aseprite'. Should I alter it to mention that
> it's a fork of Aseprite?

It's certainly not important enough to include in the synopsis, so
inheriting that is fine.

Now, I'd say it needn't be added to the description either. We
generally don't note the often chequered ancestry of our packages,
nor the fact that they are ‘free’ or ‘open source’, and this is
just a combination of the two. But at least description space is
cheaper if you disagree. ;-)

Thanks for your work on Guix,

T G-R
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXReDYwAKCRANsP+IT1Vt
eVizAP4iM3K/ubCBNuqJhHISFcsJ55Wn1BtF9uxKIn/vScbC2gD/WCBgLCPp3K7x
mNSC7fyOK21NTOm2jSSQUAlICtPuoAw=
=Nv5y
-----END PGP SIGNATURE-----

S
S
swedebugia wrote on 29 Jun 2019 19:10
(address . guix-patches@gnu.org)
909e98f0-d945-3e23-0600-0ce09930e960@riseup.net
On 2019-06-29 17:27, Tobias Geerinckx-Rice wrote:
Toggle quote (22 lines)
> Jakob,
>
> I didn't check all the bundled packages, but at least freetype2 and
> libpng are trivial to unbundle (not patched in any way) and probably the
> most important to, security-wise, so things are looking good even if
> upstream wouldn't cooperate.
>
> Jakob L. Kreuze wrote:
>>> Synopsis?
>>
>> Inherited from 'aseprite'.  Should I alter it to mention that
>> it's a fork of Aseprite?
>
> It's certainly not important enough to include in the synopsis, so
> inheriting that is fine.
>
> Now, I'd say it needn't be added to the description either.  We
> generally don't note the often chequered ancestry of our packages, nor
> the fact that they are ‘free’ or ‘open source’, and this is just a
> combination of the two.  But at least description space is cheaper if
> you disagree.  ;-)

What about noting it in the top of the recipe as a comment?
";; This is a fork of xx"
I find that helpful but it might be unnecessary too?

--
Cheers Swedebugia
J
J
Jakob L. Kreuze wrote on 30 Jun 2019 02:45
(name . Christopher Lemmer Webber)(address . cwebber@dustycloud.org)(address . 36411@debbugs.gnu.org)
87tvc7dhpu.fsf@sdf.lonestar.org
Christopher Lemmer Webber <cwebber@dustycloud.org> writes:

Toggle quote (4 lines)
> I wonder also if there are any significant benefits to keeping
> aesprite around if we have libresprite. What do you think? Maybe
> aesprite could become an alias for the new libresprite. Thoughts?

If my build system changes for unbundling duktape and simpleini are
merged upstream, that would probably make sense. Then we wouldn't need
to add a similar patch for aseprite.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEa1VJLOiXAjQ2BGSm9Qb9Fp2P2VoFAl0YBg4ACgkQ9Qb9Fp2P
2VoVkw/+PP/Q4ytSvRE5IOnmPpnp2+PTByucdL9UeYgeG6EG9IUI+B+bqcuG8Vot
PEcOcsRJzRUu7K7XseFMcBWqTbarUk8EoSTRZp4UBQ/55kdro8qwg/Uy4yW6XOYo
1lrsKWpo29MLR4j044TeKG1EhH2E0pUU2hIw5Jkw7VQXDLlvm6Sefbu3jLb4Oh1A
YwSQL9xVv2Wm+f9CWCbh50N1TpnPb4A45DSlszFCbrwprSY+e0TljznpgqPFMkxt
UnRvGAiZtGj+xum0IBSXNAmz9UrXpB80jvQtSBEt9r1es3cMKkAZTH/N61/P3E9W
Ufw2PICMdHE7x/hyU3vQV7voRl/K8ajNT9pYBFQJvtY2iQCLBbt8Ylfonc89BlE5
pVBiitEBtqPbxPpLEggRLiPDaYgQrb1raTk1+RuKkPLC2sIomBpZKxgje3HuyOz5
KZ6k4LPAYOqb7ubkP4tVK0sSoDUB4qqfGYvC2Omh69qhIGF93kcY1F8P2v68ldXH
DBgPKvn4f2X4/GKnwbNp4OqGmtHXRykNRK3Hb9WE1+pAl2Dj3UO06CIHAK41lnSC
MuevVyLWeXdzC3UiZgM8UYu5qocrURzvUJNIS3dhccWFcDUtwuZh50AYyG++H2MD
X9105kwB4wU5eQ3BekKcQ6q1G0DEXsY3nF57yrS6WhP60xckom8=
=5coB
-----END PGP SIGNATURE-----

J
J
Jakob L. Kreuze wrote on 30 Jun 2019 02:49
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 36411@debbugs.gnu.org)
87pnmvdhj3.fsf@sdf.lonestar.org
Hi Tobias,

Tobias Geerinckx-Rice <me@tobias.gr> writes:

Toggle quote (5 lines)
> I didn't check all the bundled packages, but at least freetype2 and
> libpng are trivial to unbundle (not patched in any way) and probably
> the most important to, security-wise, so things are looking good even
> if upstream wouldn't cooperate.

I believe they're already unbundled in the 'aseprite' package I'm
inheriting.

#+BEGIN_SRC scheme
(arguments
'(#:configure-flags
;; Use shared libraries instead of building bundled source.
(list "-DWITH_WEBP_SUPPORT=1"
"-DUSE_SHARED_CURL=1"
"-DUSE_SHARED_GIFLIB=1"
"-DUSE_SHARED_JPEGLIB=1"
"-DUSE_SHARED_ZLIB=1"
"-DUSE_SHARED_LIBPNG=1"
"-DUSE_SHARED_LIBLOADPNG=1"
"-DUSE_SHARED_LIBWEBP=1"
"-DUSE_SHARED_TINYXML=1"
"-DUSE_SHARED_PIXMAN=1"
"-DUSE_SHARED_FREETYPE=1"
"-DUSE_SHARED_ALLEGRO4=1"
"-DENABLE_UPDATER=0" ; no auto-updates
(string-append "-DFREETYPE_INCLUDE_DIR="
(assoc-ref %build-inputs "freetype")
"/include/freetype2"))))
#+END_SRC

#+BEGIN_SRC
jakob@Epsilon ~/Code/guix/gnu/packages $ ldd $(which libresprite) | grep freetype
libfreetype.so.6 => /gnu/store/66db1c64qm8ar4d7qjxsyl3xvjqjpgj7-freetype-2.9.1/lib/libfreetype.so.6 (0x00007fa317cd7000)
jakob@Epsilon ~/Code/guix/gnu/packages $ ldd $(which libresprite) | grep libpng
libpng16.so.16 => /gnu/store/c7sm7sn3yccffpggxrrfipqcn4wz3vfw-libpng-1.6.37/lib/libpng16.so.16 (0x00007f5715956000)
#+END_SRC

Toggle quote (6 lines)
> Now, I'd say it needn't be added to the description either. We
> generally don't note the often chequered ancestry of our packages, nor
> the fact that they are ‘free’ or ‘open source’, and this is just a
> combination of the two. But at least description space is cheaper if
> you disagree. ;-)

I just thought it'd be a little tacky if I kept the old description,
since it uses the name "Aseprite" twice.

Regards,
Jakob
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEa1VJLOiXAjQ2BGSm9Qb9Fp2P2VoFAl0YBwAACgkQ9Qb9Fp2P
2VpcOQ//TYsCLzqS73x0AS4XN9LABd4hAQhI8gcZRV3yl8IfKnzK4iVLU4KkGIBb
5MxYZFI8k1hT5pAThkOPO2zfKcwsw0f5KHU59GwwZzhNT7RvEwzHbbBa2hFgZo8C
fy32ZDflfCsaGruky3bWEKiXtW+xDRBqVRq5fHiOpQZJWMiCk7jpyQxK8ubg2MQw
U/hr+okcihdRpOlZ4H9CdNGTH02mgsFVft2KAmwfM+M/A5/4xPuyR1p+wDQ3I0C0
eOaWlaCCDKAE0jIqeNef2kh8lHcV/G9g03C5TSLpSbg/cVq0bHPrG6DT+YFxdGqv
rXUCsNYSW836uyvlya+KN6MBQeep8F+nZ1652QQcU3jOQqrh7ymAialVlhPdLBWM
dvzWR9SxaAdkJM0IB9NzMYpQb6oj2VqSSQt4NqtldgW6RtpHkAuAYKiLSk7QgM59
i8h4hD0b2Yba4KDgY76kAsn1EH52kjltyeQ+dGwRVRhxOEhrW/sFI521l8LM2CPb
ROxSa8U6TBuQmRuOcK/6FG03sQNCkd/hZIYx8wrE/ODYDKtjPr5EpPpFNaZmI1Ou
bazu38osYbYk1KmsdcYzvkQrn6xJjU6ePa6TlWN0VyAuHqRh7ydui2ad6Xhu9K3C
nAd4JaTEXT3f+uOvStmN4cUmfuugRQNXSiIhFGdA1xuXn06s7CM=
=QhTa
-----END PGP SIGNATURE-----

J
J
Julien Lepiller wrote on 22 Nov 2021 00:03
(name . Jakob L. Kreuze)(address . zerodaysfordays@sdf.lonestar.org)(address . 36411-close@debbugs.gnu.org)
20211122000328.141f74a8@tachikoma.lepiller.eu
Hi Jakob,

I noticed this patch when looking for old patches that are still open.
Ekaitz recently submitted a similar patch to add libresprite, and it
was applied quickly.

Sorry that this fell through the cracks and that you didn't receive any
feedback in such a long time! Since we now have libresprite, I'm
closing this one.
?