[PATCH 1/2] services: sddm: fix root login failure issue.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Reza Alizadeh Majd
Owner
unassigned
Submitted by
Reza Alizadeh Majd
Severity
normal
R
R
Reza Alizadeh Majd wrote on 21 May 2019 15:21
(address . guix-patches@gnu.org)(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)
20190521132110.85299-1-r.majd@pantherx.org
* gnu/services/sddm.scm
(sdm-pam-service): set uid from config.
(sdm-autologin-pam-service): set uid from config.
(sdm-pam-services): pass sddm-configuration to sddm-pam-service and
sddm-autologin-pam-service
---
gnu/services/sddm.scm | 16 ++++++++++------
1 file changed, 10 insertions(+), 6 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/services/sddm.scm b/gnu/services/sddm.scm
index b433c59e12..b0e6d40260 100644
--- a/gnu/services/sddm.scm
+++ b/gnu/services/sddm.scm
@@ -175,7 +175,7 @@ Relogin=" (if (sddm-configuration-relogin? config)
(define (sddm-etc-service config)
(list `("sddm.conf" ,(sddm-configuration-file config))))
-(define (sddm-pam-service)
+(define (sddm-pam-service config)
"Return a PAM service for @command{sddm}."
(pam-service
(name "sddm")
@@ -190,7 +190,9 @@ Relogin=" (if (sddm-configuration-relogin? config)
(pam-entry
(control "required")
(module "pam_succeed_if.so")
- (arguments (list "uid >= 1000" "quiet")))
+ (arguments (list (string-append "uid >= "
+ (number->string (sddm-configuration-minimum-uid config)))
+ "quiet")))
;; should be factored out into system-auth
(pam-entry
(control "required")
@@ -249,7 +251,7 @@ Relogin=" (if (sddm-configuration-relogin? config)
(control "required")
(module "pam_unix.so"))))))
-(define (sddm-autologin-pam-service)
+(define (sddm-autologin-pam-service config)
"Return a PAM service for @command{sddm-autologin}"
(pam-service
(name "sddm-autologin")
@@ -261,7 +263,9 @@ Relogin=" (if (sddm-configuration-relogin? config)
(pam-entry
(control "required")
(module "pam_succeed_if.so")
- (arguments (list "uid >= 1000" "quiet")))
+ (arguments (list (string-append "uid >= "
+ (number->string (sddm-configuration-minimum-uid config)))
+ "quiet")))
(pam-entry
(control "required")
(module "pam_permit.so"))))
@@ -282,9 +286,9 @@ Relogin=" (if (sddm-configuration-relogin? config)
(module "sddm"))))))
(define (sddm-pam-services config)
- (list (sddm-pam-service)
+ (list (sddm-pam-service config)
(sddm-greeter-pam-service)
- (sddm-autologin-pam-service)))
+ (sddm-autologin-pam-service config)))
(define %sddm-accounts
(list (user-group (name "sddm") (system? #t))
--
2.19.0
R
R
Reza Alizadeh Majd wrote on 21 May 2019 15:24
[PATCH 2/2] doc: update minimum-uid document for sddm-configuration.
(address . 35845@debbugs.gnu.org)(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)
20190521132423.85489-1-r.majd@pantherx.org
---
doc/guix.texi | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 27e0f72ccb..6bce474859 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -13609,7 +13609,8 @@ Directory to look for faces.
Default PATH to use.
@item @code{minimum-uid} (default 1000)
-Minimum UID to display in SDDM.
+Minimum UID to display in SDDM. This option also used in @code{sddm-pam-service} and
+@code{sddm-autologin-pam-service} in order to set minimum UID which allows to login.
@item @code{maximum-uid} (default 2000)
Maximum UID to display in SDDM
--
2.19.0
R
R
Reza Alizadeh Majd wrote on 22 May 2019 07:53
Re: [PATCH 2/2] doc: update minimum-uid document for sddm-conf iguration.
(address . 35845@debbugs.gnu.org)
7838f5ae-a0dd-4a0e-bdd1-c03e8aac9bfb@www.fastmail.com
as discussed before at bug 35749
documents related to `sddm-configuration` and submit this new PATCH.
L
L
Ludovic Courtès wrote on 24 May 2019 17:46
Re: [bug#35845] [PATCH 2/2] doc: update minimum-uid document for sddm-configuration.
(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)(address . 35845@debbugs.gnu.org)
87r28nua87.fsf@gnu.org
Hi Reza,

"Reza Alizadeh Majd" <r.majd@pantherx.org> skribis:

Toggle quote (4 lines)
> as discussed before at bug 35749
> (https://debbugs.gnu.org/cgi/bugreport.cgi?bug=35749) , I have updated the
> documents related to `sddm-configuration` and submit this new PATCH.

Thanks. However I’m a bit confused because there are now 3 issues on
this topic:


Could you please close 2 of them (or merge them), and let me know
where’s the final patch I should look at? We’re pretty much there, I
just want to make sure I don’t pick the wrong version of the patch. :-)

Thanks,
Ludo’.
R
R
Reza Alizadeh Majd wrote on 25 May 2019 11:49
Re: [bug#35845] [PATCH 2/2] doc: update minimum-uid document f or sddm-configuration.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 35845@debbugs.gnu.org)
f4bc215d-6174-4ab9-b7f6-870fb9ae1d50@www.fastmail.com
Hi Ludovic,

as we discussed in https://issues.guix.gnu.org/issue/35749#6, I had submitted
both changes in a new PATCH as https://issues.guix.gnu.org/issue/35845.

during this submission I had submitted #35844 by mistake, which I close that now.

Best,
Reza
L
L
Ludovic Courtès wrote on 25 May 2019 20:03
Re: [bug#35845] [PATCH 2/2] doc: update minimum-uid document for sddm-configuration.
(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)(address . 35845-done@debbugs.gnu.org)
8736l2pg2z.fsf@gnu.org
Hi,

"Reza Alizadeh Majd" <r.majd@pantherx.org> skribis:

Toggle quote (3 lines)
> as we discussed in https://issues.guix.gnu.org/issue/35749#6, I had submitted
> both changes in a new PATCH as https://issues.guix.gnu.org/issue/35845 .

OK, applied now; I tweaked the wording in guix.texi for clarity, I hope
that’s OK.

Thanks,
Ludo’.
Closed
?