[PATCH] gnu: go@1.4: Update to 1.4-bootstrap-20171003.

  • Done
  • quality assurance status badge
Details
3 participants
  • Alex Griffin
  • Leo Famulari
  • Ludovic Courtès
Owner
unassigned
Submitted by
Alex Griffin
Severity
normal
A
A
Alex Griffin wrote on 20 Apr 2019 21:41
(address . guix-patches@gnu.org)
6d838647-e07c-4713-a5a4-c43ec57cf526@www.fastmail.com
The Go bootstrap compiler in Guix currently includes a couple unnecessary workarounds for bugs which have already been fixed. This patch switches to using the bootstrap branch which is still maintained upstream.

--
Alex Griffin
From 4d784a54e5736d2eaeac2a6e9ed14c7d11598705 Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Sat, 20 Apr 2019 14:01:17 -0500
Subject: [PATCH] gnu: go@1.4: Update to 1.4-bootstrap-20171003.

* gnu/packages/golang.scm (go-1.4): Use the bootstrap branch that is
still support upstream.
[version]: Update to 1.4-bootstrap-20171003.
[arguments]: Remove fix to timezone test which is now included upstream. Don't
manually disable CGO because it is disabled by default. Manually enable test
suite because future releases will disable tests by default.
---
gnu/packages/golang.scm | 18 +++++-------------
1 file changed, 5 insertions(+), 13 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0b44bd3d02..3bd1c3eb8f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright @ 2018, 2019 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright @ 2019 Giovanni Biscuolo <g@xelera.eu>
+;;; Copyright @ 2019 Alex Griffin <a@ajgrf.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -61,14 +62,14 @@
(define-public go-1.4
(package
(name "go")
- (version "1.4.3")
+ (version "1.4-bootstrap-20171003")
(source (origin
(method url-fetch)
(uri (string-append "https://storage.googleapis.com/golang/"
- name version ".src.tar.gz"))
+ name version ".tar.gz"))
(sha256
(base32
- "0na9yqilzpvq0bjndbibfp07wr796gf252y471cip10bbdqgqiwr"))))
+ "0liybk5z00hizsb5ypkbhqcawnwwa6mkwgvjjg4y3jm3ndg5pzzl"))))
(build-system gnu-build-system)
(outputs '("out"
"doc"
@@ -135,13 +136,6 @@
("os/os_test.go" "(.+)(TestHostname.+)")
("time/format_test.go" "(.+)(TestParseInSydney.+)")
- ;; Tzdata 2016g changed the name of the time zone used in this
- ;; test, and the patch for Go 1.7 does not work for 1.4.3:
- ;; https://github.com/golang/go/issues/17545
- ;; https://github.com/golang/go/issues/17276
- ("time/time_test.go" "(.+)(TestLoadFixed.+)")
- ("time/format_test.go" "(.+)(TestParseInLocation.+)")
-
("os/exec/exec_test.go" "(.+)(TestEcho.+)")
("os/exec/exec_test.go" "(.+)(TestCommandRelativeName.+)")
("os/exec/exec_test.go" "(.+)(TestCatStdin.+)")
@@ -168,9 +162,7 @@
(setenv "GOOS" "linux")
(setenv "GOROOT" (dirname (getcwd)))
(setenv "GOROOT_FINAL" output)
- ;; Go 1.4's cgo will not work with binutils >= 2.27:
- ;; https://github.com/golang/go/issues/16906
- (setenv "CGO_ENABLED" "0")
+ (setenv "GO14TESTS" "1")
(invoke "sh" "all.bash"))))
(replace 'install
--
2.20.1
L
L
Ludovic Courtès wrote on 27 May 2019 16:29
(address . 35348@debbugs.gnu.org)
875zpwug0o.fsf@gnu.org
Hello Alex,

"Alex Griffin" <a@ajgrf.com> skribis:

Toggle quote (2 lines)
> The Go bootstrap compiler in Guix currently includes a couple unnecessary workarounds for bugs which have already been fixed. This patch switches to using the bootstrap branch which is still maintained upstream.

Leo, could you take a look at this patch?


Thanks in advance,
Ludo’.
L
L
Leo Famulari wrote on 27 May 2019 19:33
(name . Alex Griffin)(address . a@ajgrf.com)(address . 35348@debbugs.gnu.org)
20190527173302.GA26319@jasmine.lan
On Sat, Apr 20, 2019 at 03:41:34PM -0400, Alex Griffin wrote:
Toggle quote (5 lines)
> The Go bootstrap compiler in Guix currently includes a couple
> unnecessary workarounds for bugs which have already been fixed. This
> patch switches to using the bootstrap branch which is still maintained
> upstream.

Thanks for taking care of this!

How did you find this newer tarball? It doesn't appear at
https://golang.org/dl/ or the Go GitHub page. Can you add a code
comment with a link and send a revised patch?

Toggle quote (12 lines)
> From 4d784a54e5736d2eaeac2a6e9ed14c7d11598705 Mon Sep 17 00:00:00 2001
> From: Alex Griffin <a@ajgrf.com>
> Date: Sat, 20 Apr 2019 14:01:17 -0500
> Subject: [PATCH] gnu: go@1.4: Update to 1.4-bootstrap-20171003.
>
> * gnu/packages/golang.scm (go-1.4): Use the bootstrap branch that is
> still support upstream.
> [version]: Update to 1.4-bootstrap-20171003.
> [arguments]: Remove fix to timezone test which is now included upstream. Don't
> manually disable CGO because it is disabled by default. Manually enable test
> suite because future releases will disable tests by default.

LGTM.

I think the number of packages that will need to be rebuilt is small
enough that we can push this directly to the master branch, and this
update should not have any effect on the later compiler versions, but
did you check that major Go packages like mongo-tools, restic, and
Syncthing still build?
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlzsH0sACgkQJkb6MLrK
fwhaCA/+LQKaaiKVV4uKo1FRzg4IGfdoam115//0RxZHfE27Aaark77ELNQltd4b
Ee5y7iEEXUPm6Vxrzm66lZffXIBH1DrU1BYxt/pRrEDeGkQ5BDkE+MMzond4BSCX
wxObSb69tIv8HoPHySnKHuZa8WHsxUS3tRiaw8lKmrqKeTdFPpPwV1058VDszJ8Z
OEVZPsUdW0pQQZjMbLCiOjAwVT/jYCXfCQQ7RtXF3nThPbWyxUlAC7Z/FT5rq9La
sXZzJqtAXDRhKFXo4bZH9cv92Wfwi7Hj6ogyEAek/K37UOTmaYg3g6TU9Ts9WomR
O19Pn1vl/HvXGSYVL+SfhVD1I0/4iEsxYFjQz2JJj39P1eagEyBLjNU9CrenmuMS
N2MuYLBNWzigZ0kQA/u3S967+yYtZJXelxPFGTmuHU4krJ1JovSQnCA14MiTE0KO
R/zdSXGwnfiHgcYVVBVKob38juSyBWeRZ51cPfUkxjMOr28F/0D8dyZcySBBR4n0
rMbxViRe5fy42KF/ngnzcTePGNL1Dazelga2irxzzTD/A0+zKc1KTLDC+pIJWEEK
4hGKfxo1ven0Sv4reeE6aZQ2mFIZGIPH/vNDGcBcblJtEhd3+tAimaL7hBbh+bj3
EDYzU3Yy6HL+iM3an3aMkggr8Uhcu5WGgygaVcBu9cC0slt2HK4=
=nzOl
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 27 May 2019 19:38
(name . Alex Griffin)(address . a@ajgrf.com)(address . 35348@debbugs.gnu.org)
20190527173802.GA27386@jasmine.lan
On Mon, May 27, 2019 at 01:33:02PM -0400, Leo Famulari wrote:
Toggle quote (6 lines)
> I think the number of packages that will need to be rebuilt is small
> enough that we can push this directly to the master branch, and this
> update should not have any effect on the later compiler versions, but
> did you check that major Go packages like mongo-tools, restic, and
> Syncthing still build?

I didn't realize you sent your patch so long ago... I will test these
things myself. But can you still let me know how you found the newer
tarball?
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlzsIHoACgkQJkb6MLrK
fwig4RAAlXXeK6gxVVWLCs5P8Kqva7MLUnuc2e50sXTKminoO2BIY6EnxXvqDYNG
BOGWMRfgdFc+YeFWO88AtY1iO0duHkdIC95n4Lj0bRSl9j57Z+Gdrlvv9hQYIFwD
EgiqaophN3SidotKDagQI5arvNpPaVGKLtVvOa53IO2NkCknKEQoE5A5/doCzNbc
RH/CO5vzrTg0dEP4/nn9J7sI4C0XKvmVjHj+IMNbkkmnRgdZt37fL2N5AjyevM4B
TviibsDtaFoMZ3lzWuKQhm6u+yCLLPL5MJsyK8LlfrqEXSB3paJBFHXLLUaETEq2
GygK8aDFJ3Axli1YYYSfkR1wtkEvLTrZMk2dTCdNmkNOIDQez/8wLJ+5I5cw7/61
Bq4WOrbqjYV4hzC79Hl2eI3Ayijv37mfr7HQ3JgjiEjIQhb+ef5Lr/DSJn8Vh5U8
qp0dMQFu6aX3jFW5RnxX5gddRnuEHqXHZ9xIpv/kTu6IIfkOxZtfvfVFl5wAKLpF
Nwhz0yskofESvr1QwHwA8apWHNU3GgHkxZHBXrL+9RNVZRU8uJvC7aBixEMadawU
3ua1Cxw//CtA8V7D9pcW1mbK8Y1yLDKmFQSv4Gy6gPnUQ+NcSxAFc6O2AV4ybzGM
HwwDfMLO+6ZhjDShRr3gU15vDHqHdjstixXppgr+IQMwASlSSYE=
=7EzK
-----END PGP SIGNATURE-----


A
A
Alex Griffin wrote on 27 May 2019 19:46
Re: [bug#35348] [PATCH] gnu: go@1.4: Update to 1.4-bootstrap-2 0171003.
(name . Leo Famulari)(address . leo@famulari.name)(address . 35348@debbugs.gnu.org)
5b636505-b8e5-4858-bf7d-7067b8743887@www.fastmail.com
Hi Leo,

I found the tarball on [this page](https://golang.org/doc/install/source#go14).That's also the page to check for updates.

You can see the changes by looking at release-branch.go1.4 in git (https://github.com/golang/go/tree/release-branch.go1.4).

Thanks,
--
Alex Griffin

On Mon, May 27, 2019, at 5:38 PM, Leo Famulari wrote:
Toggle quote (13 lines)
> On Mon, May 27, 2019 at 01:33:02PM -0400, Leo Famulari wrote:
> > I think the number of packages that will need to be rebuilt is small
> > enough that we can push this directly to the master branch, and this
> > update should not have any effect on the later compiler versions, but
> > did you check that major Go packages like mongo-tools, restic, and
> > Syncthing still build?
>
> I didn't realize you sent your patch so long ago... I will test these
> things myself. But can you still let me know how you found the newer
> tarball?
>
> Attachments:
> * signature.asc
L
L
Leo Famulari wrote on 27 May 2019 20:27
Re: [bug#35348] [PATCH] gnu: go@1.4: Update to 1.4-bootstrap-20171003.
(name . Alex Griffin)(address . a@ajgrf.com)(address . 35348-done@debbugs.gnu.org)
20190527182725.GA31096@jasmine.lan
On Mon, May 27, 2019 at 05:46:44PM +0000, Alex Griffin wrote:
Toggle quote (6 lines)
> Hi Leo,
>
> I found the tarball on [this page](https://golang.org/doc/install/source#go14). That's also the page to check for updates.
>
> You can see the changes by looking at release-branch.go1.4 in git (https://github.com/golang/go/tree/release-branch.go1.4).

Thanks!

I added a comment and pushed your patch as
521d736ae97ef34f4e6136c7175a99c680c5ac95.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlzsLA0ACgkQJkb6MLrK
fwiwPBAArnundP1oMcpLwo9QTRz2jnReGtmn6pzYWx+S/eV1jgCim+7NocBpYO9f
OZYTdNDG19MpaaOWxdhM01CcAXBUhpZPw6PWX+0upGsEYaX1P+hp6pafqV9CCsYE
Mc0cwDn9/b0ryIgbXZx7t2M30OAj8+rIbbqwoAXpg7Z823OyRPCS9t1Rwx+mFrJw
eOv2yPwYhtId2D6fA6CXlanMiszFLpCZB1Y9vdEFHIjRqFVyksMkWvlRtiXBC3ZH
mXaSLaDlLul4120yfAILUyg64JJ4MYQqCcHuLa+0WP11zy8aw9mm/GzWQr2p9JE1
LOl74+LK2upklxUAE1QaeznLBJYG1Y2fWfBbGJM333WlJJSJ/MdNyS5eZ49BQ2+s
ky8Wplu51cXYMdzkzKk29UYow+6lnvLlF2tszh6XW990vV19g8GZbV1iKfXuwO76
6wHcCbZ3nOIx24vR5JHrjm6qlo+uSwuud9yNHkylzqkR4RQtqK/c1dLba2VtIeFt
RO69opwLhHizrsYW+xCS/vc+zm/UGwwOfxzHzktuswiExiSnTLdd4zHpIFGJnCMr
z/aN7S4YuJin61664cM0xLl4IPNCWEYfyQYd0AFLbu5x42UE7qhwDqoeR5aoKwVl
DTBuqR1kxsJMPPtga4F9cEqDAp+ssoT1pEENBo9DsA+V8nkjMGI=
=0Z0q
-----END PGP SIGNATURE-----


Closed
A
A
Alex Griffin wrote on 29 May 2019 18:52
Re: [bug#35348] [PATCH] gnu: go@1.4: Update to 1.4-bootstrap-2 0171003.
(name . Leo Famulari)(address . leo@famulari.name)(address . 35348-done@debbugs.gnu.org)
ca9d8e30-9ad0-464a-838c-386b9d500b6d@www.fastmail.com
On Mon, May 27, 2019, at 6:27 PM, Leo Famulari wrote:
Toggle quote (2 lines)
> I added a comment [...]

I don't know if it's worth another commit, but you misspelled "langauge" in your comment.

Toggle quote (2 lines)
> and pushed your patch as 521d736ae97ef34f4e6136c7175a99c680c5ac95.

Thanks!
--
Alex Griffin
Closed
L
L
Leo Famulari wrote on 31 May 2019 16:31
Re: [bug#35348] [PATCH] gnu: go@1.4: Update to 1.4-bootstrap-20171003.
(name . Alex Griffin)(address . a@ajgrf.com)(address . 35348-done@debbugs.gnu.org)
20190531143100.GA4577@jasmine.lan
On Wed, May 29, 2019 at 04:52:37PM +0000, Alex Griffin wrote:
Toggle quote (2 lines)
> I don't know if it's worth another commit, but you misspelled "langauge" in your comment.

Thanks, fixed in 9bc1de31348858278067a45c5965328677ee74d8
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlzxOqQACgkQJkb6MLrK
fwgsrA/9GSBElgVO29xvAJV1rjZ6O0jVBIu2PbbMBGxzblZpiTP6VQNMLCpyVM33
kyFW2eJa5FCX3Gv+7uqd1nwAfciLKwB9t7scfKiJuP5n4S6NatJa2cLGGITaVJxl
0IT128Eoeu0aQj8XJEDI4YOxQfCAJE5DxcEC8gCrITFUFWIlUlGVO31Z5ry2N+V7
uLhBzpDArB6kliWXvMxbs9Gx6prAsuc07Kr9q4t0FAjicvKc67B1AoRku5nlEU0b
AR3StXb6NIxDFT8MQLN1n2g0h9BoHVlVb5d06n9BbYS5TQNHjoMwoqYzMIRKIhEC
EfMlllzec6IOixZ+Y3VGU0SRHnFr+mzabYdnb6VcwI6SYaGipjv4RSi5pghz3tgz
RkSZY5H4/DwebrVejXC2T9HMMizBK13J8/wpRVDYWstJBP5Rxqh16Czok6I21HP5
qtTrLkDiU0oRinM8gqQVOuJQumkxU98bYrMBj1BlH+ex1d565aTy8xj3sODN91Pz
049n8iWGD8BjvAMs9TlH6mghDpCJZNUDUL2xRMw5Q5blo0wa6IDzKC4uhOneUSe2
4n3RWMzd/ADTknyXj4FTGGua0G0L7uxgXEk7Xov3CPsCeZKmnKPhmJI3JF4uSKUF
R/JldT6aU0J/hnWvQ06LvUFRlzQWTQ4bSKCDY8yeNhdeqjXMmng=
=NRHl
-----END PGP SIGNATURE-----


Closed
?