hi

Le ven. 11 janv. 2019 à 00:42, Leo Famulari <leo@famulari.name> a écrit :
On Thu, Jan 10, 2019 at 07:18:04PM +0100, Guy fleury wrote:
> From 0380fab2ad7195407fc29afb830a86dbfae03b3f Mon Sep 17 00:00:00 2001
> From: guy fleury iteriteka <hoonandon@gmail.com>
> Date: Thu, 10 Jan 2019 17:33:30 +0100
> Subject: [PATCH] gnu: Add Bochs

Thank you!

> +    (outputs '("out"))

This is the default, so it's okay to leave it out.

> +     `(#:tests? #f)) ;; no tests exits

"No tests exist"

> +    (inputs
> +     `(("glib" ,glib)
> +       ("gtk+" ,gtk+)
> +       ("libxrandr" ,libxrandr)))

I noticed that it doesn't keep references to glib and gtk+:

------
$  guix gc --references $(./pre-inst-env guix build --no-grafts bochs)
/gnu/store/2dk55i5wdhcbh2z8hhn3r55x4873iyp1-libxext-1.3.3
/gnu/store/3vlscch2sxybd34qx2ianpg92crm9akm-libxdmcp-1.1.2
/gnu/store/4sqps8dczv3g7rwbdibfz6rf5jlk7w90-gcc-5.5.0-lib
/gnu/store/6lwn8v33r2z2l2pgky2dnzim3696dwnn-libbsd-0.9.1
/gnu/store/8baabfjazsr7s4y0jig1sn84xnxf75xa-libx11-1.6.6
/gnu/store/h90vnqw0nwd0hhm1l5dgxsdrigddfmq4-glibc-2.28
/gnu/store/hnj08aavzpsi72wvi4qqrp5dqbyqxqqs-libxcb-1.13
/gnu/store/mawqhgh0bdxpa4gjxs1fjyhwvv6i8w5g-libxau-1.0.8
/gnu/store/mbbj3j86amqls868hip0l85q9lx8gbcn-libxrandr-1.5.1
/gnu/store/x6fyr53k53sd5ghnh3abpnr1mqsy3xig-bochs-2.6.9
/gnu/store/xrvwszmahcb7k2zcyag3vmqwswzrbvcg-libxrender-0.9.10
------
thanks for this tips. 
So, I think it's possible to omit those two inputs.

> +     "Bochs is an emulator which can emulate Intel x86 CPU, common I/O
> +devices, and a custom BIOS.  It can also compiled to emulate many different

"It can also be compiled to ..."

> +Bochs can running most Operating Systems inside the emulation including Linux,
> +DOS or Microsoft Windows.")

"Bochs can run most operating systems ..."

> +    (license license:lgpl2.0)))

I checked some of the source files and I think it is lgpl2.0+.

Can you send an updated patch? :)