[PATCH] gnu: octave: Fix makeinfo path configuration

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Kei Kebreau
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 3 Jan 2019 17:50
(address . guix-patches@gnu.org)
cu7h8epheiq.fsf@systemreboot.net
The makeinfo path now needs to be substituted in
libinterp/corefcn/help.h, not libinterp/corefn/help.cc. I have addressed
this in the attached patch.

I have also filed a bug upstream asking them to add a configure flag
--with-makeinfo. Hopefully, we won't have to manually substitute
the path to makeinfo in the next release.

From 36612684f6f7719aef4b1b9fd40632b8749fcd90 Mon Sep 17 00:00:00 2001
From: Arun Isaac <arunisaac@systemreboot.net>
Date: Thu, 3 Jan 2019 21:56:26 +0530
Subject: [PATCH] gnu: octave: Fix makeinfo path configuration.

* gnu/packages/maths.scm (octave-cli)[arguments]: Fix makeinfo path
configuration in configure-makeinfo phase.
---
gnu/packages/maths.scm | 11 +++++------
1 file changed, 5 insertions(+), 6 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 448d9e373..e67bc5e93 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -19,7 +19,7 @@
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
-;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017, 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Dave Love <me@fx@gnu.org>
;;; Copyright © 2018 Jan Nieuwenhuizen <janneke@gnu.org>
@@ -1484,11 +1484,10 @@ can solve two kinds of problems:
(modify-phases %standard-phases
(add-after 'configure 'configure-makeinfo
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* "libinterp/corefcn/help.cc"
- (("Vmakeinfo_program = \"makeinfo\"")
- (string-append "Vmakeinfo_program = \""
- (assoc-ref inputs "texinfo")
- "/bin/makeinfo\"")))
+ (substitute* "libinterp/corefcn/help.h"
+ (("\"makeinfo\"")
+ (string-append
+ "\"" (assoc-ref inputs "texinfo") "/bin/makeinfo\"")))
#t)))))
(home-page "https://www.gnu.org/software/octave/")
(synopsis "High-level language for numerical computation")
--
2.19.2
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAlwuPT0ACgkQLiXui2GA
K7O3Dgf/b1AN1GjyFAwkbI7GeevUNNQv818n5hs/NmwwFzysDn49NJqPnyL4dcSB
ymO7lYSymgsAhUaGpy0E1cmhcZWGkUQ7cJt5fCgmjEnzv87DSplstOv4aw5T5/HL
5q6Wyg0Am+yHTjQJb62zE+flmypLTnwkIvS2MXC6aqgAmCmIRJ0/pWHgd37baAvJ
HDcmqAQXp/KL/nla3i+EBbDsNCNd/NFfOIALj+edeI6bFNcDm9Ql90hKmiEkiYXJ
3dKKG5RbDbRUrYrrLs0gWdvYkzbCjnbyOggnL/rpQRQ5pePxFRT43fH43D16H3bc
R3N24bu7FERpGacUqVLbTdu7pywUJA==
=gSZX
-----END PGP SIGNATURE-----

K
K
Kei Kebreau wrote on 5 Jan 2019 04:24
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 33963@debbugs.gnu.org)
8736q7bxch.fsf@posteo.net
Arun Isaac <arunisaac@systemreboot.net> writes:

Toggle quote (51 lines)
> The makeinfo path now needs to be substituted in
> libinterp/corefcn/help.h, not libinterp/corefn/help.cc. I have addressed
> this in the attached patch.
>
> I have also filed a bug upstream asking them to add a configure flag
> --with-makeinfo. Hopefully, we won't have to manually substitute
> the path to makeinfo in the next release.
>
> https://savannah.gnu.org/bugs/index.php?55371
>
> From 36612684f6f7719aef4b1b9fd40632b8749fcd90 Mon Sep 17 00:00:00 2001
> From: Arun Isaac <arunisaac@systemreboot.net>
> Date: Thu, 3 Jan 2019 21:56:26 +0530
> Subject: [PATCH] gnu: octave: Fix makeinfo path configuration.
>
> * gnu/packages/maths.scm (octave-cli)[arguments]: Fix makeinfo path
> configuration in configure-makeinfo phase.
> ---
> gnu/packages/maths.scm | 11 +++++------
> 1 file changed, 5 insertions(+), 6 deletions(-)
>
> diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
> index 448d9e373..e67bc5e93 100644
> --- a/gnu/packages/maths.scm
> +++ b/gnu/packages/maths.scm
> @@ -19,7 +19,7 @@
> ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
> ;;; Copyright © 2017 Ben Woodcroft <donttrustben@gmail.com>
> ;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
> -;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
> +;;; Copyright © 2017, 2019 Arun Isaac <arunisaac@systemreboot.net>
> ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
> ;;; Copyright © 2017 Dave Love <me@fx@gnu.org>
> ;;; Copyright © 2018 Jan Nieuwenhuizen <janneke@gnu.org>
> @@ -1484,11 +1484,10 @@ can solve two kinds of problems:
> (modify-phases %standard-phases
> (add-after 'configure 'configure-makeinfo
> (lambda* (#:key inputs #:allow-other-keys)
> - (substitute* "libinterp/corefcn/help.cc"
> - (("Vmakeinfo_program = \"makeinfo\"")
> - (string-append "Vmakeinfo_program = \""
> - (assoc-ref inputs "texinfo")
> - "/bin/makeinfo\"")))
> + (substitute* "libinterp/corefcn/help.h"
> + (("\"makeinfo\"")
> + (string-append
> + "\"" (assoc-ref inputs "texinfo") "/bin/makeinfo\"")))
> #t)))))
> (home-page "https://www.gnu.org/software/octave/")
> (synopsis "High-level language for numerical computation")

LGTM.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlwwI24ACgkQ5qXuPBlG
eg2kGQ//eycgLCJkWe+cdlnuhLZ/cIb9kzNKsum7q7bir36jvBWkG+Jbe8khTeq6
lgvZ+c5N9rVcVD/8MOys4ygp7ScyuyIH3iPshM5Er+pXr/wJznI+Lczmf1qr0UcG
Hc44yadC22sJT3EOLridUYoLjqUfymsxIMmHIMAKeycCbB3gQlJwxp5VgP+9SM75
5rEB7NywAEH0ZdqT7DVjueXseTjJhnk1rHpl1DAkoAcCB9KJwzrD8anDynKr0zJq
DW+P0Iqtby3hbdMPHAuog6a8p5RmeBNdPFxoWnoEP40HGlqeH572tzWeC+Dsop2g
1vl2VjsQU3yd+7/MBMVB+VZ+ibLHsha4Lx/5zMkh6GPQG0jyE6eqoZ8Yz8TJxHEN
WfCP66eqbiF1nto0JwY67gfop6HRpXujhlb7NVVLxPln/p1WoYDZEt+P9L30puoa
UArCv0cKfGLLeuom1LUSDrM4Gjg1/NbvCwwe9F2p15RHidx/iEO4aCNIOWdOf0Q/
kQiy3kVZ0abrz7hXn9Y/y4L7XdPkbU4eDMT+wjqVQGwZiM7eJtM3DGpLXWyoI/PN
nEt80idw1AU0BQG5lFvolyIqxxz6F7zN5ygy/nZGdPzZIHA6yM7wxHjEdZ5V7Mg0
q7/ZimUlwv0Uuy3M1Vue4X19I6HA3aL3kyyLMZ3m5qMkEzx7M78=
=2VAj
-----END PGP SIGNATURE-----

A
A
Arun Isaac wrote on 5 Jan 2019 19:25
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 33963-done@debbugs.gnu.org)
cu7ef9r7yi9.fsf@systemreboot.net
Pushed, thanks for the review!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAlww9o4ACgkQLiXui2GA
K7PcOQf/QyL32q6DLS3tfL5V2otbRiho6eAw3izbSKjEDcq7jHOqCJUcINpwYhrl
YbWPAKd6pkIiGO1Z46xSFy0LUJYtP1s39zqpo/P6IPmHuQ2nIGVIg5tdxYKRD75D
qADL2FKf4TyJhfttUUoeQKBuBkcJcIRXx9U6t8qWyGuX+2nmoB0BGhpVhq6zK+us
4XjcgMLjU/P4Gfj+QCPCFnGpKQuG2sMaDSY9kpyu5WODtwG8/ud0xQjM+77HSOQ1
f95n5RjcEoFIPf9dAKqXguAppFUxA9sFEXhruiXI6uFH9U3XPt0MBjrxgxa4F8wj
0cjza9BGnSqYduKclKMTcG+YFByhMw==
=h61O
-----END PGP SIGNATURE-----

Closed
?