[PATCH] Add gnuradio

  • Done
  • quality assurance status badge
Details
4 participants
  • Charlie Ritter
  • Danny Milosavljevic
  • Guillaume Le Vaillant
  • Ludovic Courtès
Owner
unassigned
Submitted by
Charlie Ritter
Severity
normal
C
C
Charlie Ritter wrote on 25 Apr 2018 12:35
(address . guix-patches@gnu.org)
cuczi1rbmkc.fsf@posteo.net
From 20242ed16e29c90cfbbbd0e6d735e9f94187a77d Mon Sep 17 00:00:00 2001
From: Charlie Ritter <chewzerita@posteo.net>
Date: Wed, 25 Apr 2018 06:34:13 -0400
Subject: [PATCH] gnu: Add gnuradio.

* gnu/packages/ham-radio.scm (gnuradio): New variable.
---
gnu/packages/ham-radio.scm | 45 ++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (68 lines)
diff --git a/gnu/packages/ham-radio.scm b/gnu/packages/ham-radio.scm
index 0f96553c6..db38951e4 100644
--- a/gnu/packages/ham-radio.scm
+++ b/gnu/packages/ham-radio.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2018 Charlie Ritter <chewzerita@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,10 +21,54 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (gnu packages algebra)
+ #:use-module (gnu packages boost)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages libusb)
+ #:use-module (gnu packages maths)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages swig)
#:use-module (guix build-system cmake))
+(define-public gnuradio
+ (package
+ (name "gnuradio")
+ (version "3.7.9.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gnuradio.org/releases/gnuradio/gnuradio-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1fpvfslfffgvpszzmlzkjgm93cm16fqanbgllykm5qjas1201d10"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("boost" ,boost)
+ ("fftw" ,fftw)
+ ("gsl" ,gsl)
+ ("qt" ,qt-4)
+ ("qwt" ,qwt)))
+ (propagated-inputs
+ `(("python" ,python-2)
+ ("python2-pygtk" ,python2-pygtk)
+ ("python2-pyqt" ,python2-pyqt)
+ ("python2-lxml" ,python2-lxml)
+ ("python2-cheetah" ,python2-cheetah)
+ ("python2-numpy" ,python2-numpy)
+ ("swig" ,swig)))
+ (home-page "https://gnuradio.org/")
+ (synopsis "GNU Radio is a free and open-source toolkit for software radio")
+ (description "GNU Radio is a free & open-source software development
+toolkit that provides signal processing blocks to implement software radios.
+It can be used with readily-available low-cost external RF hardware to create
+software-defined radios, or without hardware in a simulation-like environment.
+It is widely used in hobbyist, academic and commercial environments to support
+both wireless communications research and real-world radio systems.")
+ (license license:gpl3+)))
+
(define-public rtl-sdr
(package
(name "rtl-sdr")
--
2.17.0
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEiNLX4rpUkGUHqgmts0r+M/VPj+8FAlrgWgMACgkQs0r+M/VP
j+84wAf/S9qAQd4x7D3mdYIVm1pxyoYnyfc1Zpdki0kwMjEz1805kX0qgV7r4O7f
90cDGnJ6RiqvGrn26VllTkRWfNmLWBxB/OAhppHyCMEMx64mILTou4iv81MdmT2e
IHe7wlWR9gCLAtJdBPybvMmC05Qmprw9cmZ87PdmOQU3hgmp1+ekom294nCGQoG1
DzP9bM755mlHydxdA7DZKj8Vh3oXloVAtd56/W0CmaGkpPpUdsT5sCWTy6j4DYrX
tElDf/9M6KHs4CTJ4whXsvmO0N1ZmTM388y0gNeQ2+kr3tkBO6WyBVdMcZozjE5s
aC9lUBfS12B1DOicUrQdDRQN898bmg==
=H1eK
-----END PGP SIGNATURE-----

D
D
Danny Milosavljevic wrote on 25 Apr 2018 13:36
(name . Charlie Ritter)(address . chewzerita@posteo.net)(address . 31259@debbugs.gnu.org)
20180425133627.35995620@scratchpost.org
Hi!

Thanks for the patch.

I have the following suggestions:

* Please unbundle volk.
* Please build the documentation (that needs doxygen, ghostscript and texlive-tiny). After that, remove docs/doxygen/html/_formulas.log because it contains timestamps.
* Please add dependency to alsa-lib.
* Please add dependency to libusb.
* Why not fftwf?
* We should investigate whether grc actually needs the inputs to be propagated (later).
* Please add dependency to cppunit.
* Please add dependency to orc.
* Swig probably is not needed at runtime - isn't a native-input enough?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlrgaDsACgkQ5xo1VCww
uqVTBwf/Qh7rWoSkyBor/pIqF/wQSsQr3eUe/POHa2Oo92+AURB3hFBhRFTCQ/Cn
V5+0pTsQBtdmS7xQtvbdaPo9lbWG4lqDN1LrcdOFRinMKejpEaLOpgndpzXwp2rg
9jRpwIY3SEBy5Q6ymzgD2cCzkr+kW+oTvBo+ASVcdDekNDYKb9ANbrzwG/pzOO28
usgaG/mo8brE39ShR0cRMZpvQnqxsaHrwvbIAZn6TaVPHltrhngfnMZXnACCp4eE
QHZD/DduGYcTc4UFLzdMqVZ0x6AP2hyuQ7+D/sNgcg04JZdCyiYla4xX08I4SgEo
c/9elmm/xGYYjJnCagtPbXO6B2IDZg==
=EIpF
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 25 May 2018 14:03
(name . Charlie Ritter)(address . chewzerita@posteo.net)
87sh6g2b8d.fsf@gnu.org
Hello Charlie,

Did you have a chance to look at implementing Danny’s suggestions?

Looks like we’re almost there so it would be sad to let the patch
bitrot!

Thanks,
Ludo’.

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (15 lines)
> Hi!
>
> Thanks for the patch.
>
> I have the following suggestions:
>
> * Please unbundle volk.
> * Please build the documentation (that needs doxygen, ghostscript and texlive-tiny). After that, remove docs/doxygen/html/_formulas.log because it contains timestamps.
> * Please add dependency to alsa-lib.
> * Please add dependency to libusb.
> * Why not fftwf?
> * We should investigate whether grc actually needs the inputs to be propagated (later).
> * Please add dependency to cppunit.
> * Please add dependency to orc.
> * Swig probably is not needed at runtime - isn't a native-input enough?
C
C
Charlie Ritter wrote on 25 May 2018 17:04
(name . Ludovic Courtès)(address . ludo@gnu.org)
cucmuwn22ve.fsf@posteo.net
Ludovic Courtès writes:

Toggle quote (28 lines)
> Hello Charlie,
>
> Did you have a chance to look at implementing Danny’s suggestions?
>
> Looks like we’re almost there so it would be sad to let the patch
> bitrot!
>
> Thanks,
> Ludo’.
>
> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>
>> Hi!
>>
>> Thanks for the patch.
>>
>> I have the following suggestions:
>>
>> * Please unbundle volk.
>> * Please build the documentation (that needs doxygen, ghostscript and texlive-tiny). After that, remove docs/doxygen/html/_formulas.log because it contains timestamps.
>> * Please add dependency to alsa-lib.
>> * Please add dependency to libusb.
>> * Why not fftwf?
>> * We should investigate whether grc actually needs the inputs to be propagated (later).
>> * Please add dependency to cppunit.
>> * Please add dependency to orc.
>> * Swig probably is not needed at runtime - isn't a native-input enough?

I have been busy with other things in my life at the moment and I cannot
contribute to free software as much as I would like to. If someone else
wants to take on the challenge, they can. Once I finish this school
year, I can pick back up the habit of contributing.

Charlie

I'm glad we don't have to play in the shade.
-- Golfer Bobby Jones on being told that it was 105 degrees
in the shade.
G
G
Guillaume Le Vaillant wrote on 9 Apr 2020 23:31
Re: [bug#31259] [PATCH] Add gnuradio.
(address . 31259-done@debbugs.gnu.org)
87zhbkmjm9.fsf@yamatai
Patch adding gnuradio 3.8.0.0 pushed as
d042caf6b73a3547a6b6ef4a0b90601303e066e6.
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQQkUwKxurH4Z/3KlryPP4Yfgut6mgUCXo+ULgAKCRCPP4Yfgut6
mjDrAQCS1wnlIqxsNWp+Xokhn7b+9mOpyJf6NzrmY36EaJrnWQD+Nxt8earUsZ3V
oS0i/1SCObM3JV84z3qZ4rtNNZqMFgE=
=L+6+
-----END PGP SIGNATURE-----

Closed
?