fetching an svn repository always results in a different hash

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • julien lepiller
  • Leo Famulari
Owner
unassigned
Submitted by
julien lepiller
Severity
normal
J
J
julien lepiller wrote on 23 Apr 2018 17:44
(address . bug-guix@gnu.org)
a259b683420b869b5c899b0685a5bd78@lepiller.eu
Hi,

I'm trying to use svn-fetch in a new package, but I always get a
different hash when I try to download the sources. I think this is due
to fetching external resources. Here are two adresses that trigger this
bug:


Here is a package definition I try to use:

(define-public kbuild
(package
(name "kbuild")
(version "0.1.9998")
(source (origin
(method svn-fetch)
(uri (svn-reference
(revision 3025)))
(file-name (string-append name "-" version))
(sha256
(base32
"1k7y2lqqhsfwfzzi7rms7a2kakimm7g46qa2gypkvzdd3drbpanj"))))
(build-system gnu-build-system)
(synopsis "Makefile framework")
(description "kBuild is a makefile framework for writing simple
makefiles
for complex tasks.")
(license license:gpl3+)))
L
L
Leo Famulari wrote on 23 Apr 2018 20:41
(name . julien lepiller)(address . julien@lepiller.eu)(address . 31247@debbugs.gnu.org)
20180423184153.GB27672@jasmine.lan
On Mon, Apr 23, 2018 at 05:44:08PM +0200, julien lepiller wrote:
Toggle quote (6 lines)
> Hi,
>
> I'm trying to use svn-fetch in a new package, but I always get a different
> hash when I try to download the sources. I think this is due to fetching
> external resources. Here are two adresses that trigger this bug:

Can you try comparing the differences between the downloaded archives?
The diffoscope program will be useful.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlreKPEACgkQJkb6MLrK
fwjbrQ/9ESRjgsnlS1fOGbIWfUHuKPoSVqBpjpPO6tU4/hUAXQDO4E8x6uHo1Vml
18+LKcXNKJEx1ahsOG3q9EEnVu9nGMcXYnKECrdLS6pMvJ5QJSwr8ELQTm/NSU3f
LVLEG4frZcIHO3JULbedVwHcSWS/G1t7W1mrzZh+E+4qM5Q3GhxNuqKN3tegRTLH
NAquuNooujlOobQ98wyMND4Asz8UVNmUmal7CoyJT26ojvr07g2FKvuqSqH3CBwF
3B9GeMbflswmNun4QhUrOufPCKgjdf//vADu74F4DmMIIB8XWrvl/xDOrJfxZCcQ
fXfYHdC3KzjLARRwP6wkyDxOMoF4zU7xHWRQljv8aY8nBPBt+N2ozYBFQHVhz66s
Kk2PYxqGLshLz1SkA7jQ4g/vky/9rGWyOXgzwuDati30JKXqjRa2YBxYhcxZ5DlP
UIO9BWYHa1e0LZkFi1ZZ0i7ZgiWONBFwN5GY3DJrfJgT4z/IodDN8ka9ccJELuEm
op86qgRr89giR3uuEfU92WGsxQzX3hMAdRnmc1mvRiwO4HAS6lnUMRA4wwPwKeGp
/Mcwm0qjST8noqgiA9F6N99JfadVjKAg2Nd4CVZ85OuK3GuZx0lQbWBsfQfI2ldb
74xnptzJCJaOzzArk5cBo9jL57yuMfgNQ6+1EuqscTc/pViaAdc=
=TQJW
-----END PGP SIGNATURE-----


J
J
Julien Lepiller wrote on 24 Apr 2018 22:40
(address . 31247@debbugs.gnu.org)
20180424224014.2f65d462@lepiller.eu
Le Mon, 23 Apr 2018 14:41:53 -0400,
Leo Famulari <leo@famulari.name> a écrit :

Toggle quote (11 lines)
> On Mon, Apr 23, 2018 at 05:44:08PM +0200, julien lepiller wrote:
> > Hi,
> >
> > I'm trying to use svn-fetch in a new package, but I always get a
> > different hash when I try to download the sources. I think this is
> > due to fetching external resources. Here are two adresses that
> > trigger this bug:
>
> Can you try comparing the differences between the downloaded archives?
> The diffoscope program will be useful.

There are differences in .svn/wc.db. The top .svn directory is removed,
but there are other .svn directories that are not removed and contain a
wc.db file. In my case, src/lib/kStuff/.svn is kept intact and differs
every time.
D
D
Danny Milosavljevic wrote on 24 Apr 2018 22:56
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 31247@debbugs.gnu.org)
20180424225641.3ce8e18f@scratchpost.org
Hi Julien,

On Tue, 24 Apr 2018 22:40:21 +0200
Julien Lepiller <julien@lepiller.eu> wrote:

Toggle quote (13 lines)
> > > I'm trying to use svn-fetch in a new package, but I always get a
> > > different hash when I try to download the sources. I think this is
> > > due to fetching external resources. Here are two adresses that
> > > trigger this bug:
> >
> > Can you try comparing the differences between the downloaded archives?
> > The diffoscope program will be useful.
>
> There are differences in .svn/wc.db. The top .svn directory is removed,
> but there are other .svn directories that are not removed and contain a
> wc.db file. In my case, src/lib/kStuff/.svn is kept intact and differs
> every time.

I think we should change guix/build/svn.scm to also delete the other ".svn"
directories.

Those contain state that is not necessary for the build - and since it's
causing trouble, we can just remove them.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlrfmgkACgkQ5xo1VCww
uqUAXAgAlRuIceVYXOF6lPe0zAmx0N2JLrA/aqLuWub0HXXtouGXRxyRu8KHJeNU
JnERBjSbmUnQy9oQ15PApluukrKr209Y84EDLal3lt98aGxQJrUgKPm3i/Hu3iFC
22+Rpr2ykkAGSSDhGY4di/GeiQuQjmNPsAtMVRGCE9cqbyAxShLvo223KGGJe4Wr
k+e1ZN73qOnXUEve7/9nwqYQ026NeJcOTrnxdzr9Q2LRPyYpOmDkf8jTv/CnI1SC
HeFBV99v92Jt2X0n+M9CNvuVfl9VPnE9dL6xHSYojaoKOuDM/t2xzc05QMpxbjE8
cgQq7qb1/RlUq+rZMmzaLRAUxVUtrg==
=+VoW
-----END PGP SIGNATURE-----


J
J
Julien Lepiller wrote on 5 Apr 2019 14:54
Re: fetching an svn repository always results in a different hash
(address . 31247-done@debbugs.gnu.org)
BADA5930-D702-4439-A744-AFE0C3D9E174@lepiller.eu
This is now fixed on master. Closing.
Closed
?