[PATCH 0/2] Add console-agetty-service.

  • Done
  • quality assurance status badge
Details
4 participants
  • Danny Milosavljevic
  • Ludovic Courtès
  • Maxim Cournoyer
  • zimoun
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal
D
D
Danny Milosavljevic wrote on 15 Feb 2018 12:42
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20180215114256.551-1-dannym@scratchpost.org
Danny Milosavljevic (2):
services: Add console-agetty-service.
services: agetty-shepherd-service: Default to providing 'term-console
instead of 'term-auto .

gnu/services/base.scm | 38 ++++++++++++++++++++++++++++++++------
1 file changed, 32 insertions(+), 6 deletions(-)
D
D
Danny Milosavljevic wrote on 15 Feb 2018 12:47
[PATCH 1/2] services: Add console-agetty-service.
(address . 30464@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20180215114742.663-1-dannym@scratchpost.org
* gnu/services/base.scm (<agetty-configuration>): Make tty default to #f.
(console-agetty-shepherd-service): New variable.
(console-agetty-service-type): New variable.
(console-agetty-service): New variable.
(%base-services): Replace agetty-service instance by console-agetty-service
instance.
---
gnu/services/base.scm | 35 ++++++++++++++++++++++++++++++-----
1 file changed, 30 insertions(+), 5 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index 1ad7c2320..29ae5fca3 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -817,7 +817,8 @@ the message of the day, among other things."
agetty-configuration?
(agetty agetty-configuration-agetty ;<package>
(default util-linux))
- (tty agetty-configuration-tty) ;string | #f
+ (tty agetty-configuration-tty ;string | #f
+ (default #f))
(term agetty-term ;string | #f
(default #f))
(baud-rate agetty-baud-rate ;string | #f
@@ -1072,6 +1073,31 @@ program.")))
the tty to run, among other things."
(service agetty-service-type config))
+(define console-agetty-shepherd-service
+ (lambda (config)
+ (let ((base-service
+ (car
+ (agetty-shepherd-service
+ (agetty-configuration (inherit config)
+ (keep-baud? #t))))))
+ (list
+ (shepherd-service (inherit base-service)
+ ;; Make sure that Linux doesn't log to the same console as well.
+ (requirement (cons 'syslogd (shepherd-service-requirement base-service))))))))
+
+(define console-agetty-service-type
+ (service-type (name 'console-agetty)
+ (extensions (list (service-extension shepherd-root-service-type
+ console-agetty-shepherd-service)))
+ (description
+ "Provide console login using the @command{agetty}
+program on the Linux console.")))
+
+(define* (console-agetty-service config)
+ "Return a service to run agetty according to @var{config}, which specifies
+the tty to run, defaulting to the Linux console."
+ (service console-agetty-service-type config))
+
(define-record-type* <mingetty-configuration>
mingetty-configuration make-mingetty-configuration
mingetty-configuration?
@@ -2053,10 +2079,9 @@ This service is not part of @var{%base-services}."
(cons tty %default-console-font))
'("tty1" "tty2" "tty3" "tty4" "tty5" "tty6")))
- (agetty-service (agetty-configuration
- (extra-options '("-L")) ; no carrier detect
- (term "vt100")
- (tty #f))) ; automatic
+ (console-agetty-service (agetty-configuration
+ (extra-options '("-L")) ; no carrier detect
+ (term "vt100")))
(mingetty-service (mingetty-configuration
(tty "tty1")))
D
D
Danny Milosavljevic wrote on 15 Feb 2018 12:47
[PATCH 2/2] services: agetty-shepherd-service: Default to providing 'term-console instead of 'term-auto .
(address . 30464@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20180215114742.663-2-dannym@scratchpost.org
* gnu/services/base.scm (agetty-shepherd-service): Default to providing
'term-console instead of 'term-auto .
---
gnu/services/base.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (14 lines)
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index 29ae5fca3..4ab83d1d2 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -937,7 +937,8 @@ to use as the tty. This is primarily useful for headless systems."
(shepherd-service
(modules '((ice-9 match) (gnu build linux-boot)))
(documentation "Run agetty on a tty.")
- (provision (list (symbol-append 'term- (string->symbol (or tty "auto")))))
+ (provision (list (symbol-append 'term- (string->symbol
+ (or tty "console")))))
;; Since the login prompt shows the host name, wait for the 'host-name'
;; service to be done. Also wait for udev essentially so that the tty
L
L
Ludovic Courtès wrote on 15 Feb 2018 15:40
Re: [bug#30464] [PATCH 1/2] services: Add console-agetty-service.
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 30464@debbugs.gnu.org)
87r2pm8gfl.fsf@gnu.org
Hello,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (7 lines)
> * gnu/services/base.scm (<agetty-configuration>): Make tty default to #f.
> (console-agetty-shepherd-service): New variable.
> (console-agetty-service-type): New variable.
> (console-agetty-service): New variable.
> (%base-services): Replace agetty-service instance by console-agetty-service
> instance.

Could you explain the rationale?

The only difference is that this shepherd service depends on ‘syslogd’
whereas the current agetty service doesn’t, right?

Toggle quote (5 lines)
> +(define* (console-agetty-service config)
> + "Return a service to run agetty according to @var{config}, which specifies
> +the tty to run, defaulting to the Linux console."
> + (service console-agetty-service-type config))

In general we don’t provide such procedures any more and instead expose
service types and configs directly.

Thanks,
Ludo’.
D
D
Danny Milosavljevic wrote on 15 Feb 2018 16:41
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30464@debbugs.gnu.org)
20180215164135.188beed0@scratchpost.org
Hi Ludo,

On Thu, 15 Feb 2018 15:40:14 +0100
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (5 lines)
> Could you explain the rationale?
>
> The only difference is that this shepherd service depends on ‘syslogd’
> whereas the current agetty service doesn’t, right?

Yes, it's my inner OCD.

Right now, the agetty is started while the Linux kernel is still booting and
printing stuff to the console. So you have two parties printing stuff
to the same console simultaneously. That looks ... not nice.

What this would do is the getty would only be started (and printing stuff)
after syslogd. The first thing syslogd does is it disables the Linux direct
console printing.

It doesn't make sense to have agetty itself depend on syslogd because
agetty can be (and usually is) used for modems etc which have nothing
to do with the local console.

Toggle quote (8 lines)
> > +(define* (console-agetty-service config)
> > + "Return a service to run agetty according to @var{config}, which specifies
> > +the tty to run, defaulting to the Linux console."
> > + (service console-agetty-service-type config))
>
> In general we don’t provide such procedures any more and instead expose
> service types and configs directly.

Okay, I can remove that one and inline it at the (only) call site.
L
L
Ludovic Courtès wrote on 15 Feb 2018 16:47
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 30464@debbugs.gnu.org)
878tbu8dat.fsf@gnu.org
Heya,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (14 lines)
> On Thu, 15 Feb 2018 15:40:14 +0100
> ludo@gnu.org (Ludovic Courtès) wrote:
>
>> Could you explain the rationale?
>>
>> The only difference is that this shepherd service depends on ‘syslogd’
>> whereas the current agetty service doesn’t, right?
>
> Yes, it's my inner OCD.
>
> Right now, the agetty is started while the Linux kernel is still booting and
> printing stuff to the console. So you have two parties printing stuff
> to the same console simultaneously. That looks ... not nice.

Right.

Toggle quote (4 lines)
> What this would do is the getty would only be started (and printing stuff)
> after syslogd. The first thing syslogd does is it disables the Linux direct
> console printing.

OK, got it.

(Which has me thinking that longer term it’d be nice to have the
Shepherd take care of syslogd-ish activity.)

Toggle quote (4 lines)
> It doesn't make sense to have agetty itself depend on syslogd because
> agetty can be (and usually is) used for modems etc which have nothing
> to do with the local console.

Alright.

How about adding a ‘dependencies’ field to <agetty-configuration>? It’d
default to the empty list, and could be set to '(syslogd) in this case.

Does that sound too obscure to you, or would it be OK?

Thanks,
Ludo’.
D
D
Danny Milosavljevic wrote on 16 Feb 2018 21:57
shepherd logging; console-agetty-service
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30464@debbugs.gnu.org)
20180216215725.58607c8c@scratchpost.org
Hi Ludo,

On Thu, 15 Feb 2018 16:47:54 +0100
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (3 lines)
> (Which has me thinking that longer term it’d be nice to have the
> Shepherd take care of syslogd-ish activity.)

If you mean that we should make sure to log shepherd's own messages, I agree.

Integrating syslogd into shepherd, not sure. I think external syslogd is fine.
If not, there are a lot of other logging programs to choose from.
I like modularity.

shepherd could write its messages to the kernel log ringbuffer in /dev/kmsg [3].
That sounds dirty, but it would synchronize messages oh-so-nicely and would
not immediately require syslogd. It would also make sure that syslogd
eventually picks shepherd's messages up (right now they are somewhere on the
first terminal - if you are lucky and they didn't scroll off).

I'm not sure whether then they would be printed to /dev/console as well then -
probably.

We'd need a guile soft-port, but it's not like I haven't done that before.

User-shepherd shouldn't do it though (and can't because it doesn't have
permission to write to /dev/kmsg).

Please stop me and tell me why it's a bad idea :)

Also a way of capturing stderr and stdout (and maybe even /dev/log) of services
would be nice.

If you thought that the above was bad, you ain't seen nothing yet :->

We could also instead open /dev/klog and dup2 its fd to 1 and 2.
That way, shepherd messages and all stray messages by any process shepherd
started will end up in the kernel log. (problem: there are some reserved
patterns that have special meaning - and we don't control what the services
do as well as we do what just shepherd does)

Also, I know one is supposed to write UNIX services as daemons, but that's
not really composable and kinda complicated to debug for no good reason.
I'd prefer if shepherd also keeps a way to run regular programs as services,
making sure that they are session leader, their output is logged, they are
kept alive and monitored.

daemontools[1][2] have done all this stuff already and I like it much more
than traditional service managers. It's much more modular, handles logging
on its own, handles error cases well, uses the file system well etc, handles
errors in the loggers (!).

Toggle quote (5 lines)
> How about adding a ‘dependencies’ field to <agetty-configuration>? It’d
> default to the empty list, and could be set to '(syslogd) in this case.
>
> Does that sound too obscure to you, or would it be OK?

Sure, let's do that.

It's a little weird to have it for all agettys, although maybe some other users
of agetty require it anyway.

Then I wonder if all guix shepherd service configs should have such a field.

dev_kmsg_fd = open("/dev/kmsg", O_RDWR|O_CLOEXEC|O_NONBLOCK|O_NOCTTY);
printf "<%i>" priority identifier "[" pid "]: " message "\n"

Linux:

/*
* Extract and skip the syslog prefix <[0-9]*>. Coming from userspace
* the decimal value represents 32bit, the lower 3 bit are the log
* level, the rest are the log facility.
*
* If no prefix or no userspace facility is specified, we
* enforce LOG_USER [which is 1], to be able to reliably distinguish
* kernel-generated messages from userspace-injected ones.
*/
D
D
Danny Milosavljevic wrote on 16 Feb 2018 22:07
Re: shepherd logging
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30464@debbugs.gnu.org)
20180216220737.0b5b7c0d@scratchpost.org
Oops, didn't see /var/log/shepherd.log - but I think it should just
use syslog for that - and it's possible to use syslog for that by
writing to /dev/kmsg .

Does the Hurd with /dev/kmsg ? How do they solve early boot logging ?
L
L
Ludovic Courtès wrote on 17 Feb 2018 17:20
Re: shepherd logging; console-agetty-service
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 30464@debbugs.gnu.org)
87sh9zk2q1.fsf@gnu.org
Hi,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (8 lines)
> On Thu, 15 Feb 2018 16:47:54 +0100
> ludo@gnu.org (Ludovic Courtès) wrote:
>
>> (Which has me thinking that longer term it’d be nice to have the
>> Shepherd take care of syslogd-ish activity.)
>
> If you mean that we should make sure to log shepherd's own messages, I agree.

That’s already done.

Toggle quote (4 lines)
> Integrating syslogd into shepherd, not sure. I think external syslogd is fine.
> If not, there are a lot of other logging programs to choose from.
> I like modularity.

Yes, I like it too. OTOH, there’s a chicken-and-egg problem here:
shepherd ends up implementing its own logging facility, and we have
situations like the one you mentioned earlier in this thread.

Toggle quote (6 lines)
> shepherd could write its messages to the kernel log ringbuffer in /dev/kmsg [3].
> That sounds dirty, but it would synchronize messages oh-so-nicely and would
> not immediately require syslogd. It would also make sure that syslogd
> eventually picks shepherd's messages up (right now they are somewhere on the
> first terminal - if you are lucky and they didn't scroll off).

Indeed, that’s something we can easily do already, and it would address
a major annoyance. :-) Actually, could it use syslog(3), which writes
to /dev/log?

Toggle quote (3 lines)
> Also a way of capturing stderr and stdout (and maybe even /dev/log) of services
> would be nice.

Yes. Though again capturing service stdout/stderr is kinda redundant
with what syslogd does. What I like in journald is the fact that it
unifies all logging facilities, and also connects them to service
management.

Toggle quote (6 lines)
> We could also instead open /dev/klog and dup2 its fd to 1 and 2.
> That way, shepherd messages and all stray messages by any process shepherd
> started will end up in the kernel log. (problem: there are some reserved
> patterns that have special meaning - and we don't control what the services
> do as well as we do what just shepherd does)

Right, so we’d need shepherd to filter these and pass them through
syslog(3), which ensures correct message formatting. That’s what
does apparently (thanks for the link!).

Toggle quote (6 lines)
> Also, I know one is supposed to write UNIX services as daemons, but that's
> not really composable and kinda complicated to debug for no good reason.
> I'd prefer if shepherd also keeps a way to run regular programs as services,
> making sure that they are session leader, their output is logged, they are
> kept alive and monitored.

Sure!

Toggle quote (5 lines)
> daemontools[1][2] have done all this stuff already and I like it much more
> than traditional service managers. It's much more modular, handles logging
> on its own, handles error cases well, uses the file system well etc, handles
> errors in the loggers (!).

Sounds like a great source of inspiration then. :-)

Toggle quote (12 lines)
>> How about adding a ‘dependencies’ field to <agetty-configuration>? It’d
>> default to the empty list, and could be set to '(syslogd) in this case.
>>
>> Does that sound too obscure to you, or would it be OK?
>
> Sure, let's do that.
>
> It's a little weird to have it for all agettys, although maybe some other users
> of agetty require it anyway.
>
> Then I wonder if all guix shepherd service configs should have such a field.

That brings us to the topic of a general service customization
mechanism: https://bugs.gnu.org/27155. Well, one thing at a time.
:-)

Thanks for the great ideas!

Ludo’.
L
L
Ludovic Courtès wrote on 17 Feb 2018 17:25
Re: shepherd logging
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 30464@debbugs.gnu.org)
87k1vbk2ho.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (6 lines)
> Oops, didn't see /var/log/shepherd.log - but I think it should just
> use syslog for that - and it's possible to use syslog for that by
> writing to /dev/kmsg .
>
> Does the Hurd with /dev/kmsg ?

It doesn’t have /dev/kmsg, but it has /dev/klog:

Toggle snippet (6 lines)
ludo@darnassus:~$ ls -l /dev/klog
crw-rw---- 1 root root 0, 0 Jul 16 2015 /dev/klog
ludo@darnassus:~$ showtrans /dev/klog
/hurd/streamio kmsg

Toggle quote (2 lines)
> How do they solve early boot logging ?

GNU Mach has a special “console” device that early boot processes can
open and write too, as in:


It’s comparable to /dev/kmsg, but it exists before file system servers
are brought up, which is why it doesn’t have an entry in the file
system hierarchy.

Ludo’.
D
D
Danny Milosavljevic wrote on 17 Feb 2018 17:47
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30464@debbugs.gnu.org)
20180217174723.7a5daf84@scratchpost.org
Toggle quote (6 lines)
>
> It’s comparable to /dev/kmsg, but it exists before file system servers
> are brought up, which is why it doesn’t have an entry in the file
> system hierarchy.

Huh, so it's just connected to stderr? That means it should work fine already
with no changes in shepherd. Nice!

Just to be sure, it is possible to read out these messages and log them to a
file later on, right?
L
L
Ludovic Courtès wrote on 17 Feb 2018 17:57
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 30464@debbugs.gnu.org)
87efljk0yx.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (9 lines)
>>
>> It’s comparable to /dev/kmsg, but it exists before file system servers
>> are brought up, which is why it doesn’t have an entry in the file
>> system hierarchy.
>
> Huh, so it's just connected to stderr? That means it should work fine already
> with no changes in shepherd. Nice!

Indeed!

Toggle quote (3 lines)
> Just to be sure, it is possible to read out these messages and log them to a
> file later on, right?

I think what goes to “console” is printed and then forever lost:


That said, not much should go there since as soon as the root file
system is up, processes can start using /dev/klog.

Ludo’.
L
L
Ludovic Courtès wrote on 26 Feb 2018 18:52
Re: [bug#30464] [PATCH 1/2] services: Add console-agetty-service.
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 30464@debbugs.gnu.org)
877eqzvdsi.fsf@gnu.org
Hi Danny,

The discussion drifted a bit… :-)

ludo@gnu.org (Ludovic Courtès) skribis:

Toggle quote (2 lines)
> Danny Milosavljevic <dannym@scratchpost.org> skribis:

[...]

Toggle quote (11 lines)
>> It doesn't make sense to have agetty itself depend on syslogd because
>> agetty can be (and usually is) used for modems etc which have nothing
>> to do with the local console.
>
> Alright.
>
> How about adding a ‘dependencies’ field to <agetty-configuration>? It’d
> default to the empty list, and could be set to '(syslogd) in this case.
>
> Does that sound too obscure to you, or would it be OK?

Thoughts? The ‘dependencies’ hack looks simple enough and would solve
this immediate need, I think.

Ludo’.
M
M
Maxim Cournoyer wrote on 8 Oct 2020 20:21
(name . Ludovic Courtès)(address . ludo@gnu.org)
87ft6otw7b.fsf@gmail.com
Hello Danny,

ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (26 lines)
> Hi Danny,
>
> The discussion drifted a bit… :-)
>
> ludo@gnu.org (Ludovic Courtès) skribis:
>
>> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>
> [...]
>
>>> It doesn't make sense to have agetty itself depend on syslogd because
>>> agetty can be (and usually is) used for modems etc which have nothing
>>> to do with the local console.
>>
>> Alright.
>>
>> How about adding a ‘dependencies’ field to <agetty-configuration>? It’d
>> default to the empty list, and could be set to '(syslogd) in this case.
>>
>> Does that sound too obscure to you, or would it be OK?
>
> Thoughts? The ‘dependencies’ hack looks simple enough and would solve
> this immediate need, I think.
>
> Ludo’.

Any update on this?

Maxim
Z
Z
zimoun wrote on 13 Jan 2022 17:02
Re: bug#30464: [PATCH 0/2] Add console-agetty-service.
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
86h7a7ipxo.fsf_-_@gmail.com
Hi,

This patch #30464 series [1] had been submitted on Feb 2018 and after a
drifting discussion, the last message is:


On Thu, 08 Oct 2020 at 14:21, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:

Toggle quote (20 lines)
>> The discussion drifted a bit… :-)
>>
>> [...]
>>
>>>> It doesn't make sense to have agetty itself depend on syslogd because
>>>> agetty can be (and usually is) used for modems etc which have nothing
>>>> to do with the local console.
>>>
>>> Alright.
>>>
>>> How about adding a ‘dependencies’ field to <agetty-configuration>? It’d
>>> default to the empty list, and could be set to '(syslogd) in this case.
>>>
>>> Does that sound too obscure to you, or would it be OK?
>>
>> Thoughts? The ‘dependencies’ hack looks simple enough and would solve
>> this immediate need, I think.
>
> Any update on this?

Therefore, any update on this?


Cheers,
simon

Z
Z
zimoun wrote on 3 Feb 2022 03:33
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
86k0ec1xxp.fsf_-_@gmail.com
Hi,



On Thu, 13 Jan 2022 at 17:02, zimoun <zimon.toutoune@gmail.com> wrote:

Toggle quote (28 lines)
> This patch #30464 series [1] had been submitted on Feb 2018 and after a
> drifting discussion, the last message is:
>
>
> On Thu, 08 Oct 2020 at 14:21, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
>
>>> The discussion drifted a bit… :-)
>>>
>>> [...]
>>>
>>>>> It doesn't make sense to have agetty itself depend on syslogd because
>>>>> agetty can be (and usually is) used for modems etc which have nothing
>>>>> to do with the local console.
>>>>
>>>> Alright.
>>>>
>>>> How about adding a ‘dependencies’ field to <agetty-configuration>? It’d
>>>> default to the empty list, and could be set to '(syslogd) in this case.
>>>>
>>>> Does that sound too obscure to you, or would it be OK?
>>>
>>> Thoughts? The ‘dependencies’ hack looks simple enough and would solve
>>> this immediate need, I think.
>>
>> Any update on this?
>
> Therefore, any update on this?

Without any update on this, I plan to mark it as ’donewontfix’ in a
couple of weeks. Let me know if it is worth to keep it open.


Cheers,
simon
D
D
Danny Milosavljevic wrote on 3 Feb 2022 21:55
(name . zimoun)(address . zimon.toutoune@gmail.com)
20220203215534.1fc0f095@scratchpost.org
Heh.

This problem is really not that bad in the big scheme of things.

first, obsoleting the need for this workaround here :(

Toggle quote (4 lines)
> >>>>> It doesn't make sense to have agetty itself depend on syslogd because
> >>>>> agetty can be (and usually is) used for modems etc which have nothing
> >>>>> to do with the local console.

For completeness:

It would also be possible to depend on syslogd by default and *also* have the
modem agettys startup delayed until syslogd is there. But if you have a
modem agetty service but NO syslogd shepherd service in your config, that
would hang the boot with no remote access. So let's not do that.

27155 could maybe statically analyze whether there is a syslogd and an agetty
in the config, and error out if not both or neither.

Toggle quote (3 lines)
> >>>> How about adding a ‘dependencies’ field to <agetty-configuration>? It’d
> >>>> default to the empty list, and could be set to '(syslogd) in this case.

Yeah, we have to default to '() in the interest of backward compatibility
anyway.

Toggle quote (2 lines)
> >>>> Does that sound too obscure to you, or would it be OK?

Yes, it should be ok.

See bug# 53763 for a patchset.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAmH8QUYACgkQ5xo1VCww
uqVsVAf/f/wDUQ2JenPPoEEUw4l33hhvNcTLdtpPC5oH1BJJkDDjCbiP7Ndx6EII
TwFXey9OA0gqbNu0yF1bqfhR5Dgj7yES1UBcydpPlcxYcEn8Z+kIi5giZsbWUKt4
8Tb7MsWkC1NV0KIWq7k7bSq5IMSHZJnFzf6cwoxP7V664ky2qtrLRUw6OzWdrjhh
S/NBAfDUna5uV7yDr900mwwgff9iMtOPUo+u8z5jX/eTark9TcxHk30DHsFOLOgX
E9q2w1CDqf6vW0N+32e/bb4aYRHyLLsMElGykK6lU0btP3SqL51MTDMAi40rDgef
nLdQkCCLCJdf0pLLQlSRg7hGlLXx9A==
=z/e3
-----END PGP SIGNATURE-----


D
D
Danny Milosavljevic wrote on 25 Feb 2022 17:17
Re: [PATCH 0/3] Make console agetty wait for syslogd to start up
20220225171738.296d1a25@scratchpost.org
Pushed agetty changes as commits ed17082d94bdcdb67713e95d181061d179299aad, fcb6cab62149fd46d9fe496b91cc019a43774a43, 07c3a439555113bdd0bd416265221063d263f44c.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAmIZASIACgkQ5xo1VCww
uqVyZQf8CSv33uhNWAxCDjWHePLx5Im+XgnaXju4BprxOf4wLkYu3DWdZfo+jFER
vXzeofIbnBZFeDEOtCxfFbpuXTi9UwPXWJL/Ba6pz+nrcnU37aQyApVQZgHfytLS
3goV2iLTh6reAX7nZzUyvGclP5HumbJLxguByK0uOLp8XPvJp7tYwt2xjiQNYR2r
9/BedNcOlzjqz0j3WrWxeOj3UYKHboGM2fqQjCcCrnGiTL0ZON3E2/CuB9ts+m+O
1XuM/7NZDRDtHRmYVItIA3tyw4TYSl9vp78qtE35Z6QMNjZREoYk4QOMANX5LCXj
LETOE8ajWNQs4vceJHTmZzfLw/To6g==
=Ccqf
-----END PGP SIGNATURE-----


Closed
Z
Z
zimoun wrote on 23 Mar 2022 14:00
Re: bug#30464: [PATCH 0/2] Add console-agetty-service.
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
86ils4zuvz.fsf_-_@gmail.com
Hi Danny,

On Thu, 03 Feb 2022 at 21:55, Danny Milosavljevic <dannym@scratchpost.org> wrote:

Toggle quote (2 lines)
> See bug# 53763 for a patchset.

Thanks! Really cool that this old report is now closed. :-)


Cheers,
simon
?