[PATCH] gnu: Add mtr.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Tobias Geerinckx-Rice
Severity
normal
T
T
Tobias Geerinckx-Rice wrote on 30 Nov 2017 03:10
(address . guix-patches@gnu.org)
20171130021035.12580-1-me@tobias.gr
* gnu/packages/networking.scm (mtr): New public variable.
---

Guix,

This adds mtr, the “it can't not be in Guix already what am I searching
wrong!?” network monitor.

Kind regards,

T G-R

gnu/packages/networking.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 1f4906b7b..755f76b15 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1536,3 +1536,34 @@ at the IP layer and link layer, as well as a host of supplementary
functionality. Using libnet, quick and simple packet assembly applications
can be whipped up with little effort.")
(license license:bsd-2)))
+
+(define-public mtr
+ (package
+ (name "mtr")
+ (version "0.92")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "ftp://ftp.bitwizard.nl/" name "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32 "10j3ds3p27jygys4x08kj8fi3zlsgiv72xsfazkah6plwawrv5zj"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libcap" ,libcap)
+ ("ncurses" ,ncurses)))
+ (native-inputs
+ ;; The 0.92 release tarball still requires the ‘autoheader’ tool.
+ `(("autoconf" ,autoconf)))
+ (arguments
+ `(#:tests? #f)) ; tests require network access
+ (home-page "https://www.bitwizard.nl/mtr/")
+ (synopsis "Network diagnostic tool")
+ (description
+ "@dfn{mtr} (My TraceRoute) combines the functionality of the
+@command{traceroute} and @command{ping} programs in a single network diagnostic
+tool. @command{mtr} uses ICMP ECHO packets to detect intermediate routers (or
+@dfn{hops}) between the local host and a user-specified destination. It then
+continually measures the response time and packet loss at each hop, and
+displays the results in real time.")
+ (license license:gpl2+)))
--
2.15.0
L
L
Ludovic Courtès wrote on 30 Nov 2017 18:13
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 29502@debbugs.gnu.org)
87bmjj1yhk.fsf@gnu.org
Tobias Geerinckx-Rice <me@tobias.gr> skribis:

Toggle quote (8 lines)
> * gnu/packages/networking.scm (mtr): New public variable.
> ---
>
> Guix,
>
> This adds mtr, the “it can't not be in Guix already what am I searching
> wrong!?” network monitor.

Heheh, I didn’t know it. :-) LGTM!

Ludo’.
T
T
Tobias Geerinckx-Rice wrote on 1 Dec 2017 16:13
(address . ludo@gnu.org)(address . 29502-done@debbugs.gnu.org)
995cfebf-93ce-3249-ffbf-f5b075c4811c@tobias.gr
Ludovic Courtès wrote on 30/11/17 at 18:13:
Toggle quote (2 lines)
> Heheh, I didn’t know it. :-) LGTM!

Thanks! Pushed as b59a8fd49afa79bb9c3bf5e71dce6f3eec2a0808.

Kind regards,

T G-R
Closed
?