offloading: empty machines file leads to error

  • Done
  • quality assurance status badge
Details
4 participants
  • ng0
  • Maxim Cournoyer
  • Tobias Geerinckx-Rice
  • zimoun
Owner
unassigned
Submitted by
ng0
Severity
normal
N
(address . bug-guix@gnu.org)
20170303165648.wg5nypcizxr2n6t5@abyayala
I have misplaced my log for this, but it is easy to reproduce:

configure offloading on master and build-machine, comment the entire
content of the file which holds the build-machines, run "guix build
hello" and see the error.

This should even work when you haven't configured offloading, just with
an empty machines file.
Z
Z
zimoun wrote on 3 May 2020 18:43
Bug#25952: offloading empty machines file
CAJ3okZ2DrBGb8WCGe=utnzMEpFf=myJXAO6AuX5Y8kCGNvMDGA@mail.gmail.com
Dear,

Digging in the bug tracker, I found this bug report [1]. Could you
expand on the issue? And report the error message?

Thank you in advance.

Best regards,
simon

Z
Z
zimoun wrote on 22 May 2020 02:12
tags 25952 moreinfo
(address . control@debbugs.gnu.org)
CAJ3okZ1JJtd63tmTubSw_2D2y4uJSxvUwsLYtXCzi7N=wYYm5g@mail.gmail.com
tags 25952 moreinfo
thanks
Z
Z
zimoun wrote on 25 May 2020 19:12
bug#25952: offloading empty machines file
CAJ3okZ2789hrEjvDX2Tsp84tnJgTa4fGP0DR+wfsUEVKCi21bw@mail.gmail.com
Dear,

This bug [1] had not been commented since the last 3 years and it has
been asked more info 3 weeks ago. Therefore, I am closing. Feel free
to reopen if I misunderstand something.



All the best,
simon
Closed
T
T
Tobias Geerinckx-Rice wrote on 25 May 2020 22:32
(name . zimoun)(address . zimon.toutoune@gmail.com)
87tv03ycvo.fsf@nckx
Simon,

zimoun ???
Toggle quote (4 lines)
> This bug [1] had not been commented since the last 3 years and
> it has
> been asked more info 3 weeks ago.

The issue is that files such as /etc/guix/machines.scm (but this
applies equally to /etc/guix/acl & so on) are expected to evaluate
to a sexp.

An empty file does not a valid sexp make, so Guix throws an
prickly backtrace @ your face & dies. This is unlike most other
configuration formats where an empty file or one consisting
entirely of comments is a no-op.

We should decide whether ‘’ is a valid sexp (oh dear, philosophy)
or throw something softer at people.

Toggle quote (3 lines)
> Therefore, I am closing. Feel free to reopen if I misunderstand
> something.

I think this bug should remain open until it's decided. What you?

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXswrSwAKCRANsP+IT1Vt
eXXjAQCx5MlfcTM3OO12N+85EBSGgK5re8c+ELoLFe/8AZlU3wEAjffZYlMaH0Ti
9NXxZ4ykPcG7ehnK23MX4z9c67PJ/wU=
=SxtD
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 26 May 2020 00:43
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)
CAJ3okZ0G+4um-=xfq1SL7ZwiOBXzAjXvNcPR91MdfqPGz+qUBw@mail.gmail.com
Hi Tobias,

On Mon, 25 May 2020 at 22:32, Tobias Geerinckx-Rice <me@tobias.gr> wrote:

Toggle quote (9 lines)
> The issue is that files such as /etc/guix/machines.scm (but this
> applies equally to /etc/guix/acl & so on) are expected to evaluate
> to a sexp.
>
> An empty file does not a valid sexp make, so Guix throws an
> prickly backtrace @ your face & dies. This is unlike most other
> configuration formats where an empty file or one consisting
> entirely of comments is a no-op.

Hum? I am not sure to get the point. Are we talking about this kind
of situations, e.g.,

Toggle snippet (4 lines)
touch /tmp/empty.scm
guix package -m /tmp/empty.scm -p /tmp/empy

or

Toggle snippet (4 lines)
echo ";; hello" > /tmp/comment.scm
guix package -m /tmp/comment.scm -p /tmp/comment

or

Toggle snippet (4 lines)
echo "(define x 42)" > /tmp/answer.scm
guix package -m /tmp/answer.scm -p /tmp/answer

?


Toggle quote (3 lines)
> We should decide whether ‘’ is a valid sexp (oh dear, philosophy)
> or throw something softer at people.

Throw something more "helping" than e.g.,

Toggle snippet (10 lines)
Backtrace:
1 (primitive-load "/home/simon/.config/guix/current/bin/g…")
In guix/ui.scm:
1936:12 0 (run-guix-command _ . _)

guix/ui.scm:1936:12: In procedure run-guix-command:
In procedure struct-vtable: Wrong type argument in position 1
(expecting struct): #<unspecified>

?


Toggle quote (5 lines)
> > Therefore, I am closing. Feel free to reopen if I misunderstand
> > something.
>
> I think this bug should remain open until it's decided. What you?

Well, it is a variant of Cunningham's Law, isn't it? :-)
So, let reopen it and decide on the philosophical dilemma. ;-)


Cheers,
simon
Z
Z
zimoun wrote on 14 Sep 2020 19:26
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)
87k0wwqng4.fsf@gmail.com
Dear,

On Tue, 26 May 2020 at 00:43, zimoun <zimon.toutoune@gmail.com> wrote:
Toggle quote (30 lines)
> On Mon, 25 May 2020 at 22:32, Tobias Geerinckx-Rice <me@tobias.gr> wrote:
>
>> The issue is that files such as /etc/guix/machines.scm (but this
>> applies equally to /etc/guix/acl & so on) are expected to evaluate
>> to a sexp.
>>
>> An empty file does not a valid sexp make, so Guix throws an
>> prickly backtrace @ your face & dies. This is unlike most other
>> configuration formats where an empty file or one consisting
>> entirely of comments is a no-op.
>
> Hum? I am not sure to get the point. Are we talking about this kind
> of situations, e.g.,
>
> touch /tmp/empty.scm
> guix package -m /tmp/empty.scm -p /tmp/empy
>
> or
>
> echo ";; hello" > /tmp/comment.scm
> guix package -m /tmp/comment.scm -p /tmp/comment
>
> or
>
> echo "(define x 42)" > /tmp/answer.scm
> guix package -m /tmp/answer.scm -p /tmp/answer
>
>
> ?

If we are talking about such cases, I think we can close this bug
report.


Toggle quote (16 lines)
>> We should decide whether ‘’ is a valid sexp (oh dear, philosophy)
>> or throw something softer at people.
>
> Throw something more "helping" than e.g.,
>
> Backtrace:
> 1 (primitive-load "/home/simon/.config/guix/current/bin/g…")
> In guix/ui.scm:
> 1936:12 0 (run-guix-command _ . _)
>
> guix/ui.scm:1936:12: In procedure run-guix-command:
> In procedure struct-vtable: Wrong type argument in position 1
> (expecting struct): #<unspecified>
>
> ?

More helping as suggested for example in this message:


If yes, the bug report should be renamed. And probably goes to the
Guile bug tracker. :-)


All the best,
simon
Z
Z
zimoun wrote on 5 Jul 2021 13:07
Re: bug#25952: offloading: empty machines file leads to error
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)
87wnq5j9ye.fsf_-_@gmail.com
Hi,


On Mon, 14 Sep 2020 at 19:26, zimoun <zimon.toutoune@gmail.com> wrote:
Toggle quote (59 lines)
> On Tue, 26 May 2020 at 00:43, zimoun <zimon.toutoune@gmail.com> wrote:
>> On Mon, 25 May 2020 at 22:32, Tobias Geerinckx-Rice <me@tobias.gr> wrote:
>>
>>> The issue is that files such as /etc/guix/machines.scm (but this
>>> applies equally to /etc/guix/acl & so on) are expected to evaluate
>>> to a sexp.
>>>
>>> An empty file does not a valid sexp make, so Guix throws an
>>> prickly backtrace @ your face & dies. This is unlike most other
>>> configuration formats where an empty file or one consisting
>>> entirely of comments is a no-op.
>>
>> Hum? I am not sure to get the point. Are we talking about this kind
>> of situations, e.g.,
>>
>> touch /tmp/empty.scm
>> guix package -m /tmp/empty.scm -p /tmp/empy
>>
>> or
>>
>> echo ";; hello" > /tmp/comment.scm
>> guix package -m /tmp/comment.scm -p /tmp/comment
>>
>> or
>>
>> echo "(define x 42)" > /tmp/answer.scm
>> guix package -m /tmp/answer.scm -p /tmp/answer
>>
>>
>> ?
>
> If we are talking about such cases, I think we can close this bug
> report.
>
>
>>> We should decide whether ‘’ is a valid sexp (oh dear, philosophy)
>>> or throw something softer at people.
>>
>> Throw something more "helping" than e.g.,
>>
>> Backtrace:
>> 1 (primitive-load "/home/simon/.config/guix/current/bin/g…")
>> In guix/ui.scm:
>> 1936:12 0 (run-guix-command _ . _)
>>
>> guix/ui.scm:1936:12: In procedure run-guix-command:
>> In procedure struct-vtable: Wrong type argument in position 1
>> (expecting struct): #<unspecified>
>>
>> ?
>
> More helping as suggested for example in this message:
>
> <https://lists.gnu.org/archive/html/guix-devel/2020-09/msg00125.html>
>
> If yes, the bug report should be renamed. And probably goes to the
> Guile bug tracker. :-)


What do we do? What is the next action? Close? If not, please provide
explanations about what the issue really is and what could be the plan
to fix it. :-)

Cheers,
simon
Z
Z
zimoun wrote on 13 Jul 2021 10:11
Re: bug#25952: offloading empty machines file
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)
86bl76pr9p.fsf@gmail.com
Hi Tobias,

On Mon, 25 May 2020 at 22:32, Tobias Geerinckx-Rice <me@tobias.gr> wrote:
Toggle quote (18 lines)
> zimoun ???
>> This bug [1] had not been commented since the last 3 years and it has
>> been asked more info 3 weeks ago.
>
> The issue is that files such as /etc/guix/machines.scm (but this applies
> equally to /etc/guix/acl & so on) are expected to evaluate to a sexp.
>
> An empty file does not a valid sexp make, so Guix throws an prickly backtrace
> @ your face & dies. This is unlike most other configuration formats where an
> empty file or one consisting entirely of comments is a no-op.
>
> We should decide whether ‘’ is a valid sexp (oh dear, philosophy) or throw
> something softer at people.
>
>> Therefore, I am closing. Feel free to reopen if I misunderstand something.
>
> I think this bug should remain open until it's decided. What you?

This bug [1] had been initially opened on March, 3rd 2017 then commented
for the first time [2] on May, 3rd 2020 and closed [3] on May, 25th
2020. Then reopen the same day [4] with this “philosophical” question
about: is empty ’’ a valid sexp? On May, 26th 2020 [5], I provided more
examples.

From my understanding, «throw something softer» should be done on the
Guile side, as suggested by [6] on September, 13rd 2020.

Personally, I do not see what could be the next action [7]? Therefore,
if no more explanations about what the issue really is and what be the
plan to fix it, I will close it. WDYT?

All the best,
simon

M
M
Maxim Cournoyer wrote on 18 Aug 2021 03:24
Re: bug#25952: offloading: empty machines file leads to error
(name . zimoun)(address . zimon.toutoune@gmail.com)
87a6lfy278.fsf_-_@gmail.com
Hi Simon,

zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (34 lines)
> Hi Tobias,
>
> On Mon, 25 May 2020 at 22:32, Tobias Geerinckx-Rice <me@tobias.gr> wrote:
>> zimoun ???
>>> This bug [1] had not been commented since the last 3 years and it has
>>> been asked more info 3 weeks ago.
>>
>> The issue is that files such as /etc/guix/machines.scm (but this applies
>> equally to /etc/guix/acl & so on) are expected to evaluate to a sexp.
>>
>> An empty file does not a valid sexp make, so Guix throws an prickly backtrace
>> @ your face & dies. This is unlike most other configuration formats where an
>> empty file or one consisting entirely of comments is a no-op.
>>
>> We should decide whether ‘’ is a valid sexp (oh dear, philosophy) or throw
>> something softer at people.
>>
>>> Therefore, I am closing. Feel free to reopen if I misunderstand something.
>>
>> I think this bug should remain open until it's decided. What you?
>
> This bug [1] had been initially opened on March, 3rd 2017 then commented
> for the first time [2] on May, 3rd 2020 and closed [3] on May, 25th
> 2020. Then reopen the same day [4] with this “philosophical” question
> about: is empty ’’ a valid sexp? On May, 26th 2020 [5], I provided more
> examples.
>
>>From my understanding, «throw something softer» should be done on the
> Guile side, as suggested by [6] on September, 13rd 2020.
>
> Personally, I do not see what could be the next action [7]? Therefore,
> if no more explanations about what the issue really is and what be the
> plan to fix it, I will close it. WDYT?

What happens:

# mv /etc/guix/machines.scm{,.bak}

$ guix build hello --no-substitutes

-> Download sources and builds locally. OK!

# touch /etc/guix/machines.scm

$ guix build hello --no-substitutes

-> Builds locally. OK!

Seems the original issue has been resolved since.

Closing.

Maxim
Closed
?