This is a first effort towards making emacs-build-system more suitable for
cross-compilation.
* guix/build-system/emacs.scm (emacs-build)[#:tests?]: Enable when not
cross-compiling.
* gnu/packages/emacs-xyz.scm (emacs-ac-php, emacs-inspector)
(emacs-tree-inspector, emacs-pug-mode, emacs-llama, emacs-magit)
(emacs-speed-type, emacs-graphql, emacs-fb2-reader, emacas-ample-regexps)
(emacs-relative-buffers, emacs-aio, emacs-async, emacs-latex-extra)
(emacs-auto-themer, emacs-bm, emacs-varuga, emacs-org-fc, emacs-go-mode)
(emacs-dash, emacs-undo-fu-session, emacs-s, emacs-lemon, emacs-fringe-helper)
(emacs-git-link, emacs-explain-pause-mode, emacs-calc-currency)
(emacs-string-inflection, emacs-ob-go, emacs-robot-log, emacs-rspec)
(emacs-sqlite3-api, emacs-shx, emacs-el-job, emacs-elisp-demos)
(emacs-sudo-edit, emacs-subed, emacs-deferred, emacs-company-lsp, emacs-jack)
(emacs-elquery, emacs-cov, emacs-god-mode, emacs-org-pomodoro)
(emacs-eglot-tempel, emacs-dumbparens, emacs-perspective, emacs-realgud)
(emacs-hydra, emacs-avy,emacs-lispy, emacs-clojure-mode, emacs-qt-pro-mode)
(emacs-sphinx-doc, emacs-julia-mode, emacs-js2-mode, emacs-nodejs-repl)
(emacs-projectile, emacs-skeletor, emacs-elfeed, emacs-elfeed-org)
(emacs-mocker, emacs-find-file-in-project, emacs-pyvenv, emacs-elpy)
(emacs-rainbow-delimiters, emacs-visual-replace, emacs-wucuo, emacs-yaml)
(emacs-wgrep, emacs-islisp-mode, emacs-lua-mode, emacs-evil-collection)
(emacs-evil-owl, emacs-evil-exchange, emacs-evil-lion, emacs-evil-expat)
(emacs-monky, emacs-org, emacs-ht, emacs-yasnippet, emacs-memoize)
(emacs-use-package, emacs-xmlgen, emacs-cc-mode, emacs-php-mode)
(emacs-evil-surround, emacs-org-transclusion, emacs-json-reformat)
(emacs-display-wttr, emacs-git-messenger, emacs-enh-ruby-mode)
(emacs-browse-at-remote, emacs-tiny, emacs-unidecode, emacs-circe)
(emacs-evil-quickscope, emacs-groovy-modes, emacs-kotlin-mode, emacs-kv)
(emacs-auth-source-pass, emacs-emacsql, emacs-org-recur)
(emacs-org-super-agenda, emacs-ts, emacs-circadian, emacs-eldev, emacs-citar)
(emacs-loop, emacs-elisp-refs, emacs-esup, emacs-macrostep, emacs-parent-mode)
(emacs-helpful, emacs-suggest, emacs-auto-yasnippet)
(emacs-git-auto-commit-mode, emacs-devil, emacs-devil-multiedit)
(emacs-go-translate, emacs-langtool, emacs-helm-company, emacs-picpocket)
(emacs-srht, emacs-github-review, emacs-deadgrep, emacs-adoc-mode)
(emacs-racer, emacs-sesman, emacs-buttercup, emacs-cort, emacs-annalist)
(emacs-general, emacs-libmpdel, emacs-navigel, emacs-eat, emacs-detached)
(emacs-repology, emacs-bfuture, emacs-undo-propose-el, emacs-tco-el)
(emacs-vdiff, emacs-exwm-firefox, emacs-rjsx-mode, emacs-dash-docs)
(emacs-casual-lib, emacs-evil-numbers, emacs-evil-traces, emacs-ox-tufte)
(emacs-org-jira, emacs-systemd-mode, emacs-doom-themes, emacs-exiftool)
(emacs-qrencode, emacs-org-journal, emacs-weblorg, emacs-execline)
(emacs-webpaste, emacs-keystore-mode, emacs-ein, emacs-straight-el)
(emacs-org-cliplink, emacs-x509-mode)[arguments]: Remove #:tests?.
(emacs-f, emacs-shut-up, emacs-ansi, emacs-commander)
(emacs-ert-runner)[arguments]: Add #:tests? #f.
(emacs-el-x, emacs-pkg-info, emacs-helm, emacs-tablist, emacs-ghub)
(emacs-with-editor, emacs-repo): Likewise.
---
gnu/packages/emacs-xyz.scm | 330 ++++++++++--------------------------
guix/build-system/emacs.scm | 2 +-
2 files changed, 89 insertions(+), 243 deletions(-)
Toggle diff (419 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 272be3a275d..d7e28d7aa44 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -365,7 +365,6 @@ (define-public emacs-ac-php
(build-system emacs-build-system)
(arguments
(list
- #:tests? #true
#:test-command #~(list "ert-runner")))
(inputs
(list emacs-auto-complete
@@ -955,7 +954,6 @@ (define-public emacs-inspector
(build-system emacs-build-system)
(arguments
(list
- #:tests? #t
#:test-command #~(list "emacs" "-Q" "--batch"
"-l" "inspector.el"
"-l" "inspector-tests.el"
@@ -1013,7 +1011,6 @@ (define-public emacs-tree-inspector
(build-system emacs-build-system)
(arguments
(list
- #:tests? #true
#:test-command #~(list "emacs" "-Q" "--batch"
"-L" "."
"-l" "tree-inspector-tests.el"
@@ -1374,7 +1371,6 @@ (define-public emacs-pug-mode
(build-system emacs-build-system)
(arguments
(list
- #:tests? #t
#:test-command #~(list "ert-runner")))
(home-page "https://github.com/hlissner/emacs-pug-mode")
(synopsis "Pug support for Emacs")
@@ -1703,6 +1699,7 @@ (define-public emacs-with-editor
(build-system emacs-build-system)
(arguments
(list
+ #:tests? #f ; no test suite
#:phases
#~(modify-phases %standard-phases
(add-before 'install 'enter-lisp-directory
@@ -1830,8 +1827,7 @@ (define-public emacs-llama
"0f2v1fw5iahlh0ypbwxfpav48h43h0zqqmicgs2hg7r251ss2j8j"))))
(build-system emacs-build-system)
(arguments
- (list #:tests? #true
- #:test-command #~(list "emacs" "-Q" "--batch"
+ (list #:test-command #~(list "emacs" "-Q" "--batch"
"-l" "llama.el"
"-f" "ert-run-tests-batch-and-exit")))
(propagated-inputs (list emacs-compat))
@@ -1883,7 +1879,6 @@ (define-public emacs-magit
(build-system emacs-build-system)
(arguments
(list
- #:tests? #t
#:test-command #~(list "make" "test")
#:exclude #~(cons* "magit-libgit.el"
"magit-libgit-pkg.el"
@@ -2541,7 +2536,6 @@ (define-public emacs-speed-type
(build-system emacs-build-system)
(arguments
(list
- #:tests? #true
#:test-command
#~(list "emacs" "-Q" "--batch" "-L" "."
"-l" "test-speed-type.el"
@@ -2581,7 +2575,6 @@ (define-public emacs-graphql
(build-system emacs-build-system)
(arguments
(list
- #:tests? #true
#:test-command #~(list "ert-runner")
#:phases
#~(modify-phases %standard-phases
@@ -2679,6 +2672,7 @@ (define-public emacs-ghub
(build-system emacs-build-system)
(arguments
(list
+ #:tests? #f ; no test suite
#:phases
#~(modify-phases %standard-phases
(add-before 'install 'make-info
@@ -3094,7 +3088,6 @@ (define-public emacs-fb2-reader
(build-system emacs-build-system)
(arguments
(list
- #:tests? #t
#:test-command
#~(list "buttercup" "-L" ".")
#:phases
@@ -3570,8 +3563,7 @@ (define-public emacs-ample-regexps
(native-inputs
(list emacs-ert-runner))
(arguments
- `(#:tests? #t
- #:test-command '("ert-runner" "-l" "ample-regexps")))
+ `(#:test-command '("ert-runner" "-l" "ample-regexps")))
(home-page "https://github.com/immerrr/ample-regexps.el")
(synopsis "Compose and reuse Emacs regexps")
(description
@@ -3736,7 +3728,6 @@ (define-public emacs-relative-buffers
(build-system emacs-build-system)
(arguments
(list
- #:tests? #t
#:test-command #~(list "ert-runner")))
(native-inputs
(list emacs-ert-runner))
@@ -4899,8 +4890,7 @@ (define-public emacs-aio
"1y7j10j74r3fy0rcb8g3cm9nlls34qb0pz9xkia7psp77syrlz54"))))
(build-system emacs-build-system)
(arguments
- `(#:tests? #t
- #:test-command '("emacs" "--batch"
+ `(#:test-command '("emacs" "--batch"
"-l" "aio-test.el"
"-f" "ert-run-tests-batch-and-exit")))
(propagated-inputs
@@ -4929,8 +4919,7 @@ (define-public emacs-async
"0krg7n8l3yv1fnixnx6j5imdh10jpfabm6ym9s1s610hp47gpfaz"))))
(build-system emacs-build-system)
(arguments
- `(#:tests? #t
- #:test-command '("buttercup" "-L" ".")))
+ `(#:test-command '("buttercup" "-L" ".")))
(native-inputs
(list emacs-buttercup))
(synopsis "Asynchronous processing in Emacs")
@@ -5012,7 +5001,6 @@ (define-public emacs-latex-extra
(build-system emacs-build-system)
(arguments
(list
- #:tests? #true
#:test-command
#~(list "emacs" "-Q" "--batch"
"--eval=(cd \"tests/\")"
@@ -5077,7 +5065,6 @@ (define-public emacs-autothemer
(build-system emacs-build-system)
(arguments
(list
- #:tests? #true
#:test-command #~(list "emacs" "-Q" "--batch"
"-l" "tests/autothemer-tests.el"
"-f" "ert-run-tests-batch-and-exit")))
@@ -5161,7 +5148,6 @@ (define-public emacs-bm
(build-system emacs-build-system)
(arguments
(list
- #:tests? #true
#:test-command #~(list "emacs" "-Q" "--batch"
"-l" "bm-tests.el"
"-f" "ert-run-tests-batch-and-exit")))
@@ -5210,7 +5196,6 @@ (define-public emacs-varuga
(base32
"01hlnhqhys8qzfwhza1ypc436zg5lhlkx5yy71bhmrbmyfzfh0fr"))))
(build-system emacs-build-system)
- (arguments (list #:tests? #t))
(home-page "https://git.systemreboot.net/varuga/about/")
(synopsis "Send iCal calendar invites by email")
(description
@@ -5659,7 +5644,6 @@ (define-public emacs-org-fc
(list
#:include #~(cons* "\\.awk$" "\\.org$" %default-include)
#:exclude #~(cons "^tests/" %default-exclude)
- #:tests? #t
#:test-command #~(list "emacs" "--batch"
"-L" "."
"-L" "tests/"
@@ -5903,7 +5887,6 @@ (define-public emacs-go-mode
"00qzn136d8cl3szbi44xf3iiv75r6n1m7wwgldmzn4i5mpz8dbq7"))))
(arguments
(list
- #:tests? #t
#:test-command #~(list "ert-runner")
#:phases
#~(modify-phases %standard-phases
@@ -6191,6 +6174,7 @@ (define-public emacs-tablist
(base32
"11vmvrhmsxy97bfj7jndpc58bik7177i3wvc45mlyldxwyirs962"))))
(build-system emacs-build-system)
+ (arguments (list #:tests? #f)) ; no test suite
(home-page "https://github.com/politza/tablist")
(synopsis "Extension for @code{tabulated-list-mode}")
(description "Tablist is the Emacs package that provides several
@@ -6513,8 +6497,7 @@ (define-public emacs-dash
"0z6f8y1m9amhg427iz1d4xcyr6n0kj5w7kmiz134p320ixsdnzd8"))))
(build-system emacs-build-system)
(arguments
- (list #:tests? #t
- #:phases
+ (list #:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'disable-byte-compile-error-on-warn
(lambda _
@@ -6969,7 +6952,6 @@ (define-public emacs-undo-fu-session
(build-system emacs-build-system)
(arguments
(list
- #:tests? #t
;; The tests require temp files handling which a recent change disabled
;; by default. We re-enable it here to make tests work again.
#:test-command #~(list "emacs" "--batch" "--eval"
@@ -7002,8 +6984,7 @@ (define-public emacs-s
(base32 "010i92kagqbfis46n1ffa28fgkdkjp55n13b6f4izar5r7ixm6wx"))))
(build-system emacs-build-system)
(arguments
- `(#:tests? #t
- #:test-command '("./run-tests.sh")))
+ `(#:test-command '("./run-tests.sh")))
(home-page "https://github.com/magnars/s.el")
(synopsis "Emacs string manipulation library")
(description "This package provides an Emacs library for manipulating
@@ -7105,8 +7086,6 @@ (define-public emacs-lemon
(build-system emacs-build-system)
(arguments
(list
- #:tests? #true
-
;; Only one test out of the four passes
#:test-command #~(list "emacs" "-Q" "--batch" "-L" "."
;; "-l" "lemon--test.el"
@@ -7259,6 +7238,7 @@ (define-public emacs-f
(base32
"0ccrcfhqfbv9qff38sfym69mai7k7z89yndi6nip8wi5hpd2addc"))))
(build-system emacs-build-system)
+ (arguments (list #:tests? #f)) ; circular dependency on ert-runner
(propagated-inputs
(list emacs-s emacs-dash))
(home-page "https://github.com/rejeep/f.el")
@@ -7310,8 +7290,7 @@ (define-public emacs-fringe-helper
(base32 "0ra9rc53l1gvkqank8apasl3r7wz2yfjrcvmfk3wpxhh24ppxv9d"))))
(build-system emacs-build-system)
(arguments
- `(#:tests? #t
- #:test-command '("emacs" "--batch"
+ `(#:test-command '("emacs" "--batch"
"-l" "tests.el"
"-f" "ert-run-tests-batch-and-exit")))
(home-page "https://github.com/nschum/fringe-helper.el")
@@ -7388,7 +7367,6 @@ (define-public emacs-git-link
(build-system emacs-build-system)
(arguments
(list
- #:tests? #t
#:test-command #~(list "make" "test")))
(home-page "https://github.com/sshaw/git-link")
(synopsis "Create links for files and commits in GitHub/GitLab/etc. repos")
@@ -7777,8 +7755,7 @@ (define-public emacs-explain-pause-mode
(native-inputs
(list emacs-buttercup))
(arguments
- '(#:tests? #t
- #:phases
+ '(#:phases
(modify-phases %standard-phases
;; This causes the byte-compilation before unit-tests to fail.
(add-after 'unpack 'remove-error-on-warn
@@ -8082,7 +8059,6 @@ (define-public emacs-zig-mode
(build-system emacs-build-system)
(arguments
(list
- #:tests? #t
#:emacs emacs
#:test-command #~(list "emacs" "--batch"
"-l" "zig-mode.el"
@@ -8195,6 +8171,7 @@ (define-public emacs-shut-up
(sha256
(base32 "1bnmrwrhra6cpc3jjgwwzrydj5ps7q2dlkh2ag4j7rkyv4dlk351"))))
(build-system emacs-build-system)
+ (arguments (list #:tests? #f)) ; circular dependency on ert-runner
(home-page "https://github.com/cask/shut-up")
(synopsis "Silence Emacs")
(description "This package silences most output of Emacs when running an
@@ -8380,7 +8357,6 @@ (define-public emacs-calc-currency
(build-system emacs-build-system)
(arguments
(list
- #:tests? #t
#:test-command #~(list "emacs" "--batch"
"-L" "."
"-l" "test/calc-currency-init.el"
@@ -8484,8 +8460,7 @@ (define-public emacs-string-inflection
(native-inputs
(list emacs-ert-runner))
(arguments
- `(#:tests? #t
- #:test-command '("ert-runner")))
+ `(#:test-command '("ert-runner")))
(home-page "https://github.com/akicho8/string-inflection")
(synopsis "Convert symbol names between different naming conventions")
(description
@@ -8792,7 +8767,6 @@ (define-public emacs-ob-go
(build-system emacs-build-system)
(arguments
(list
- #:tests? #t
#:test-command #~(list "emacs" "--batch" "-L" "."
"--eval=(require 'ob-go)"
"-l" "test-ob-go.el"
@@ -8980,7 +8954,6 @@ (define-public emacs-robot-log
"1l9yxryrhvylh2x17cczd8v8978w1nv8173d4l9hv0cr26kp5b68"))))
(build-system emacs-build-system)
(native-inputs (list python-robotframework))
- (arguments (list #:tests? #t))
(home-page "https://sr.ht/~apteryx/emacs-robot-log/")
(synopsis "Emacs major mode for viewing RobotFramework debug log files")
(description "@code{robot-log} is an Emacs major mode that allows more
@@ -9060,7 +9033,6 @@ (define-public emacs-rspec
(build-system emacs-build-system)
(arguments
`(#:include (cons "^snippets\\/rspec-mode\\/" %default-include)
- #:tests? #t
#:test-command '("make" "test")))
(home-page "https://github.com/pezra/rspec-mode")
(synopsis "Provides a rspec mode for working with RSpec")
@@ -9241,7 +9213,6 @@ (define-public emacs-sqlite3-api
(build-system emacs-build-system)
(arguments
(list
- #:tests? (not (%current-target-system))
#:test-command #~(list "make" "test" "EMACS=emacs")
#:modules '((guix build emacs-build-system)
(guix build emacs-utils)
@@ -9394,7 +9365,6 @@ (define-public emacs-shx
(build-system emacs-build-system)
(arguments
(list
- #:tests? #t
#:test-command
#~(list "emacs" "--batch" "--quiet" "--script" "test/script.el")
#:phases
@@ -9799,8 +9769,7 @@ (define-public emacs-el-job
"0mj92dsd169ij2g3vmq626vdh5aqc9zbc43yjip7dl1qy4lh34sk"))))
(build-system emacs-build-system)
(arguments
- (list #:tests? #true
- #:test-command #~(list "emacs" "-Q" "--batch"
+ (list #:test-command #~(list "emacs" "-Q" "--batch"
"-l" "el-job-test.el"
"-f" "ert-run-tests-batch-and-exit")))
(propagated-inputs (list emacs-compat))
@@ -9832,7 +9801,6 @@ (define-public emacs-elisp-demos
(arguments
(list
#:include #~(cons* "\\.org$" %default-include)
- #:tests? #t
#:test-command #~(list "make" "test")))
(home-page "https://github.com/xuchunyang/elisp-demos/")
(synopsis "Enhance @code{*Help*} buffers with additional examples")
@@ -9943,7 +9911,6 @@ (define-public emacs-sudo-edit
(lambda _
(substitute* "Makefile"
(("\\$\\(CASK\\) exec ") "")))))
- #:tests? #t
#:test-command #~(list "make" "test")))
(home-page "https://github.com/nflath/sudo-edit/")
(synopsis "Open files as another user")
@@ -9965,7 +9932,6 @@ (define-public emacs-subed
"0bvsv688mqhga8dffy3841wxs5pkw0vish15dgligll47cj98mzp"))))
(arguments
(list
- #:tests? #t
#:test-command #~(list "buttercup" "-L" ".")))
(native-inputs (list emacs-buttercup))
(inputs (list ffmpeg))
@@ -10217,7 +10183,6 @@ (define-public emacs-deferred
(lambda _
(substitute* "Makefile"
(("\\$\\(CASK\\) exec ") "")))))
- #:tests? #t
#:test-command '("make" "test")))
(native-inputs
(list emacs-ert-expectations emacs-ert-runner emacs-undercover))
@@ -11095,8 +11060,7 @@ (define-public emacs-company-lsp
(native-inputs
(list emacs-buttercup))
(arguments
- `(#:tests? #t
- #:test-command '("buttercup" "-L" ".")))
+ `(#:test-command '("buttercup" "-L" ".")))
(home-page "https://github.com/tigersoldier/company-lsp")
(synopsis "Completion for @code{lsp-mode}")
(description
@@ -11746,7 +11710,6 @@ (define-public emacs-jack
(build-system emacs-build-system)
(arguments
(list
- #:tests? #t
#:test-command #~(list "emacs"
"--batch"
"-l"
@@ -11857,7 +11820,6 @@ (define-public emacs-elquery
(arguments
(list
#:emacs emacs-no-x
- #:tests? #t
#:test-command #~(list "ert-runner")
#:phases #~(modify-phases %standard-phases
(add-after 'unpack 'fix-native-compilation
@@ -11903,7 +11865,6 @@ (define-public emacs-cov
(arguments
(list
#:emacs emacs-no-x ;for libxml
- #:tests? #t
#:test-command #~(list "ert-runner")
#:phases
#~(modify-phases %standard-phases
@@ -12019,8 +11980,7 @@ (define-public emacs-god-mode
"1njln47w25ix9w0xjv02110ngr8d8ma3w7db0x4xcxhihbl65zly"))))
(build-system emacs-build-system)
(arguments
- (list #:tests? #true
- #:test-command
+ (list #:test-command
#~(list "emacs" "--no-init-file"