[PATCH 0/2] gnu: librewolf: Allow installation of unsigned extensions.

  • Open
  • quality assurance status badge
Details
4 participants
  • Clément Lassieur
  • Hilton Chain
  • Ian Eure
  • Mike Jones
Owner
unassigned
Submitted by
Mike Jones
Severity
normal

Debbugs page

Mike Jones wrote 2 weeks ago
(address . guix-patches@gnu.org)(name . Mike Jones)(address . mike@mjones.io)
cover.1740676848.git.mike@mjones.io
The librewolf package does not allow extensions to be installed unless
they are signed by Mozilla's key. Even though there is an about:config
option "xpinstall.signatures.required", setting this to false still
doesn't allow it. It turns out that one needs to compile librewolf with
the option MOZ_REQUIRE_SIGNING= to permit this.

I hope you'll agree that forbidding users from running software on their
own machines is not in the spirit of free software. While there may be
security advantages to enforcing signing (if you trust Mozilla), it can
still be enabled with the aforementioned about:config option, even when
compiled using this new option.

For what it's worth, upstream librewolf sets this option in their
default mozconfig:


This series also includes a patch to fix some missing newlines which I
found while testing it.

Mike Jones (2):
gnu: librewolf: Fix missing newlines when generating mozconfig.
gnu: librewolf: Allow installation of unsigned extensions.

gnu/packages/librewolf.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)


base-commit: f1810c84f72090b02544ac41d0582c4785728ec4
--
2.48.1
Mike Jones wrote 2 weeks ago
[PATCH 1/2] gnu: librewolf: Fix missing newlines when generating mozconfig.
(address . 76616@debbugs.gnu.org)(name . Mike Jones)(address . mike@mjones.io)
c9f4b8ebdeade98d8e4f59c048a305d2c045c2b8.1740676848.git.mike@mjones.io
These were being concatenated on a single line together, probably
causing them to have no effect.

* gnu/packages/librewolf.scm (librewolf)[phases]: Add missing newlines
to last two entries in mozconfig.

Change-Id: I12e7e33d9c4f9269ea5b0b24d276289f6f47890a
---
gnu/packages/librewolf.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 2a4bf3fada..03a6acc455 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -455,9 +455,9 @@ (define-public librewolf
(display "mk_add_options MOZ_CRASHREPORTER=0\n")
(display "mk_add_options MOZ_DATA_REPORTING=0\n")
(display
- "mk_add_options MOZ_SERVICES_HEALTHREPORT=0")
+ "mk_add_options MOZ_SERVICES_HEALTHREPORT=0\n")
(display
- "mk_add_options MOZ_TELEMETRY_REPORTING=0")))
+ "mk_add_options MOZ_TELEMETRY_REPORTING=0\n")))
(setenv "MOZCONFIG" mozconfig))
(invoke "./mach" "configure")))
(add-before 'build 'fix-addons-placeholder
--
2.48.1
Mike Jones wrote 2 weeks ago
[PATCH 2/2] gnu: librewolf: Allow installation of unsigned extensions.
(address . 76616@debbugs.gnu.org)(name . Mike Jones)(address . mike@mjones.io)
91c66e4f667e9c4acb6f38fdcbd79af8f7c81b75.1740676848.git.mike@mjones.io
* gnu/packages/librewolf.scm (librewolf)[phases]: Set
MOZ_REQUIRE_SIGNING to empty in mozconfig.

Change-Id: I786b4e9817e915a4b8c2ce38db8087db0c23bfdf
---
gnu/packages/librewolf.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 03a6acc455..3f5d838447 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -457,7 +457,8 @@ (define-public librewolf
(display
"mk_add_options MOZ_SERVICES_HEALTHREPORT=0\n")
(display
- "mk_add_options MOZ_TELEMETRY_REPORTING=0\n")))
+ "mk_add_options MOZ_TELEMETRY_REPORTING=0\n")
+ (display "MOZ_REQUIRE_SIGNING=\n")))
(setenv "MOZCONFIG" mozconfig))
(invoke "./mach" "configure")))
(add-before 'build 'fix-addons-placeholder
--
2.48.1
Mike Jones wrote 2 weeks ago
[PATCH v2 0/2] gnu: librewolf: Allow installation of unsigned extensions.
(address . 76616@debbugs.gnu.org)(name . Mike Jones)(address . mike@mjones.io)
cover.1740687144.git.mike@mjones.io
Oops, I forgot the "export" before "MOZ_REQUIRE_SIGNING" in the original
version. (I did my testing with the "export" present; I just messed up
splitting it into two commits.)

Mike Jones (2):
gnu: librewolf: Fix missing newlines when generating mozconfig.
gnu: librewolf: Allow installation of unsigned extensions.

gnu/packages/librewolf.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)


base-commit: f1810c84f72090b02544ac41d0582c4785728ec4
--
2.48.1
Mike Jones wrote 2 weeks ago
[PATCH v2 1/2] gnu: librewolf: Fix missing newlines when generating mozconfig.
(address . 76616@debbugs.gnu.org)(name . Mike Jones)(address . mike@mjones.io)
c9f4b8ebdeade98d8e4f59c048a305d2c045c2b8.1740687144.git.mike@mjones.io
These were being concatenated on a single line together, probably
causing them to have no effect.

* gnu/packages/librewolf.scm (librewolf)[phases]: Add missing newlines
to last two entries in mozconfig.

Change-Id: I12e7e33d9c4f9269ea5b0b24d276289f6f47890a
---
gnu/packages/librewolf.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 2a4bf3fada..03a6acc455 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -455,9 +455,9 @@ (define-public librewolf
(display "mk_add_options MOZ_CRASHREPORTER=0\n")
(display "mk_add_options MOZ_DATA_REPORTING=0\n")
(display
- "mk_add_options MOZ_SERVICES_HEALTHREPORT=0")
+ "mk_add_options MOZ_SERVICES_HEALTHREPORT=0\n")
(display
- "mk_add_options MOZ_TELEMETRY_REPORTING=0")))
+ "mk_add_options MOZ_TELEMETRY_REPORTING=0\n")))
(setenv "MOZCONFIG" mozconfig))
(invoke "./mach" "configure")))
(add-before 'build 'fix-addons-placeholder
--
2.48.1
Mike Jones wrote 2 weeks ago
[PATCH v2 2/2] gnu: librewolf: Allow installation of unsigned extensions.
(address . 76616@debbugs.gnu.org)(name . Mike Jones)(address . mike@mjones.io)
d37ea5c7df6b39725e6d4c61ea684664e3e4448e.1740687144.git.mike@mjones.io
* gnu/packages/librewolf.scm (librewolf)[phases]: Set
MOZ_REQUIRE_SIGNING to empty in mozconfig.

Change-Id: I786b4e9817e915a4b8c2ce38db8087db0c23bfdf
---
gnu/packages/librewolf.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 03a6acc455..19d6ac461a 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -457,7 +457,8 @@ (define-public librewolf
(display
"mk_add_options MOZ_SERVICES_HEALTHREPORT=0\n")
(display
- "mk_add_options MOZ_TELEMETRY_REPORTING=0\n")))
+ "mk_add_options MOZ_TELEMETRY_REPORTING=0\n")
+ (display "export MOZ_REQUIRE_SIGNING=\n")))
(setenv "MOZCONFIG" mozconfig))
(invoke "./mach" "configure")))
(add-before 'build 'fix-addons-placeholder
--
2.48.1
Ian Eure wrote 2 weeks ago
Re: [bug#76616] [PATCH 0/2] gnu: librewolf: Allow installation of unsigned extensions.
(name . Mike Jones)(address . mike@mjones.io)(name . André Batista)(address . nandre@riseup.net)(name . Mark H Weaver)(address . mhw@netris.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 76616@debbugs.gnu.org)(name . Clément Lassieur)(address . clement@lassieur.org)
87eczifye9.fsf@retrospec.tv
Hi Mike,

Mike Jones <mike@mjones.io> writes:

Toggle quote (20 lines)
> The librewolf package does not allow extensions to be installed
> unless
> they are signed by Mozilla's key. Even though there is an
> about:config
> option "xpinstall.signatures.required", setting this to false
> still
> doesn't allow it. It turns out that one needs to compile
> librewolf with
> the option MOZ_REQUIRE_SIGNING= to permit this.
>
> I hope you'll agree that forbidding users from running software
> on their
> own machines is not in the spirit of free software. While there
> may be
> security advantages to enforcing signing (if you trust Mozilla),
> it can
> still be enabled with the aforementioned about:config option,
> even when
> compiled using this new option.

I definitely agree that unsigned extensions should be allowed. Do
you have an example of one I could use for testing?


Toggle quote (6 lines)
> For what it's worth, upstream librewolf sets this option in
> their
> default mozconfig:
>
> https://codeberg.org/librewolf/source/src/commit/9478c8a016460d883ee050f90a4c4410d210bb91/assets/mozconfig.new#L24

Thanks for pointing this out and sending a patch. I think it’d be
best if we used their config with just the Guix-specific changes
added, like --prefix. This has some important stuff, and it’d be
better to let upstream handle that than risk missing something
because the Guix config has drifted out of sync.

Would you be willing to contribute a patch which does that? If
not, that’s no problem, I’m working on the patches for 135.0.1
already, and could do that at the same time.

Either way, thank you very much for the report, it’s certainly an
oversight that needs to be corrected.

Thanks,

-- Ian
Hilton Chain wrote 2 weeks ago
(name . Mike Jones)(address . mike@mjones.io)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(name . Ian Eure)(address . ian@retrospec.tv)(name . André Batista)(address . nandre@riseup.net)(name . Mark H Weaver)(address . mhw@netris.org)(name . Clément Lassieur)(address . clement@lassieur.org)(address . 76616@debbugs.gnu.org)
8734fyr4m6.wl-hako@ultrarare.space
On Fri, 28 Feb 2025 02:51:01 +0800,
Mike Jones wrote:
Toggle quote (34 lines)
>
> The librewolf package does not allow extensions to be installed unless
> they are signed by Mozilla's key. Even though there is an about:config
> option "xpinstall.signatures.required", setting this to false still
> doesn't allow it. It turns out that one needs to compile librewolf with
> the option MOZ_REQUIRE_SIGNING= to permit this.
>
> I hope you'll agree that forbidding users from running software on their
> own machines is not in the spirit of free software. While there may be
> security advantages to enforcing signing (if you trust Mozilla), it can
> still be enabled with the aforementioned about:config option, even when
> compiled using this new option.
>
> For what it's worth, upstream librewolf sets this option in their
> default mozconfig:
>
> https://codeberg.org/librewolf/source/src/commit/9478c8a016460d883ee050f90a4c4410d210bb91/assets/mozconfig.new#L24
>
> This series also includes a patch to fix some missing newlines which I
> found while testing it.
>
> Mike Jones (2):
> gnu: librewolf: Fix missing newlines when generating mozconfig.
> gnu: librewolf: Allow installation of unsigned extensions.
>
> gnu/packages/librewolf.scm | 5 +++--
> 1 file changed, 3 insertions(+), 2 deletions(-)
>
>
> base-commit: f1810c84f72090b02544ac41d0582c4785728ec4
> --
> 2.48.1


Unsigned extensions are allowed. Some extensions are packaged in
(gnu packages browser-extensions), which are unsigned.

In case you didn't know, packaged extensions can be used by installing them to
the same profile of librewolf. e.g.
$ guix shell librewolf adaptive-tab-bar-colour-icecat -- librewolf
Mike Jones wrote 2 weeks ago
(name . Ian Eure)(address . ian@retrospec.tv)(name . Hilton Chain)(address . hako@ultrarare.space)(name . André Batista)(address . nandre@riseup.net)(name . Mark H Weaver)(address . mhw@netris.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 76616@debbugs.gnu.org)(name . Clément Lassieur)(address . clement@lassieur.org)
acae66dc-cb6d-4968-8154-e1701b14e580@app.fastmail.com
On Fri, 28 Feb 2025, at 5:09 AM, Ian Eure wrote:
Toggle quote (3 lines)
> I definitely agree that unsigned extensions should be allowed. Do
> you have an example of one I could use for testing?

You can build one with

guix shell -C -N nss-certs bash node git -- \
&& cd darkreader && npm i && npm run build:firefox'

and it will be at darkreader/build/release/darkreader-firefox.xpi

Toggle quote (10 lines)
> Thanks for pointing this out and sending a patch. I think it’d be
> best if we used their config with just the Guix-specific changes
> added, like --prefix. This has some important stuff, and it’d be
> better to let upstream handle that than risk missing something
> because the Guix config has drifted out of sync.
>
> Would you be willing to contribute a patch which does that? If
> not, that’s no problem, I’m working on the patches for 135.0.1
> already, and could do that at the same time.

Sure, I can try that this weekend, but if it takes me too long, feel
free to do it :)

On Fri, 28 Feb 2025, at 6:00 AM, Hilton Chain wrote:
Toggle quote (7 lines)
> Unsigned extensions are allowed. Some extensions are packaged in
> (gnu packages browser-extensions), which are unsigned.
>
> In case you didn't know, packaged extensions can be used by installing them to
> the same profile of librewolf. e.g.
> $ guix shell librewolf adaptive-tab-bar-colour-icecat -- librewolf

Thanks, I didn't know about that! It seems to only allow ones in
$ICECAT_SYSTEM_DIR - if you build your own outside of a Guix package, it
won't let you install it, saying "This addon could not be installed
because it has not been verified". Even overriding ICECAT_SYSTEM_DIR to
point to a directory containing my locally-built extension doesn't
work, so I guess there is some other condition.

I think it's still useful to have this option, in case someone wants to
build and install an extension that's not packaged in Guix yet. What do
you think? I can try Ian's suggestion of using the upstream mozconfig as
a base which would give us this as a side-effect.
Clément Lassieur wrote 2 weeks ago
(name . Mike Jones)(address . mike@mjones.io)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(name . Ian Eure)(address . ian@retrospec.tv)(name . André Batista)(address . nandre@riseup.net)(name . Mark H Weaver)(address . mhw@netris.org)(name . Hilton Chain)(address . hako@ultrarare.space)(address . 76616@debbugs.gnu.org)
87o6ymb87g.fsf@lassieur.org
Hi,

On Fri, Feb 28 2025, Mike Jones wrote:

Toggle quote (7 lines)
> Thanks, I didn't know about that! It seems to only allow ones in
> $ICECAT_SYSTEM_DIR - if you build your own outside of a Guix package, it
> won't let you install it, saying "This addon could not be installed
> because it has not been verified". Even overriding ICECAT_SYSTEM_DIR to
> point to a directory containing my locally-built extension doesn't
> work, so I guess there is some other condition.

Librewolf (and other Firefox based browsers in Guix) don't look at
$ICECAT_SYSTEM_DIR for extensions, but at
$ICECAT_SYSTEM_DIR/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}.

{ec8030f7-c20a-464f-9b0e-13a3a9e97384} is the application ID of
Firefox[1].

Also in that directory, your extension must be a directory or an .xpi
file whose name must be the add-on id[2] (e.g. ‘uBlock0@raymondhill.net’
for a directory, or ‘uBlock0@raymondhill.net.xpi’ for an xpi file).

Finally, Firefox checks for add-ons updates by comparing their path with
a cached one. So make sure to change the path, or use another database
(move ~/.mozilla/icecat or ~/.librewolf...). before starting the browser
with an updated add-on.

So for example if I run ‘guix shell ublock-origin-icecat librewolf’, and
then
‘ls $ICECAT_SYSTEM_DIR/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}’,
I'll see ‘uBlock0@raymondhill.net’.

You can definitely do
‘mkdir -p ~/test/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}’,
copy your .xpi (or extension directory) in there, and run librewolf like
this:

‘ICECAT_SYSTEM_DIR=/home/clement/test librewolf’

With Librewolf, system add-ons are disabled by default (you need to
enable them manually), I don't know why. But on other browsers (icecat,
torbrorwser, mullvadbrowser), it works correctly.


Cheers,
Clément

Toggle quote (4 lines)
> I think it's still useful to have this option, in case someone wants to
> build and install an extension that's not packaged in Guix yet. What do
> you think? I can try Ian's suggestion of using the upstream mozconfig as
> a base which would give us this as a side-effect.
Mike Jones wrote 2 weeks ago
(name . Clément Lassieur)(address . clement@lassieur.org)(name . Ian Eure)(address . ian@retrospec.tv)(name . André Batista)(address . nandre@riseup.net)(name . Hilton Chain)(address . hako@ultrarare.space)(address . 76616@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(name . Mark H Weaver)(address . mhw@netris.org)
e97aa483-145a-42f8-b3f4-f0e3726c6fb3@app.fastmail.com
On Fri, 28 Feb 2025, at 11:49 AM, Clément Lassieur wrote:
Toggle quote (7 lines)
> You can definitely do
> ‘mkdir -p ~/test/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}’,
> copy your .xpi (or extension directory) in there, and run librewolf like
> this:
>
> ‘ICECAT_SYSTEM_DIR=/home/clement/test librewolf’

Thank you, I got that to work!


I'm about to send a v3 patch series, in which we append our config to
the upstream mozconfig, so that we inherit their options. I added
--disable-jxl and --disable-bootstrap because upstream enables those
and we didn't, so this preserves that.

The third patch also removes the duplicated options that are already
set upstream, but I am not sure about it, as it feels wrong to rely on
implicit options, especially for important things like disabling
telemetry. I kept "unset MOZ_TELEMETRY_REPORTING" and the preceding
comment, because that exact line is not present in the upstream
config, but I don't know how it relates to "mk_add_options
MOZ_TELEMETRY_REPORTING=0". Presumably they achieve the same thing,
but I don't know for sure.

So I am not sure if patches 2 and 3 make sense, but feel free to use
any or none of them :)
Mike Jones wrote 2 weeks ago
[PATCH v3 1/3] gnu: librewolf: Fix missing newlines when generating mozconfig.
(address . 76616@debbugs.gnu.org)(name . Mike Jones)(address . mike@mjones.io)
c9f4b8ebdeade98d8e4f59c048a305d2c045c2b8.1740829218.git.mike@mjones.io
These were being concatenated on a single line together, probably
causing them to have no effect.

* gnu/packages/librewolf.scm (librewolf)[phases]: Add missing newlines
to last two entries in mozconfig.

Change-Id: I12e7e33d9c4f9269ea5b0b24d276289f6f47890a
---
gnu/packages/librewolf.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 2a4bf3fada..03a6acc455 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -455,9 +455,9 @@ (define-public librewolf
(display "mk_add_options MOZ_CRASHREPORTER=0\n")
(display "mk_add_options MOZ_DATA_REPORTING=0\n")
(display
- "mk_add_options MOZ_SERVICES_HEALTHREPORT=0")
+ "mk_add_options MOZ_SERVICES_HEALTHREPORT=0\n")
(display
- "mk_add_options MOZ_TELEMETRY_REPORTING=0")))
+ "mk_add_options MOZ_TELEMETRY_REPORTING=0\n")))
(setenv "MOZCONFIG" mozconfig))
(invoke "./mach" "configure")))
(add-before 'build 'fix-addons-placeholder

base-commit: f1810c84f72090b02544ac41d0582c4785728ec4
--
2.48.1
Mike Jones wrote 2 weeks ago
[PATCH v3 2/3] gnu: librewolf: Append our configuration options to upstream mozconfig.
(address . 76616@debbugs.gnu.org)(name . Mike Jones)(address . mike@mjones.io)
19e18b0f50538859c3e7a854f2f8014f9996328c.1740829218.git.mike@mjones.io
* gnu/packages/librewolf.scm (librewolf)[configure-flags]: Add
--disable-jxl, --disable-bootstrap to match previous configuration.
[phases]: Use upstream's mozconfig as the start of ours.

Change-Id: I7f21df8a84e9adb0cee69ad566daddb75bd790fb
---
gnu/packages/librewolf.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 03a6acc455..0c99231092 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -236,6 +236,7 @@ (define-public librewolf
"--with-system-ffi"
"--enable-system-pixman"
"--enable-jemalloc"
+ "--disable-jxl"
;; see https://bugs.gnu.org/32833
"--with-system-nspr"
@@ -271,7 +272,8 @@ (define-public librewolf
"--enable-optimize"
"--enable-strip"
"--enable-hardening"
- "--disable-elf-hack"))
+ "--disable-elf-hack"
+ "--disable-bootstrap"))
#:imported-modules %cargo-utils-modules
#:modules `((ice-9 regex)
(ice-9 string-fun)
@@ -424,6 +426,8 @@ (define-public librewolf
(getcwd))
(let* ((mozconfig (string-append (getcwd) "/mozconfig"))
+ (orig-mozconfig-content (call-with-input-file
+ mozconfig get-string-all))
(out (assoc-ref outputs "out"))
(flags (cons (string-append "--prefix=" out)
configure-flags)))
@@ -439,6 +443,7 @@ (define-public librewolf
(display "\n")))
(with-output-to-file mozconfig
(lambda ()
+ (display orig-mozconfig-content)
(apply write-flags flags)
;; The following option unsets Telemetry
;; Reporting. With the Addons Fiasco,
--
2.48.1
Mike Jones wrote 2 weeks ago
[PATCH v3 3/3] gnu: librewolf: Remove config options already set by upstream
(address . 76616@debbugs.gnu.org)(name . Mike Jones)(address . mike@mjones.io)
ce3f3b25ac8ae4b51347f8eb86f4e0dd05665b40.1740829218.git.mike@mjones.io
* gnu/packages/librewolf.scm (librewolf)[arguments]: Remove configure
flags and variables already set in the upstream mozconfig.

Change-Id: I9af791e9a10a7823ab77866e2918ec485d3cb3ff
---
gnu/packages/librewolf.scm | 24 ++----------------------
1 file changed, 2 insertions(+), 22 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 0c99231092..2ece922dd5 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -222,10 +222,8 @@ (define-public librewolf
(arguments
(list
#:configure-flags #~(let ((clang #$(this-package-native-input "clang")))
- `("--enable-application=browser"
-
;; Configuration
- "--without-wasm-sandboxed-libraries"
+ `("--without-wasm-sandboxed-libraries"
"--with-system-jpeg"
"--with-system-zlib"
"--with-system-png"
@@ -249,29 +247,17 @@ (define-public librewolf
;; Distribution
"--with-distribution-id=org.guix"
- "--with-app-name=librewolf"
"--with-app-basename=LibreWolf"
- "--with-branding=browser/branding/librewolf"
;; Features
- "--disable-tests"
- "--disable-updater"
"--enable-pulseaudio"
- "--disable-crashreporter"
- "--allow-addon-sideload"
- "--with-unsigned-addon-scopes=app,system"
;; switch only available on x86, whereas EME
;; is not supported on other targets
,@(if #$(target-x86?) '("--disable-eme") '())
;; Build details
- "--disable-debug"
- "--enable-rust-simd"
- "--enable-release"
- "--enable-optimize"
"--enable-strip"
- "--enable-hardening"
"--disable-elf-hack"
"--disable-bootstrap"))
#:imported-modules %cargo-utils-modules
@@ -456,13 +442,7 @@ (define-public librewolf
;; As a result of this, use the following
;; command to permanently disable
;; telemetry reporting.
- (display "unset MOZ_TELEMETRY_REPORTING\n")
- (display "mk_add_options MOZ_CRASHREPORTER=0\n")
- (display "mk_add_options MOZ_DATA_REPORTING=0\n")
- (display
- "mk_add_options MOZ_SERVICES_HEALTHREPORT=0\n")
- (display
- "mk_add_options MOZ_TELEMETRY_REPORTING=0\n")))
+ (display "unset MOZ_TELEMETRY_REPORTING\n")))
(setenv "MOZCONFIG" mozconfig))
(invoke "./mach" "configure")))
(add-before 'build 'fix-addons-placeholder
--
2.48.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76616@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76616
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help