[PATCH] gnu: wdl: Update to 0-1.c9bc5ff.

  • Open
  • quality assurance status badge
Details
One participant
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal

Debbugs page

Sughosha wrote 1 months ago
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
1f77d2e3572930ae269a8de40670bafd340ec37b.1739505070.git.sughosha@disroot.org
* gnu/packages/cpp.scm (wdl): Update to 0-1.c9bc5ff.
[source]: Remove patches.
[arguments]<#:test-target>: Remove argument.
<#:tests?>: Disable.
<#:make-flags>: Add "SWELL_SUPPORT_GTK=true".
<#:phases>: In chdir phase, change directory to "WDL". In build phase, rewrite
it to honor key arguments and do not build eel2 and jnetlib. In install phase,
do not change directory. In install phase, install "libSwell.so" to its own
"WDL" directory and do not install "loose_eel" and "jnl.a".
* gnu/packages/patches/wdl-link-libs-and-fix-jnetlib.patch: Delete file.
* gnu/local.mk: Deregister it.

Change-Id: Iad1fd1a2513f76daa2daf1d81598e1b772509693
---
gnu/local.mk | 1 -
gnu/packages/cpp.scm | 43 +++++++--------
.../wdl-link-libs-and-fix-jnetlib.patch | 53 -------------------
3 files changed, 20 insertions(+), 77 deletions(-)
delete mode 100644 gnu/packages/patches/wdl-link-libs-and-fix-jnetlib.patch

Toggle diff (161 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 244420fc76..0354d86ea9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2379,7 +2379,6 @@ dist_patch_DATA = \
%D%/packages/patches/warsow-qfusion-fix-bool-return-type.patch \
%D%/packages/patches/waybar-0.11.0-fix-tray-icons.patch \
%D%/packages/patches/wcstools-extend-makefiles.patch \
- %D%/packages/patches/wdl-link-libs-and-fix-jnetlib.patch \
%D%/packages/patches/webkitgtk-adjust-bubblewrap-paths.patch \
%D%/packages/patches/webrtc-audio-processing-big-endian.patch \
%D%/packages/patches/webrtc-audio-processing-byte-order-pointer-size.patch \
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index c6c63d3ffc..23f5689323 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -3058,8 +3058,8 @@ (define-public wide-integer
(define-public wdl
;; No tag is available.
- (let ((commit "da86a62d11e46e4ecd8b16f9775cb5188340a0e2")
- (revision "0"))
+ (let ((commit "c9bc5ffb7babcc57b3104e379d2d1179276be54e")
+ (revision "1"))
(package
(name "wdl")
(version (git-version "0" revision commit))
@@ -3069,13 +3069,9 @@ (define-public wdl
(url "https://github.com/justinfrankel/WDL")
(commit commit)))
(file-name (git-file-name name version))
- ;; This patch fixes error of undefined functions, due to not
- ;; linking libraries, and invalid object.
- (patches
- (search-patches "wdl-link-libs-and-fix-jnetlib.patch"))
(sha256
(base32
- "0hdb604szkbrlyffiw94rz8wx4nvmk3zdkycfirqgjs7mh0l6vbq"))
+ "1j3q9h965a1nqhgh7wff05wa7a1f9y0wrfn5ai9iyd7jvmx69pr7"))
(modules '((guix build utils)))
;; Unbundle third party libraries which are not needed.
(snippet
@@ -3090,23 +3086,28 @@ (define-public wdl
(build-system gnu-build-system)
(arguments
(list
- #:test-target "test"
+ #:tests? #f ;no test rule
+ #:make-flags #~(list "SWELL_SUPPORT_GTK=true")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'chdir
- (lambda _ (chdir "WDL/swell")))
+ (lambda _ (chdir "WDL")))
(delete 'configure)
(replace 'build
- (lambda _
- (with-directory-excursion ".."
- (invoke "make" "-Ceel2") ;build eel2
- (invoke "make" "-Cjnetlib")) ;build jnetlib
- (invoke "make" "SWELL_SUPPORT_GTK=true")
- (invoke "make" "libSwell.colortheme")))
+ (lambda* (#:key (make-flags '()) (parallel-build? #t)
+ #:allow-other-keys)
+ (let ((make-flags
+ (append (if parallel-build?
+ `(,(string-append "-j"
+ (number->string
+ (parallel-job-count))))
+ '())
+ make-flags)))
+ (with-directory-excursion "swell"
+ (apply invoke "make" make-flags)
+ (apply invoke "make" "libSwell.colortheme" make-flags)))))
(replace 'install
(lambda _
- (chdir "..")
-
;; Do not install these directories
(delete-file-recursively "lice/test")
(delete-file-recursively "swell/sample_project")
@@ -3119,14 +3120,10 @@ (define-public wdl
(string-append include "/"
(dirname file))))
(find-files "." "\\.h$")))
- (install-file "swell/libSwell.so"
+ (install-file "swell/WDL/libSwell.so"
(string-append #$output "/lib"))
(install-file "swell/libSwell.colortheme"
- (string-append #$output "/share/WDL"))
- (install-file "eel2/loose_eel"
- (string-append #$output "/libexec"))
- (install-file "jnetlib/jnl.a"
- (string-append #$output "/lib")))))))
+ (string-append #$output "/share/WDL")))))))
(native-inputs (list pkg-config nasm))
(inputs
(list cairo
diff --git a/gnu/packages/patches/wdl-link-libs-and-fix-jnetlib.patch b/gnu/packages/patches/wdl-link-libs-and-fix-jnetlib.patch
deleted file mode 100644
index 29ec0f058c..0000000000
--- a/gnu/packages/patches/wdl-link-libs-and-fix-jnetlib.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 2d129502354da4fe39dac13463ea742f8026ab91 Mon Sep 17 00:00:00 2001
-From: Sughosha <sughosha@proton.me>
-Date: Tue, 3 Jan 2023 22:15:09 +0100
-Subject: [PATCH] Link libs and fix jnetlib.
-
----
- WDL/eel2/Makefile | 2 +-
- WDL/jnetlib/Makefile | 2 +-
- WDL/swell/Makefile | 2 +-
- 3 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/WDL/eel2/Makefile b/WDL/eel2/Makefile
-index ac2e41f1..0ffca97a 100644
---- a/WDL/eel2/Makefile
-+++ b/WDL/eel2/Makefile
-@@ -153,7 +153,7 @@ gen-lex: # the output of this, lex.nseel.c, is unused because we have a handwri
- $(CXX) $(CXXFLAGS) -c -o $@ $^
-
- loose_eel: loose_eel.o $(OBJS) $(OBJS2)
-- g++ -o $@ $^ $(CXXFLAGS) $(LFLAGS)
-+ g++ -o $@ $^ $(CXXFLAGS) $(LFLAGS) -lGL
-
- clean:
- -rm -f -- loose_eel loose_eel.o $(OBJS)
-diff --git a/WDL/jnetlib/Makefile b/WDL/jnetlib/Makefile
-index 10d9fe8a..85570c5a 100644
---- a/WDL/jnetlib/Makefile
-+++ b/WDL/jnetlib/Makefile
-@@ -7,7 +7,7 @@ CC = gcc
- CPP = g++
- CXX = g++
-
--OBJS = asyncdns.o connection.o httpget.o httpserv.o listen.o util.o sercon.o
-+OBJS = asyncdns.o connection.o httpget.o httpserv.o listen.o util.o
-
- jnl.a: ${OBJS}
- -rm -f jnl.a
-diff --git a/WDL/swell/Makefile b/WDL/swell/Makefile
-index 9e7e2d87..8e98a543 100644
---- a/WDL/swell/Makefile
-+++ b/WDL/swell/Makefile
-@@ -167,7 +167,7 @@ libSwell$(DLL_EXT): $(OBJS)
- $(CXX) -shared -o $@ $(CFLAGS) $(LFLAGS) $^ $(LINKEXTRA)
-
- test: $(OBJS) test.o
-- $(CXX) -o test $(CFLAGS) $(LFLAGS) $^ $(LINKEXTRA)
-+ $(CXX) -o test $(CFLAGS) $(LFLAGS) $^ $(LINKEXTRA) -lpthread -ldl $(shell $(PKG_CONFIG) --libs gtk+-3.0 freetype2) -lfontconfig -lGL -lXi -lX11
-
- libSwell.colortheme: swell-gdi-generic.cpp $(SWELL_HEADERS)
- $(CXX) $(CFLAGS) -o make-theme -DSWELL__MAKE_THEME swell-gdi-generic.cpp -lpthread
---
-2.38.1
-

base-commit: 4c05f513fdc225c1b5cdb7f2f61aab5d30bcbfe5
--
2.47.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76276@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76276
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help