[PATCH] gnu: Add emacs-syncthing.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ian Eure
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ian Eure
Severity
normal

Debbugs page

Ian Eure wrote 4 weeks ago
(address . guix-patches@gnu.org)(name . Ian Eure)(address . ian@retrospec.tv)
20250213204421.6057-1-ian@retrospec.tv
* gnu/packages/emacs-xyz.scm (emacs-syncthing): New variable.

Change-Id: I357c59c35b818c9e1e74b191afa6b500d833845a
---
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 40e207bf0a..64aa9e636e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -845,6 +845,27 @@ (define-public emacs-geiser-chez
"This package adds support for using Chez Scheme in Emacs with Geiser.")
(license license:bsd-3)))
+(define-public emacs-syncthing
+ (package
+ (name "emacs-syncthing")
+ (version "3.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KeyWeeUsr/emacs-syncthing.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1q755rcmlmpz9zb1i3ic3a3svyqwavncnfzmx0bsg6229qg06d0l"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/KeyWeeUsr/emacs-syncthing")
+ (synopsis "Emacs client for Syncthing")
+ (description
+ "Emacs-Syncthing is a client for the Syncthing file synchronization tool
+which provides an Emacs interface to replace the built-in web UI.")
+ (license license:gpl3+)))
+
(define-public emacs-vc-hgcmd
(package
(name "emacs-vc-hgcmd")
--
2.48.1
Ludovic Courtès wrote 3 weeks ago
(name . Ian Eure)(address . ian@retrospec.tv)(address . 76272@debbugs.gnu.org)
87bjuv74zo.fsf@gnu.org
Ian Eure <ian@retrospec.tv> skribis:

Toggle quote (4 lines)
> * gnu/packages/emacs-xyz.scm (emacs-syncthing): New variable.
>
> Change-Id: I357c59c35b818c9e1e74b191afa6b500d833845a

LGTM! :-)
Ian Eure wrote 3 weeks ago
control message for bug #76272
(address . control@debbugs.gnu.org)
87ikp1h9nj.fsf_-_@retrospec.tv
close 76272
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76272@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76272
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help