[PATCH] gnu: tractor: Invoke glib-compile-schemas.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danial Behzadi
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danial Behzadi
Severity
normal

Debbugs page

Danial Behzadi wrote 1 months ago
(address . guix-patches@gnu.org)(name . Danial Behzadi)(address . dani.behzi@ubuntu.com)
93f4c0568898a704fdeef460a90821121e0351a9.1739366531.git.dani.behzi@ubuntu.com
This is needed for packages which have tractor in their input to access the compile schemas of tractor in their environment.
---
gnu/packages/tor.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index b6b73f92..d9aa1ca2 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -484,7 +484,10 @@ (define-public tractor
(add-after 'install 'install-gschema
(lambda _
(let ((schemas (string-append #$output "/share/glib-2.0/schemas")))
- (install-file "src/tractor/tractor.gschema.xml" schemas)))))))
+ (install-file "src/tractor/tractor.gschema.xml" schemas)
+ ;; The following line is needed for packages having tractor as input
+ (invoke "glib-compile-schemas" schemas)))))))
+
(home-page "https://framagit.org/tractor")
(synopsis "Setup an onion routing proxy")
(description
--
2.47.2
Ludovic Courtès wrote 4 weeks ago
(name . Danial Behzadi)(address . dani.behzi@ubuntu.com)(address . 76224-done@debbugs.gnu.org)
8734gbji3p.fsf@gnu.org
Danial Behzadi <dani.behzi@ubuntu.com> skribis:

Toggle quote (4 lines)
> This is needed for packages which have tractor in their input to access the compile schemas of tractor in their environment.
> ---
> gnu/packages/tor.scm | 5 ++++-

I tweaked the commit log and applied it, thanks!

Ludo'.
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76224@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76224
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help