Danial Behzadi wrote 1 months ago
(address . guix-patches@gnu.org)(name . Danial Behzadi)(address . dani.behzi@ubuntu.com)
This is needed for packages which have tractor in their input to access the compile schemas of tractor in their environment.
---
gnu/packages/tor.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
Toggle diff (18 lines)
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index b6b73f92..d9aa1ca2 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -484,7 +484,10 @@ (define-public tractor
(add-after 'install 'install-gschema
(lambda _
(let ((schemas (string-append #$output "/share/glib-2.0/schemas")))
- (install-file "src/tractor/tractor.gschema.xml" schemas)))))))
+ (install-file "src/tractor/tractor.gschema.xml" schemas)
+ ;; The following line is needed for packages having tractor as input
+ (invoke "glib-compile-schemas" schemas)))))))
+
(home-page "https://framagit.org/tractor")
(synopsis "Setup an onion routing proxy")
(description
--
2.47.2