[PATCH] gnu: Add python-nmap.

  • Open
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • peter
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
peter
Severity
normal

Debbugs page

peter wrote 1 months ago
(address . guix-patches@gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
f34f47e6bcc75192056351f1a50c9e2984bc84a5.1738959615.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-nmap): New variable.

Change-Id: Ibc89f501e4d663e8661e3f988aa58e7544bde750
---
gnu/packages/python-xyz.scm | 24 +++++++++++++++++++++++-
1 file changed, 23 insertions(+), 1 deletion(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 07d31570f1..b99ae55439 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -180,6 +180,7 @@
(define-module (gnu packages python-xyz)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages adns)
#:use-module (gnu packages aidc)
#:use-module (gnu packages algebra)
@@ -39226,6 +39227,27 @@ (define-public python-nfcpy
Communication.")
(license license:eupl1.1)))
+(define-public python-nmap
+ (package
+ (name "python-nmap")
+ (version "1.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python3-nmap" version))
+ (sha256
+ (base32 "0b16ni4ywylj0k24x1pi6bp83d80wvd0ri2h225gmkgm2fqcyrc4"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-simplejson nmap which))
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://github.com/nmmapper/python3-nmap")
+ (synopsis
+ "Python interface to the nmap utility for network discovery and security auditing")
+ (description
+ "This library helps use the nmap port scanner in Python, allowing
+automation of scanning tasks and reports.")
+ (license license:gpl3)))
+
(define-public python-clrprint
(package
(name "python-clrprint")
@@ -39237,7 +39259,7 @@ (define-public python-clrprint
(base32
"0xfn8d1by2w7pjiji887qljk1avn4fylbnz1mj28gysm5g0zvy43"))))
(build-system python-build-system)
- (arguments '(#:tests? #f)) ;there are no tests
+ (arguments '(#:tests? #f)) ;there are no tests
(propagated-inputs (list python-colorama python-termcolor))
(home-page "https://github.com/AbhijithAJ/clrprint")
(synopsis "Print colorful output in the terminal")

base-commit: 8455e44cbbe2b23cadb6e15fe1e40f92b8a5e581
--
2.48.1
Sharlatan Hellseher wrote 1 months ago
(address . 76125@debbugs.gnu.org)
877c5ww7xo.fsf@gmail.com
Hi,

Thank you for the patch.

Toggle snippet (2 lines)
+ (propagated-inputs (list python-simplejson nmap which))
nmap and which need to be in inputs.

Toggle snippet (3 lines)
+ (synopsis
+ "Python interface to the nmap utility for network discovery and security auditing")
It may be shorten to: "Python wraper to Nmap"

Toggle snippet (4 lines)
+ (description
+ "This library helps use the nmap port scanner in Python, allowing
+automation of scanning tasks and reports.")
Maybe describe why this package may be helpful. Skiming the README it's
hard to deduce ...
e.g: "This package implements a functionality to wrap @code{nmap}
command into Python scripts, where each command invocation is wrapped
into function providing JSON output."

Toggle snippet (10 lines)
(define-public python-clrprint
(package
(name "python-clrprint")
@@ -39237,7 +39259,7 @@ (define-public python-clrprint
(base32
"0xfn8d1by2w7pjiji887qljk1avn4fylbnz1mj28gysm5g0zvy43"))))
(build-system python-build-system)
- (arguments '(#:tests? #f)) ;there are no tests
+ (arguments '(#:tests? #f)) ;there are no tests
Please, apply to the right package ;-)

Toggle snippet (2 lines)
+ #:use-module (gnu packages admin)
You may keep it there to reduce the number of cross references.

License looks correct as seen in LICENSE file:
Toggle snippet (4 lines)
GNU GENERAL PUBLIC LICENSE
Version 3, 29 June 2007

No related to the review comments, the value of the project is
questionable as Nmap provides a very powerful scripting in Lua
https://nmap.org/book/nse-language.html, why someone needs to reduce
tooling by wrapping it inside hacky Python script I'm doubt to say :-).

And the project admires that fact!
Toggle quote (4 lines)
> Nmap is a complicated piece of software used for reconnaissance on
> target networks, over the years new features have been added making it
> more sophisticated.

Waiting for v2 to cover review points.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmersNMACgkQdtcnv/Ys
0rVxnRAAnVOh4HxCfmlEXWNoPSN/37K+s5w8lkG7Mk3yrHRcIRqg1ouoRoVQtaYL
b8xXZt+rIcsOeEaaGq/1b2dTGmCR+KhtzAA0ErwoNs5Kv16w0UWbOeSzCrMsOZjd
vgC1tu/9bT9s00NTtPloF6Dc1i5AT36Cuk9IFubn0zDKhV873YyhM1j0UzcXc9HS
xh/NaCuymw9AxpVIOowN04i39853hABKMB0OQ1NjovRboFv3/jNcLw7Oj4nhbvwa
5l8gE1wMvNi5f1N8Lik6jLPhXlQYrTyJOnbDA/NJW55dvbt/Na0HGISI6JpD6KXp
xj2LZ1IeTZfQM546KC5YFFdJAc+6KQZZY2qkaxYKQGGeZHPmKe5a7l0QUBoFfiA2
h6x3GzP1VQFIPxvB1y1jyDfFJbiguIRxQr/+F2eAEncNkoKIkJ4OwYnbVZ8J9xk3
OVEKDdR4ZczWwhLYAr7Qo++YjqTrvz8sG2zbePPh63W0Lx90RV9C6R1tsP2TnqZo
MrNFimJ9Q6Tox7tHuADM9Ckv8IURsuAnZnhiMtFiYAjwtJgJlqaIN2+RiCYnjOJZ
db0SS66kb6rSnHe2GeYlBFz2DAi85dKks0YQZSlJg4advIZMLmYlxgz78DMqM4T6
gZWqHrNHHNxNJCTjFFhYP4VewuO3VA3xWSL/PW6jGAqiFGVjtDg=
=SuAu
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 1 weeks ago
control message for bug #76125
(address . control@debbugs.gnu.org)
87ecz7sbaf.fsf@gnu.org
tags 76125 + moreinfo
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76125@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76125
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help