peter wrote 1 months ago
(address . guix-patches@gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
From: Peter Polidoro <peter@polidoro.io>
* gnu/packages/python-xyz.scm (python-nmap): New variable.
Change-Id: Ibc89f501e4d663e8661e3f988aa58e7544bde750
---
gnu/packages/python-xyz.scm | 24 +++++++++++++++++++++++-
1 file changed, 23 insertions(+), 1 deletion(-)
Toggle diff (53 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 07d31570f1..b99ae55439 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -180,6 +180,7 @@
(define-module (gnu packages python-xyz)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages adns)
#:use-module (gnu packages aidc)
#:use-module (gnu packages algebra)
@@ -39226,6 +39227,27 @@ (define-public python-nfcpy
Communication.")
(license license:eupl1.1)))
+(define-public python-nmap
+ (package
+ (name "python-nmap")
+ (version "1.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python3-nmap" version))
+ (sha256
+ (base32 "0b16ni4ywylj0k24x1pi6bp83d80wvd0ri2h225gmkgm2fqcyrc4"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-simplejson nmap which))
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://github.com/nmmapper/python3-nmap")
+ (synopsis
+ "Python interface to the nmap utility for network discovery and security auditing")
+ (description
+ "This library helps use the nmap port scanner in Python, allowing
+automation of scanning tasks and reports.")
+ (license license:gpl3)))
+
(define-public python-clrprint
(package
(name "python-clrprint")
@@ -39237,7 +39259,7 @@ (define-public python-clrprint
(base32
"0xfn8d1by2w7pjiji887qljk1avn4fylbnz1mj28gysm5g0zvy43"))))
(build-system python-build-system)
- (arguments '(#:tests? #f)) ;there are no tests
+ (arguments '(#:tests? #f)) ;there are no tests
(propagated-inputs (list python-colorama python-termcolor))
(home-page "https://github.com/AbhijithAJ/clrprint")
(synopsis "Print colorful output in the terminal")
base-commit: 8455e44cbbe2b23cadb6e15fe1e40f92b8a5e581
--
2.48.1