[PATCH] gnu: emacs-go-translate: Improve code style.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ian Eure
  • Evgeny Pisemsky
Owner
unassigned
Submitted by
Evgeny Pisemsky
Severity
normal

Debbugs page

Evgeny Pisemsky wrote 1 months ago
(address . guix-patches@gnu.org)
dbec5e09f23898d52d87ee7524c72632373fe924.1738775132.git.mail@pisemsky.site
* gnu/packages/emacs-xyz.scm (emacs-go-translate): Improve code style.

Change-Id: I0a2601a34907169a0792e1a7a2b05ecd8ca2119a
---
gnu/packages/emacs-xyz.scm | 16 ++++++----------
1 file changed, 6 insertions(+), 10 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cbd4e25e2b..dd052d0b93 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29204,15 +29204,10 @@ (define-public emacs-go-translate
(arguments
(list
#:tests? #t
- #:test-command #~(list "emacs"
- "-Q"
- "--batch"
- "-L"
- "."
- "-l"
- "gt-tests.el"
- "-f"
- "ert-run-tests-batch-and-exit")
+ #:test-command #~(list "emacs" "-Q" "--batch"
+ "-L" "."
+ "-l" "gt-tests.el"
+ "-f" "ert-run-tests-batch-and-exit")
#:phases #~(modify-phases %standard-phases
(add-before 'check 'skip-failing-tests
(lambda _
@@ -29220,7 +29215,8 @@ (define-public emacs-go-translate
(("\\(ert-deftest test--gt-translation-life-cycle .*"
all)
(string-append all "(skip-unless nil)\n"))
- (("\\(ert-deftest test--gt-valid-literally .*" all)
+ (("\\(ert-deftest test--gt-valid-literally .*"
+ all)
(string-append all "(skip-unless nil)\n"))))))))
(home-page "https://github.com/lorniu/go-translate/")
(synopsis "Configurable and scalable translation framework")

base-commit: c25137aaa75236a8d9f06fa2f38a8c29e77c0f16
--
2.48.1
Ian Eure wrote 1 months ago
(name . Evgeny Pisemsky)(address . mail@pisemsky.site)(address . control@debbugs.gnu.org)(address . 76074@debbugs.gnu.org)
87msevya8v.fsf@retrospec.tv
Hi Evgeny,

Pushed as fd3876ec2a. Thank you for contributing!

-- Ian
Ian Eure wrote 1 months ago
control message for bug #76074
(address . control@debbugs.gnu.org)
87ldufya8i.fsf@retrospec.tv
close 76074
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 76074@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76074
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help