[PATCH] gnu: Add mc2mt-cpp.

  • Open
  • quality assurance status badge
Details
2 participants
  • Adam Faiz
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Adam Faiz
Severity
normal

Debbugs page

Adam Faiz wrote 2 months ago
(address . guix-patches@gnu.org)(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . iyzsong@envs.net)
9749c831-5b2c-448a-8c98-10eee274b446@disroot.org
From d4c0e54e420eaf5937266310b42e9addf6528903 Mon Sep 17 00:00:00 2001
Message-ID: <d4c0e54e420eaf5937266310b42e9addf6528903.1738402724.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Sat, 1 Feb 2025 17:35:49 +0800
Subject: [PATCH] gnu: Add mc2mt-cpp.

* gnu/packages/game-development.scm (mc2mt-cpp): New variable.
---
gnu/packages/game-development.scm | 32 +++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 57cebedda8..8cd3a0a3ee 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2004,6 +2004,38 @@ (define-public mc2mt
(home-page "https://github.com/listia/mc2mt")
(license license:expat))))
+(define-public mc2mt-cpp
+ (let ((commit "4ee1e76643e6ad98ede07e1a92378a057c4e9851")
+ (revision "0"))
+ (package
+ (name "mc2mt-cpp")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rollerozxa/MC2MT")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0by6pnpp1bq0akq4s9r6v0jc5s4ywxi9ysvlg845rbd0vpam075k"))))
+ (build-system cmake-build-system)
+ (inputs (list sqlite zlib))
+ (arguments
+ (list
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'install
+ (lambda _
+ (install-file "bin/MC2MT"
+ (string-append #$output "/bin")))))))
+ (synopsis "Minecraft to Minetest world converter")
+ (description "@code{MC2MT} is a Minecraft to Minetest world converter.
+It can convert worlds from Minecraft 1.12 and below.")
+ (home-page "https://github.com/rollerozxa/MC2MT")
+ (license license:lgpl2.1+))))
+
(define-public mygui
(package
(name "mygui")

base-commit: ba0340eec2e50439cfd94e85b40bf41c2d488a74
--
2.46.0
Liliana Marie Prikler wrote 2 months ago
(name . Adam Faiz)(address . adam.faiz@disroot.org)(address . 75989@debbugs.gnu.org)(address . iyzsong@envs.net)
f6b9d469b1235f14229a8714119d832b9c95af50.camel@gmail.com
Am Samstag, dem 01.02.2025 um 17:45 +0800 schrieb Adam Faiz:
Toggle quote (10 lines)
> From d4c0e54e420eaf5937266310b42e9addf6528903 Mon Sep 17 00:00:00
> 2001
> Message-ID:
> <d4c0e54e420eaf5937266310b42e9addf6528903.1738402724.git.adam.faiz@di
> sroot.org>
> From: AwesomeAdam54321 <adam.faiz@disroot.org>
> Date: Sat, 1 Feb 2025 17:35:49 +0800
> Subject: [PATCH] gnu: Add mc2mt-cpp.
>
> * gnu/packages/game-development.scm (mc2mt-cpp): New variable.
Why the suffix -cpp?


Lexically LGTM.

Cheers
Adam Faiz wrote 2 months ago
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 75989@debbugs.gnu.org)(address . iyzsong@envs.net)
d667d02a-2197-494e-a288-3db9c654f359@disroot.org
On 2/1/25 17:48, Liliana Marie Prikler wrote:
Toggle quote (13 lines)
> Am Samstag, dem 01.02.2025 um 17:45 +0800 schrieb Adam Faiz:
>> From d4c0e54e420eaf5937266310b42e9addf6528903 Mon Sep 17 00:00:00
>> 2001
>> Message-ID:
>> <d4c0e54e420eaf5937266310b42e9addf6528903.1738402724.git.adam.faiz@di
>> sroot.org>
>> From: AwesomeAdam54321 <adam.faiz@disroot.org>
>> Date: Sat, 1 Feb 2025 17:35:49 +0800
>> Subject: [PATCH] gnu: Add mc2mt-cpp.
>>
>> * gnu/packages/game-development.scm (mc2mt-cpp): New variable.
> Why the suffix -cpp?

I added the suffix -cpp so that it won't conflict with my previous submission for a very similiar package:

Toggle quote (4 lines)
>
> Lexically LGTM.
>
> Cheers
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75989@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75989
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help