Adam Faiz wrote 2 months ago
(address . guix-patches@gnu.org)(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . iyzsong@envs.net)
From d4c0e54e420eaf5937266310b42e9addf6528903 Mon Sep 17 00:00:00 2001
Message-ID: <d4c0e54e420eaf5937266310b42e9addf6528903.1738402724.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Sat, 1 Feb 2025 17:35:49 +0800
Subject: [PATCH] gnu: Add mc2mt-cpp.
* gnu/packages/game-development.scm (mc2mt-cpp): New variable.
---
gnu/packages/game-development.scm | 32 +++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
Toggle diff (47 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 57cebedda8..8cd3a0a3ee 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2004,6 +2004,38 @@ (define-public mc2mt
(home-page "https://github.com/listia/mc2mt")
(license license:expat))))
+(define-public mc2mt-cpp
+ (let ((commit "4ee1e76643e6ad98ede07e1a92378a057c4e9851")
+ (revision "0"))
+ (package
+ (name "mc2mt-cpp")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rollerozxa/MC2MT")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0by6pnpp1bq0akq4s9r6v0jc5s4ywxi9ysvlg845rbd0vpam075k"))))
+ (build-system cmake-build-system)
+ (inputs (list sqlite zlib))
+ (arguments
+ (list
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'install
+ (lambda _
+ (install-file "bin/MC2MT"
+ (string-append #$output "/bin")))))))
+ (synopsis "Minecraft to Minetest world converter")
+ (description "@code{MC2MT} is a Minecraft to Minetest world converter.
+It can convert worlds from Minecraft 1.12 and below.")
+ (home-page "https://github.com/rollerozxa/MC2MT")
+ (license license:lgpl2.1+))))
+
(define-public mygui
(package
(name "mygui")
base-commit: ba0340eec2e50439cfd94e85b40bf41c2d488a74
--
2.46.0