[PATCH] gnu: Add emacs-reverso.

  • Open
  • quality assurance status badge
Details
2 participants
  • Cayetano Santos
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Cayetano Santos
Severity
normal
C
C
Cayetano Santos wrote on 30 Jan 16:12 +0100
(address . guix-patches@gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
43d6b5070970ecdfbe55a8bb0c906e49349cbae9.1738249962.git.csantosb@inventati.org
* gnu/packages/emacs-xyz.scm (emacs-reverso): New variable.

Change-Id: I3b16a1c307d574d2bbff7daaee42a4964572ab00
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 153785e017..a6d56960f5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4317,6 +4317,28 @@ (define-public emacs-rebecca-theme
the @code{Dracula} theme for Emacs and the @code{Gloom} theme for Atom.")
(license license:expat))))
+(define-public emacs-reverso
+ (let ((commit "d1b39da3c7df1541f98435f3172a7ff4f3123634")
+ (revision "0"))
+ (package
+ (name "emacs-reverso")
+ (version (git-version "0.1.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SqrtMinusOne/reverso.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fpk5wyzlssfrm4jbsrflxvlfn80yh6y1nh63ml8barf1nypsx55"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-fedi emacs-request emacs-transient))
+ (home-page "https://github.com/SqrtMinusOne/reverso.el")
+ (synopsis "Translation, grammar checking, context search")
+ (description "Emacs client for the reverso.net service.")
+ (license license:gpl3+))))
+
(define-public emacs-bbdb
(package
(name "emacs-bbdb")

base-commit: b85d20e853192a92093cd8d6a5756ec80e94c658
--
2.48.1
N
N
Nicolas Goaziou wrote on 30 Jan 17:13 +0100
(name . Cayetano Santos via Guix-patches via)(address . guix-patches@gnu.org)
87y0ys700l.fsf@nicolasgoaziou.fr
Hello,

Cayetano Santos via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-reverso): New variable.

Thank you. This looks good to me except…

Toggle quote (2 lines)
> + (description "Emacs client for the reverso.net service.")

… the description, which is expected to include only complete sentences.

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
C
C
Cayetano Santos wrote on 30 Jan 17:27 +0100
[PATCH v1] gnu: Add emacs-reverso.
(address . 75948@debbugs.gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
d317c99dc349793d3141ab46569ebc7d9b9c5b08.1738254458.git.csantosb@inventati.org
* gnu/packages/emacs-xyz.scm (emacs-reverso): New variable.

Change-Id: I3b16a1c307d574d2bbff7daaee42a4964572ab00
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 153785e017..dd75aa6194 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4317,6 +4317,28 @@ (define-public emacs-rebecca-theme
the @code{Dracula} theme for Emacs and the @code{Gloom} theme for Atom.")
(license license:expat))))
+(define-public emacs-reverso
+ (let ((commit "d1b39da3c7df1541f98435f3172a7ff4f3123634")
+ (revision "0"))
+ (package
+ (name "emacs-reverso")
+ (version (git-version "0.1.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SqrtMinusOne/reverso.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fpk5wyzlssfrm4jbsrflxvlfn80yh6y1nh63ml8barf1nypsx55"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-fedi emacs-request emacs-transient))
+ (home-page "https://github.com/SqrtMinusOne/reverso.el")
+ (synopsis "Translation, grammar checking, context search")
+ (description "Reverso is an emacs client for the reverso.net service.")
+ (license license:gpl3+))))
+
(define-public emacs-bbdb
(package
(name "emacs-bbdb")

base-commit: b85d20e853192a92093cd8d6a5756ec80e94c658
--
2.48.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75948@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75948
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch