[PATCH] gnu: python-lsp-black: Update to 2.0.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 21 Jan 16:06 +0100
(address . guix-patches@gnu.org)
871pwk4qfc.fsf@ngraves.fr
* gnu/packages/python-xyz.scm (python-lsp-black): Update to 2.0.0.
[arguments]<#:test-flags>: Add failing tests.
---
gnu/packages/python-xyz.scm | 12 ++++++++++--
1 file changed, 10 insertions(+), 2 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bf18dec630..763b0fee77 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3529,7 +3529,7 @@ (define-public python-pylatexenc
(define-public python-lsp-black
(package
(name "python-lsp-black")
- (version "1.3.0")
+ (version "2.0.0")
(source
(origin
(method git-fetch)
@@ -3538,8 +3538,16 @@ (define-public python-lsp-black
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1gwf3vwb01a3l8b75jbn8kyfmn0lva8vpgjnr75vazhm3lsf78fp"))))
+ (base32 "0ilh6nx15kzrp29nkrpx03vx6dw3n7wq65qwv7bg7kcnyiwacplx"))))
(build-system pyproject-build-system)
+ (arguments
+ ;; The python version is too old for these tests to pass properly.
+ (list #:test-flags
+ `'("-k" ,(string-append
+ "not test_pylsp_format_document_syntax_error"
+ " and not test_pylsp_format_range_syntax_error"
+ " and not test_load_config_defaults"
+ " and not test_load_config_with_skip_options"))))
(propagated-inputs
(list python-black python-lsp-server python-tomli))
(native-inputs
--
2.47.1



--
Best regards,
Nicolas Graves
J
J
jgart wrote 7 days ago
(address . 75941-done@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
87zfj27lxk.fsf@dismail.de
Applied, thanks!
--
all the best,
jgart
Closed
J
J
jgart wrote 7 days ago
(address . 75941-done@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
87wme67lvc.fsf@dismail.de

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75941@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75941
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch