[PATCH] services: Use beaconDB as location provider in geoclue.

  • Open
  • quality assurance status badge
Details
One participant
  • Jonathan Brielmaier
Owner
unassigned
Submitted by
Jonathan Brielmaier
Severity
normal
J
J
Jonathan Brielmaier wrote on 29 Jan 17:04 +0100
(address . guix-patches@gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
43a531a884ca66f3dcb35dacffe91860816846b4.1738166436.git.jonathan.brielmaier@web.de
The previous used Mozilla Location Service (MLS) was retired in 2024:

* gnu/services/desktop.scm (<geoclue-configuration>)
[wifi-geolocation-url]: Switch default provider to beaconDB.
[wifi-submission-url]: Dito.

Change-Id: I95e4600a2d5454bdde4be44b09273694536bd44e
---
gnu/services/desktop.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/services/desktop.scm b/gnu/services/desktop.scm
index e5446561822..b01e7faa301 100644
--- a/gnu/services/desktop.scm
+++ b/gnu/services/desktop.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2024 45mg <45mg.writes@gmail.com>
;;; Copyright © 2024 Raven Hallsby <karl@hallsby.com>
+;;; Copyright © 2025 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -374,12 +375,12 @@ (define-record-type* <geoclue-configuration>
(wifi-geolocation-url
geoclue-configuration-wifi-geolocation-url
;; Mozilla geolocation service:
- (default "https://location.services.mozilla.com/v1/geolocate?key=geoclue"))
+ (default "https://api.beacondb.net/v1/geolocate"))
(submit-data? geoclue-configuration-submit-data?
(default #f))
(wifi-submission-url
geoclue-configuration-wifi-submission-url
- (default "https://location.services.mozilla.com/v1/submit?key=geoclue"))
+ (default "https://api.beacondb.net/v2/geosubmit"))
(submission-nick geoclue-configuration-submission-nick
(default "geoclue"))
(applications geoclue-configuration-applications

base-commit: ac103c2eab1a169ca18c88fd0b0d03c7d2e02c9d
--
2.47.1
J
J
Jonathan Brielmaier wrote on 29 Jan 17:08 +0100
(address . 75929@debbugs.gnu.org)
4def226b-d9ec-45e9-84a1-362641f18b41@web.de
Due too difficulties with Guix System on my laptop I did not had the
chance to test this patch.

~Jonathan
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75929@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75929
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch