[PATCH] gnu: e2fsprogs: Update to 1.47.1.

  • Open
  • quality assurance status badge
Details
2 participants
  • Ashish SHUKLA
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ashish SHUKLA
Severity
normal

Debbugs page

Ashish SHUKLA wrote 3 months ago
(address . guix-patches@gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
40470449d9a1cc059f5bfaa234e4a7ccdac1627b.1735225166.git.ashish.is@lostca.se
* gnu/packages/linux.scm (e2fsprogs): Update to 1.47.1.

Change-Id: I428973b6a04a99eca96592d79d1bf7da47fd6680
---
gnu/packages/linux.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 78d3d737b5..b9c7755dfa 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2738,7 +2738,7 @@ (define-public usbip-utils
(define-public e2fsprogs
(package
(name "e2fsprogs")
- (version "1.47.0")
+ (version "1.47.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2747,7 +2747,7 @@ (define-public e2fsprogs
"e2fsprogs-" version ".tar.xz"))
(sha256
(base32
- "1nymjw801lmlr5y6bg1zv9jsip5dkyxqislbdzpir4mx5czzajhl"))))
+ "1lg0k5fh41nl0ldbh76hwdx3g5kqzqyc245vljy88wnlgw2dqcss"))))
(build-system gnu-build-system)
(inputs (list `(,util-linux "lib")))
(native-inputs (list pkg-config

base-commit: f96c14e3ca6b22e56621cc04a1bf06a8cac6ca23
--
2.47.1
Ludovic Courtès wrote 7 days ago
(name . Ashish SHUKLA)(address . ashish.is@lostca.se)(address . 75119@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)(name . Leo Famulari)(address . leo@famulari.name)
87cyepq8y3.fsf@gnu.org
Ashish SHUKLA <ashish.is@lostca.se> skribis:

Toggle quote (4 lines)
> * gnu/packages/linux.scm (e2fsprogs): Update to 1.47.1.
>
> Change-Id: I428973b6a04a99eca96592d79d1bf7da47fd6680

Interestingly, this breaks btrfs-progs:

Toggle snippet (38 lines)
convert/source-ext2.c: In function ‘ext4_copy_inode_timespec_extra’:
convert/source-ext2.c:733:13: warning: implicit declaration of function ‘inode_includes’ [-Wimplicit-function-declaration]
733 | if (inode_includes(inode_size, i_ ## xtime ## _extra)) { \
| ^~~~~~~~~~~~~~
convert/source-ext2.c:769:9: note: in expansion of macro ‘EXT4_COPY_XTIME’
769 | EXT4_COPY_XTIME(atime, dst, tv_sec, tv_nsec);
| ^~~~~~~~~~~~~~~
convert/source-ext2.c:733:40: error: ‘i_atime_extra’ undeclared (first use in this function)
733 | if (inode_includes(inode_size, i_ ## xtime ## _extra)) { \
| ^~
convert/source-ext2.c:769:9: note: in expansion of macro ‘EXT4_COPY_XTIME’
769 | EXT4_COPY_XTIME(atime, dst, tv_sec, tv_nsec);
| ^~~~~~~~~~~~~~~
convert/source-ext2.c:733:40: note: each undeclared identifier is reported only once for each function it appears in
733 | if (inode_includes(inode_size, i_ ## xtime ## _extra)) { \
| ^~
convert/source-ext2.c:769:9: note: in expansion of macro ‘EXT4_COPY_XTIME’
769 | EXT4_COPY_XTIME(atime, dst, tv_sec, tv_nsec);
| ^~~~~~~~~~~~~~~
convert/source-ext2.c:733:40: error: ‘i_mtime_extra’ undeclared (first use in this function)
733 | if (inode_includes(inode_size, i_ ## xtime ## _extra)) { \
| ^~
convert/source-ext2.c:770:9: note: in expansion of macro ‘EXT4_COPY_XTIME’
770 | EXT4_COPY_XTIME(mtime, dst, tv_sec, tv_nsec);
| ^~~~~~~~~~~~~~~
convert/source-ext2.c:733:40: error: ‘i_ctime_extra’ undeclared (first use in this function)
733 | if (inode_includes(inode_size, i_ ## xtime ## _extra)) { \
| ^~
convert/source-ext2.c:771:9: note: in expansion of macro ‘EXT4_COPY_XTIME’
771 | EXT4_COPY_XTIME(ctime, dst, tv_sec, tv_nsec);
| ^~~~~~~~~~~~~~~
convert/source-ext2.c:774:40: error: ‘i_crtime_extra’ undeclared (first use in this function)
774 | if (inode_includes(inode_size, i_crtime_extra)) {
| ^~~~~~~~~~~~~~
[LD] btrfs-select-super
make: *** [Makefile:453: convert/source-ext2.o] Error 1

(I tested with “./pre-inst-env guix build -P1 e2fsprogs”.)

Could you take a look?

Thanks
Ludo’.
Ashish SHUKLA wrote 6 days ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 75119@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)(name . Leo Famulari)(address . leo@famulari.name)
D8CU4AFMS2KA.39EBISNKKI2GX@lostca.se
El 2025-03-10 15:03, Ludovic Courtès escribió:
Toggle quote (51 lines)
> Ashish SHUKLA <ashish.is@lostca.se> skribis:
>
>> * gnu/packages/linux.scm (e2fsprogs): Update to 1.47.1.
>>
>> Change-Id: I428973b6a04a99eca96592d79d1bf7da47fd6680
>
> Interestingly, this breaks btrfs-progs:
>
> --8<---------------cut here---------------start------------->8---
> convert/source-ext2.c: In function ‘ext4_copy_inode_timespec_extra’:
> convert/source-ext2.c:733:13: warning: implicit declaration of function ‘inode_includes’ [-Wimplicit-function-declaration]
> 733 | if (inode_includes(inode_size, i_ ## xtime ## _extra)) { \
> | ^~~~~~~~~~~~~~
> convert/source-ext2.c:769:9: note: in expansion of macro ‘EXT4_COPY_XTIME’
> 769 | EXT4_COPY_XTIME(atime, dst, tv_sec, tv_nsec);
> | ^~~~~~~~~~~~~~~
> convert/source-ext2.c:733:40: error: ‘i_atime_extra’ undeclared (first use in this function)
> 733 | if (inode_includes(inode_size, i_ ## xtime ## _extra)) { \
> | ^~
> convert/source-ext2.c:769:9: note: in expansion of macro ‘EXT4_COPY_XTIME’
> 769 | EXT4_COPY_XTIME(atime, dst, tv_sec, tv_nsec);
> | ^~~~~~~~~~~~~~~
> convert/source-ext2.c:733:40: note: each undeclared identifier is reported only once for each function it appears in
> 733 | if (inode_includes(inode_size, i_ ## xtime ## _extra)) { \
> | ^~
> convert/source-ext2.c:769:9: note: in expansion of macro ‘EXT4_COPY_XTIME’
> 769 | EXT4_COPY_XTIME(atime, dst, tv_sec, tv_nsec);
> | ^~~~~~~~~~~~~~~
> convert/source-ext2.c:733:40: error: ‘i_mtime_extra’ undeclared (first use in this function)
> 733 | if (inode_includes(inode_size, i_ ## xtime ## _extra)) { \
> | ^~
> convert/source-ext2.c:770:9: note: in expansion of macro ‘EXT4_COPY_XTIME’
> 770 | EXT4_COPY_XTIME(mtime, dst, tv_sec, tv_nsec);
> | ^~~~~~~~~~~~~~~
> convert/source-ext2.c:733:40: error: ‘i_ctime_extra’ undeclared (first use in this function)
> 733 | if (inode_includes(inode_size, i_ ## xtime ## _extra)) { \
> | ^~
> convert/source-ext2.c:771:9: note: in expansion of macro ‘EXT4_COPY_XTIME’
> 771 | EXT4_COPY_XTIME(ctime, dst, tv_sec, tv_nsec);
> | ^~~~~~~~~~~~~~~
> convert/source-ext2.c:774:40: error: ‘i_crtime_extra’ undeclared (first use in this function)
> 774 | if (inode_includes(inode_size, i_crtime_extra)) {
> | ^~~~~~~~~~~~~~
> [LD] btrfs-select-super
> make: *** [Makefile:453: convert/source-ext2.o] Error 1
> --8<---------------cut here---------------end--------------->8---
>
> (I tested with “./pre-inst-env guix build -P1 e2fsprogs”.)
>
> Could you take a look?

Sure, while here I'm also updating it to its latest version, 6.13.

Thanks!
--
Ashish SHUKLA | GPG: F682 CDCC 39DC 0FEA E116 20B6 C746 CFA9 E74F A4B0

"If I destroy you, what business is it of yours ?" (Dark Forest, Liu Cixin)
-----BEGIN PGP SIGNATURE-----

iQKoBAABCgCSFiEE9oLNzDncD+rhFiC2x0bPqedPpLAFAmfPPiVfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldEY2
ODJDRENDMzlEQzBGRUFFMTE2MjBCNkM3NDZDRkE5RTc0RkE0QjAUHGFzaGlzaC5p
c0Bsb3N0Y2Euc2UACgkQx0bPqedPpLBNWA//enyGAckCGDlWe3fQlVTx0H6USI7Z
IqafdvYI7Y+WO9qTZkIuIQJf3mb4r9xDv6dfPccu2du3ZLCNIk/Mc1e0RyTg73PR
0RoPvYs/BFHor5wZJGwzutl0owqTDWgVcOtza1tYoa6qk8hwbWr94AlAmly0OoEh
M7vm53Xj5mqd9UssHe3fkXldGpLY2mzyJ1NmG/fiwtO0BtQuQiU44IhbRz3GkbBC
VX8KyQ4GLvyzyAd/ZKcCYXtSAkYU0v1Z2MMxpTFGpMNcvb4ivXafO+HVwFlPd6Sp
u06a1I4hV2w3MgagoKWh4p+wfE53465HMTezJMnzX+ioJuj6puWE3mxHJd9q+ApG
ys7aB89G82Ni5m4Z3pKE36k3GcG12HsYlJTbEse9cwADcG1jj5pNJnkLXANfem7u
Y09obTnm7AJcFWQXmvPXLI93FGe6I7Aor3Q/szZ28weMnhLbvLLERdKKl11wleU6
7sEFNCein3rkw/ER/jr6qOKFITMZPHhUjQQ3TD6zfzqW4KZ9oDZkKJpOJ9oEZx4e
r5pJwcccM9t9aGug7ywHA1b3qaVm5L+PLK5Grbs2I2+2kyd6D6FwoTFCfUNGknUC
NKlY3lQWUPJ1M6Vv9LW03sYy6O/4u3w4WSqZKGhq+0h3FDqwRN+6mCdFko6Jfx1V
Pus8OvD6glD4oXE=
=Vsd9
-----END PGP SIGNATURE-----


Ashish SHUKLA wrote 6 days ago
[PATCH v2 1/2] gnu: e2fsprogs: Update to 1.47.1.
(address . ludo@gnu.org)(address . 75119@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)(name . Leo Famulari)(address . leo@famulari.name)
0350de0a8007960c737f84de5e63fd0483940c0e.1741635259.git.ashish.is@lostca.se
* gnu/packages/linux.scm (e2fsprogs): Update to 1.47.1.

Change-Id: I428973b6a04a99eca96592d79d1bf7da47fd6680
---
gnu/packages/linux.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5dbb6f9a96..690e9e23d5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2790,7 +2790,7 @@ (define-public usbip-utils
(define-public e2fsprogs
(package
(name "e2fsprogs")
- (version "1.47.0")
+ (version "1.47.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2799,7 +2799,7 @@ (define-public e2fsprogs
"e2fsprogs-" version ".tar.xz"))
(sha256
(base32
- "1nymjw801lmlr5y6bg1zv9jsip5dkyxqislbdzpir4mx5czzajhl"))))
+ "1lg0k5fh41nl0ldbh76hwdx3g5kqzqyc245vljy88wnlgw2dqcss"))))
(build-system gnu-build-system)
(inputs (list `(,util-linux "lib")))
(native-inputs (list pkg-config

base-commit: 5b4ae0b5c2d63e40c8adaf15d9ce0c456189f321
--
2.48.1
Ashish SHUKLA wrote 6 days ago
[PATCH v2 2/2] gnu: btrfs-progs: Update to 6.13.
(address . ludo@gnu.org)(address . 75119@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)(name . Leo Famulari)(address . leo@famulari.name)
09849aab20394a877eec8c4679ce54d2ef359cf1.1741635259.git.ashish.is@lostca.se
* gnu/packages/linux.scm (btrfs-progs): Update to 6.13.
[native-inputs]: Add python-wrapper, and python-sphinx-rtd-theme.

Change-Id: I839f3f20518b632eceaf73cc8c57df7bece1dfb9
---
gnu/packages/linux.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 690e9e23d5..673f7019df 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6429,7 +6429,7 @@ (define-public gpm
(define-public btrfs-progs
(package
(name "btrfs-progs")
- (version "6.3.3")
+ (version "6.13")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/kernel/"
@@ -6437,7 +6437,7 @@ (define-public btrfs-progs
version ".tar.xz"))
(sha256
(base32
- "0vmrjn3dcmka9rj5b81ag9jwprzyicx05h1ccj0x0w02fqah1qsb"))))
+ "16pffd6wf1pmdw9rgasyq2qf59y6xh764cml2c0gi5552w8z5cv5"))))
(build-system gnu-build-system)
(outputs '("out" "static")) ;static versions of the binaries in "out"
(arguments
@@ -6498,7 +6498,7 @@ (define-public btrfs-progs
;; For building documentation. Since python-sphinx requires Rust, add
;; it conditionally depending on such support.
(if (supported-package? python-sphinx)
- (list python-sphinx)
+ (list python-wrapper python-sphinx python-sphinx-rtd-theme)
'())
(list pkg-config
acl ;for tests
--
2.48.1
Ludovic Courtès wrote 3 days ago
Re: [bug#75119] [PATCH] gnu: e2fsprogs: Update to 1.47.1.
(name . Ashish SHUKLA)(address . ashish.is@lostca.se)(address . 75119@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)(name . Leo Famulari)(address . leo@famulari.name)
871pv0y0us.fsf@gnu.org
Hi Ashish,

"Ashish SHUKLA" <ashish.is@lostca.se> skribis:

Toggle quote (2 lines)
> Sure, while here I'm also updating it to its latest version, 6.13.

Making progress. :-)

Toggle snippet (5 lines)
$ ./pre-inst-env guix build --no-grafts -P1 e2fsprogs -P1 btrfs-progs
[…]
guix build: error: build of `/gnu/store/0qsdl31a7nz2vpmv78h32fp1vp89rwgh-genimage-18-0.00009af.drv', `/gnu/store/40mwpgnprz01wbsszprmaa8bc7ah3d59-spacefm-1.0.6.drv', `/gnu/store/7ixdhhydzp1dycqzmk7sr55k6xzjq4pk-lxd-4.24.drv', `/gnu/store/dawnvrspcp7vyl58nlsfc0pnb7an4x6l-libblockdev-3.1.1.drv', `/gnu/store/fqxh88cknlizw1k388wpwvyyrg4d6wyl-aegis-4.24.drv', `/gnu/store/isi2miz2rj8jjr2rfwxg7c7dy5ql30f7-compsize-1.5.drv' failed

I looked at ‘compsize’: there’s no fix in the upstream repo, so perhaps
we’ll have to leave it like this, unless there are patches in downstream
distros.

Could you take a look at the others though?

Thanks,
Ludo’.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75119@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75119
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help