El 2025-03-10 15:03, Ludovic Courtès escribió:
Toggle quote (51 lines)
> Ashish SHUKLA <ashish.is@lostca.se> skribis:
>
>> * gnu/packages/linux.scm (e2fsprogs): Update to 1.47.1.
>>
>> Change-Id: I428973b6a04a99eca96592d79d1bf7da47fd6680
>
> Interestingly, this breaks btrfs-progs:
>
> --8<---------------cut here---------------start------------->8---
> convert/source-ext2.c: In function ‘ext4_copy_inode_timespec_extra’:
> convert/source-ext2.c:733:13: warning: implicit declaration of function ‘inode_includes’ [-Wimplicit-function-declaration]
> 733 | if (inode_includes(inode_size, i_ ## xtime ## _extra)) { \
> | ^~~~~~~~~~~~~~
> convert/source-ext2.c:769:9: note: in expansion of macro ‘EXT4_COPY_XTIME’
> 769 | EXT4_COPY_XTIME(atime, dst, tv_sec, tv_nsec);
> | ^~~~~~~~~~~~~~~
> convert/source-ext2.c:733:40: error: ‘i_atime_extra’ undeclared (first use in this function)
> 733 | if (inode_includes(inode_size, i_ ## xtime ## _extra)) { \
> | ^~
> convert/source-ext2.c:769:9: note: in expansion of macro ‘EXT4_COPY_XTIME’
> 769 | EXT4_COPY_XTIME(atime, dst, tv_sec, tv_nsec);
> | ^~~~~~~~~~~~~~~
> convert/source-ext2.c:733:40: note: each undeclared identifier is reported only once for each function it appears in
> 733 | if (inode_includes(inode_size, i_ ## xtime ## _extra)) { \
> | ^~
> convert/source-ext2.c:769:9: note: in expansion of macro ‘EXT4_COPY_XTIME’
> 769 | EXT4_COPY_XTIME(atime, dst, tv_sec, tv_nsec);
> | ^~~~~~~~~~~~~~~
> convert/source-ext2.c:733:40: error: ‘i_mtime_extra’ undeclared (first use in this function)
> 733 | if (inode_includes(inode_size, i_ ## xtime ## _extra)) { \
> | ^~
> convert/source-ext2.c:770:9: note: in expansion of macro ‘EXT4_COPY_XTIME’
> 770 | EXT4_COPY_XTIME(mtime, dst, tv_sec, tv_nsec);
> | ^~~~~~~~~~~~~~~
> convert/source-ext2.c:733:40: error: ‘i_ctime_extra’ undeclared (first use in this function)
> 733 | if (inode_includes(inode_size, i_ ## xtime ## _extra)) { \
> | ^~
> convert/source-ext2.c:771:9: note: in expansion of macro ‘EXT4_COPY_XTIME’
> 771 | EXT4_COPY_XTIME(ctime, dst, tv_sec, tv_nsec);
> | ^~~~~~~~~~~~~~~
> convert/source-ext2.c:774:40: error: ‘i_crtime_extra’ undeclared (first use in this function)
> 774 | if (inode_includes(inode_size, i_crtime_extra)) {
> | ^~~~~~~~~~~~~~
> [LD] btrfs-select-super
> make: *** [Makefile:453: convert/source-ext2.o] Error 1
> --8<---------------cut here---------------end--------------->8---
>
> (I tested with “./pre-inst-env guix build -P1 e2fsprogs”.)
>
> Could you take a look?
Sure, while here I'm also updating it to its latest version, 6.13.
Thanks!
--
Ashish SHUKLA | GPG: F682 CDCC 39DC 0FEA E116 20B6 C746 CFA9 E74F A4B0
"If I destroy you, what business is it of yours ?" (Dark Forest, Liu Cixin)