[PATCH] gnu: emacs-next: Update to 30.0.93.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Arto Jantunen
Owner
unassigned
Submitted by
Arto Jantunen
Severity
normal

Debbugs page

Arto Jantunen wrote 3 months ago
(address . guix-patches@gnu.org)(name . Arto Jantunen)(address . viiru@iki.fi)
20241225065822.855774-1-viiru@iki.fi
Update to the latest pretest.
---
gnu/packages/emacs.scm | 38 ++++++++++++++++++--------------------
1 file changed, 18 insertions(+), 20 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c5b57211dd10..4784af2937f3 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -567,26 +567,24 @@ (define-public emacs-wide-int
#~(cons "--with-wide-int" #$flags))))))
(define-public emacs-next-minimal
- (let ((commit "881d593a9879f3355733f1b627af7cc0c12b429e")
- (revision "0"))
- (package
- (inherit emacs-minimal)
- (name "emacs-next-minimal")
- (version (git-version "30.0.92" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.savannah.gnu.org/git/emacs.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0nj3a7wsl5piqf6a8wnmfyjbpxp2dwl0r48flv9q624jx4nxfr2p"))
- (patches
- (search-patches "emacs-next-exec-path.patch"
- "emacs-fix-scheme-indent-function.patch"
- "emacs-next-native-comp-driver-options.patch"
- "emacs-pgtk-super-key-fix.patch")))))))
+ (package
+ (inherit emacs-minimal)
+ (name "emacs-next-minimal")
+ (version "30.0.93")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.savannah.gnu.org/git/emacs.git")
+ (commit (string-append "emacs-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05a587a7bnbz8ms45h4hs1c33j8268aymf3y1bpxipl3abi43jlm"))
+ (patches
+ (search-patches "emacs-next-exec-path.patch"
+ "emacs-fix-scheme-indent-function.patch"
+ "emacs-next-native-comp-driver-options.patch"
+ "emacs-pgtk-super-key-fix.patch"))))))
(define* (emacs->emacs-next emacs #:optional name
#:key (version (package-version emacs-next-minimal))

base-commit: eb6d784852dfcade2f5052c4d6fc1bd469f3cdb6
--
2.45.2
Arto Jantunen wrote 1 months ago
(address . 75081@debbugs.gnu.org)(name . Arto Jantunen)(address . viiru@iki.fi)
9b912d5abd7c903a9ddda5cc269429f5845cc4d3.1738307974.git.viiru@iki.fi
Update to the latest pretest.
---
gnu/packages/emacs.scm | 44 ++++++++++++++++++++----------------------
1 file changed, 21 insertions(+), 23 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c5e671c6a98f..78a4981e4103 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -573,29 +573,27 @@ (define-public emacs-wide-int
#~(cons "--with-wide-int" #$flags))))))
(define-public emacs-next-minimal
- (let ((commit "881d593a9879f3355733f1b627af7cc0c12b429e")
- (revision "0"))
- (package
- (inherit emacs-minimal)
- (name "emacs-next-minimal")
- (version (git-version "30.0.92" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.savannah.gnu.org/git/emacs.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0nj3a7wsl5piqf6a8wnmfyjbpxp2dwl0r48flv9q624jx4nxfr2p"))
- (patches
- (search-patches "emacs-disable-jit-compilation.patch"
- "emacs-next-exec-path.patch"
- "emacs-fix-scheme-indent-function.patch"
- "emacs-next-native-comp-driver-options.patch"
- "emacs-next-native-comp-fix-filenames.patch"
- "emacs-native-comp-pin-packages.patch"
- "emacs-pgtk-super-key-fix.patch")))))))
+ (package
+ (inherit emacs-minimal)
+ (name "emacs-next-minimal")
+ (version "30.0.93")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.savannah.gnu.org/git/emacs.git")
+ (commit (string-append "emacs-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05a587a7bnbz8ms45h4hs1c33j8268aymf3y1bpxipl3abi43jlm"))
+ (patches
+ (search-patches "emacs-disable-jit-compilation.patch"
+ "emacs-next-exec-path.patch"
+ "emacs-fix-scheme-indent-function.patch"
+ "emacs-next-native-comp-driver-options.patch"
+ "emacs-next-native-comp-fix-filenames.patch"
+ "emacs-native-comp-pin-packages.patch"
+ "emacs-pgtk-super-key-fix.patch"))))))
(define* (emacs->emacs-next emacs #:optional name
#:key (version (package-version emacs-next-minimal))

base-commit: 4176f6c52f485549f829af048ef9a6726b52e112
--
2.39.5
Liliana Marie Prikler wrote 1 months ago
(name . Arto Jantunen)(address . viiru@iki.fi)(address . 75081@debbugs.gnu.org)(address . cox.katherine.e+guix@gmail.com)(address . ian@retrospec.tv)(address . divya@subvertising.org)(address . andrew@trop.in)
d62a9b7283709ccc7f6c8ed4bc03e57362c77979.camel@gmail.com
Am Freitag, dem 31.01.2025 um 09:20 +0200 schrieb Arto Jantunen:
Toggle quote (2 lines)
> Update to the latest pretest.
> ---
There should be a ChangeLog.

Toggle quote (41 lines)
>  gnu/packages/emacs.scm | 44 ++++++++++++++++++++--------------------
> --
>  1 file changed, 21 insertions(+), 23 deletions(-)
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index c5e671c6a98f..78a4981e4103 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -573,29 +573,27 @@ (define-public emacs-wide-int
>          #~(cons "--with-wide-int" #$flags))))))
>  
>  (define-public emacs-next-minimal
> -  (let ((commit "881d593a9879f3355733f1b627af7cc0c12b429e")
> -        (revision "0"))
> -   (package
> -    (inherit emacs-minimal)
> -    (name "emacs-next-minimal")
> -    (version (git-version "30.0.92" revision commit))
> -    (source
> -     (origin
> -       (method git-fetch)
> -       (uri (git-reference
> -             (url "https://git.savannah.gnu.org/git/emacs.git")
> -             (commit commit)))
> -       (file-name (git-file-name name version))
> -       (sha256
> -        (base32
> "0nj3a7wsl5piqf6a8wnmfyjbpxp2dwl0r48flv9q624jx4nxfr2p"))
> -       (patches
> -        (search-patches "emacs-disable-jit-compilation.patch"
> -                        "emacs-next-exec-path.patch"
> -                        "emacs-fix-scheme-indent-function.patch"
> -                        "emacs-next-native-comp-driver-
> options.patch"
> -                        "emacs-next-native-comp-fix-filenames.patch"
> -                        "emacs-native-comp-pin-packages.patch"
> -                        "emacs-pgtk-super-key-fix.patch")))))))
> +  (package
> +   (inherit emacs-minimal)
> +   (name "emacs-next-minimal")
> +   (version "30.0.93")
Do keep git-version for emacs-next, because we "regularly" update it
using non-tagged releases. Keep using "0" for the revision.
Toggle quote (19 lines)
> +   (source
> +    (origin
> +     (method git-fetch)
> +     (uri (git-reference
> +           (url "https://git.savannah.gnu.org/git/emacs.git")
> +           (commit (string-append "emacs-" version))))
> +     (file-name (git-file-name name version))
> +     (sha256
> +      (base32
> "05a587a7bnbz8ms45h4hs1c33j8268aymf3y1bpxipl3abi43jlm"))
> +     (patches
> +      (search-patches "emacs-disable-jit-compilation.patch"
> +                      "emacs-next-exec-path.patch"
> +                      "emacs-fix-scheme-indent-function.patch"
> +                      "emacs-next-native-comp-driver-options.patch"
> +                      "emacs-next-native-comp-fix-filenames.patch"
> +                      "emacs-native-comp-pin-packages.patch"
> +                      "emacs-pgtk-super-key-fix.patch"))))))

Cheers
Liliana Marie Prikler wrote 1 months ago
(name . Arto Jantunen)(address . viiru@iki.fi)(address . cox.katherine.e+guix@gmail.com)(address . ian@retrospec.tv)(address . divya@subvertising.org)(address . 75081@debbugs.gnu.org)(address . andrew@trop.in)
b28f206d058813a2704c656cff1f4a5391dcf8bc.camel@gmail.com
Am Freitag, dem 31.01.2025 um 11:50 +0200 schrieb Arto Jantunen:
Toggle quote (12 lines)
>
> Thanks for the very timely review.
>
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> > Am Freitag, dem 31.01.2025 um 09:20 +0200 schrieb Arto Jantunen:
> > > Update to the latest pretest.
> > > ---
> > There should be a ChangeLog.
>
> I looked at previously applied patches to find a hint about what this
> might look like, but couldn't find anything. Would you have a
> documentation reference or an example I could follow?
This example is so common that we have snippets for them :)
However, said snippet assumes you're only doing an update, which in
this v1 at least, you don't.

Toggle quote (51 lines)
> > >  gnu/packages/emacs.scm | 44 ++++++++++++++++++++----------------
> > > ----
> > > --
> > >  1 file changed, 21 insertions(+), 23 deletions(-)
> > >
> > > diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> > > index c5e671c6a98f..78a4981e4103 100644
> > > --- a/gnu/packages/emacs.scm
> > > +++ b/gnu/packages/emacs.scm
> > > @@ -573,29 +573,27 @@ (define-public emacs-wide-int
> > >          #~(cons "--with-wide-int" #$flags))))))
> > >  
> > >  (define-public emacs-next-minimal
> > > -  (let ((commit "881d593a9879f3355733f1b627af7cc0c12b429e")
> > > -        (revision "0"))
> > > -   (package
> > > -    (inherit emacs-minimal)
> > > -    (name "emacs-next-minimal")
> > > -    (version (git-version "30.0.92" revision commit))
> > > -    (source
> > > -     (origin
> > > -       (method git-fetch)
> > > -       (uri (git-reference
> > > -             (url "https://git.savannah.gnu.org/git/emacs.git")
> > > -             (commit commit)))
> > > -       (file-name (git-file-name name version))
> > > -       (sha256
> > > -        (base32
> > > "0nj3a7wsl5piqf6a8wnmfyjbpxp2dwl0r48flv9q624jx4nxfr2p"))
> > > -       (patches
> > > -        (search-patches "emacs-disable-jit-compilation.patch"
> > > -                        "emacs-next-exec-path.patch"
> > > -                        "emacs-fix-scheme-indent-function.patch"
> > > -                        "emacs-next-native-comp-driver-
> > > options.patch"
> > > -                        "emacs-next-native-comp-fix-
> > > filenames.patch"
> > > -                        "emacs-native-comp-pin-packages.patch"
> > > -                        "emacs-pgtk-super-key-fix.patch")))))))
> > > +  (package
> > > +   (inherit emacs-minimal)
> > > +   (name "emacs-next-minimal")
> > > +   (version "30.0.93")
> > Do keep git-version for emacs-next, because we "regularly" update
> > it
> > using non-tagged releases.  Keep using "0" for the revision.
>
> I was thinking the versioning would revert back to git-version after
> Emacs 30 is released and emacs-next returns to git snapshots. Using
> it for tagged releases doesn't look quite right to my (untrained)
> eye.
Fair enough, but the point is to reduce the noise when that happens in
either direction. Note that the current source should point at 30.0.92
exactly.

Cheers
Arto Jantunen wrote 1 months ago
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . cox.katherine.e+guix@gmail.com)(address . ian@retrospec.tv)(address . divya@subvertising.org)(address . 75081@debbugs.gnu.org)(address . andrew@trop.in)
87bjvncnwj.fsf@iki.fi
Thanks for the very timely review.
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
Toggle quote (4 lines)
> Am Freitag, dem 31.01.2025 um 09:20 +0200 schrieb Arto Jantunen:
>> Update to the latest pretest.
>> ---
> There should be a ChangeLog.
I looked at previously applied patches to find a hint about what this
might look like, but couldn't find anything. Would you have a
documentation reference or an example I could follow?
Toggle quote (43 lines)
>>  gnu/packages/emacs.scm | 44 ++++++++++++++++++++--------------------
>> --
>>  1 file changed, 21 insertions(+), 23 deletions(-)
>>
>> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
>> index c5e671c6a98f..78a4981e4103 100644
>> --- a/gnu/packages/emacs.scm
>> +++ b/gnu/packages/emacs.scm
>> @@ -573,29 +573,27 @@ (define-public emacs-wide-int
>>          #~(cons "--with-wide-int" #$flags))))))
>>  
>>  (define-public emacs-next-minimal
>> -  (let ((commit "881d593a9879f3355733f1b627af7cc0c12b429e")
>> -        (revision "0"))
>> -   (package
>> -    (inherit emacs-minimal)
>> -    (name "emacs-next-minimal")
>> -    (version (git-version "30.0.92" revision commit))
>> -    (source
>> -     (origin
>> -       (method git-fetch)
>> -       (uri (git-reference
>> -             (url "https://git.savannah.gnu.org/git/emacs.git")
>> -             (commit commit)))
>> -       (file-name (git-file-name name version))
>> -       (sha256
>> -        (base32
>> "0nj3a7wsl5piqf6a8wnmfyjbpxp2dwl0r48flv9q624jx4nxfr2p"))
>> -       (patches
>> -        (search-patches "emacs-disable-jit-compilation.patch"
>> -                        "emacs-next-exec-path.patch"
>> -                        "emacs-fix-scheme-indent-function.patch"
>> -                        "emacs-next-native-comp-driver-
>> options.patch"
>> -                        "emacs-next-native-comp-fix-filenames.patch"
>> -                        "emacs-native-comp-pin-packages.patch"
>> -                        "emacs-pgtk-super-key-fix.patch")))))))
>> +  (package
>> +   (inherit emacs-minimal)
>> +   (name "emacs-next-minimal")
>> +   (version "30.0.93")
> Do keep git-version for emacs-next, because we "regularly" update it
> using non-tagged releases. Keep using "0" for the revision.
I was thinking the versioning would revert back to git-version after
Emacs 30 is released and emacs-next returns to git snapshots. Using it
for tagged releases doesn't look quite right to my (untrained) eye.
Toggle quote (20 lines)
>> +   (source
>> +    (origin
>> +     (method git-fetch)
>> +     (uri (git-reference
>> +           (url "https://git.savannah.gnu.org/git/emacs.git")
>> +           (commit (string-append "emacs-" version))))
>> +     (file-name (git-file-name name version))
>> +     (sha256
>> +      (base32
>> "05a587a7bnbz8ms45h4hs1c33j8268aymf3y1bpxipl3abi43jlm"))
>> +     (patches
>> +      (search-patches "emacs-disable-jit-compilation.patch"
>> +                      "emacs-next-exec-path.patch"
>> +                      "emacs-fix-scheme-indent-function.patch"
>> +                      "emacs-next-native-comp-driver-options.patch"
>> +                      "emacs-next-native-comp-fix-filenames.patch"
>> +                      "emacs-native-comp-pin-packages.patch"
>> +                      "emacs-pgtk-super-key-fix.patch"))))))
>
> Cheers
--
Arto Jantunen
Arto Jantunen wrote 1 months ago
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . cox.katherine.e+guix@gmail.com)(address . ian@retrospec.tv)(address . divya@subvertising.org)(address . 75081@debbugs.gnu.org)(address . andrew@trop.in)
877c6bchki.fsf@iki.fi
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
Toggle quote (17 lines)
> Am Freitag, dem 31.01.2025 um 11:50 +0200 schrieb Arto Jantunen:
>>
>> Thanks for the very timely review.
>>
>> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>> > Am Freitag, dem 31.01.2025 um 09:20 +0200 schrieb Arto Jantunen:
>> > > Update to the latest pretest.
>> > > ---
>> > There should be a ChangeLog.
>>
>> I looked at previously applied patches to find a hint about what this
>> might look like, but couldn't find anything. Would you have a
>> documentation reference or an example I could follow?
> This example is so common that we have snippets for them :)
> However, said snippet assumes you're only doing an update, which in
> this v1 at least, you don't.

If you prefer, the minimal-change version looks like this:
From 93f9a86eddf1ac24be9de1891d653d98cff65f43 Mon Sep 17 00:00:00 2001
Message-Id: <93f9a86eddf1ac24be9de1891d653d98cff65f43.1738325020.git.viiru@iki.fi>
From: Arto Jantunen <viiru@iki.fi>
Date: Fri, 31 Jan 2025 13:52:03 +0200
Subject: [PATCH] gnu: emacs-next: Update to 30.0.93-0.68bcabf.

Change-Id: I42ed2626b01c72c6f35a0de74afd317d2a9f6ed8
---
gnu/packages/emacs.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c5e671c6a98f..9a33cb2107db 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -573,12 +573,12 @@ (define-public emacs-wide-int
#~(cons "--with-wide-int" #$flags))))))
(define-public emacs-next-minimal
- (let ((commit "881d593a9879f3355733f1b627af7cc0c12b429e")
+ (let ((commit "68bcabf58afddb377d172857ce7648ad3ff09618")
(revision "0"))
(package
(inherit emacs-minimal)
(name "emacs-next-minimal")
- (version (git-version "30.0.92" revision commit))
+ (version (git-version "30.0.93" revision commit))
(source
(origin
(method git-fetch)
@@ -587,7 +587,7 @@ (define-public emacs-next-minimal
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "0nj3a7wsl5piqf6a8wnmfyjbpxp2dwl0r48flv9q624jx4nxfr2p"))
+ (base32 "05a587a7bnbz8ms45h4hs1c33j8268aymf3y1bpxipl3abi43jlm"))
(patches
(search-patches "emacs-disable-jit-compilation.patch"
"emacs-next-exec-path.patch"

base-commit: bdd6760b8c46e59f86415d67981acb6f77e9ed22
--
2.39.5
My feelings for which is the correct way to do this aren't all that
strong, all I really want is to have the current version of Emacs 30
available (who doesn't like a less buggy Emacs?)..

--
Arto Jantunen
Arto Jantunen wrote 3 weeks ago
Superseded
(address . 75081-done@debbugs.gnu.org)
87y0xzh1ix.fsf@iki.fi
No point in updating to the third pre-release now that the first RC is
out and we are moments away from the final release on 30.1.

--
Arto Jantunen
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75081@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75081
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help