[PATCH 0/2] gnu: stargate: Fix inputs and paths.

  • Open
  • quality assurance status badge
Details
One participant
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal

Debbugs page

Sughosha wrote 3 months ago
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
cover.1733561303.git.sughosha@disroot.org
Sughosha (2):
gnu: stargate: Fix finding portmidi.
gnu: stargate: Add python-distro to inputs.

gnu/packages/music.scm | 12 ++++++++----
1 file changed, 8 insertions(+), 4 deletions(-)


base-commit: 369d2698b0bfc3726f8e6d232d43d0dda832225f
--
2.46.0
Sughosha wrote 3 months ago
[PATCH 1/2] gnu: stargate: Fix finding portmidi.
(address . 74724@debbugs.gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
0703ebdd3123bb76d05252b4aaf694b16817b892.1733561303.git.sughosha@disroot.org
* gnu/packages/music.scm (stargate)[inputs]: Replace portmidi with
portmidi-2.
[arguments]<#:phases>: Replace patch-portaudio-path with
patch-portaudio-and-portmidi-paths.

Change-Id: Icd5dbe154d2f8cdb9a18006b03ce74ea73d328d4
---
gnu/packages/music.scm | 11 +++++++----
1 file changed, 7 insertions(+), 4 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index cd9cdbdacd..c7f5063107 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5282,13 +5282,16 @@ (define-public stargate
(string-append "CXX=" #$(cxx-for-target)))
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'patch-portaudio-path
+ (add-after 'unpack 'patch-portaudio-and-portmidi-paths
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/sgui/widgets/hardware_dialog.py"
(("\\\"libportaudio")
(string-append "\"" (assoc-ref inputs "portaudio")
- "/lib/libportaudio")))))
- (add-after 'patch-portaudio-path 'change-directory
+ "/lib/libportaudio"))
+ (("'libportmidi")
+ (string-append "'" (assoc-ref inputs "portmidi")
+ "/lib/libportmidi")))))
+ (add-after 'patch-portaudio-and-portmidi-paths 'change-directory
(lambda _
(chdir "src")))
(delete 'configure) ;no configure script
@@ -5335,7 +5338,7 @@ (define-public stargate
jq
libsndfile
portaudio
- portmidi
+ portmidi-2
python
python-jinja2
python-mido
--
2.46.0
Sughosha wrote 3 months ago
[PATCH 2/2] gnu: stargate: Add python-distro to inputs.
(address . 74724@debbugs.gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
558761e6d556947417c003ebb873fa57b42f8d6a.1733561303.git.sughosha@disroot.org
* gnu/packages/music.scm (stargate)[inputs]: Add python-distro.

Change-Id: I5558767835fd9a5d9fbe0742f9c6c22b033941f0
---
gnu/packages/music.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index c7f5063107..47e057a6d3 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5340,6 +5340,7 @@ (define-public stargate
portaudio
portmidi-2
python
+ python-distro
python-jinja2
python-mido
python-mutagen
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74724@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74724
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help