* gnu/packages/gnome.scm (gnome-shell): Update to 46.7.
[#:configure-flags]: Adjust accordingly.
[#:phases]<wrap-programs>: Likewise.
<unbreak-perf-tests>: Rename to…
<unbreak-shell-tests>: … this. Adjust accordingly.
---
Update since v1: Moved to 46.7. Found the broken tests and fixed them.
gnu/packages/gnome.scm | 21 +++++++--------------
1 file changed, 7 insertions(+), 14 deletions(-)
Toggle diff (72 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 565dcec6ab..f3f7da58d8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9467,7 +9467,7 @@ (define-public gnome-control-center
(define-public gnome-shell
(package
(name "gnome-shell")
- (version "44.10")
+ (version "46.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -9475,7 +9475,7 @@ (define-public gnome-shell
name "-" version ".tar.xz"))
(sha256
(base32
- "01pw9qnnvh64x56z1gqh0qk6vfn0ihh4zijq23f4bpz9wszlbpwf"))))
+ "0n19160ab6chcnxmwwv4m0kfz856n7851dv4ck0p08mfp39wzwhw"))))
(build-system meson-build-system)
(arguments
(let ((disallowed-references
@@ -9490,8 +9490,7 @@ (define-public gnome-shell
#~(list "-Dsystemd=false"
;; Otherwise, the RUNPATH will lack the final path component.
(string-append "-Dc_link_args=-Wl,-rpath="
- #$output "/lib/gnome-shell")
- "-Dsoup2=false")
+ #$output "/lib/gnome-shell"))
#:modules '((guix build meson-build-system)
(guix build utils)
(ice-9 match)
@@ -9513,11 +9512,11 @@ (define-public gnome-shell
(substitute* "meson.build"
(("gtk_update_icon_cache: true")
"gtk_update_icon_cache: false"))))
- (add-after 'unpack 'unbreak-perf-tests
+ (add-after 'unpack 'unbreak-shell-tests
(lambda _
;; Lest non-fatal dbus warnings be made fatal again…
(substitute* "tests/meson.build"
- (("perf_testenv\\.set\\('G_DEBUG'" all)
+ (("shell_testenv\\.set\\('G_DEBUG'" all)
(string-append "# " all)))))
(add-before 'configure 'record-absolute-file-names
(lambda* (#:key inputs #:allow-other-keys)
@@ -9557,7 +9556,7 @@ (define-public gnome-shell
(lambda (prog)
(wrap-program (string-append #$output "/bin/" prog)
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
- '("gnome-shell" "gnome-extensions-app"))
+ '("gnome-shell" "gnome-extensions" "gnome-extensions-app"))
(substitute* (string-append #$output "/share/gnome-shell/"
"org.gnome.Shell.Extensions")
(("imports\\.package\\.start" all)
@@ -9577,13 +9576,7 @@ (define-public gnome-shell
"[imports.gi.GLib.getenv('GST_PLUGIN_SYSTEM_PATH'),"
"'" gst-plugin-path "'].filter(v => v).join(':'),"
"true);\n"
- all)))
- (for-each
- (lambda (prog)
- (wrap-program (string-append #$output "/bin/" prog)
- `("GUIX_PYTHONPATH" ":" prefix (,python-path))
- `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
- '("gnome-shell-perf-tool")))))
+ all))))))
(add-after 'install 'rewire
(lambda* (#:key inputs #:allow-other-keys)
(for-each
--
2.46.0