[PATCH 0/3] Update clinguin to 2.1.1

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 29 Nov 10:44 +0100
(address . guix-patches@gnu.org)
cover.1732873441.git.liliana.prikler@gmail.com
Time flies in Python.
When I initially packaged clinguin, it used to be a prerelease, now we
have 2.1.1. I tested this on one of their examples, and it works™.

Liliana Marie Prikler (3):
gnu: Add python-clingexplaid.
gnu: python-clinguin: Fix homepage.
gnu: python-clinguin: Update to 2.1.1.

gnu/packages/potassco.scm | 44 +++++++++++++++++++++++++++++++++++----
1 file changed, 40 insertions(+), 4 deletions(-)


base-commit: f8979b4bcc8772d02640f6f665b4195380d57df9
--
2.46.0
L
L
Liliana Marie Prikler wrote on 29 Nov 09:51 +0100
[PATCH 2/3] gnu: python-clinguin: Fix homepage.
(address . 74601@debbugs.gnu.org)
0ff1e6c9886efd1c0e5c4dc2a2667a780b99d987.1732873441.git.liliana.prikler@gmail.com
* gnu/packages/potassco.scm (python-clinguin)[home-page]: Use
---
gnu/packages/potassco.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index 57caf6aabc..a421810067 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -726,7 +726,7 @@ (define-public python-clinguin
python-sphinx-rtd-theme
python-traitlets
python-uvicorn))
- (home-page "https://github.com/potassco/clingraph")
+ (home-page "https://github.com/potassco/clinguin")
(synopsis "Clingo-based interactive UI")
(description "Clinguin is a graphical user interface toolkit for clingo,
which allows user interfaces to be specified entirely as a logic program.")
--
2.46.0
L
L
Liliana Marie Prikler wrote on 29 Nov 09:52 +0100
[PATCH 3/3] gnu: python-clinguin: Update to 2.1.1.
(address . 74601@debbugs.gnu.org)
142bc6d977cfd1a5f3c2bffad0a24fba91b7a5fd.1732873441.git.liliana.prikler@gmail.com
* gnu/packages/potassco.scm (python-clinguin): Update to 2.1.1.
[source]: Adjust snippet accordingly.
[inputs]: Add python-clingo-dl and python-clingexplaid.
---
gnu/packages/potassco.scm | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index a421810067..c5d00c9b1c 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -690,7 +690,7 @@ (define-public python-clingraph
(define-public python-clinguin
(package
(name "python-clinguin")
- (version "1.0.0-beta")
+ (version "2.1.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -699,7 +699,7 @@ (define-public python-clinguin
(file-name (git-file-name name version))
(sha256
(base32
- "032fnzxv6wl01sdq7n2k0ikajpmkg8ihjh5mck1mwjvmis8z16d4"))
+ "0wfgrs8h5i5mmd5sbzca2xw57f3d3ni75775wjkaq6sg0zm9sqjs"))
(modules '((guix build utils)))
(snippet
#~(begin
@@ -708,11 +708,14 @@ (define-public python-clinguin
;; some typo squatter hosted
;; a package named tk
(("tk") "")
- (("typing") "typing;python_version<\"3.5\""))))))
+ ;; XXX: python-clingo-dl installs clingodl instead…
+ (("clingo-dl") "clingodl"))))))
(build-system pyproject-build-system)
(propagated-inputs
(list python-clingo
+ python-clingo-dl
python-clorm
+ python-clingexplaid
python-clingraph
python-fastapi
python-httpx
--
2.46.0
L
L
Liliana Marie Prikler wrote on 29 Nov 08:31 +0100
[PATCH 1/3] gnu: Add python-clingexplaid.
(address . 74601@debbugs.gnu.org)
be5daaf9cc11ca952517d482025419407553054b.1732873441.git.liliana.prikler@gmail.com
* gnu/packages/potassco.scm (python-clingexplaid): New variable.
---
gnu/packages/potassco.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index ec990f1382..57caf6aabc 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -756,3 +756,36 @@ (define-public python-clintest
outcome while solving to abort the search for solutions once the outcome is
certain.")
(license license:expat)))
+
+(define-public python-clingexplaid
+ (package
+ (name "python-clingexplaid")
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/potassco/clingo-explaid")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1s80cs3clvz26r7cvjprlk6zip7yqswwhzzwmmrv5mf5p89ymrgm"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:test-flags #~(list "-k" "not test_main")
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-pyproject-toml
+ (lambda _
+ (substitute* "pyproject.toml"
+ (("dynamic = .*" all)
+ (string-append "version = \""
+ #$version
+ "\"\n"))
+ (("\"autoflake\",") "")))))))
+ (propagated-inputs (list python-clingo))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/potassco/clingo-explaid")
+ (synopsis "Develop explanation systems with Clingo")
+ (description "This package provides tools to develop explanation systems
+with clingo. It allows extracting minimal unsatisfiable subsets and
+unsatisfiable constraints.")
+ (license license:expat)))
--
2.46.0
S
S
Sharlatan Hellseher wrote on 30 Nov 21:08 +0100
[PATCH 0/3] Update clinguin to 2.1.1
(address . 74601@debbugs.gnu.org)
878qt0pjrr.fsf@gmail.com
Hi,

The series looks nice and LGFM for me

One pick on this:
Toggle snippet (2 lines)
+ (list #:test-flags #~(list "-k" "not test_main")
May you provide a comment why it's deselected?

tests and set version, so you may reduce package complexity if you pull
from there, no need to adjust version in pyproject.toml.

--
Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmdLcKgACgkQdtcnv/Ys
0rV51BAAiJs4kx/mBkAK/MQ+XH7cvQ/WCPrIAqpQXJolIYgogcruG1vLtzqH0BZ1
REXQvXoQyBIga7Bd3u65AnSMh1dTfdU0Fj0/BpqCjDlZSrtRAwkUn9LRLGtaD4Z+
LTD8plvGTCJg7vbXJTLPkFO7AHfR4HeQ6v89yc31SBXPnfANzmNcfQ4wL9jXdujK
nNS3nINudVhPDrC0rWouMOh4DI0ECZHhEuW+JtPlKHlIPeRvqR33i5HKzYspGIXh
x3TEik/V9wEJrUtGn++oL4tP+J81MouEgP5k61LTSHyDpgoPiO1c7F3W60bKjYVx
lz9Bd54GcfQtxxnaWurhqGOndDAX9duZyNnZOJe7zWJpmcwmqWudF1b7a/yRx+xb
e2Dq8y2TZE5H8SM5J7zpv38inUk5BjeOWZoY3+g4l6tCROpGaMrLQwP+GEWhN7Zj
8JRWYDZQBLL9XYwzEIlDfuNenFZHKbQWmkr1d2hqm9/sgEFs4HWQ8Tx3aDgYBLro
QYxyBwn0fE5WVd6ke7ETBQvFDHjkUwE6/yLU8r+dVEd61LyCFEwlf9tB3bFcfDZD
4oDiU1SpHAib3hOupMFXTBEdHy1INXRM948xjetyO7Uhpz1fxuFM42eW/WCoeWUW
73bD/U1jyusV2HeOWJekCNf+pQfTiai3Gn5VlbjRvutvRFhnP3U=
=31hp
-----END PGP SIGNATURE-----

L
L
Liliana Marie Prikler wrote 5 days ago
Re: [PATCH 3/3] gnu: python-clinguin: Update to 2.1.1.
(address . 74601-done@debbugs.gnu.org)
87f2933e7d33252b3a2c0d9c510dce4ac3ec434b.camel@gmail.com
Am Freitag, dem 29.11.2024 um 09:52 +0100 schrieb Liliana Marie
Prikler:
Toggle quote (4 lines)
> * gnu/packages/potassco.scm (python-clinguin): Update to 2.1.1.
> [source]: Adjust snippet accordingly.
> [inputs]: Add python-clingo-dl and python-clingexplaid.
> ---
Pushed as a4bdae0f4787a0b7247f7f83d3e73aaae429604a.
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74601@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74601
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch