[PATCH] add scenefx

  • Open
  • quality assurance status badge
Details
2 participants
  • Josep Bigorra
  • Zheng Junjie
Owner
unassigned
Submitted by
Josep Bigorra
Severity
normal
J
J
Josep Bigorra wrote 42 hours ago
(address . guix-patches@gnu.org)
CAM_04A2kE9tS8FNMWgnADmPDuEEiYutVHwhk6X7T6VqWu+bO5A@mail.gmail.com
This is my first attempt to contribute! :) I want to update Swayfx to 0.4
after this, but first, scenefx must be in guix packages. Hopefully this
will do?
Attachment: file
Z
Z
Zheng Junjie wrote 7 hours ago
(name . Josep Bigorra)(address . jjbigorra@gmail.com)(address . 74568@debbugs.gnu.org)
87a5div16s.fsf@iscas.ac.cn
Josep Bigorra <jjbigorra@gmail.com> writes:

Toggle quote (6 lines)
> This is my first attempt to contribute! :) I want to update Swayfx to 0.4 after this, but first, scenefx must be in
> guix packages. Hopefully this will do?
>
> [4. text/x-patch; 0001-added-scenefx-to-Guix-packages.patch]...
>
> [5. text/x-patch; 0002-formatting.patch]...
From ae1ce49f82544ad2a8e48624072fc00f8989586b Mon Sep 17 00:00:00 2001
Message-ID: <ae1ce49f82544ad2a8e48624072fc00f8989586b.1732872470.git.zhengjunjie@iscas.ac.cn>
From: Josep Bigorra <jjbigorra@gmail.com>
Date: Wed, 27 Nov 2024 22:30:54 +0100
Subject: [PATCH] gnu: Add scenefx.

* gnu/packages/wm.scm (scenefx): New variable.

Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Change-Id: Ia91747cbec59226a83a020b5fedbfd99886c35df
---
gnu/packages/wm.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 921f9750378..2ab6f88cd5b 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -76,6 +76,7 @@
;;; Copyright © 2024 dan <i@dan.games>
;;; Copyright © 2024 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
+;;; Copyright © 2024 Josep Bigorra <jjbigorra@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3969,3 +3970,32 @@ (define-public wf-config
configuration files of Wayifre. It can set key and mouse bindings,
configure input, and customize Wayfire plugins.")
(license license:expat)))
+
+(define-public scenefx
+ (package
+ (name "scenefx")
+ (version "0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wlrfx/scenefx")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1r7f8bprsn0mwlkmc8d14nr3iibljfyxypb4i06v66ghlngaw6dw"))))
+ (build-system meson-build-system)
+ (native-inputs (list pkg-config
+ ;; for wayland-scanner.
+ wayland))
+ (inputs (list pixman
+ mesa
+ libxkbcommon
+ libdrm
+ wlroots-0.17))
+ (home-page "https://github.com/wlrfx/scenefx")
+ (synopsis "Drop-in replacement for the wlroots scene API")
+ (description
+ "A drop-in replacement for the wlroots scene API that allows wayland
+compositors to render surfaces with eye-candy effects.")
+ (license license:expat)))

base-commit: c5421392081944d43db18fe04eafecec521f994a
prerequisite-patch-id: 87446432571a7ef03b5b1c5a831298c21b1b28a8
prerequisite-patch-id: fed79dd6ff68c92729413fc125b19314aa1bc3c4
--
2.46.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmdJiTsACgkQO1qpk+Gi
3/AbShAAqpdH+R4xKVnnnPmCU89niEwIfLs2k5Mz6pZRO63RBbUoVhBAwahnhJT5
FFYg2U8NgRFMhpULt2M9s82UgxpV9L10BweylGMS7KD4PTTabWLIEzoCA5KSyN3y
zXQ0FT7H7ixTwvU4DkOMKJW5CdZCYS27s2s3clWY4KEm26i72CcGuFNBPJ3i9EO2
TK4Vt4rOmhMCw0tcEaEufQPaN40aAKTQ1HqxwnRRo3V1pjxhLCcLP4q4XRPZoCwW
m9ckXJiBrll9y93yUAt5pVhksV7hUdDxaI8AUr/6L7mZ84+ZAN9ihgjVaeBc0OAx
LXAcIsT/bU3kP0UItYBD887Yr7GDarA8te6Na9ozZPggHt7wgUkwu/KusPoT3DzY
dAXmz/XmcWcLfslUHA8wXlR8sdcDaFeXNe3ldsddIEcgFdmyjGLo8fECHhect981
rUW+dXHnVxNmYJkNJO82NOCsWnwE51RDCqIom34gVJjSow2eyG9vuvctAfGwwNc0
5yLygqHnmgX4RRWyAF/agpUupqN9yo6XCe+MAhdxJVRZbJQEmXZbdRQwP55UatVp
FH4E8Pz94pYduzc8QN+CAIpSu3Zvah+ekFU9BsVvOjMJk1/7JO+8h9d5y1BapVTS
CPsQWoSXMalxr3SNmqNdOj5vgjx8aWyusT7oD9+Gm5DCcf9w9Kc=
=Ey9P
-----END PGP SIGNATURE-----

Z
Z
Zheng Junjie wrote 6 hours ago
(name . Josep Bigorra)(address . jjbigorra@gmail.com)(address . 74568@debbugs.gnu.org)
87plmetltv.fsf@iscas.ac.cn
Josep Bigorra <jjbigorra@gmail.com> writes:

Toggle quote (3 lines)
> This is my first attempt to contribute! :) I want to update Swayfx to 0.4 after this, but first, scenefx must be in guix packages. Hopefully
> this will do?

please use plain-txt e-mail. and use `mumi send-email' or
`git send-email' to send patch. see

Toggle quote (2 lines)
>- (name "sway")

If you do not modify the package, do not modify the indentation of the package

Toggle quote (16 lines)
>+ (inputs (map (lambda (x) (specification->package x))
>+ `("basu"
>+ "cairo"
>+ "gdk-pixbuf"
>+ "json-c"
>+ "cmake"
>+ "libevdev"
>+ "libinput-minimal"
>+ "libxkbcommon"
>+ "pcre2"
>+ "pkg-config"
>+ "pcre2"
>+ "wayland"
>+ "libdrm"
>+ "wlroots@0.17.4")))

You cannot use specification->package in a package, use the scheme
variable.

many package is not needed, just pixman mesa libxkbcommon libdrm
wlroots-0.17. see meson.build.

and pkg-config usually is native-inputs, It need to actually run on
cross-compiling.

Toggle quote (2 lines)
guix lint scenefx say scenefx@0.1: permanent redirect from https://github.com/wlrfx/scenefx.gitto https://github.com/wlrfx/scenefx.


Toggle quote (4 lines)
>+ (synopsis "SceneFX")
>+ (description
>+ "SceneFX")

Please write useful synopsis and description

After the completion of the modified like
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmdJjTwACgkQO1qpk+Gi
3/AtuA//UAGBOiPvhSGifazahpziZqKIcPiu/m3wpxMkH+tpgXgtlXO59SW58oUM
ZX5t+vM9Pi+DrKNKq0L9A/jjbeAblTus8yUNeUDjO9r9LOF5fXhk+2z6210ZzOTY
pGPOtCsM3s3BTGKB4LR9iEVKoOFTFg7c+MiN6qGbopxuHGRqJapSlqZ3cnqdngBI
NdO8P9UUAaaQwdoTUKAlylgsVQi9U1OasqVWTXTOMh+GTbfaPrkK0GeGN0sSpZrb
Jfgze9GWuJTNHSxKdzbUIGGUhb9yIpIyEop36yBaaww2eHpVK2ngR15+sH+qNRPo
XHJBTnofxYoZ0W9UEPOkqgxgK8DimFy9nK9q35XTHy5BqhkFtAtfn1ECryJLpgrp
GxP11D/lW328M6J5Wj212agjEv144iAI3X0f0yZI1rlmqjU7sMeEuJHd/qDSNv/7
os3ikRKWgRNB8+7BODT38A4BqhvJ6wNdI9U7hnkPMskQlp1myLBW43Q8BVTp5njW
W2wnE3dQD/g37bxDPXRuV1b6gx06ddtjGXO+FjXVV1xWddB1+2lRxFbpUW7hUD6R
R5or7UiCSxlDI2/tD+I+bDG/ghOFBSc52IacMmvz5BKAHUJIkt6dXRbZzj1XtYyj
w7DjwBY+G9ULuoqMunX/iMYKEGFyLb/c53/JFWL0hYOjAlBOod0=
=KyOC
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74568@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74568
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch