[PATCH] gnu: gdb: Update to 15.2.

  • Open
  • quality assurance status badge
Details
3 participants
  • Ashish SHUKLA
  • Greg Hogan
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ashish SHUKLA
Severity
normal
Blocked by
A
A
Ashish SHUKLA wrote on 3 Oct 16:23 +0200
(address . guix-patches@gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
b8682c03153e4e232f5d99bc20d276344af11e61.1727965437.git.ashish.is@lostca.se
* gnu/packages/gdb.scm (gdb-15): New variable.

Change-Id: I5c234c85b904a07e8b7d247e596cd2acf8f54536
---
gnu/packages/gdb.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 8fc2ec14a1..6146b104af 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -158,6 +158,19 @@ (define-public gdb-14
"0wkprsjyyh204fdjlkaz20k847l88i9y8m9zqsv15vcd3l3dhk9d"))))
(properties '())))
+(define-public gdb-15
+ (package
+ (inherit gdb/pinned)
+ (version "15.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gdb/gdb-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0k9i8mizg4hby020k53kqmc835pajh9c8d5klv5s1ddm6p6hqdc3"))))
+ (properties '())))
+
(define-public gdb
;; The "default" version.
gdb-14)

base-commit: 2f0644a8c024f589b9237e1d0fb1ce1025fa522f
--
2.46.2
G
G
Greg Hogan wrote on 3 Oct 21:36 +0200
(name . Ashish SHUKLA)(address . ashish.is@lostca.se)(address . 73615@debbugs.gnu.org)
CA+3U0Zna4ZjOZb2GFnaF=euOGAaedZjLyjM=OHkFZoVj2JAQwg@mail.gmail.com
On Thu, Oct 3, 2024 at 10:25?AM Ashish SHUKLA via Guix-patches via
<guix-patches@gnu.org> wrote:
Toggle quote (37 lines)
>
> * gnu/packages/gdb.scm (gdb-15): New variable.
>
> Change-Id: I5c234c85b904a07e8b7d247e596cd2acf8f54536
> ---
> gnu/packages/gdb.scm | 13 +++++++++++++
> 1 file changed, 13 insertions(+)
>
> diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
> index 8fc2ec14a1..6146b104af 100644
> --- a/gnu/packages/gdb.scm
> +++ b/gnu/packages/gdb.scm
> @@ -158,6 +158,19 @@ (define-public gdb-14
> "0wkprsjyyh204fdjlkaz20k847l88i9y8m9zqsv15vcd3l3dhk9d"))))
> (properties '())))
>
> +(define-public gdb-15
> + (package
> + (inherit gdb/pinned)
> + (version "15.2")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "mirror://gnu/gdb/gdb-"
> + version ".tar.xz"))
> + (sha256
> + (base32
> + "0k9i8mizg4hby020k53kqmc835pajh9c8d5klv5s1ddm6p6hqdc3"))))
> + (properties '())))
> +
> (define-public gdb
> ;; The "default" version.
> gdb-14)
>
> base-commit: 2f0644a8c024f589b9237e1d0fb1ce1025fa522f
> --
> 2.46.2

Hi Ashish,

The message summary "gnu: gdb: Update to 15.2." does not match the
patch, which leaves the default gdb as gdb-14.

Do we want to add gdb-15 or can we replace gdb-14 as was done
previously (updating gdb 12 to 14 in commit 75bad753)?

Greg
A
A
Ashish SHUKLA wrote on 4 Oct 00:04 +0200
(name . Greg Hogan)(address . code@greghogan.com)(address . 73615@debbugs.gnu.org)
D4MIF4H3H4S0.KKOES6KTGEKF@lostca.se
On Thu Oct 3, 2024 at 9:36 PM CEST, Greg Hogan wrote:
Toggle quote (47 lines)
> On Thu, Oct 3, 2024 at 10:25?AM Ashish SHUKLA via Guix-patches via
> <guix-patches@gnu.org> wrote:
> >
> > * gnu/packages/gdb.scm (gdb-15): New variable.
> >
> > Change-Id: I5c234c85b904a07e8b7d247e596cd2acf8f54536
> > ---
> > gnu/packages/gdb.scm | 13 +++++++++++++
> > 1 file changed, 13 insertions(+)
> >
> > diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
> > index 8fc2ec14a1..6146b104af 100644
> > --- a/gnu/packages/gdb.scm
> > +++ b/gnu/packages/gdb.scm
> > @@ -158,6 +158,19 @@ (define-public gdb-14
> > "0wkprsjyyh204fdjlkaz20k847l88i9y8m9zqsv15vcd3l3dhk9d"))))
> > (properties '())))
> >
> > +(define-public gdb-15
> > + (package
> > + (inherit gdb/pinned)
> > + (version "15.2")
> > + (source (origin
> > + (method url-fetch)
> > + (uri (string-append "mirror://gnu/gdb/gdb-"
> > + version ".tar.xz"))
> > + (sha256
> > + (base32
> > + "0k9i8mizg4hby020k53kqmc835pajh9c8d5klv5s1ddm6p6hqdc3"))))
> > + (properties '())))
> > +
> > (define-public gdb
> > ;; The "default" version.
> > gdb-14)
> >
> > base-commit: 2f0644a8c024f589b9237e1d0fb1ce1025fa522f
> > --
> > 2.46.2
>
> Hi Ashish,
>
> The message summary "gnu: gdb: Update to 15.2." does not match the
> patch, which leaves the default gdb as gdb-14.
>
> Do we want to add gdb-15 or can we replace gdb-14 as was done
> previously (updating gdb 12 to 14 in commit 75bad753)?

Hi Greg,

Thanks for reviewing the diff.

I agree the title of the diff is not quite accurate. Sorry about that.

I'm not sure the point of having an indirect reference, so this is why I
have not updated the `gdb' variable.

Let me know if it's needed. I can revise my commit then.

Thanks!
--
Ashish
-----BEGIN PGP SIGNATURE-----

iQKoBAABCgCSFiEE9oLNzDncD+rhFiC2x0bPqedPpLAFAmb/FOtfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldEY2
ODJDRENDMzlEQzBGRUFFMTE2MjBCNkM3NDZDRkE5RTc0RkE0QjAUHGFzaGlzaC5p
c0Bsb3N0Y2Euc2UACgkQx0bPqedPpLB5Gw//aCjCy6mQZr55F3gesJSOrQsfsvhB
6TsUDTThll+YOxe4PKApGnQbpbZtBScV9JEu/JYiGexDI58/iZQtH4h1WBBsEC//
USfa/HkRpbMANmI2v5dmijGcsDSrleUUP3bbwH7WN+1aLhlYWUKKyEgNLIo095mI
UYoC3OBx1sHQ0xFxwIZAz/39JyzaC4K8rXUStVb5pSWqu78TJkfD46QapesM+3EX
G6oa7o5pdKpvghV/KfBK8x9rnXILrQZWILITNtkQWxJ8B1+8KRh2bqhKa/Gq2UZ6
O83OAXO4jbgDInNWlXlDdqWhCVEMeuWt5w0E7gnd203ky85yGo1bN2DmPa6AwlAf
qk3nmNSg1rV0wCaa1j+ctxjBJJQihmORYQ4Q61pX/TCzAcW5gNtkSYYNshePOqn6
JH+eMzoXqs/Nv+Sgj9j7EdYDdEW8FODSBiQY9e0WNwi/jpvs1T/DZCrElvU8NzNI
Y9y2pE75cOqPDKtwhV9DDLigfUdectvs3RCf6VMWDE6CbkMzkfQdGUQ3Gj/TPwXv
m4kkM9toXX8mUkF4Uq8Tm4flfMENicfAULALLuJsKPax6+DdX7+gr6JhK64rhw1g
mHCYPnXm/60USuqxK7ryIV9LNVbPQyytkLazY3T/AO2lhMiR0biOZS/MGo+aDgtr
JGeERT6xUvOByi4=
=e3l2
-----END PGP SIGNATURE-----


G
G
Greg Hogan wrote on 6 Oct 13:05 +0200
(name . Ashish SHUKLA)(address . ashish.is@lostca.se)(address . 73615@debbugs.gnu.org)
CA+3U0Z=mJFUmjQaL0p5zaKvy8jke6zdHhDU4ac5meZVSHfSVyQ@mail.gmail.com
On Thu, Oct 3, 2024 at 6:04?PM Ashish SHUKLA <ashish.is@lostca.se> wrote:
Toggle quote (4 lines)
>
> I'm not sure the point of having an indirect reference, so this is why I
> have not updated the `gdb' variable.

Yes, that's a nice observation, if we only have one public choice then
why the default selector?

'guix refresh' shows gdb with 414 dependent packages. It would be
helpful if that partial dependency tree could be exported as in 'guix
graph' to better identity packages which could be pinned to reduce
that number. Even a simple option, means, or tool to filter out leaves
would greatly reduce the list.
L
L
Ludovic Courtès wrote on 24 Oct 14:49 +0200
(name . Greg Hogan)(address . code@greghogan.com)
87wmhx4qdr.fsf@gnu.org
Greg Hogan <code@greghogan.com> skribis:

Toggle quote (14 lines)
> On Thu, Oct 3, 2024 at 6:04?PM Ashish SHUKLA <ashish.is@lostca.se> wrote:
>>
>> I'm not sure the point of having an indirect reference, so this is why I
>> have not updated the `gdb' variable.
>
> Yes, that's a nice observation, if we only have one public choice then
> why the default selector?
>
> 'guix refresh' shows gdb with 414 dependent packages. It would be
> helpful if that partial dependency tree could be exported as in 'guix
> graph' to better identity packages which could be pinned to reduce
> that number. Even a simple option, means, or tool to filter out leaves
> would greatly reduce the list.


I’ll rebase that pydevd patch and eventually apply it.

Ludo’.
L
L
Ludovic Courtès wrote on 24 Oct 14:57 +0200
control message for bug #73615
(address . control@debbugs.gnu.org)
87r0854q1t.fsf@gnu.org
block 73615 by 70393
quit
L
L
Ludovic Courtès wrote on 30 Nov 17:19 +0100
Re: [bug#73615] [PATCH] gnu: gdb: Update to 15.2.
(name . Greg Hogan)(address . code@greghogan.com)
87frn8y9rm.fsf@gnu.org
Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (20 lines)
> Greg Hogan <code@greghogan.com> skribis:
>
>> On Thu, Oct 3, 2024 at 6:04?PM Ashish SHUKLA <ashish.is@lostca.se> wrote:
>>>
>>> I'm not sure the point of having an indirect reference, so this is why I
>>> have not updated the `gdb' variable.
>>
>> Yes, that's a nice observation, if we only have one public choice then
>> why the default selector?
>>
>> 'guix refresh' shows gdb with 414 dependent packages. It would be
>> helpful if that partial dependency tree could be exported as in 'guix
>> graph' to better identity packages which could be pinned to reduce
>> that number. Even a simple option, means, or tool to filter out leaves
>> would greatly reduce the list.
>
> See <https://issues.guix.gnu.org/70393>.
>
> I’ll rebase that pydevd patch and eventually apply it.

Done in 94bb6a5a88b17da1178fdc1d16cb87b9913bc1c1.

Should we (finally!) upgrade ‘gdb’ after renaming ‘gdb-14’ to ‘gdb’?

Ludo’.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73615@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73615
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch