[PATCH] gnu: Add mimeo-2023.

  • Open
  • quality assurance status badge
Details
One participant
  • Sisiutl
Owner
unassigned
Submitted by
Sisiutl
Severity
normal

Debbugs page

Sisiutl wrote 6 months ago
(address . guix-patches@gnu.org)(name . Sisiutl)(address . sisiutl@egregore.fun)
20240920213849.12111-1-sisiutl@egregore.fun
* gnu/packages/freedesktop.scm (mimeo): New variable.

Change-Id: If5267855462306532637096ad5943dcca4c9154e
---
gnu/packages/freedesktop.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index e9f6841f7c..b370cbca48 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1313,2 +1313,2 @@ (define-public python-pyxdg
Python.")
(license license:lgpl2.0)))

+(define-public mimeo
+ (package
+ (name "mimeo")
+ (version "2023")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://xyne.dev/projects/mimeo/src/mimeo-"
+ version ".tar.xz"))
+ (sha256
+ (base32 "1459kvnf96bvxxf5r8lg2lldm5ymfbdpdlriaj3mcivh595nza09"))))
+ (build-system python-build-system)
+ (home-page "https://xyne.dev/projects/mimeo/")
+ (synopsis
+ "This program opens files by MIME-type or file name using regular expressions")
+ (description
+ "Mimeo uses MIME-type file associations to determine which
+application should be used to open a file. It can launch files or print
+information such as the command that it would use, the detected MIME-type, etc.")
+ (native-inputs (list file python-pyxdg))
+ (license license:gpl3)))
+
(define-public wayland
(package
(name "wayland")
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73397@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73397
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help