[PATCH] fix: maven-surefire-plugin version parsing error

  • Open
  • quality assurance status badge
Details
One participant
  • Dr. Arne Babenhauserheide
Owner
unassigned
Submitted by
Dr. Arne Babenhauserheide
Severity
normal

Debbugs page

Dr. Arne Babenhauserheide wrote 6 months ago
(address . bug-guix@gnu.org)
87ldzrtx99.fsf@web.de
Hi,

maven-surefire-plugin could not be detected, because the version was
mis-replaced as 3.0.0-M4-M8 instead of 3.0.0-M4.

The fix is attached.
From ffc73708995a57101c7ce80ccdf3f3c66fb80c8d Mon Sep 17 00:00:00 2001
Message-ID: <ffc73708995a57101c7ce80ccdf3f3c66fb80c8d.1726501594.git.arne_bab@web.de>
From: Arne Babenhauserheide <arne_bab@web.de>
Date: Mon, 16 Sep 2024 17:46:07 +0200
Subject: [PATCH] gnu: maven: fix maven-surefire-plugin version parsing.

* gnu/packages/maven.scm (maven-core): cope with pattern maven-surefire-plugin:x.y.z-M8

Change-Id: Ib2bb2c7ddfc13da6e3d06535d9ac5d841f2d08be
---
gnu/packages/maven.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index 67b95a5f7b..bffeafed2c 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -1766,7 +1766,7 @@ (define-public maven-core
(("maven-compiler-plugin:[0-9.]+")
(string-append "maven-compiler-plugin:"
,(package-version maven-compiler-plugin)))
- (("maven-surefire-plugin:[0-9.]+")
+ (("maven-surefire-plugin:[0-9.M\\-]+") ;; i.e. 3.0.0-M4
(string-append "maven-surefire-plugin:"
,(package-version maven-surefire-plugin)))
(("maven-jar-plugin:[0-9.]+")

base-commit: 778dd796bff808f1f8520533bab239ecbe83cd87
prerequisite-patch-id: ce1c559ff080d2a116e5fefd876cb1b32570f977
prerequisite-patch-id: 088a72da8c11e5d1c7087b4a5e8bb9c4a3b9b2af
prerequisite-patch-id: a092dba2c994aba4c74f1484621cebe53f548492
prerequisite-patch-id: 09ee3fdfcc708aeec9e6a7a54e2993e857e19aca
prerequisite-patch-id: 7957383d6685c848a7cbfa78e930adeaf528a2e1
prerequisite-patch-id: aa5d5050c29bbacf33790ca89f8c2690337f3ac7
--
2.45.2
Best wishes,
Arne
--
Unpolitisch sein
heißt politisch sein,
ohne es zu merken.
draketo.de
-----BEGIN PGP SIGNATURE-----

iQJEBAEBCAAuFiEE801qEjXQSQPNItXAE++NRSQDw+sFAmboU2MQHGFybmVfYmFi
QHdlYi5kZQAKCRAT741FJAPD61WyD/9c/W/p9/cuUF8OaFDc5sselRDl52Nbbr6w
ubZQeo2QLI7XDVBXejMyX6wDUy9vN7aaAn8cdehLBIfzHLm+GxKyjargDtLk1zb6
GghwF+WqPNH7vUgLwjIOLaER8o13WYH6P4GrJs3/KanYo9N2l4ArDOPoot5IAHGX
kvZs8f8OfFVMFh70wW+XdORmp2znJh5zhjM6MyJuHe1wHsWkWl+LkkbNnzVZBEjt
riuQXthEOncFCOKmRjSuly2eq4vgtVwVd1DRE3Vv3GLpXUKTMxvb3LeqGlD8+nId
PiCvwugH8u22qXKMKZwHY1jcHE9d5ZTVOoO8KfIucAGA+CA2TrAGw4wJBQp7mqyQ
dhyIwdGLCA94LrcaoYg84ylvWAZfQGJMPTBM1j0pnZ7AKtxDHKGVBRTGBIeEG6Vr
vua9cWPVmIlf2bgzewQ9ldF1N44FG/l7W+1MT2t6fgSyKkYJ4p7AztKnb1vT4BQT
ayBEMVSRUAZ+zjAX8s28cAaRmRcGalpShX7WyWWZk5OvbfZelTiX3q63JL6Sp8pv
QtWbL7ie7ED/I/YH/NHVT7Eqpcg4rKbI8dAUOP3pN0FECAA31jsffRAcV0jwQlNB
gToHAVlRAj0n6C9srWWtjtP/ehPNmISK+9KGxlMvY3moj6aa9bnfO5zj6EJDxw7y
tOM9dgECIIjEBAEBCAAuFiEE3Si95tmHXKvOSosd3M8NswvBBUgFAmboU2MQHGFy
bmVfYmFiQHdlYi5kZQAKCRDczw2zC8EFSNmNA/9rA23bjMN4Ux0ct3MFaqPXf5HR
DZBgdSoqEspqCH7Ryeb4I/Wsy1V/SlANtMaAK+zZlyr8u7Jt6V+sa0P4AoBEjwEl
C0If3ImCSvm6KQcd+JEVetTJX8HPjtjPxUjdeOJ29QAHqwgjI8cp0SDIL3FTClOH
fQBa8js21N9Cd3AXsA==
=rib+
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73300@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73300
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help