[PATCH] home: services: dbus: Add utilities to profile.

  • Open
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Antero Mejr
  • Simon Streit
Owner
unassigned
Submitted by
Antero Mejr
Severity
normal

Debbugs page

Antero Mejr wrote 6 months ago
(address . guix-patches@gnu.org)(address . paren@disroot.org)(address . ludo@gnu.org)(address . tanguy@bioneland.org)(address . andrew@trop.in)
87zfo7r828.fsf@antr.me
* gnu/home/services/sound.scm (home-dbus-service-type)[extensions]:
Extend home-profile-service-type to add dbus-launch and other such
utilities to the home profile.

Change-Id: I9a3dc00d52b66c327f4eae523bddf758bddddb9e
---
gnu/home/services/desktop.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (20 lines)
diff --git a/gnu/home/services/desktop.scm b/gnu/home/services/desktop.scm
index 679ba31c0f..6d8ac275ca 100644
--- a/gnu/home/services/desktop.scm
+++ b/gnu/home/services/desktop.scm
@@ -327,7 +327,10 @@ (define home-dbus-service-type
(list (service-extension home-shepherd-service-type
home-dbus-shepherd-services)
(service-extension home-environment-variables-service-type
- home-dbus-environment-variables)))
+ home-dbus-environment-variables)
+ (service-extension home-profile-service-type
+ (lambda (config)
+ (list (home-dbus-dbus config))))))
(default-value (home-dbus-configuration))
(description
"Run the session-specific D-Bus inter-process message bus.")))

base-commit: ecc95ecd399ce7917a19ae3e687ea1a92caf830a
--
2.46.0
Antero Mejr wrote 6 months ago
[PATCH v2] home: services: dbus: Add utilities to profile.
(address . 73296@debbugs.gnu.org)(address . paren@disroot.org)(address . ludo@gnu.org)(address . tanguy@bioneland.org)(address . andrew@trop.in)
87setzr7ea.fsf_-_@antr.me
* gnu/home/services/desktop.scm (home-dbus-service-type)[extensions]:
Extend home-profile-service-type to add dbus-launch and other such
utilities to the home profile.

Change-Id: I9a3dc00d52b66c327f4eae523bddf758bddddb9e
---
Please ignore the last patch, it had a typo in the commit message.

gnu/home/services/desktop.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (20 lines)
diff --git a/gnu/home/services/desktop.scm b/gnu/home/services/desktop.scm
index 679ba31c0f..6d8ac275ca 100644
--- a/gnu/home/services/desktop.scm
+++ b/gnu/home/services/desktop.scm
@@ -327,7 +327,10 @@ (define home-dbus-service-type
(list (service-extension home-shepherd-service-type
home-dbus-shepherd-services)
(service-extension home-environment-variables-service-type
- home-dbus-environment-variables)))
+ home-dbus-environment-variables)
+ (service-extension home-profile-service-type
+ (lambda (config)
+ (list (home-dbus-dbus config))))))
(default-value (home-dbus-configuration))
(description
"Run the session-specific D-Bus inter-process message bus.")))

base-commit: ecc95ecd399ce7917a19ae3e687ea1a92caf830a
--
2.46.0
Ludovic Courtès wrote 6 months ago
(name . Antero Mejr)(address . mail@antr.me)(address . paren@disroot.org)(address . 73296@debbugs.gnu.org)(address . tanguy@bioneland.org)(address . andrew@trop.in)
87v7yc525y.fsf@gnu.org
Hello,

Antero Mejr <mail@antr.me> skribis:

Toggle quote (6 lines)
> * gnu/home/services/desktop.scm (home-dbus-service-type)[extensions]:
> Extend home-profile-service-type to add dbus-launch and other such
> utilities to the home profile.
>
> Change-Id: I9a3dc00d52b66c327f4eae523bddf758bddddb9e

I must say I don’t fully understand the use case of
‘home-dbus-service-type’ since usually the user’s dbus session is
started automatically, on demand (for example, spawning pulseaudio will
automatically start a dbus session if it’s not already running).

Often I find that for such services we don’t necessarily want to
“clutter” the user’s profile with low-level tools such as ‘dbus-launch’
in this case. But I’m not sure here.

Could you explain? What’s the point of ‘home-dbus-service-type’? :-)

Thanks,
Ludo’.
Simon Streit wrote 6 months ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(name . Antero Mejr)(address . mail@antr.me)(address . paren@disroot.org)(address . 73296@debbugs.gnu.org)(address . tanguy@bioneland.org)(address . andrew@trop.in)
ygu4j5vcwhq.fsf@netpanic.org
Hello!

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (19 lines)
> Antero Mejr <mail@antr.me> skribis:
>
>> * gnu/home/services/desktop.scm (home-dbus-service-type)[extensions]:
>> Extend home-profile-service-type to add dbus-launch and other such
>> utilities to the home profile.
>>
>> Change-Id: I9a3dc00d52b66c327f4eae523bddf758bddddb9e
>
> I must say I don’t fully understand the use case of
> ‘home-dbus-service-type’ since usually the user’s dbus session is
> started automatically, on demand (for example, spawning pulseaudio will
> automatically start a dbus session if it’s not already running).
>
> Often I find that for such services we don’t necessarily want to
> “clutter” the user’s profile with low-level tools such as ‘dbus-launch’
> in this case. But I’m not sure here.
>
> Could you explain? What’s the point of ‘home-dbus-service-type’? :-)

This is an interesting question that you are asking. For me, and the
first two years with Guix, I never had a proper running dbus session
when running, first with i3, and then with sway from there on. It would
work with GNOME. But I'd never hang around there for long and I learned
to live without dbus that would produce strange effects in strange
situations.

It only happened after I migrated to Guix Home and enabling
home-dbus-service-type that I finally had a fully functioning
environment with dbus. It solved so many problems since and I never
fully understood why I was missing dbus in the first place. It either
never either launched properly -- which I doubt, since applications like
pulseaudio where running --, or I had never sourced some variables
properly.

To answer your question: This service is quite the requirement to have a
desktop environment that is not based on the bigger variants that
usually provide it.


Kind regards

--
Simon
Ludovic Courtès wrote 4 months ago
(name . Simon Streit)(address . simon@netpanic.org)(name . Antero Mejr)(address . mail@antr.me)(address . paren@disroot.org)(address . 73296@debbugs.gnu.org)(address . tanguy@bioneland.org)(address . andrew@trop.in)
87y11hh5xv.fsf@gnu.org
Hi,

Simon Streit <simon@netpanic.org> skribis:

Toggle quote (21 lines)
>> Could you explain? What’s the point of ‘home-dbus-service-type’? :-)
>
> This is an interesting question that you are asking. For me, and the
> first two years with Guix, I never had a proper running dbus session
> when running, first with i3, and then with sway from there on. It would
> work with GNOME. But I'd never hang around there for long and I learned
> to live without dbus that would produce strange effects in strange
> situations.
>
> It only happened after I migrated to Guix Home and enabling
> home-dbus-service-type that I finally had a fully functioning
> environment with dbus. It solved so many problems since and I never
> fully understood why I was missing dbus in the first place. It either
> never either launched properly -- which I doubt, since applications like
> pulseaudio where running --, or I had never sourced some variables
> properly.
>
> To answer your question: This service is quite the requirement to have a
> desktop environment that is not based on the bigger variants that
> usually provide it.

OK, interesting. I’m not using it and not noticing problems (or did I
get used to the D-Bus class of problems?).

Thanks for your reply,
Ludo’.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73296@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73296
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help