* gnu/packages/image.scm (libsixel)[source]: Fix bash completion.
Reported-By: elaexuotee@wilsonb.com
Reported-by: Einar Largenius <einar.largenius@gmail.com>
Change-Id: I7e30bfa4ad6efcf27b2e89a42c34802b53bd30e0
---
Does this patch fix the issue?
gnu/packages/image.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
Toggle diff (25 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 7337a27b88..0367c08994 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -2831,7 +2831,12 @@ (define-public libsixel
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1nny4295ipy4ajcxmmh04c796hcds0y7z7rv3qd17mj70y8j0r2d"))))
+ (base32 "1nny4295ipy4ajcxmmh04c796hcds0y7z7rv3qd17mj70y8j0r2d"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; https://github.com/libsixel/libsixel/issues/81
+ #~(substitute* "converters/shell-completion/bash/img2sixel"
+ (("have") "_have")))))
(build-system meson-build-system)
(arguments
(list
base-commit: 006679d1e6ca7acea0629b4f019c8cf89cde08be
prerequisite-patch-id: f132b4af7b85df465998e4f459bf729f8b66f320
prerequisite-patch-id: 71423f8b55ad6f04c3f3d647cbd9d42c6c332e06
prerequisite-patch-id: be124126488f174ea7e3bff735083a3edc09619a
prerequisite-patch-id: 244ca7d9a3430a90876970592a78d05207ee1893
prerequisite-patch-id: 53dc53cf4e9f0bb6e2f2c55194f3bc75a7381106