gnu: josm: Update to 19160.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Julien Lepiller
Owner
unassigned
Submitted by
Julien Lepiller
Severity
normal
J
J
Julien Lepiller wrote on 26 Aug 19:56 +0200
(address . guix-patches@gnu.org)
20240826195639.497dd449@lepiller.eu
Hi Guix!

this small patch series updates JOSM to the latest version. This
requires an update to jmapviewer, whose development stopped in 2022. It
is now maintained by JOSM developpers, hence the source change.

The new version had an issue when starting, where it was not able to
load projections. This is because the generate-epsg phase failed
silently. Creating another empty file was enough (not just renaming the
file, as only one empty file failed differently). When starting, it
showed a message asking to add some options to the java command line,
which I did in this patch.
J
J
Julien Lepiller wrote on 26 Aug 20:18 +0200
[PATCH 1/2] gnu: java-jmapviewer: Update to 2.20.
(address . 72822@debbugs.gnu.org)
e1e927511045aac440d886b554072edee5611371.1724696223.git.julien@lepiller.eu
* gnu/packages/geo.scm (java-jmapviewer): Update to 2.20.
[source]: Update URL.

Change-Id: I75fdb48601854bdda4fd5f7357a2c4c7ce2f54c5
---
gnu/packages/geo.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 954a4ad4a0..70dc127c1d 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2121,15 +2121,15 @@ (define-public python-rtree
(define-public java-jmapviewer
(package
(name "java-jmapviewer")
- (version "2.13")
+ (version "2.20")
(source (origin
(method url-fetch)
- (uri (string-append "https://svn.openstreetmap.org/applications/"
- "viewer/jmapviewer/releases/" version
- "/JMapViewer-" version "-Source.zip"))
+ (uri (string-append "https://josm.openstreetmap.de/osmsvn/"
+ "/applications/viewer/jmapviewer/releases/"
+ version "/JMapViewer-" version "-Source.zip"))
(sha256
(base32
- "0sy6r5fkbb9bclw0is6gwnbzz627m7pjfnsqydxz58pbndakkhrv"))))
+ "02cvmmvvlqpbwn022w3m60xkq4gh4jh9lajs6yjgvjf2hnwxll31"))))
(build-system ant-build-system)
(native-inputs
(list unzip))

base-commit: 4b011ee4abaa9199700b30cd83abadb7f9a66d2d
--
2.45.2
J
J
Julien Lepiller wrote on 26 Aug 20:18 +0200
[PATCH 2/2] gnu: josm: Update to 19160.
(address . 72822@debbugs.gnu.org)
14590dc93e101bd37cd6d5f8ad7cefb32bdb3374.1724696223.git.julien@lepiller.eu
* gnu/packages/geo.scm (josm): Update to 19160.
[arguments]: Update phases accordingly. Update launcher following josm
advice.

Change-Id: Ic168cb04cf4248167b0724faecba8f2b2d238527
---
gnu/packages/geo.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 70dc127c1d..171821fe4d 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2200,7 +2200,7 @@ (define-public java-opening-hours-parser
(define-public josm
(package
(name "josm")
- (version "18907")
+ (version "19160")
(source (origin
(method svn-fetch)
(uri (svn-reference
@@ -2209,7 +2209,7 @@ (define-public josm
(recursive? #f)))
(sha256
(base32
- "0vkczijw537f4y1b7hfxa45k3ww6nf2cf485b19dnbgh9ab6mnjl"))
+ "06m6rg9czs7mhkh0byd3c8n8y1gbzqqw2iy7qyn4084al4mdrw2z"))
(file-name (string-append name "-" version "-checkout"))
(modules '((guix build utils)))
(snippet
@@ -2280,6 +2280,9 @@ (define-public josm
(lambda _
(system* "javac" "scripts/BuildProjectionDefinitions.java"
"-cp" "build/classes")
+ (mkdir-p "resources/data/projection")
+ (with-output-to-file "resources/data/projection/custom-epsg"
+ (lambda _ (display "")))
(mkdir-p "data/projection")
(with-output-to-file "data/projection/custom-epsg"
(lambda _ (display "")))
@@ -2342,6 +2345,9 @@ (define-public josm
(not (string-contains jar "-javacc-"))))
(string-split (getenv "CLASSPATH") #\:))
":")
+ " --add-exports=java.base/sun.security.action=ALL-UNNAMED"
+ " --add-exports=java.desktop/com.sun.imageio.plugins.jpeg=ALL-UNNAMED"
+ " --add-exports=java.desktop/com.sun.imageio.spi=ALL-UNNAMED"
" org.openstreetmap.josm.gui.MainApplication"))))
(chmod (string-append bin "/josm") #o755))
#t)))))
--
2.45.2
A
A
Andreas Enge wrote on 13 Sep 12:42 +0200
(name . Julien Lepiller)(address . julien@lepiller.eu)
ZuQXLg-sm3or35cK@jurong
Hello Julien,

the patches look good to me. Given the delay in QA, I think you can push them.

Andreas
J
J
Julien Lepiller wrote on 14 Sep 18:53 +0200
(name . Andreas Enge)(address . andreas@enge.fr)
20240914185318.39c3b4af@lepiller.eu
Le Fri, 13 Sep 2024 12:42:54 +0200,
Andreas Enge <andreas@enge.fr> a écrit :

Toggle quote (8 lines)
> Hello Julien,
>
> the patches look good to me. Given the delay in QA, I think you can
> push them.
>
> Andreas
>

Pushed to master as 5fb9e04b6de24d5ff6478c9e4abe88a3a21fc43a and
e48426b45421eb8199a0dadbcd0eef3f14511e27, thanks!
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72822@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72822
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch