[PATCH 0/3] linux-libre kernel updates (2024-08-05)

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Wilko Meyer
Owner
unassigned
Submitted by
Wilko Meyer
Severity
normal
W
W
Wilko Meyer wrote on 4 Aug 00:20 +0200
(address . guix-patches@gnu.org)
cover.1722723385.git.w@wmeyer.eu
Hi Leo,

There's been updates to all currently supported 6.x kernels today. I'll
prepare for the removal of 6.9 later on today, so we can handle this as well
with the current round of updates. Deblob scripts aren't up yet, so I'll check
them later and update this patch series if necessary.

Wilko Meyer (3):
gnu: linux-libre 6.10: Update to 6.10.3.
gnu: linux-libre 6.6: Update to 6.6.44.
gnu: linux-libre 6.1: Update to 6.1.103.

gnu/packages/linux.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)


base-commit: 48d9cf7631c104a4d220cd8435d044542027d3d2
--
2.45.2
W
W
Wilko Meyer wrote on 4 Aug 00:23 +0200
[PATCH 2/3] gnu: linux-libre 6.6: Update to 6.6.44.
(address . 72454@debbugs.gnu.org)
79e7dd0911a201b1ceda5f487d1e633d7413aa79.1722723385.git.w@wmeyer.eu
* gnu/packages/linux.scm (linux-libre-6.6-version): Update to 6.6.44.
(linux-libre-6.6-pristine-source): Update hash.

Change-Id: Ibeccb3d0c05122df81701618b7493d89e53d678b
---
gnu/packages/linux.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f0747a9743..f7b8539d20 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -550,7 +550,7 @@ (define-public linux-libre-6.9-pristine-source
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
-(define-public linux-libre-6.6-version "6.6.43")
+(define-public linux-libre-6.6-version "6.6.44")
(define-public linux-libre-6.6-gnu-revision "gnu")
(define deblob-scripts-6.6
(linux-libre-deblob-scripts
@@ -560,7 +560,7 @@ (define deblob-scripts-6.6
(base32 "15xb4miirfmi1khlq4zhb8zmmh82f41jhsfbsfpv8v98yfka2nmb")))
(define-public linux-libre-6.6-pristine-source
(let ((version linux-libre-6.6-version)
- (hash (base32 "0pha226h5011kl5r2iiddxi0rib3xraslmcdjjnil2kq38d3pn0a")))
+ (hash (base32 "1n6ckxx0i4dbq018b56q1wkwq944jhjy225swrpn65a9jfb848ck")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-6.6)))
--
2.45.2
W
W
Wilko Meyer wrote on 4 Aug 00:23 +0200
[PATCH 1/3] gnu: linux-libre 6.10: Update to 6.10.3.
(address . 72454@debbugs.gnu.org)
15a89fd8cec2983c90d4d28db56e2fd65f164f9f.1722723385.git.w@wmeyer.eu
* gnu/packages/linux.scm (linux-libre-6.10-version): Update to 6.10.3.
(linux-libre-6.10-pristine-source): Update hash.

Change-Id: I0dc960e15a8584df343e3b6b56c2aaeb3f07ae34
---
gnu/packages/linux.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 675a9121d4..f0747a9743 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -512,7 +512,7 @@ (define (%upstream-linux-source version hash)
;; The current "mainline" kernel.
-(define-public linux-libre-6.10-version "6.10.2")
+(define-public linux-libre-6.10-version "6.10.3")
(define-public linux-libre-6.10-gnu-revision "gnu")
(define deblob-scripts-6.10
(linux-libre-deblob-scripts
@@ -522,7 +522,7 @@ (define deblob-scripts-6.10
(base32 "00bx8g1ijswi9zypmwqhxsk9fdkzmarxdbdx5h6gpn7z4d1qly3j")))
(define-public linux-libre-6.10-pristine-source
(let ((version linux-libre-6.10-version)
- (hash (base32 "0w4vsb0c8bp34j90l89qms50nx6r6mmyf23jbvyar9fbv46m5n3k")))
+ (hash (base32 "1666dypfg193l5460maadki4hc291hr7k9fw74nq21fxczyj4pzs")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-6.10)))
--
2.45.2
W
W
Wilko Meyer wrote on 4 Aug 00:23 +0200
[PATCH 3/3] gnu: linux-libre 6.1: Update to 6.1.103.
(address . 72454@debbugs.gnu.org)
4b7f3f3398f3d30edc43e791aedf04d8d1f407cd.1722723385.git.w@wmeyer.eu
* gnu/packages/linux.scm (linux-libre-6.1-version): Update to 6.1.103.
(linux-libre-6.1-pristine-source): Update hash.

Change-Id: I5c7d36fdb3f4611a60e496945f6c6d62e4a483cf
---
gnu/packages/linux.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f7b8539d20..b854e5ec2b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -565,7 +565,7 @@ (define-public linux-libre-6.6-pristine-source
(%upstream-linux-source version hash)
deblob-scripts-6.6)))
-(define-public linux-libre-6.1-version "6.1.102")
+(define-public linux-libre-6.1-version "6.1.103")
(define-public linux-libre-6.1-gnu-revision "gnu")
(define deblob-scripts-6.1
(linux-libre-deblob-scripts
@@ -575,7 +575,7 @@ (define deblob-scripts-6.1
(base32 "11jbnj0d3262grf9vkn0668kvfxifxw98ccvn81wkaykll01k5nx")))
(define-public linux-libre-6.1-pristine-source
(let ((version linux-libre-6.1-version)
- (hash (base32 "1v4p4i8pfg4i6v90dr7m65npkxjnqv3fxcj8zs3pbb8y84xzk98v")))
+ (hash (base32 "0ws59jjd71vhwbzkn0wqaby3yb8kjbc4clgza8aqhl4gi5pp1d2y")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-6.1)))
--
2.45.2
A
A
Andreas Enge wrote 6 days ago
Close
(address . 72454-done@debbugs.gnu.org)
ZtbF4ZzYb_bUV1sS@jurong
Hello,

seeing the issue as not applicable in QA, I notice it must be a left-over,
since newer kernel versions of all three minor releases are in master.
Closing the issue.

Andreas
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72454@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72454
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch