[PATCH] gnu: Patch gnome-dictionary meson configs, fixes 63687.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • raingloom
Owner
unassigned
Submitted by
raingloom
Severity
normal
R
R
raingloom wrote on 16 Sep 2023 14:03
(address . guix-patches@gnu.org)
1e17e882afc871f9fd1c1ea0a1ddcc997fabcbfb.1694865791.git.raingloom@riseup.net
* gnu/packages/gnome.scm (gnome-dictionary): Apply patch.
* gnu/packages/patches/gnome-dictionary-meson-i18n.patch: New file.
* gnu/local.mk: Add it.
---
gnu/local.mk | 1 +
gnu/packages/gnome.scm | 4 +-
.../patches/gnome-dictionary-meson-i18n.patch | 52 +++++++++++++++++++
3 files changed, 56 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/gnome-dictionary-meson-i18n.patch

Toggle diff (90 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 4f8637418a..ad7407a3b9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1306,6 +1306,7 @@ dist_patch_DATA = \
%D%/packages/patches/gnash-fix-giflib-version.patch \
%D%/packages/patches/gnome-2048-fix-positional-argument.patch \
%D%/packages/patches/gnome-control-center-libexecdir.patch \
+ %D%/packages/patches/gnome-dictionary-meson-i18n.patch \
%D%/packages/patches/gnome-online-miners-tracker-3.patch \
%D%/packages/patches/gnome-settings-daemon-gc.patch \
%D%/packages/patches/gnome-session-support-elogind.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 36fe1a80a1..908b5782b5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10497,7 +10497,9 @@ (define-public gnome-dictionary
name "-" version ".tar.xz"))
(sha256
(base32
- "1d8dhcfys788vv27v34i3s3x3jdvdi2kqn2a5p8c937a9hm0qr9f"))))
+ "1d8dhcfys788vv27v34i3s3x3jdvdi2kqn2a5p8c937a9hm0qr9f"))
+ (patches
+ (search-patches "gnome-dictionary-meson-i18n.patch"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
diff --git a/gnu/packages/patches/gnome-dictionary-meson-i18n.patch b/gnu/packages/patches/gnome-dictionary-meson-i18n.patch
new file mode 100644
index 0000000000..fea45af69a
--- /dev/null
+++ b/gnu/packages/patches/gnome-dictionary-meson-i18n.patch
@@ -0,0 +1,52 @@
+From 71933f6586475b36c70ef325373fe6d50c7a034f Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Mon, 24 Jan 2022 11:13:54 +0000
+Subject: [PATCH] meson: drop unused argument for i18n.merge_file()
+
+Ignored in Meson < 0.60.0, deprecated since 0.60.1 and fatal since 0.61.0.
+
+data/appdata/meson.build:3:5: ERROR: Function does not take positional arguments.
+data/meson.build:6:5: ERROR: Function does not take positional arguments.
+data/meson.build:49:5: ERROR: Function does not take positional arguments.
+---
+ data/appdata/meson.build | 2 +-
+ data/meson.build | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/data/appdata/meson.build b/data/appdata/meson.build
+index 1dc4ed7..e44a58e 100644
+--- a/data/appdata/meson.build
++++ b/data/appdata/meson.build
+@@ -1,6 +1,6 @@
+ appdata_conf = configuration_data()
+ appdata_conf.set('application_id', application_id)
+-i18n.merge_file('appdata',
++appdata_file = i18n.merge_file(
+ input: configure_file(
+ input: 'org.gnome.Dictionary.appdata.xml.in.in',
+ output: 'org.gnome.Dictionary.appdata.xml.in',
+diff --git a/data/meson.build b/data/meson.build
+index 660e6b8..7ec7251 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -3,7 +3,7 @@ subdir('appdata')
+ desktop_conf = configuration_data()
+ desktop_conf.set('icon', application_id)
+ desktop_conf.set('application_id', application_id)
+-i18n.merge_file('desktop',
++desktop_file = i18n.merge_file(
+ input: configure_file(
+ input: 'org.gnome.Dictionary.desktop.in.in',
+ output: 'org.gnome.Dictionary.desktop.in',
+@@ -45,7 +45,7 @@ sources = [
+ ]
+
+ foreach s: sources
+- i18n.merge_file('sources',
++ i18n.merge_file(
+ input: '@0@.in'.format(s),
+ output: s,
+ install: true,
+--
+2.41.0
+

base-commit: 07d43c66d5c11fef61f9846fefb97fa18e4764f1
prerequisite-patch-id: eb16d5ed274dbedb1425d7a092aa75a6424299de
--
2.41.0
L
L
Liliana Marie Prikler wrote on 16 Sep 2023 17:51
0d4fed40da1b863f1518ff33e3b775813ed6ad01.camel@gmail.com
Am Samstag, dem 16.09.2023 um 14:03 +0200 schrieb raingloom:
Toggle quote (4 lines)
> * gnu/packages/gnome.scm (gnome-dictionary): Apply patch.
> * gnu/packages/patches/gnome-dictionary-meson-i18n.patch: New file.
> * gnu/local.mk: Add it.
> ---
Reworded slightly and applied.

Thanks

PS: Don't worry about the semantics of the Fixes: line that I added; we
aren't parsing them yet.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66031@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66031
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch