[PATCH emacs-team 0/7] Fix failing builds

  • Done
  • quality assurance status badge
Details
One participant
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 15 Sep 2023 21:13
(address . guix-patches@gnu.org)
cover.1694805224.git.liliana.prikler@gmail.com
Hi Guix,

this series catches some low hanging fruits of packages that currently
fail to build on the emacs-team branch. The remaining failures appear
to require more work to debug.

Cheers

Liliana Marie Prikler (7):
gnu: emacs-go-mode: Fix build.
gnu: emacs-lispy: Fix build.
gnu: emacs-elfeed-org: Fix build.
gnu: emacs-matcha: Update to 0.0.1-2.dc4a940.
gnu: emacs-ob-go: Fix build.
gnu: emacs-pyvenv: Fix build.
gnu: emacs-rjsx-mode: Fix build.

gnu/packages/emacs-xyz.scm | 71 ++++++++++++++++++++++++++++++++------
1 file changed, 61 insertions(+), 10 deletions(-)


base-commit: 94ca5b4357af8f8921f0cb0873a7cf316f13aa69
prerequisite-patch-id: d0443b7419bc67a24d0b46aa68612b50aa2774da
prerequisite-patch-id: 83be27438bd83442f5399daed59fecace1629e73
prerequisite-patch-id: ef4ca3bf8f55d6fa18a273d08f1df46e8616a818
prerequisite-patch-id: ada783c46ef6e30084718a8528089be650732b23
prerequisite-patch-id: 345a15215df91347298b7f8830cfc8b24e9d6f84
--
2.41.0
L
L
Liliana Marie Prikler wrote on 15 Sep 2023 20:17
[PATCH emacs-team 2/7] gnu: emacs-lispy: Fix build.
(address . 66016@debbugs.gnu.org)
187f64299887a6e2dc09b74dc1cce9f161c2c7f6.1694805224.git.liliana.prikler@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-lispy)[#:phases]: Rename
‘remove-failing-test’ to ‘fix-tests’. Adjust to new failures with Emacs 29.
---
gnu/packages/emacs-xyz.scm | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c20909b843..b15b769103 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12753,11 +12753,16 @@ (define-public emacs-lispy
(add-before 'check 'make-test-writable
(lambda _
(make-file-writable "lispy-test.el")))
- (add-before 'check 'remove-failing-test
+ (add-before 'check 'fix-tests
(lambda _
+ (ert-number-tests "lispy-test.el" "lispy-outline-add")
+ (ert-number-tests "lispy-test.el" "lispy-ace-subword")
(emacs-batch-edit-file "lispy-test.el"
`(progn
- (dolist (test '("lispy-eval-python-str" "lispy--clojure-dot-object"))
+ (dolist (test '("lispy-eval-python-str"
+ "lispy-outline-add-0"
+ "lispy--clojure-dot-object"
+ "lispy--pretty-args"))
(goto-char (point-min))
(re-search-forward
(concat "ert-deftest " test))
--
2.41.0
L
L
Liliana Marie Prikler wrote on 15 Sep 2023 19:18
[PATCH emacs-team 1/7] gnu: emacs-go-mode: Fix build.
(address . 66016@debbugs.gnu.org)
74873c5746607813a41b1606a24b4b090a532e8b.1694805224.git.liliana.prikler@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-go-mode)[fix-tests]: Also fix duplicate
“go--fill-paragraph-block-region” test.
---
gnu/packages/emacs-xyz.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c4a2fe3ba1..c20909b843 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4873,7 +4873,9 @@ (define-public emacs-go-mode
(make-file-writable test-file)
(substitute* test-file
(("testdata/indentation_tests/" all)
- (string-append "test/" all)))))))))
+ (string-append "test/" all)))
+ (ert-number-tests "test/go-fill-paragraph-test.el"
+ "go--fill-paragraph-block-region")))))))
(build-system emacs-build-system)
(native-inputs (list emacs-ert-runner))
(home-page "https://github.com/dominikh/go-mode.el")
--
2.41.0
L
L
Liliana Marie Prikler wrote on 15 Sep 2023 20:43
[PATCH emacs-team 4/7] gnu: emacs-matcha: Update to 0.0.1-2.dc4a940.
(address . 66016@debbugs.gnu.org)
30a339b364b779049a81715cea21583943d84d2b.1694805224.git.liliana.prikler@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-matcha): Update to 0.0.1-2.dc4a940.
---
gnu/packages/emacs-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 95217aea1a..4ca6b62026 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30321,10 +30321,10 @@ (define-public emacs-forge
(license license:gpl3+)))
(define-public emacs-matcha
- (let ((commit "c7df5cf5cdac9ae369e241342389ccda0205eab9"))
+ (let ((commit "dc4a940b3360aadeb2d9eaab7bd0c85e1e85ab76"))
(package
(name "emacs-matcha")
- (version (git-version "0.0.1" "1" commit)) ;no upstream release
+ (version (git-version "0.0.1" "2" commit)) ;no upstream release
(source (origin
(method git-fetch)
(uri (git-reference
@@ -30333,7 +30333,7 @@ (define-public emacs-matcha
(file-name (git-file-name name version))
(sha256
(base32
- "1lfnh1glg6al677m7ci0x8g5wjdhjxlfl3nv1f1ppsw4dpnwsj9b"))))
+ "1bljnv5z289hxn73y7krbd0wya6acnwphabxwfajilpc118qz3lp"))))
(propagated-inputs (list emacs-hydra))
(build-system emacs-build-system)
(home-page "https://github.com/jojojames/matcha/")
--
2.41.0
L
L
Liliana Marie Prikler wrote on 15 Sep 2023 20:48
[PATCH emacs-team 5/7] gnu: emacs-ob-go: Fix build.
(address . 66016@debbugs.gnu.org)
73388a1a19787f8be011a25fd497e48fef9b3aba.1694805224.git.liliana.prikler@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-ob-go)[#:phases]: Add ‘ert-number-tests’.
---
gnu/packages/emacs-xyz.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4ca6b62026..01c9273ac4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7437,7 +7437,14 @@ (define-public emacs-ob-go
#:test-command #~(list "emacs" "--batch" "-L" "."
"--eval=(require 'ob-go)"
"-l" "test-ob-go.el"
- "-f" "ert-run-tests-batch-and-exit")))
+ "-f" "ert-run-tests-batch-and-exit")
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'ert-number-tests
+ (lambda _
+ (ert-number-tests "test-ob-go.el"
+ "ob-go/string-variables")
+ (ert-number-tests "test-ob-go.el"
+ "ob-go/imports"))))))
(home-page "https://github.com/pope/ob-go")
(synopsis "Org Babel support for evaluating Go code")
(description "@code{ob-go} enables Org Babel support for evaluating Go
--
2.41.0
L
L
Liliana Marie Prikler wrote on 15 Sep 2023 21:03
[PATCH emacs-team 6/7] gnu: emacs-pyvenv: Fix build.
(address . 66016@debbugs.gnu.org)
3c7cbaf461919c8c11185b2a040cb152797c28d7.1694805224.git.liliana.prikler@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-pyvenv)[#:phases]: Add ‘ert-number-tests’.
---
gnu/packages/emacs-xyz.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 01c9273ac4..6b4c23290c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14124,7 +14124,11 @@ (define-public emacs-pyvenv
(modify-phases %standard-phases
;; This phase incorrectly attempts to substitute "activate" and fails
;; doing so.
- (delete 'patch-el-files))
+ (delete 'patch-el-files)
+ (add-after 'unpack 'ert-number-tests
+ (lambda _
+ (ert-number-tests "test/pyvenv-hook-dir-test.el"
+ "pyvenv-hook-dir"))))
#:tests? #t
#:test-command '("ert-runner")))
(native-inputs
--
2.41.0
L
L
Liliana Marie Prikler wrote on 15 Sep 2023 20:35
[PATCH emacs-team 3/7] gnu: emacs-elfeed-org: Fix build.
(address . 66016@debbugs.gnu.org)
66abcaacde92ea2aa92546a1cb6d11311dab161f.1694805224.git.liliana.prikler@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-elfeed-org)[#:phases]: Add ‘xt-number-tests’.
---
gnu/packages/emacs-xyz.scm | 17 ++++++++++++++++-
1 file changed, 16 insertions(+), 1 deletion(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b15b769103..95217aea1a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13840,7 +13840,22 @@ (define-public emacs-elfeed-org
(modify-phases %standard-phases
(add-before 'check 'chmod
(lambda _
- (chmod "test/fixture-mark-feed-ignore.org" #o644))))))
+ (chmod "test/fixture-mark-feed-ignore.org" #o644)))
+ (add-before 'check 'xt-number-tests
+ (lambda _
+ ((lambda (file test-name) ; variant of ert-number-tests
+ (emacs-batch-edit-file file
+ `(let ((i 0))
+ (while (re-search-forward ,(string-append "xt-deftest "
+ test-name)
+ nil t)
+ (goto-char (match-beginning 0))
+ (kill-region (match-beginning 0) (match-end 0))
+ (insert (format "xt-deftest %s-%d" ,test-name i))
+ (setq i (+ i 1)))
+ (basic-save-buffer))))
+ "test/elfeed-org-test.el"
+ "rmh-elfeed-org-convert-headline-to-tagger-params"))))))
(propagated-inputs
(list emacs-elfeed emacs-org emacs-dash emacs-s))
(native-inputs
--
2.41.0
L
L
Liliana Marie Prikler wrote on 15 Sep 2023 21:11
[PATCH emacs-team 7/7] gnu: emacs-rjsx-mode: Fix build.
(address . 66016@debbugs.gnu.org)
10664c0f1c351eae24629127d97fe23f5e18a93c.1694805225.git.liliana.prikler@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-rjsx-mode)[#:phases]: Add
‘js2-number-tests’.
---
gnu/packages/emacs-xyz.scm | 20 +++++++++++++++++++-
1 file changed, 19 insertions(+), 1 deletion(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6b4c23290c..6ca833b484 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31014,7 +31014,25 @@ (define-public emacs-rjsx-mode
(list emacs-js2-mode))
(arguments
`(#:tests? #t
- #:test-command '("make" "test")))
+ #:test-command '("make" "test")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'js2-number-tests
+ (lambda _
+ ((lambda (file test-name) ; variant of ert-number-tests
+ (emacs-batch-edit-file file
+ `(let ((i 0))
+ (while (re-search-forward
+ ,(string-append "js2-deftest-parse "
+ test-name)
+ nil t)
+ (goto-char (match-beginning 0))
+ (kill-region (match-beginning 0) (match-end 0))
+ (insert (format "xt-deftest %s-%d" ,test-name i))
+ (setq i (+ i 1)))
+ (basic-save-buffer))))
+ "rjsx-tests.el.el"
+ "no-attr-no-children-self-closing"))))))
(home-page "https://github.com/felipeochoa/rjsx-mode")
(synopsis "Major mode for JSX files")
(description "This package extends the parser of @code{js2-mode} to
--
2.41.0
L
L
Liliana Marie Prikler wrote on 23 Sep 2023 01:27
(address . 66016-done@debbugs.gnu.org)
937df940f270e809614eb07a3613d03bb44b27cf.camel@gmail.com
Am Freitag, dem 15.09.2023 um 21:11 +0200 schrieb Liliana Marie
Prikler:
Toggle quote (3 lines)
> * gnu/packages/emacs-xyz.scm (emacs-rjsx-mode)[#:phases]: Add
> ‘js2-number-tests’.
> ---
Pushed along with the rest.

Cheers
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66016@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66016
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch