[PATCH 0/1] update dune to 3.10

  • Done
  • quality assurance status badge
Details
3 participants
  • Benjamin
  • pukkamustard
  • Simon Tournier
Owner
unassigned
Submitted by
Benjamin
Severity
normal
B
B
Benjamin wrote on 15 Sep 16:20 +0200
(address . guix-patches@gnu.org)(name . Benjamin)(address . benjamin@uvy.fr)
cover.1694787299.git.benjamin@uvy.fr
Hello,

This patch update dune to version 3.10.

This will allow me to push a series of patch to bump eio to 0.12 (as it
depends on dune 3.9 [0]

I check the build of affected packages by running `guix build` on `guix
refresh -l dune`

By doing so, I discovered that it is not possible to build current coq
version with latest dune. That is the reason why I kept the current
version of dune for those packages.



Benjamin (1):
gnu: dune-bootstrap: Update to 3.10.0.

gnu/packages/coq.scm | 3 +++
gnu/packages/ocaml.scm | 31 +++++++++++++++++++++++--------
2 files changed, 26 insertions(+), 8 deletions(-)


base-commit: 69580997bd1b383659b990a5e1e46817e371fa8c
--
2.41.0
B
B
Benjamin wrote on 15 Sep 16:23 +0200
[PATCH 1/1] gnu: dune-bootstrap: Update to 3.10.0.
(address . 66000@debbugs.gnu.org)(name . Benjamin)(address . benjamin@uvy.fr)
a2a8e6a0408bcee285319c92672f3db320086aa8.1694787299.git.benjamin@uvy.fr
* gnu/packages/ocaml.scm (dune-bootstrap): Update to 3.10.0.

old version of dune is kept to be compatible with coq
---
gnu/packages/coq.scm | 3 +++
gnu/packages/ocaml.scm | 31 +++++++++++++++++++++++--------
2 files changed, 26 insertions(+), 8 deletions(-)

Toggle diff (128 lines)
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 09ca4030ea..a3f48648e4 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -84,6 +84,7 @@ (define-public coq-core
(list ocaml-ounit2 which))
(arguments
`(#:package "coq-core"
+ #:dune ,dune-3.6.1
#:test-target "."))
(properties '((upstream-name . "coq"))) ; also for inherited packages
(home-page "https://coq.inria.fr")
@@ -103,6 +104,7 @@ (define-public coq-stdlib
(arguments
`(#:package "coq-stdlib"
#:test-target "."
+ #:dune ,dune-3.6.1
#:phases
(modify-phases %standard-phases
(add-before 'build 'fix-dune
@@ -145,6 +147,7 @@ (define-public coq-ide
(name "coq-ide")
(arguments
`(#:tests? #f
+ #:dune ,dune-3.6.1
#:package "coqide"))
(propagated-inputs
(list coq coq-ide-server))
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8ff755aea9..b5713c37d6 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1818,7 +1818,7 @@ (define-public ocaml-stringext
(define dune-bootstrap
(package
(name "dune")
- (version "3.6.1")
+ (version "3.10.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1827,7 +1827,7 @@ (define dune-bootstrap
(file-name (git-file-name name version))
(sha256
(base32
- "0gv851wxbv5ln20429nj7p92spzxgw8vngg9z94q39aawn6q8lx6"))))
+ "0zwih4fwwrc8lwi2i4mmps9ng7z6mf46pps2i503lmx0dh8dl606"))))
(build-system ocaml-build-system)
(arguments
`(#:tests? #f; require odoc
@@ -1947,6 +1947,21 @@ (define-public ocaml5.0-dune
(propagated-inputs
(list ocaml5.0-dune-configurator))))
+(define-public dune-3.6.1
+ (package
+ (inherit dune-bootstrap)
+ (name "dune")
+ (version "3.6.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml/dune")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gv851wxbv5ln20429nj7p92spzxgw8vngg9z94q39aawn6q8lx6"))))))
+
(define-public ocaml-csexp
(package
(name "ocaml-csexp")
@@ -2180,7 +2195,7 @@ (define-public ocaml-ppx-bitstring
(description
"This package provides a way to write bitstrings and matching over
bitsrings in Erlang style as primitives to the language.")))
-
+
(define-public ocaml-result
(package
(name "ocaml-result")
@@ -2223,7 +2238,7 @@ (define-public ocaml5.0-result
`(#:dune ,ocaml5.0-dune-bootstrap
#:ocaml ,ocaml-5.0
#:findlib ,ocaml5.0-findlib))))
-
+
(define-public ocaml-topkg
(package
(name "ocaml-topkg")
@@ -2253,7 +2268,7 @@ (define-public ocaml-topkg
configuration and to specify information about the package's distribution,
creation and publication procedures.")
(license license:isc)))
-
+
(define-public ocaml-rresult
(package
(name "ocaml-rresult")
@@ -3772,7 +3787,7 @@ (define-public ocaml-jsonm
the JSON data format. It can process JSON text without blocking on IO and
without a complete in-memory representation of the data.")
(license license:isc)))
-
+
(define-public ocaml-ocp-indent
(package
(name "ocaml-ocp-indent")
@@ -3807,7 +3822,7 @@ (define-public ocaml-ocp-indent
fault-tolerant and approximate parsing.
@end itemize")
(license license:lgpl2.1)))
-
+
(define-public ocaml-ocp-index
(package
(name "ocaml-ocp-index")
@@ -6138,7 +6153,7 @@ (define-public ocaml-yojson
yojson package. The program @code{atdgen} can be used to derive OCaml-JSON
serializers and deserializers from type definitions.")
(license license:bsd-3)))
-
+
(define-public ocaml-merlin-lib
(package
(name "ocaml-merlin-lib")
--
2.41.0
P
P
pukkamustard wrote on 15 Sep 16:25 +0200
Re: [bug#66000] [PATCH 0/1] update dune to 3.10
(name . Benjamin)(address . benjamin@uvy.fr)
86cyyjjysg.fsf@posteo.net
Hi,

There's a patch series to update the OCaml compiler, dune and the Coq
clique here:


Maybe we can close this issue for #64249?

Benjamin <benjamin@uvy.fr> writes:

Toggle quote (3 lines)
> This will allow me to push a series of patch to bump eio to 0.12 (as it
> depends on dune 3.9 [0]

Nice, looking forward to the patches.

Regards,
pukkamustard
B
B
Benjamin wrote 7 days ago
(name . pukkamustard)(address . pukkamustard@posteo.net)
CVJM2BX2RNZ0.1WDYPUBLKNG2H@robot.uvy.fr
Hi

Toggle quote (7 lines)
> There's a patch series to update the OCaml compiler, dune and the Coq
> clique here:
>
> https://issues.guix.gnu.org/64249
>
> Maybe we can close this issue for #64249?

Oh I looked for dune open issues but did not find that one.
Sure we can merge it and close this issue
S
S
Simon Tournier wrote 7 days ago
87il8b9yaz.fsf@gmail.com
Hi,

On Fri, 15 Sep 2023 at 17:54, "Benjamin" <benjamin@uvy.fr> wrote:

Toggle quote (10 lines)
>> There's a patch series to update the OCaml compiler, dune and the Coq
>> clique here:
>>
>> https://issues.guix.gnu.org/64249
>>
>> Maybe we can close this issue for #64249?
>
> Oh I looked for dune open issues but did not find that one.
> Sure we can merge it and close this issue

I am closing #66000… nice id number btw. ;-)

Cheers,
simon
Closed
?