Ricardo Wurmus wrote 2 years ago
(address . bug-guix@gnu.org)
Consider this scenario: a number of users access a shared jupyterhub /
jupyterlab installation, which allows them to launch their own jupyter
kernels. The shared installation was deployed with Guix. The user
kernels are installed like this:
$ guix shell python python-ipykernel python-foo python-bar …
$ [env] python3 -m ipykernel install --user --name whatever --display-name whatever
Installed kernelspec whatever in /home/rekado/.local/share/jupyter/kernels/whatever
The installed kernel.json looks like this:
Toggle snippet (16 lines)
{
"argv": [
"/gnu/store/…-profile/bin/python3",
"-m",
"ipykernel_launcher",
"-f",
"{connection_file}"
],
"display_name": "whatever",
"language": "python",
"metadata": {
"debugger": true
}
]
That’s not sufficient because the “ipykernel_launcher” module is
provided by the python-ipykernel package and the shared jupyter{hub,lab}
doesn’t know about this package. That’s because it doesn’t use the
GUIX_PYTHONPATH of the profile containing the user’s packages.
Perhaps we could add a profile hook that adds an “env” field to the
generated kernel.json file, which augments the existing GUIX_PYTHONPATH
with the appropriate value for the current profile.
We can do this on the command line like this:
Toggle snippet (5 lines)
python3 -m ipykernel install \
--user --name whatever --display-name whatever \
--env GUIX_PYTHONPATH "${GUIX_PYTHONPATH}:\${GUIX_PYTHONPATH}"
Or we can edit the JSON directly.
The documentation of the kernel.json format is available here:
--
Ricardo