* gnu/packages/check.scm (python-lit)[native-inputs]: Replace llvm-14
with llvm-15.
* gnu/packages/dlang.scm (ldc-bootstrap)[arguments]: Adjust
configure-flags to make use of llvm shared libraries.
[native-inputs]: Replace lld-wrapper-14 with lld-wrapper-15, llvm-14
with llvm-15.
(ldc)[arguments]: Inherit configure-flags from ldc-bootstrap. Update
skipped tests.
[native-inputs]: Replace clang-14 with clang-15.
---
gnu/packages/check.scm | 2 +-
gnu/packages/dlang.scm | 64 +++++++++++++++++++++++++++++++++---------
2 files changed, 52 insertions(+), 14 deletions(-)
Toggle diff (137 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 82b4741212..4c1ba085c4 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2349,7 +2349,7 @@ (define-public python-lit
(when tests?
(invoke "python" "lit.py" "tests")))))))
(native-inputs
- (list llvm-14))
+ (list llvm-15))
(home-page "https://llvm.org/")
(synopsis "LLVM Software Testing Tool")
(description "@code{lit} is a portable tool for executing LLVM and Clang
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index 2b5b1235e4..3103e629d9 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -163,7 +163,9 @@ (define ldc-bootstrap
#:tests? #f ;skip in the bootstrap
#:build-type "Release"
#:configure-flags
- (list "-GNinja")
+ (list "-GNinja"
+ "-DLLVM_IS_SHARED=ON"
+ "-DBUILD_SHARED_LIBS=ON")
#:make-flags ;used as build targets
(list "all")
#:phases
@@ -190,8 +192,8 @@ (define ldc-bootstrap
("libedit" ,libedit)
("zlib" ,zlib)))
(native-inputs
- `(("lld-wrapper" ,(make-lld-wrapper lld-14 #:lld-as-ld? #t))
- ("llvm" ,llvm-14)
+ `(("lld-wrapper" ,(make-lld-wrapper lld-15 #:lld-as-ld? #t))
+ ("llvm" ,llvm-15)
("ldc" ,gdmd)
("ninja" ,ninja)
("python-wrapper" ,python-wrapper)
@@ -224,10 +226,6 @@ (define-public ldc
'(list "all"
;; Also build the test runner binaries.
"ldc2-unittest" "all-test-runners"))
- ((#:configure-flags flags)
- `(,@flags "-DBUILD_SHARED_LIBS=ON"
- "-DLDC_LINK_MANUALLY=OFF"
- "-DLDC_DYNAMIC_COMPILE=OFF"))
((#:phases phases)
`(modify-phases ,phases
(add-after 'unpack 'fix-compiler-rt-library-discovery
@@ -314,13 +312,39 @@ (define-public ldc
"instrument/xray_check_pipeline.d"
"instrument/xray_link.d"
"instrument/xray_simple_execution.d"
+ "sanitizers/fuzz_asan.d"
+ "sanitizers/fuzz_basic.d"
+ "sanitizers/fuzz_mixin.d"
+ "sanitizers/link_fuzzer.d"
"sanitizers/msan_noerror.d"
"sanitizers/msan_uninitialized.d"
"dmd/runnable_cxx/cppa.d")))
(,(target-aarch64?)
(for-each delete-file
- '("dmd/runnable/ldc_cabi1.d"
+ '("PGO/allstatementtypes.d"
+ "PGO/branching_switch.d"
+ "PGO/break.d"
+ "PGO/exceptions.d"
+ "PGO/final_switch_release.d"
+ "PGO/functions.d"
+ "PGO/hash.d"
+ "PGO/hash_smallchange.d"
+ "PGO/irbased_indirect_calls.d"
+ "PGO/max_function_count.d"
+ "PGO/profile_rt_calls.d"
+ "PGO/reset_counters.d"
+ "PGO/singleobj.d"
+ "PGO/summary.d"
+ "PGO/unrolledloopstatement_gh3375.d"
+ "instrument/xray_link.d"
+ "instrument/xray_simple_execution.d"
+ "sanitizers/asan_dynalloc.d"
+ "sanitizers/asan_interface.d"
+ "sanitizers/asan_noerror.d"
+ "sanitizers/asan_stackoverflow.d"
+ "sanitizers/fuzz_asan.d"
"sanitizers/fuzz_basic.d"
+ "sanitizers/lsan_memleak.d"
"sanitizers/msan_noerror.d"
"sanitizers/msan_uninitialized.d")))
(#t '())))))
@@ -341,9 +365,11 @@ (define-public ldc
;; finer-grained diagnostics (see:
;; https://raw.githubusercontent.com/ldc-developers/
;; ldc/master/.azure-pipelines/3-posix-test.yml)
- (display "running the ldc2 unit tests...\n")
- (invoke "ctest" "--output-on-failure" "-j" job-count
- "-R" "ldc2-unittest")
+ ;; This test segfaults on i686-linux.
+ (unless ,(target-x86-32?)
+ (display "running the ldc2 unit tests...\n")
+ (invoke "ctest" "--output-on-failure" "-j" job-count
+ "-R" "ldc2-unittest"))
(display "running the lit test suite...\n")
(invoke "ctest" "--output-on-failure" "-j" job-count
"-R" "lit-tests")
@@ -354,12 +380,24 @@ (define-public ldc
(display "running the defaultlib unit tests and druntime \
integration tests...\n")
(invoke "ctest" "--output-on-failure" "-j" job-count
- "-E" "dmd-testsuite|lit-tests|ldc2-unittest")))))))))
+ "-E" (string-join
+ (append
+ (list "dmd-testsuite"
+ "lit-tests"
+ "ldc2-unittest")
+ ;; from .cirrus.yaml
+ (if ,(target-aarch64?)
+ '("^core.thread.fiber(-shared)?$"
+ "^std.internal.math.gammafunction"
+ "^std.math.exponential(-shared)?$"
+ "^druntime-test-exceptions-debug$")
+ `()))
+ "|"))))))))))
(native-inputs
(append (delete "llvm"
(alist-replace "ldc" (list ldc-bootstrap)
(package-native-inputs ldc-bootstrap)))
- `(("clang" ,clang-14) ;propagates llvm and clang-runtime
+ `(("clang" ,clang-15) ;propagates llvm and clang-runtime
("python-lit" ,python-lit))))))
(define-public dub
--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted