[PATCH 1/2] gnu: Add qbittorrent-enhanced.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 29 May 2023 09:01
(address . guix-patches@gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
20230529070109.768-1-hako@ultrarare.space
* gnu/packages/bittorrent.scm (qbittorrent-enhanced): New variable.
---
gnu/packages/bittorrent.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 38e959b884..acec7a48d9 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -519,6 +519,33 @@ (define-public qbittorrent-nox
(modify-inputs (package-inputs base)
(delete "qtsvg-5"))))))
+(define-public qbittorrent-enhanced
+ (package
+ (inherit qbittorrent)
+ (name "qbittorrent-enhanced")
+ (version "4.5.2.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/c0re100/qBittorrent-Enhanced-Edition")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18z4panaqbmhbw5i1yn17wpqzslhy6w08zcc5bx2hhlg8slp1r9j"))))
+ (home-page "https://github.com/c0re100/qBittorrent-Enhanced-Edition")
+ (description
+ "qBittorrent Enhanced is a bittorrent client based on qBittorrent with
+the following features:
+
+@itemize
+@item Auto Ban Xunlei, QQ, Baidu, Xfplay, DLBT and Offline downloader
+@item Auto Ban Unknown Peer from China Option (Default: OFF)
+@item Auto Update Public Trackers List (Default: OFF)
+@item Auto Ban BitTorrent Media Player Peer Option (Default: OFF)
+@item Peer whitelist/blacklist
+@end itemize\n")))
+
(define-public deluge
(package
(name "deluge")

base-commit: d64d6ea2cf5a1be801be355031fb2cfa5901a92a
--
2.40.1
H
H
Hilton Chain wrote on 29 May 2023 09:03
[PATCH 2/2] gnu: Add qbittorrent-enhanced-nox.
(address . 63782@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
20230529070331.1067-1-hako@ultrarare.space
* gnu/packages/bittorrent.scm (qbittorrent-enhanced-nox): New variable.
---
gnu/packages/bittorrent.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (20 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index acec7a48d9..a55fb1e6c7 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -546,6 +546,13 @@ (define-public qbittorrent-enhanced
@item Peer whitelist/blacklist
@end itemize\n")))
+(define-public qbittorrent-enhanced-nox
+ (package
+ (inherit qbittorrent-enhanced)
+ (name "qbittorrent-enhanced-nox")
+ (arguments (package-arguments qbittorrent-nox))
+ (inputs (package-inputs qbittorrent-nox))))
+
(define-public deluge
(package
(name "deluge")
--
2.40.1
N
N
Nicolas Goaziou wrote on 1 Jul 2023 12:09
Re: [bug#63782] [PATCH 1/2] gnu: Add qbittorrent-enhanced.
(name . Hilton Chain via Guix-patches via)(address . guix-patches@gnu.org)
871qhskko1.fsf@nicolasgoaziou.fr
Hello,

Hilton Chain via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/bittorrent.scm (qbittorrent-enhanced): New variable.

Applied. Thank you.

Toggle quote (12 lines)
> + (description
> + "qBittorrent Enhanced is a bittorrent client based on qBittorrent with
> +the following features:
> +
> +@itemize
> +@item Auto Ban Xunlei, QQ, Baidu, Xfplay, DLBT and Offline downloader
> +@item Auto Ban Unknown Peer from China Option (Default: OFF)
> +@item Auto Update Public Trackers List (Default: OFF)
> +@item Auto Ban BitTorrent Media Player Peer Option (Default: OFF)
> +@item Peer whitelist/blacklist
> +@end itemize\n")))

Note the newline character is not necessary at the end of the
description. I removed it.

Regards,
--
Nicolas Goaziou
?