[PATCH] gnu: d-feet: Fix the build error when using Meson 1.1.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Zhu Zihao
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Zhu Zihao
Severity
normal
Z
Z
Zhu Zihao wrote on 19 May 2023 14:35
(address . guix-patches@gnu.org)(name . Zhu Zihao)(address . all_but_last@163.com)
20230519123528.5119-1-all_but_last@163.com
Fix the build error:

data/meson.build:15:0: ERROR: Function does not take positional arguments.
data/meson.build:27:0: ERROR: Function does not take positional arguments.

* gnu/packages/patches/d-feet-drop-unused-meson-argument.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add new entry.
* gnu/packages/gnome.scm (d-feet)[source]: Apply the patch.
---
gnu/local.mk | 1 +
gnu/packages/gnome.scm | 19 +++++-----
.../d-feet-drop-unused-meson-argument.patch | 36 +++++++++++++++++++
3 files changed, 48 insertions(+), 8 deletions(-)
create mode 100644 gnu/packages/patches/d-feet-drop-unused-meson-argument.patch

Toggle diff (93 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index d31b40f3bf..f44192b28f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1033,6 +1033,7 @@ dist_patch_DATA = \
%D%/packages/patches/cvs-CVE-2017-12836.patch \
%D%/packages/patches/c++-gsl-find-system-gtest.patch \
%D%/packages/patches/c++-gsl-move-array-bounds-tests.patch \
+ %D%/packages/patches/d-feet-drop-unused-meson-argument.patch \
%D%/packages/patches/date-output-pkg-config-files.patch \
%D%/packages/patches/datefudge-gettimeofday.patch \
%D%/packages/patches/dbacl-include-locale.h.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 754bb668ba..5a0259d5ab 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -74,6 +74,7 @@
;;; Copyright © 2022 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
+;;; Copyright © 2023 Zhu Zihao <all_but_last@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7190,14 +7191,16 @@ (define-public d-feet
(package
(name "d-feet")
(version "0.3.16")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1jqw5ndpgyb0zxh0g21ai1911lfrm56vz18xbccfqm4sk95wwcw7"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1jqw5ndpgyb0zxh0g21ai1911lfrm56vz18xbccfqm4sk95wwcw7"))
+ (patches (search-patches "d-feet-drop-unused-meson-argument.patch"))))
(build-system meson-build-system)
(arguments
(list
diff --git a/gnu/packages/patches/d-feet-drop-unused-meson-argument.patch b/gnu/packages/patches/d-feet-drop-unused-meson-argument.patch
new file mode 100644
index 0000000000..5d728d7d60
--- /dev/null
+++ b/gnu/packages/patches/d-feet-drop-unused-meson-argument.patch
@@ -0,0 +1,36 @@
+From 05465d486afdba116dbc22fc22c1e6573aea4f22 Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Mon, 24 Jan 2022 12:11:57 +0000
+Subject: [PATCH] meson: drop unused argument for i18n.merge_file()
+
+Ignored in Meson < 0.60.0, deprecated since 0.60.1 and fatal since 0.61.0.
+
+data/meson.build:15:0: ERROR: Function does not take positional arguments.
+data/meson.build:27:0: ERROR: Function does not take positional arguments.
+---
+ data/meson.build | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/data/meson.build b/data/meson.build
+index 026bd80..3b03b94 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -13,7 +13,6 @@ desktop_in = configure_file(
+ )
+
+ i18n.merge_file(
+- desktop,
+ type: 'desktop',
+ input: desktop_in,
+ output: '@BASENAME@',
+@@ -25,7 +24,6 @@ i18n.merge_file(
+ appdata = df_namespace + '.appdata.xml'
+
+ i18n.merge_file(
+- appdata,
+ input: appdata + '.in',
+ output: '@BASENAME@',
+ po_dir: po_dir,
+--
+GitLab
+
--
2.39.2
Z
Z
Zhu Zihao wrote on 29 May 2023 17:02
Re: bug#63584: Acknowledgement ([PATCH] gnu: d-feet: Fix the build error when using Meson 1.1.0.)
(address . 63584@debbugs.gnu.org)
86leh7yycf.fsf@163.com
ping.

And this should close https://issues.guix.gnu.org/63270

--
Retrieve my PGP public key:

gpg --recv-keys B3EBC086AB0EBC0F45E0B4D433DB374BCEE4D9DC

Zihao
-----BEGIN PGP SIGNATURE-----

iIsEARYIADMWIQT4UAIrVkIEZilSHr2K2nJqP6LM8gUCZHS+oRUcYWxsX2J1dF9s
YXN0QDE2My5jb20ACgkQitpyaj+izPI2jgEAsr8i83ikgbFmBELIybSL+XAoGSaC
RuV/W/jw7JvudXwBAOvGh1k0R55NwtXA9Gd1WSIeYX+dNu5rw8Q+ZvQjfOYB
=A6+k
-----END PGP SIGNATURE-----

L
L
Liliana Marie Prikler wrote on 29 May 2023 21:34
9524d67b742a66a76f407887f250d8c8d66e2a13.camel@gmail.com
Am Montag, dem 29.05.2023 um 23:02 +0800 schrieb Zhu Zihao:
Toggle quote (3 lines)
> ping.
>
> And this should close https://issues.guix.gnu.org/63270
Note that you mentioned the wrong thread there, but anyway: the patch
mixes functional and non-functional changes, which I think should be
kept separate. If I count my columns correctly, you can do with -1/+2
on gnu/packages/gnome.scm

Cheers
Z
Z
Zhu Zihao wrote on 31 May 2023 06:05
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 63584@debbugs.gnu.org)
86r0qxw3er.fsf@163.com
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (5 lines)
> Note that you mentioned the wrong thread there, but anyway: the patch
> mixes functional and non-functional changes, which I think should be
> kept separate. If I count my columns correctly, you can do with -1/+2
> on gnu/packages/gnome.scm

Do you mean I should not change the indentation here?

--
Retrieve my PGP public key:

gpg --recv-keys B3EBC086AB0EBC0F45E0B4D433DB374BCEE4D9DC

Zihao
-----BEGIN PGP SIGNATURE-----

iIsEARYIADMWIQT4UAIrVkIEZilSHr2K2nJqP6LM8gUCZHbHvBUcYWxsX2J1dF9s
YXN0QDE2My5jb20ACgkQitpyaj+izPJFQwD9FANOh9t1paPble5UC/ETLG4ujgNG
+wDGwSiIdjwZSPoBAMD8WZ6X+Dr/JkReS2Dqu+Z/klr94+oA4aBE1u8/9HoK
=55xJ
-----END PGP SIGNATURE-----

L
L
Liliana Marie Prikler wrote on 31 May 2023 06:24
(name . Zhu Zihao)(address . all_but_last@163.com)(address . 63584@debbugs.gnu.org)
6394442394ce24a7ba47227314529737040b2b00.camel@gmail.com
Am Mittwoch, dem 31.05.2023 um 12:05 +0800 schrieb Zhu Zihao:
Toggle quote (9 lines)
>
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
> > Note that you mentioned the wrong thread there, but anyway: the
> > patch mixes functional and non-functional changes, which I think
> > should be kept separate.  If I count my columns correctly, you can
> > do with -1/+2 on gnu/packages/gnome.scm
>
> Do you mean I should not change the indentation here?
Exactly. If you wish to apply `guix style' or similar formatting, I
recommend a follow-up commit.

Cheers
Z
Z
Zhu Zihao wrote on 1 Jun 2023 15:27
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 63584@debbugs.gnu.org)
86bkhzwbvn.fsf@163.com
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (3 lines)
> Exactly. If you wish to apply `guix style' or similar formatting, I
> recommend a follow-up commit.

Done it with -1/+3 :)
-----BEGIN PGP SIGNATURE-----

iIsEARYIADMWIQT4UAIrVkIEZilSHr2K2nJqP6LM8gUCZHic3BUcYWxsX2J1dF9s
YXN0QDE2My5jb20ACgkQitpyaj+izPJ/+QD/RZFAFCKb3R50szefabb1UsxQIQmL
b0KvMz5zGZL6clgBAOaqCKtRJXd5NcMMNAKi6oEbQ7X04nIzbeIkcHEukKoN
=vp+a
-----END PGP SIGNATURE-----

From 954ffef03e1637048b537f704f05d78b823b5806 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Fri, 19 May 2023 19:51:41 +0800
Subject: [PATCH] gnu: d-feet: Fix the build error when using Meson 1.1.0.

Fix the build error:

data/meson.build:15:0: ERROR: Function does not take positional arguments.
data/meson.build:27:0: ERROR: Function does not take positional arguments.

* gnu/packages/patches/d-feet-drop-unused-meson-argument.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add new entry.
* gnu/packages/gnome.scm (d-feet)[source]: Apply the patch.
---
gnu/local.mk | 1 +
gnu/packages/gnome.scm | 5 ++-
.../d-feet-drop-unused-meson-argument.patch | 36 +++++++++++++++++++
3 files changed, 41 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/d-feet-drop-unused-meson-argument.patch

Toggle diff (79 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 18e8235140..68dfc21df1 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1034,6 +1034,7 @@ dist_patch_DATA = \
%D%/packages/patches/cvs-CVE-2017-12836.patch \
%D%/packages/patches/c++-gsl-find-system-gtest.patch \
%D%/packages/patches/c++-gsl-move-array-bounds-tests.patch \
+ %D%/packages/patches/d-feet-drop-unused-meson-argument.patch \
%D%/packages/patches/date-output-pkg-config-files.patch \
%D%/packages/patches/datefudge-gettimeofday.patch \
%D%/packages/patches/dbacl-include-locale.h.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7df18f055f..516c9f98d3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -76,6 +76,7 @@
;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
;;; Copyright © 2023 Juliana Sims <juli@incana.org>
;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
+;;; Copyright © 2023 Zhu Zihao <all_but_last@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7199,7 +7200,9 @@ (define-public d-feet
name "-" version ".tar.xz"))
(sha256
(base32
- "1jqw5ndpgyb0zxh0g21ai1911lfrm56vz18xbccfqm4sk95wwcw7"))))
+ "1jqw5ndpgyb0zxh0g21ai1911lfrm56vz18xbccfqm4sk95wwcw7"))
+ (patches
+ (search-patches "d-feet-drop-unused-meson-argument.patch"))))
(build-system meson-build-system)
(arguments
(list
diff --git a/gnu/packages/patches/d-feet-drop-unused-meson-argument.patch b/gnu/packages/patches/d-feet-drop-unused-meson-argument.patch
new file mode 100644
index 0000000000..5d728d7d60
--- /dev/null
+++ b/gnu/packages/patches/d-feet-drop-unused-meson-argument.patch
@@ -0,0 +1,36 @@
+From 05465d486afdba116dbc22fc22c1e6573aea4f22 Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Mon, 24 Jan 2022 12:11:57 +0000
+Subject: [PATCH] meson: drop unused argument for i18n.merge_file()
+
+Ignored in Meson < 0.60.0, deprecated since 0.60.1 and fatal since 0.61.0.
+
+data/meson.build:15:0: ERROR: Function does not take positional arguments.
+data/meson.build:27:0: ERROR: Function does not take positional arguments.
+---
+ data/meson.build | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/data/meson.build b/data/meson.build
+index 026bd80..3b03b94 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -13,7 +13,6 @@ desktop_in = configure_file(
+ )
+
+ i18n.merge_file(
+- desktop,
+ type: 'desktop',
+ input: desktop_in,
+ output: '@BASENAME@',
+@@ -25,7 +24,6 @@ i18n.merge_file(
+ appdata = df_namespace + '.appdata.xml'
+
+ i18n.merge_file(
+- appdata,
+ input: appdata + '.in',
+ output: '@BASENAME@',
+ po_dir: po_dir,
+--
+GitLab
+
--
2.39.2
--
Retrieve my PGP public key:

gpg --recv-keys B3EBC086AB0EBC0F45E0B4D433DB374BCEE4D9DC

Zihao
L
L
Liliana Marie Prikler wrote on 4 Jun 2023 08:30
(name . Zhu Zihao)(address . all_but_last@163.com)(address . 63584-done@debbugs.gnu.org)
c44fb05e0fbdd4f3df6d60b44a18d8c33814093a.camel@gmail.com
Am Donnerstag, dem 01.06.2023 um 21:27 +0800 schrieb Zhu Zihao:
Toggle quote (7 lines)
>
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
> > Exactly.  If you wish to apply `guix style' or similar formatting,
> > I recommend a follow-up commit.
>
> Done it with -1/+3 :)
+4 due to copyright, but good enough for me.

Thanks
Closed
?